Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 17/12/2018, à 19:16

nam1962

Commande pour voir les versions de paquets différentes des dépôts

apt-forktracer -v

En ressortent les paquets qui n'ont pas la version des dépôts (donc en principe sortis des PPA.)

Ce peut permettre d'illustrer les dégâts de PPA fourre-tout qui envoient plein de version à leur sauce (comme feu Getdeb, Nilarimogard ou autres WebUpd8)

Le retour est assez moche par contre hmm

Dernière modification par nam1962 (Le 18/12/2018, à 14:49)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#2 Le 18/12/2018, à 14:02

LukePerp

Re : Commande pour voir les versions de paquets différentes des dépôts

Intéressant. Je suppose qu'une installation fraîche ne renvoi rien pour cette commande ? Ce serait intéressant connaître les démarches à suivre pour nettoyer les paquets sorties en l'absence ou obsolescence d'un ppa.


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop asus : Ubuntu Mate 18.04 - Intel i5 - 4 Go
Vieux laptop de 2005 : Bodhi Linux - Pentium M - 436 Mo

Hors ligne

#3 Le 18/12/2018, à 14:15

nam1962

Re : Commande pour voir les versions de paquets différentes des dépôts

Ta première question : normalement oui, mais à vérifier wink
Pour la seconde, il y a en principe ppa-purge, mais ppa-purge ne fonctionnera pas si le ppa appartient à une autre version (cas souvent rencontré hmm ) et si le ppa est mal écrit.
D'où l'utilité de la commande qui peut aider à se débarrasser de paquets parasites repérés

Sinon, on peut virer sauvagement le ppa et prier pour que le temps permette de revenir à une version propre, mais :

..truc que j'ai repéré parfois (exemple réinventé) :
Version legit -1 : 2.10-3
Version legit à jour : 2.10-4
Version bidouille : 2.1-xr2201
Et là, tu as 9 chances sur 10 de rester sur la bidouille...

(les devs ne peuvent pas prévoir toutes les fantaisies des bidouilleurs)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#4 Le 18/12/2018, à 14:15

michel_04

Re : Commande pour voir les versions de paquets différentes des dépôts

Bonjour,


Ah oui, quand même. sad

michel@Michel-E320:~$ apt-forktracer -v
net.downloadhelper.coapp (1.2.4)
libdns-export162 (1:9.10.3.dfsg.P4-12.6ubuntu1)
libqpdf18 (7.1.1-1)
openjdk-9-jre-headless (9.0.4+12-4ubuntu2)
libgksu2-0 (2.0.13~pre1-9ubuntu2)
master-pdf-editor (5.0.02)
libisccfg140 (1:9.10.3.dfsg.P4-12.6ubuntu1)
libmpfr4 (3.1.6-1)
libav-tools (7:3.4.2-1build1)
libtxc-dxtn-s2tc (1.0+git20151227-2)
adobe-flash-properties-gtk (1:20181205.1-0ubuntu0.18.04.1) [Canonical: 1:20181205.1-0ubuntu0.18.04.1]
libcdio16 (0.94-1)
libicu59 (59.1-3ubuntu1)
google-earth-pro-stable (7.3.0.3832-r0)
google-chrome-stable (71.0.3578.98-1) [Google LLC: 71.0.3578.98-1]
anydesk (4.0.1-1)
libisc160 (1:9.10.3.dfsg.P4-12.6ubuntu1)
qarte (4.6.0-0ubuntu1) [LP-PPA-vincent-vandevyvre-vvv: 4.6.0-0ubuntu1 4.6.0-0ubuntu1]
libsuitesparseconfig4 (1:4.5.6-1)
libntfs-3g872 (1:2016.2.22AR.2-2)
libvpx4 (1.6.1-3)
adobe-flashplugin (1:20181205.1-0ubuntu0.18.04.1) [Canonical: 1:20181205.1-0ubuntu0.18.04.1]
kclean (4.1)
gtk-theme-config (1.2.2-1)
multisystem (1.0426) [liveusb.info: 1.0426 1.0426]
libdvdcss-dev (1.4.2-1~local)
dpluzz (1.7.10~ubuntu16.04) [LP-PPA-yoggic-dpluzz: 1.7.10~ubuntu16.04]
libva1 (1.8.3-2)
libgnome-desktop-3-12 (3.26.2-1ubuntu1)
libisc-export160 (1:9.10.3.dfsg.P4-12.6ubuntu1)
gksu (2.0.2-9ubuntu2)
libgcr-3-common (3.20.0-6)
liblouisutdml7 (2.6.0-5)
liborcus-0.12-0 (0.12.1-3build2)
libgdbm3 (1.8.3-14)
liblwres141 (1:9.10.3.dfsg.P4-12.6ubuntu1)
openjdk-9-jre (9.0.4+12-4ubuntu2)
libxfont1 (1:1.5.2-4ubuntu2)
libcryptsetup4 (2:1.7.3-4ubuntu1)
libgnome-games-support-1-2 (1.2.3-3)
libsodium18 (1.0.14-1)
pyrenamer (0.6.0-1.2)
waterfox-locale-fr (56.2.5.1-0) [obs://build.opensuse.org/home:hawkeye116477:waterfox/xUbuntu_18.04: 56.2.5.1-0] [Bintray: 56.2.3 56.2.2 56.2.1 56.2.0 56.1.0 56.0.4.1 56.0.4 56.0.3 56.0.2 56.0.1 56.0 55.2.2 55.2.1.1 55.2.0 55.1.0.1 55.1.0 55.0.2.1]
libdns162 (1:9.10.3.dfsg.P4-12.6ubuntu1)
libgimp2.0 (2.8.22-ubu18.04.1~ppa) [Ubuntu: 2.8openjdk-9-jre (9.0.4+12-4ubuntu2).22-1]
libva-x11-1 (1.8.3-2)
snapd-login-service (1.32-1)
libunistring0 (0.9.3-5.2ubuntu1)
libisccc140 (1:9.10.3.dfsg.P4-12.6ubuntu1)
libva-drm1 (1.8.3-2)
libbind9-140 (1:9.10.3.dfsg.P4-12.6ubuntu1)
waterfox (56.2.5.1-0) [obs://build.opensuse.org/home:hawkeye116477:waterfox/xUbuntu_18.04: 56.2.5.1-0] [Bintray: 56.2.4.2 56.2.4-0 56.2.3 56.2.2 56.2.1 56.2.0 56.1.0 56.0.4.1 56.0.4 56.0.3 56.0.2 56.0.1 56.0 55.2.2 55.2.1.1 55.2.0 55.1.0.1 55.1.0 55.0.2.1]
libpoppler68 (0.57.0-2ubuntu5)
gtkdialog (2:0.8.3-2) [liveusb.info: 2:0.8.3-2]
libdvdcss2 (1.4.2-1~local)
michel@Michel-E320:~$ 

Tiens je vois qu'il reste kclean et gksu de la 16.04.


A+

En ligne

#5 Le 19/12/2018, à 08:11

kholo

Re : Commande pour voir les versions de paquets différentes des dépôts

salut, les gens...
très intéressant ce truc... Nam débusqueur !!! wink
voilà mon retour sur ma machine du moment :

apt-forktracer -v
net.downloadhelper.coapp (1.2.4)
libmpx0 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libgcc-5-dev (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libobjc4 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
cpp-5 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libitm1 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libcilkrts5 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libasan2 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libquadmath0 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
gcc-5-base (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libstdc++-5-dev (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libtsan0 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libubsan0 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
g++-5 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libgfortran3 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
gcc-5 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
liblsan0 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libgomp1 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libatomic1 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libcc1-0 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
libstdc++6 (5.4.0-6ubuntu1~16.04.10->5.4.0-6ubuntu1~16.04.11) [Ubuntu: 5.4.0-6ubuntu1~16.04.11 5.4.0-6ubuntu1~16.04.10 5.3.1-14ubuntu2]
teamviewer (14.0.14470->14.1.3399) [TeamViewer GmbH: 14.1.3399 14.0.14470 13.2.26559 13.2.13582]

NB : ça semble être en full python !

cat /usr/bin/apt-forktracer
#!/usr/bin/python
# apt-forktracer - a utility for managing package versions
# Copyright (C) 2008 Marcin Owsiany <marcin@owsiany.pl>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License along
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

import sys
sys.path.insert(0, '/usr/share/apt-forktracer')
from apt_forktracer import forktracer

if __name__ == '__main__':
	forktracer.main(sys)

Hors ligne

#6 Le 19/12/2018, à 09:01

diesel83140

Re : Commande pour voir les versions de paquets différentes des dépôts

Chez moi, ça ne renvoie rien du tout. Je trouve donc que le retour est assez propre. wink smile smile

Comme quoi, je dois être assez raisonnable. wink big_smile big_smile

Amicalement.

Jean-Marie


Je déteste qu'on cherche à me faire passer pour un con, j'y arrive déjà très bien tout seul.
Le mort, il sait pas qu'il est mort ; c'est pour les autres que c'est dur.................... Pour les cons, c'est pareil.

Hors ligne

#7 Le 20/12/2018, à 21:21

pseudofab

Re : Commande pour voir les versions de paquets différentes des dépôts

Bonsoir,
Merci , je note...
Si j'ai bien interprété le retour de cette commande, mes PPAs sont à jour et ne disposent pas d'autre version tongue

~ jt'écoute :apt-forktracer -v
libpython3.6-minimal (3.6.7-1~16.04.york3) [LP-PPA-jonathonf-python-3.6: 3.6.7-1~16.04.york3]
boot-info (4ppa65) [LP-PPA-yannubuntu-boot-repair: 4ppa65 4ppa65]
audio-recorder (1.7-5~xenial) [LP-PPA-audio-recorder: 1.7-5~xenial]
libpython3.6-stdlib (3.6.7-1~16.04.york3) [LP-PPA-jonathonf-python-3.6: 3.6.7-1~16.04.york3]
youtube-dlg (0.3.8-4~xenial1.0) [LP-PPA-flexiondotorg-youtube-dl-gui: 0.3.8-4~xenial1.0 0.3.8-4~xenial1.0]
python3.6 (3.6.7-1~16.04.york3) [LP-PPA-jonathonf-python-3.6: 3.6.7-1~16.04.york3]
brscan4 (0.4.4-3)
boot-sav (4ppa65) [LP-PPA-yannubuntu-boot-repair: 4ppa65 4ppa65]
dcpl2550dnpdrv (4.0.0-1)
python3.6-minimal (3.6.7-1~16.04.york3) [LP-PPA-jonathonf-python-3.6: 3.6.7-1~16.04.york3]
boot-sav-extra (4ppa65) [LP-PPA-yannubuntu-boot-repair: 4ppa65 4ppa65]
idle-python3.6 (3.6.7-1~16.04.york3) [LP-PPA-jonathonf-python-3.6: 3.6.7-1~16.04.york3 3.6.7-1~16.04.york3]
glade2script (3.2.3~ppa4) [LP-PPA-yannubuntu-boot-repair: 3.2.3~ppa4 3.2.3~ppa4]
brscan-skey (0.2.4-1)
python3-tk (3.6.5-3~16.04.york4) [LP-PPA-jonathonf-python-3.6: 3.6.5-3~16.04.york4] [Ubuntu: 3.5.1-1]
python3-gdbm (3.6.5-3~16.04.york4) [LP-PPA-jonathonf-python-3.6: 3.6.5-3~16.04.york4] [Ubuntu: 3.5.1-1]
~ jt'écoute :

Dernière modification par pseudofab (Le 20/12/2018, à 21:23)


# Là pour le plaisir de découvrir .

# Débutant en tout ...  je me régale !

Hors ligne

#8 Le 20/12/2018, à 21:38

nam1962

Re : Commande pour voir les versions de paquets différentes des dépôts

Si je comprends bien son man et si il fait bien son boulot, oui !
Il t'indique que tes paquets qui ne sont pas dans les dépôts semblent à jour.
Il dirait autre chose si ils avaient aussi une version dépôts.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#9 Le 20/12/2018, à 23:13

Naziel

Re : Commande pour voir les versions de paquets différentes des dépôts

Sur mon petit thinkpad, il y a juste une ligne à propos de geogebra (vient d'un ppa, c'est normal)
Sur mon hp,

naziel@naziel-HP-desktop:~$ apt-forktracer -v
libreoffice-wiki-publisher (1.2.0+LibO6.0.6-0ubuntu0.18.04.1->1.2.0+LibO6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1.2.0+LibO6.0.7-0ubuntu0.18.04.2 1.2.0+LibO6.0.7-0ubuntu0.18.04.2 1.2.0+LibO6.0.3-0ubuntu1 1.2.0+LibO6.0.3-0ubuntu1]
libreoffice-math (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libreoffice-script-provider-js (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libreoffice-report-builder-bin (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
postfix (3.3.0-1ubuntu0.1->3.3.0-1ubuntu0.2) [Ubuntu: 3.3.0-1ubuntu0.2 3.3.0-1]
libwayland-egl1 (1.15.0-2~oibaf~b) [LP-PPA-paulo-miguel-dias-pkppa: 1.15.0-2~oibaf~b]
libreoffice-sdbc-postgresql (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
update-manager-core (1:18.04.11.7->1:18.04.11.8) [Ubuntu: 1:18.04.11.8 1:18.04.11.8 1:18.04.11 1:18.04.11]
libdrm-nouveau2 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libdrm-nouveau2 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
python3-software-properties (0.96.24.32.5->0.96.24.32.6) [Ubuntu: 0.96.24.32.6 0.96.24.32.6 0.96.24.32.1 0.96.24.32.1]
libllvm7 (1:7-2~oibaf~b) [LP-PPA-paulo-miguel-dias-pkppa: 1:7-2~oibaf~b]
libllvm7 (1:7-2~oibaf~b) [LP-PPA-paulo-miguel-dias-pkppa: 1:7-2~oibaf~b]
qemu-system-mips (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
qemu-system-misc (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libegl-mesa0 (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libreoffice-gtk3 (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.4->3.28.1-0ubuntu4.18.04.8) [Ubuntu: 3.28.1-0ubuntu4.18.04.8 3.28.1-0ubuntu4]
libreoffice-java-common (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
qemu-system-ppc (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libreoffice-base (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libreoffice-core (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libglapi-mesa (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libglapi-mesa (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
gnome-desktop3-data (3.28.2-0ubuntu1.1->3.28.2-0ubuntu1.2) [Ubuntu: 3.28.2-0ubuntu1.2 3.28.2-0ubuntu1.2 3.28.2-0ubuntu1.2 3.28.2-0ubuntu1.2 3.28.1-1ubuntu1 3.28.1-1ubuntu1]
update-manager (1:18.04.11.7->1:18.04.11.8) [Ubuntu: 1:18.04.11.8 1:18.04.11.8 1:18.04.11 1:18.04.11]
libreoffice-l10n-en-gb (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libreoffice-l10n-en-za (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
gnome-software (3.28.1-0ubuntu4.18.04.4->3.28.1-0ubuntu4.18.04.8) [Ubuntu: 3.28.1-0ubuntu4.18.04.8 3.28.1-0ubuntu4]
qemu-system-x86 (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libxatracker2 (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
qemu-system-s390x (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libegl1-mesa (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libreoffice-l10n-fr (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
qemu-user (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libreoffice-librelogo (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
software-properties-gtk (0.96.24.32.5->0.96.24.32.6) [Ubuntu: 0.96.24.32.6 0.96.24.32.6 0.96.24.32.1 0.96.24.32.1]
python3-uno (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libgbm1 (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libreoffice-script-provider-python (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libreoffice-style-galaxy (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libreoffice-base-core (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libwayland-client0 (1.15.0-2~oibaf~b) [LP-PPA-paulo-miguel-dias-pkppa: 1.15.0-2~oibaf~b] [Ubuntu: 1.14.0-2]
multisystem (1.0426) [liveusb.info: 1.0426 1.0426]
libdrm-amdgpu1 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libdrm-amdgpu1 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libreoffice-ogltrans (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libreoffice-impress (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
qemu (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libreoffice-style-elementary (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libgnome-desktop-3-17 (3.28.2-0ubuntu1.1->3.28.2-0ubuntu1.2) [Ubuntu: 3.28.2-0ubuntu1.2 3.28.2-0ubuntu1.2 3.28.1-1ubuntu1]
libreoffice-help-fr (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
python3-update-manager (1:18.04.11.7->1:18.04.11.8) [Ubuntu: 1:18.04.11.8 1:18.04.11.8 1:18.04.11 1:18.04.11]
qemu-utils (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libwayland-egl1-mesa (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
ure (6.0.6-0ubuntu0.18.04.1->6.0.7-0ubuntu0.18.04.2) [Ubuntu: 6.0.7-0ubuntu0.18.04.2 6.0.3-0ubuntu1]
wine-stable (3.0.4~bionic) [dl.winehq.org: 3.0.4~bionic 3.0.3~bionic 3.0.2~bionic 3.0.1~bionic] [Ubuntu: 3.0-1ubuntu1 3.0-1ubuntu1]
libreoffice-sdbc-hsqldb (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libreoffice-writer (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
qemu-system-sparc (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libreoffice-common (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libdrm2 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libdrm2 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libreoffice-script-provider-bsh (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libgl1-mesa-dri (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libgl1-mesa-dri (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
qemu-user-binfmt (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libosmesa6 (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libosmesa6 (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
winehq-stable (3.0.4~bionic) [dl.winehq.org: 3.0.4~bionic 3.0.3~bionic 3.0.2~bionic 3.0.1~bionic]
qemu-kvm (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libreoffice-nlpsolver (0.9+LibO6.0.6-0ubuntu0.18.04.1->0.9+LibO6.0.7-0ubuntu0.18.04.2) [Ubuntu: 0.9+LibO6.0.7-0ubuntu0.18.04.2 0.9+LibO6.0.7-0ubuntu0.18.04.2 0.9+LibO6.0.3-0ubuntu1 0.9+LibO6.0.3-0ubuntu1]
libgl1-mesa-glx (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libgl1-mesa-glx (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libreoffice (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
minecraft-launcher (2.1.1431)
fonts-opensymbol (2:102.10+LibO6.0.6-0ubuntu0.18.04.1->2:102.10+LibO6.0.7-0ubuntu0.18.04.2) [Ubuntu: 2:102.10+LibO6.0.7-0ubuntu0.18.04.2 2:102.10+LibO6.0.7-0ubuntu0.18.04.2 2:102.10+LibO6.0.3-0ubuntu1 2:102.10+LibO6.0.3-0ubuntu1]
libdrm-intel1 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libdrm-intel1 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libreoffice-report-builder (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
uno-libs3 (6.0.6-0ubuntu0.18.04.1->6.0.7-0ubuntu0.18.04.2) [Ubuntu: 6.0.7-0ubuntu0.18.04.2 6.0.3-0ubuntu1]
libreoffice-style-tango (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
wine-stable-i386 (3.0.4~bionic) [dl.winehq.org: 3.0.4~bionic 3.0.3~bionic 3.0.2~bionic 3.0.1~bionic]
libdrm-radeon1 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
libdrm-radeon1 (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2]
qemu-system-arm (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
mesa-vdpau-drivers (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libreoffice-help-en-gb (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libreoffice-help-en-us (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1 1:6.0.3-0ubuntu1]
libreoffice-gnome (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
wine-stable-amd64 (3.0.4~bionic) [dl.winehq.org: 3.0.4~bionic 3.0.3~bionic 3.0.2~bionic 3.0.1~bionic]
libreoffice-calc (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
geogebra5 (5.0.513.0-657050->5.0.516.0-659750) [www.geogebra.net: 5.0.516.0-659750]
qemu-block-extra (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
gnome-software-common (3.28.1-0ubuntu4.18.04.4->3.28.1-0ubuntu4.18.04.8) [Ubuntu: 3.28.1-0ubuntu4.18.04.8 3.28.1-0ubuntu4.18.04.8 3.28.1-0ubuntu4 3.28.1-0ubuntu4]
qemu-system-common (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
libreoffice-base-drivers (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libwayland-server0 (1.15.0-2~oibaf~b) [LP-PPA-paulo-miguel-dias-pkppa: 1.15.0-2~oibaf~b] [Ubuntu: 1.14.0-2]
gtkdialog (2:0.8.3-2) [liveusb.info: 2:0.8.3-2]
libreoffice-draw (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
libreoffice-avmedia-backend-gstreamer (1:6.0.6-0ubuntu0.18.04.1->1:6.0.7-0ubuntu0.18.04.2) [Ubuntu: 1:6.0.7-0ubuntu0.18.04.2 1:6.0.3-0ubuntu1]
qemu-system (1:2.11+dfsg-1ubuntu7.8->1:2.11+dfsg-1ubuntu7.9) [Ubuntu: 1:2.11+dfsg-1ubuntu7.9 1:2.11+dfsg-1ubuntu7.8 1:2.11+dfsg-1ubuntu7]
mesa-va-drivers (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libglx-mesa0 (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libglx-mesa0 (18.2.4-0~b~padoka0->18.3.0-2~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 18.3.0-2~b~padoka0] [Ubuntu: 18.0.5-0ubuntu0~18.04.1 18.0.0~rc5-1ubuntu1]
libdrm-common (2.4.91-2->2.4.96-0~b~padoka0) [LP-PPA-paulo-miguel-dias-pkppa: 2.4.96-0~b~padoka0 2.4.96-0~b~padoka0] [Ubuntu: 2.4.91-2 2.4.91-2]
libwayland-cursor0 (1.15.0-2~oibaf~b) [LP-PPA-paulo-miguel-dias-pkppa: 1.15.0-2~oibaf~b] [Ubuntu: 1.14.0-2]
software-properties-common (0.96.24.32.5->0.96.24.32.6) [Ubuntu: 0.96.24.32.6 0.96.24.32.6 0.96.24.32.1 0.96.24.32.1]
naziel@naziel-HP-desktop:~$ 

je comprends pas trop d'où viennent tous ces libreoffice, mais le reste je pense savoir d'où ça vient


[ poster correctement un retour de commande ] [ poster correctement une photo ]
Nouvel adhérent FDN
thinkpad x220, Thinkstation E32 modifié: i5-4570, GTX 1060 6 Gb, 16 Gb de RAM, ...
Pour reprendre le contrôle des semences: https://kokopelli-semences.fr/fr/

Hors ligne

#10 Le 21/12/2018, à 08:26

bruno

Re : Commande pour voir les versions de paquets différentes des dépôts

Intéressant, mais effectivement la sortie n'est pas très lisible. Je me demande ce que l'on peut faire dans ce sens avec les commandes existantes.

Avec aptitude (malheureusement pas installé par défaut) :

- listes des paquets installés dont l'«origine» n'est pas Ubuntu

aptitude search '?narrow(?installed,?not(?origin(Ubuntu)))'

- liste des paquets dont l'origine est Canonical :

aptitude search '?narrow(?installed,?origin(Canonical))'

- liste des paquets installés dont l'origine contient 'ppa' :

aptitude search '?narrow(?installed,?origin(ppa))'

- liste des paquets installés dont le nom de l'archive ne contient pas 'bionic' :

aptitude search '?narrow(?installed,?not(?archive(bionic)))'

On doit pouvoir faire la même chose avec apt-cache search, mais j'ai la flemme de chercher les regexp pour le faire wink

Dernière modification par bruno (Le 21/12/2018, à 08:27)

Hors ligne

#11 Le 22/12/2018, à 17:28

LeoMajor

Re : Commande pour voir les versions de paquets différentes des dépôts

bonjour,

aptitude search '~i (~Vppa|~Oppa)' --disable-columns -F %p" § "%v 
..
arc-theme § 16.04~xenial~NoobsLab.com
libgtop11dotnet0 § 2.2.0.12-0~ppa+xenial1
..

Hors ligne

#12 Le 22/12/2018, à 17:45

nam1962

Re : Commande pour voir les versions de paquets différentes des dépôts

On m'avait dit qu'il ne fallait pas faire cohabiter apt-get et aptitude, est-ce aussi le cas pour apt ?


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#13 Le 28/12/2018, à 14:46

bruno

Re : Commande pour voir les versions de paquets différentes des dépôts

C'est qui « on » ? J'ai toujours utilisé les deux et je n'ai jamais eu le moindre souci. aptitude m'a même plusieurs fois trouvés des solutions là où apt/apt-get échoue lamentablement…

Hors ligne

#14 Le 28/12/2018, à 15:21

Naziel

Re : Commande pour voir les versions de paquets différentes des dépôts

aptitude est très fort pour résoudre les problèmes de dépendances effectivement.


[ poster correctement un retour de commande ] [ poster correctement une photo ]
Nouvel adhérent FDN
thinkpad x220, Thinkstation E32 modifié: i5-4570, GTX 1060 6 Gb, 16 Gb de RAM, ...
Pour reprendre le contrôle des semences: https://kokopelli-semences.fr/fr/

Hors ligne

#15 Le 28/12/2018, à 16:00

michel_04

Re : Commande pour voir les versions de paquets différentes des dépôts

Bonjour,


bruno a écrit :

C'est qui « on » ? J'ai toujours utilisé les deux …

Peut être à cause d'une ancienne note (note annotée depuis Lenny wink ) dans le Chapitre 2. Gestion des paquets Debian du Manuel Référence Debian ?

Gestion des paquets Debian a écrit :

Note

Bien que la commande aptitude soit disponible avec de riches fonctionnalités comme son solveur de paquets avancé, cette complexité a causé (et peut encore causer) certaines régressions comme le bogue #411123, le bogue #514930 et le bogue #570377. En cas de doute, veuillez utiliser les commandes apt, apt-get et apt-cache plutôt que la commande aptitude.

Gestion des paquets Debian (correctif) a écrit :

Note

Puisqu’apt / apt-get et aptitude partagent l’état de paquet installé automatiquement (consultez Section 2.5.5, « État des paquets pour APT ») après lenny, vous pouvez mélanger ces outils sans trop de problème (consultez le Bogue #594490).

Depuis Thu, 26 Aug 2010 11:48:01 UTC, on peut utiliser sans problème apt-get, apt et aptitude. big_smile


A+

Dernière modification par michel_04 (Le 28/12/2018, à 16:06)

En ligne

#16 Le 28/12/2018, à 17:20

nam1962

Re : Commande pour voir les versions de paquets différentes des dépôts

Merci, voilà mon info enfin mise à jour ! tongue


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne