Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/12/2018, à 14:28

guillaume32

Problème swap/Hibernation

Bonjour,

Je reviens vers ce forum car je souhaiterais mettre mon ordinateur en hibernation afin d'économiser de la batterie. J'ai eu l'occasion de suivre quelques tutos pour mettre en œuvre l'hibernation, problème rien ne fonctionne.
Bon, j'ai commencé par agrandir ma partition swap pour qu'elle soit de la même taille que la RAM de ma machine (4GO). Voici un petit détail des mes partitions :

Périphérique      Début        Fin  Secteurs Taille Type
/dev/sda1          2048     206847    204800   100M Système EFI
/dev/sda2        206848     239615     32768    16M Réservé Microsoft
/dev/sda3        239616  488520865 488281250 232,9G Données de base Microsoft
/dev/sda4    1951426560 1953523711   2097152     1G Environnement de récupération
/dev/sda5     488521728 1172113407 683591680   326G Système de fichiers Linux
/dev/sda7    1172113408 1941280767 769167360 366,8G Données de base Microsoft
/dev/sda8    1941280768 1951426559  10145792   4,9G Partition d'échange Linux

sda1 à sda4, c'est du windows, sur la 5 j'ai installé ubuntu, la 7 me sert de partage entre les deux OS et enfin la 8, c'est la partition de swap pour ubuntu.
Lorsque je teste la commande :

sudo systemctl hibernate

Le terminal me retourne :

Failed to hibernate system via logind: Sleep verb not supported

Si je teste la commande, sudo pm-hibernate, ça n'as aucun effet.
Bref, suite à quelques recherches, j'ai l'impression que la partition swap n'est pas vraiment reconnue par ubuntu, ce qui me fais dire ça, c'est mon fichier /etc/fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=c85911a0-e491-4b06-bc29-f75fb8b42871 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=80F1-3327  /boot/efi       vfat    umask=0077      0       1
/swapfile                                    none            swap    sw  $
 

Enfin, je suis un peu nouveau sur linux alors je sais pas si je suis sur la bonne voit et j'ai peur de faire des bêtises, si quelqu'un pourrai me venir en aide, je lui serai très reconnaissant.

Cordialement

Guillaume

Dernière modification par guillaume32 (Le 30/12/2018, à 14:42)

Hors ligne

#2 Le 30/12/2018, à 15:50

Babdu89

Re : Problème swap/Hibernation

Bonjour.

Oui, dans le fstab, on voit que l’installation de ton Ubuntu (18.04 ?) n'utilise pas une partition swap, mais le fichier wap-file

/swapfile                                    none            swap    sw  $

Voir la doc;

https://doc.ubuntu-fr.org/swap

Je ne sais pas si le swap-file est utilisable pour l'hibernation.

https://doc.ubuntu-fr.org/veille_et_hibernation

https://doc.ubuntu-fr.org/tutoriel/activer_hibernation


@+.   Babdu89   .

Dernière modification par Babdu89 (Le 30/12/2018, à 17:06)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#3 Le 30/12/2018, à 17:31

guillaume32

Re : Problème swap/Hibernation

Bonjour,
Merci pour ta réponse, j'ai un avancé un peu, effectivement c'est un swap sous forme de fichier, mais j'ai bien créé une partition swap de 4.9 GO, ma ram est de 4 GO.
J'ai donc rajouté une ligne au fichier /etc/fstab

UUID=numéroUUID  none swap sw 0 0

Comme indiqué sur la doc espace d'échange swap. J'ai ensuite suivie le tuto en modifiant le fichier /etc/initramfs-tools/conf.d/resume comme indiqué, également /etc/default/grub puis j'ai fait les update (update-grub et update-initramfs -u -k $(uname -r)). après tout ça, quand j'execute la commande "pm-hibernate" mon écran s'éteint mais pas le pc, le ventillo et la led d'allumage reste allumé. Il doit encore me manquer quelques chose mais je ne trouve pas.

Guillaume

Hors ligne

#4 Le 30/12/2018, à 18:22

Babdu89

Re : Problème swap/Hibernation

Dans le fstab.
Tu as commenté la ligne ?;

 /swapfile                                    none            swap    sw  $ 

pour qu'elle devienne;

#/swapfile                                    none            swap    sw  $ 

Sinon le fichier et la partition seront pris en compte.

Tu as installé le paquet  pm-utils  ?

@+.   Babdu89  .

Dernière modification par Babdu89 (Le 30/12/2018, à 18:30)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#5 Le 30/12/2018, à 20:42

guillaume32

Re : Problème swap/Hibernation

En effet je n'ai pas commenté cette ligne, je vais essayé ça, et oui le paquet pm-utils est bien installé, j'en suis sur car si je fais pm-suspend mon ordinateur se met en veille.

Guillaume

Hors ligne

#6 Le 30/12/2018, à 21:13

guillaume32

Re : Problème swap/Hibernation

Je viens d'essayer et le résultat reste malheureusement le même hmm.

Guillaume

Hors ligne

#7 Le 31/12/2018, à 00:23

Babdu89

Re : Problème swap/Hibernation

Alors, désolé, mais je n'ai plus d'idée pour le moment pour t'aider.

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#8 Le 31/12/2018, à 13:53

guillaume32

Re : Problème swap/Hibernation

Merci à toi, si quelqu'un d'autre à une idée, je suis preneur smile.

Guillaume

Hors ligne

#9 Le 31/12/2018, à 14:23

michel_04

Re : Problème swap/Hibernation

Bonjour,


Tu as suivi Comment activer l'hibernation ?
Quels retours pour les commandes proposées ?


A+

Hors ligne

#10 Le 31/12/2018, à 18:11

guillaume32

Re : Problème swap/Hibernation

Bonjour, oui j'ai suivi ce tuto, la commande pm-hibernate éteint juste mon écran, le ventilo et la led d'allumage reste allumé, je suis obliger d'éteindre mon ordinateur sauvagement en restant appuyé sur le bouton power.
Pour la commande "sudo update-initramfs -u -k $(uname -r)" voici ce qu'elle me retourne :

update-initramfs: Generating /boot/initrd.img-4.15.0-43-generic

Guillaume

Dernière modification par guillaume32 (Le 03/01/2019, à 19:54)

Hors ligne

#11 Le 04/01/2019, à 11:56

guillaume32

Re : Problème swap/Hibernation

Bonjour,

Quand je démarre mon pc, j'ai un message d'erreur concernant resume/hibernation, ça peux aider sûrement, je met le début du message car il est très long :

1546595483-capture-d-ecran-de-2019-01-04-09-54-44.png]erreur

Je pense que le problème viens du kernel, le truc c'est que je ne comprend pas grand chose à ce truc, comment je sais quel kernel il faut que j'installe ?

Cordialement

guillaume

Dernière modification par guillaume32 (Le 04/01/2019, à 12:41)

Hors ligne

#12 Le 04/01/2019, à 13:50

Papoon

Re : Problème swap/Hibernation

Peut être cela va t'il t'aider.

J'avais installé Ubuntu 18.4 avec 4Go de Swap et lorsque mon ordi était en veille (hibernation doit être la même chose) l'écran restait noir ou avec des petits traits de couleurs et seule la flèche de la souris fonctionnait.
J'étais obligé de rebooter à la dure.

J'ai lu quelques part que la partition swap ne servait à rien quand on avait beaucoup de RAM (j'en ai 16Go)... bon ok, novice je ré-installe sans partition Swap.

L'ordi fonctionne bien mais dès que je ferme le capot, même résultat, l'écran plante et je suis obligé de redémarrer à la dure.

Je tente alors de re distribuer ma partition /home pour laisser 16Go de Swap.

Hourra ça fonctionne, nickel...

Je redescends la partition swap à 8Go et ça fonctionne aussi.

Force est de constater que 4go pour le/la SWAP n'est pas assez.

Par contre maintenant je ne sais pas ré allouer les 8 Go de vide à la partition /home


G5 Dell - i7 8750H - GXForce 1050 Ti  - 16go de RAM - ubuntu 19.4

Hors ligne

#13 Le 04/01/2019, à 21:21

Papoon

Re : Problème swap/Hibernation

Finalement je ne sais pas si je n'ai pas raconté des bêtises car je viens de faire une re-install avec 8Go de swap et ca re-plante


G5 Dell - i7 8750H - GXForce 1050 Ti  - 16go de RAM - ubuntu 19.4

Hors ligne

#14 Le 04/01/2019, à 21:36

guillaume32

Re : Problème swap/Hibernation

Salut papoon, en fait la mise en veille et l'hibernation ne sont pas la même chose. Quand on fait une hibernation, tous les processus sont enregistrés dans la partition swap puis le pc est éteint, d'où le fait que la partition doit être au moins égale à la RAM. Alors qu'en mise en veille, les processus reste sur la RAM qui reste donc alimenté.
Dans mon cas la mise en veille fonctionne très bien. Et pour ton cas, je pense pas que la swap n'a rien à voir avec ton problème. Pour réalouer ta mémoire sur ton home, boute ton pc sur une clef ou le cd d'installation en faisant essayer ubuntu, et ensuite avec le logiciel Gparted tu peux le faire.
Merci pour ton message smile

Cordialement

Guillaume

Hors ligne

#15 Le 04/01/2019, à 21:37

nam1962

Re : Problème swap/Hibernation

Jamais pigé l'intérêt de l'hibernation, mais bon.
@Papoon : de ce que je comprend de l'hibernation en elle même, elle va stocker la conso instantanée de RAM + swap dans la swap, donc, par définition ta swapfile ou ta partition swap doit être largement plus grande que la RAM (un multiple en principe) pour éviter la plantade.

Dans tous les cas, je conseille d'avoir, en amont, réglé la swappiness agressivement pour maximiser l'usage de la RAM (et donc minimiser la swap :

echo vm.swappiness=5 | sudo tee -a /etc/sysctl.d/99-sysctl.conf
echo vm.vfs_cache_pressure=50 | sudo tee -a /etc/sysctl.d/99-sysctl.conf
sudo sysctl -p /etc/sysctl.d/99-sysctl.conf

@guillaume32 en plus de çà, pour savoir l'organisation de ta swap et ce qui est dispo :

cat /proc/swaps

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#16 Le 04/01/2019, à 21:47

guillaume32

Re : Problème swap/Hibernation

Salut nam1962, l'interêt de l'hibernation est de "mettre en veille un pc" sans fermer le travail commencé et économiser l'énergie, bref chaqu'un y voit ses avantages.
J'ai pas bien compris les 3 premières lignes de code que tu as mis, ça sert à maximiser l'utilisation de la RAM par rapport à la swap ?

guillaume32

Hors ligne

#17 Le 04/01/2019, à 21:49

nam1962

Re : Problème swap/Hibernation

Oui

Dernière modification par nam1962 (Le 04/01/2019, à 21:53)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#18 Le 04/01/2019, à 21:53

guillaume32

Re : Problème swap/Hibernation

D'acc, je viens de le faire, voici ce que me retourne la dernière commande :

$ cat /proc/swaps
Filename				Type		Size	Used	Priority
/dev/sda8                               partition	5072892	38392	-2

Hors ligne

#19 Le 04/01/2019, à 21:55

nam1962

Re : Problème swap/Hibernation

Ok, donc un peu plus que la RAM, mais comme tu vois, tu swappes, donc ce sera limite (il faut juste voir si tu swappes toujours après redémarrage avec le nouveau réglage de swappiness.)


Sinon je comprends mieux : l'hibernation c'est ajouter un moyen supplémentaire de perdre le boulot récent tongue
Je vois que c'est désactivé par défaut : https://doc.ubuntu-fr.org/veille_et_hib … ibernation pas plus mal !

Dernière modification par nam1962 (Le 04/01/2019, à 21:56)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#20 Le 04/01/2019, à 22:06

guillaume32

Re : Problème swap/Hibernation

Bon, apparemment le paramétrage à fonctionné et pour le tuto je l'ai déjà fait.

cat /proc/swaps
Filename				Type		Size	Used	Priority
/dev/sda8                               partition	5072892	0	-2

Hors ligne

#21 Le 04/01/2019, à 22:10

uboops

Re : Problème swap/Hibernation

Re
Il faudrait modifier probablement, et ajouter: resume=UUID=UUID-SWAP :

blkid # pour uuid swap
cat /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=785--la-swap--1952c0d"

update-grub
cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-4.20.0 root=UUID=8543--la-racine--6b97 ro resume=UUID=785--la-swap--1952c0d

Ubuntu 16.04-LTS, MX18-LTS, Win7-LTS - avec rEFInd + Grub ... et ncdu, Timeshift ... pour le LTS aussi ;-)

Hors ligne

#22 Le 04/01/2019, à 22:11

nam1962

Re : Problème swap/Hibernation

Moins il y aura de used, mieux ce sera pour ton hibernation, sinon, ce sera vite serré.
Sinon, pour voir l'impact du réglage de swappiness, en fait il faudrait exactement la même session qu'avant (mêmes logiciels ouverts, même historique.)

Mais avec

free -m

tu constateras en principe que tu swappes très tard (ou pas)

Dernière modification par nam1962 (Le 04/01/2019, à 22:12)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#23 Le 04/01/2019, à 22:21

guillaume32

Re : Problème swap/Hibernation

salut uboops, j'ai déja fait ça mis resume=UUID=....swap.. mais je l'ai mis dans "GRUB_CMDLINE_LINUX" et dans le default aussi, peut-être qu'il ne fallait pas le mettre dans les deux ?

cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=ab52af33-4758-4361-8965-73e3afcdb820"
GRUB_CMDLINE_LINUX="resume=UUID=ab52af33-4758-4361-8965-73e3afcdb820"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Ta deuxième commande me répond ça :

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=c85911a0-e491-4b06-bc29-f75fb8b42871 ro resume=UUID=ab52af33-4758-4361-8965-73e3afcdb820 quiet splash resume=UUID=ab52af33-4758-4361-8965-73e3afcdb820 vt.handoff=1

nam1962, j'ai fait en sorte d'ouvrir les mêmes processus, voir un peu plus.

free -m
              total       utilisé      libre     partagé tamp/cache   disponible
Mem:           3886        1656        1101          54        1128        1949
Partition d'échange:        4953           0        4953

Hors ligne

#24 Le 05/01/2019, à 01:10

uboops

Re : Problème swap/Hibernation

guillaume32 a écrit :

salut uboops, j'ai déja fait ça mis resume=UUID=....swap.. mais je l'ai mis dans "GRUB_CMDLINE_LINUX" et dans le default aussi, peut-être qu'il ne fallait pas le mettre dans les deux ?
...
Ta deuxième commande me répond ça :

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=c85911a0-e491-4b06-bc29-f75fb8b42871 ro resume=UUID=ab52af33-4758-4361-8965-73e3afcdb820 quiet splash resume=UUID=ab52af33-4758-4361-8965-73e3afcdb820 vt.handoff=1

... Ah ben du coup il y en a un de trop (je le laisserais plutôt que dans le default)

Pour voir si ça marche (test d'hibernation, puis reboot)

sudo -s
echo reboot > /sys/power/disk
echo disk > /sys/power/state
# ... Attendre que ça redémarre

... Et le système , crée l'image d'hibernation, puis reboote, puis doit revenir dans l'état initial dans le terminal précédent (ça marche chez moi avec mon kernel )

Dernière modification par uboops (Le 05/01/2019, à 01:26)


Ubuntu 16.04-LTS, MX18-LTS, Win7-LTS - avec rEFInd + Grub ... et ncdu, Timeshift ... pour le LTS aussi ;-)

Hors ligne

#25 Le 05/01/2019, à 11:01

Papoon

Re : Problème swap/Hibernation

bon plus simple,  finalement j'ai installé la version ubuntu 18.10 et tout fonctionne. Plus de problème d'écran figé au réveil.


G5 Dell - i7 8750H - GXForce 1050 Ti  - 16go de RAM - ubuntu 19.4

Hors ligne