Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous souhaite d'excellentes fêtes de fin d'année !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/01/2019, à 16:31

Ubuntux31

Problème de son sur Asus X206HA - Ubuntu 18.04

Bonjour tout le monde,

Voilà cela fait deux jours que je bute sur un problème de son après avoir installé Ubuntu 18.04 sur mon Asus X206HA,
J'ai parcourus tous les sujets relatifs à ce problème sur le forum et toutes mes tentatives ont échouées,
À présent je viens solliciter votre aide et pour cela je vous met ci dessous les informations qui pourraient vous être utiles.
Sachant que j'ai suivi les tutos suivants :

Probleme de son et de video lubuntu 18.04 sur netbook asus X206H
https://forum.ubuntu-fr.org/viewtopic.php?id=2029054
Carte son non prise en compte Asus x206h
https://forum.ubuntu-fr.org/viewtopic.php?id=1992597
Alsa, installation et configuration
https://forum.ubuntu-fr.org/viewtopic.php?id=1821191

Plus d'autres pour lesquels je n'ai pas pensé à relever l'adresse des pages

Aussi lorsque j'ouvre AlsaMixer il est inscrit : "Ce périphérique" n'a pas de commandes."
Cela voudrait il dire que ma carte son n'est reconnu ?
Serait-ce un problème de driver (ce modèle de PC étant connu pour cette panne) ?
Pour en être sûr j'ai installé le Kernel proposé sur https://github.com/Grippy98/Asus-E200HA … all-Script mais cela n'a strictement rien changé...

Les infos de mon poste :

marilys@marilys-E200HA:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"
marilys@marilys-E200HA:~$ lspci | grep [Aa]udio && lsusb | grep [Aa]udio
marilys@marilys-E200HA:~$
marilys@marilys-E200HA:~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.15.0-43-generic.
marilys@marilys-E200HA:~$ uname -a
Linux marilys-E200HA 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
marilys@marilys-E200HA:~$ lspci -v
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 22)
    Subsystem: ASUSTeK Computer Inc. Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register
    Flags: bus master, fast devsel, latency 0
    Kernel driver in use: iosf_mbi_pci

00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 22) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers
    Flags: bus master, fast devsel, latency 0, IRQ 121
    Memory at 90000000 (64-bit, non-prefetchable) [size=16M]
    Memory at 80000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 22)
    Subsystem: ASUSTeK Computer Inc. Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller
    Flags: fast devsel, IRQ 131
    Memory at 91639000 (64-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: proc_thermal
    Kernel modules: processor_thermal_device

00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 22) (prog-if 30 [XHCI])
    Subsystem: ASUSTeK Computer Inc. Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller
    Flags: bus master, medium devsel, latency 0, IRQ 117
    Memory at 91600000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: xhci_hcd

00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 22)
    Subsystem: ASUSTeK Computer Inc. Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine
    Flags: bus master, fast devsel, latency 0, IRQ 132
    Memory at 91500000 (32-bit, non-prefetchable) [size=1M]
    Memory at 91400000 (32-bit, non-prefetchable) [size=1M]
    Capabilities: <access denied>
    Kernel driver in use: mei_txe
    Kernel modules: mei_txe

00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 22) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0, IRQ 116
    Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
    Memory behind bridge: 91200000-913fffff
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 22)
    Subsystem: ASUSTeK Computer Inc. Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU
    Flags: bus master, medium devsel, latency 0
    Capabilities: <access denied>
    Kernel driver in use: lpc_ich
    Kernel modules: lpc_ich

01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)
    Subsystem: AzureWave QCA9377 802.11ac Wireless Network Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 133
    Memory at 91200000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: <access denied>
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
marilys@marilys-E200HA:~$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 22)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 22)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 22)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 22)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 22)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 22)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 22)
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)
marilys@marilys-E200HA:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: Audio [Intel HDMI/DP LPE Audio], périphérique 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: Audio [Intel HDMI/DP LPE Audio], périphérique 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: Audio [Intel HDMI/DP LPE Audio], périphérique 2: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

J'espère que vous pourrez me venir en aide car là je sèche et désespère...

Vous en remerciant par avance ! smile

Dernière modification par Ubuntux31 (Le 05/01/2019, à 17:34)

Hors ligne

#2 Le 05/01/2019, à 22:56

hibou7

Re : Problème de son sur Asus X206HA - Ubuntu 18.04

Bonsoir

Dans tes essais, en 4e position, tu as installé un noyau alternatif qui devrait permettre d'avoir du son sur ce modèle Asus:
https://github.com/Grippy98/Asus-E200HA … all-Script

As-tu bien démarré ta machine sur ce noyau? En voyant

marilys@marilys-E200HA:~$ uname -a
Linux marilys-E200HA 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

j'ai l'impression que tu es toujours sur le noyau habituel (c'est celui que j'utilise aussi actuellement).

Pour démarrer sur un noyau alternatif, tu devras passer par grub-pc
Pour accéder à grub, tiens la touche "Shift" (= "Maj") enfoncée au démarrage du pc, une liste de noyaux possibles va s'afficher. Dans cette liste tu devrais trouver le noyau 4.12-rc6.
Déplace-toi sur cette ligne avec la flèche "bas" et démarre.

Dernière modification par hibou7 (Le 05/01/2019, à 23:01)


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio 
Les tutos vidéo d'Alexis. Madrzejewski: http://www.tutoriels-video.fr/category/tutoriel-video/
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne

#3 Le 06/01/2019, à 19:44

Ubuntux31

Re : Problème de son sur Asus X206HA - Ubuntu 18.04

Bonsoir Hibou7,
Effectivement je râle, mais je n'ai pas fais le changement de noyau au démarrage d'Ubuntu donc il est normal que je n'ai pas de résultat.
Je suis entrain de ré-installer le script et reviens vers toi pour te dire ce qu'il en est.
Merci en tout cas d'avoir pris le temps de pointer mon erreur.

Edit :
J'ai donc redémarré sur le bon kernel, seulement celui-ci n'a rien changé.
- Je n'ai plus l'icône son
- Pulseaudio ne se lance plus (loader en boucle)
- Quand j'ouvre alsamixer j'ai la carte "chtcx2072x" qui remonte mais toujours pas de son

Du coup j'ai fais une recherche sur cette carte et j'ai trouvé ces fils :
https://bugzilla.kernel.org/show_bug.cgi?id=115531 (avec la présence de Pierre Bossart)
https://forum.manjaro.org/t/asus-e200ha … d/44205/13
https://forums.linuxmint.com/viewtopic.php?t=274487

Qui m'ont amené vers ce tuto qui semblerait résoudre ce pb de son mais à vrai dire je n'y comprend pas grand chose...
https://github.com/heikomat/linux/tree/ … and_manual

Si Hibou7 ou quelqu'un de l'équipe pourrait me filer un coup de main, je lui en serai bien reconnaissant... je suis épuisé par toutes ces recherches / install / ré-install / changement de distrib / ...

Merci à vous

Dernière modification par Ubuntux31 (Le 06/01/2019, à 21:33)

Hors ligne

#4 Le 07/01/2019, à 00:22

hibou7

Re : Problème de son sur Asus X206HA - Ubuntu 18.04

Bravo pour tes recherches!
Avant de se lancer dans ce tuto, j'amerais mettre au clair quelques points,

chtcx2072x est le pilote pour la carte son, la carte son elle-même s'appelle Intel-ssd ou intel-ssd-acpi.
Peux-tu envoyer le retour de commande de

sudo lshw

pour qu'on puisse voir ça?

Pourrais-tu aussi envoyer une copie de ton dmesg, pour voir si tu as un message se rapportant à la carte son (comme chez Gianmaria Scorza)?

Le tuto que tu as trouvé https://github.com/heikomat/linux/tree/ … and_manual est fait pour un Asus X200HA, mais il est dit "devices like the Asus E200HA"
As tu trouvé une info qui te fait penser que ça marchera aussi sur un X206HA?

... je suis épuisé par toutes ces recherches / install / ré-install / changement de distrib / ...

Si tu en as assez du cambouis, il y aussi une solution plus radicale: changer la carte son.
Tu en prends une bien reconnue par Linux et ça devrait le faire aussi. smile

Dernière modification par hibou7 (Le 07/01/2019, à 00:41)


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio 
Les tutos vidéo d'Alexis. Madrzejewski: http://www.tutoriels-video.fr/category/tutoriel-video/
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne

#5 Le 07/01/2019, à 07:01

xubu1957

Re : Problème de son sur Asus X206HA - Ubuntu 18.04

Bonjour,

Le 06/01/2019, Ubuntux31 a écrit :

Bonjour tout le monde,

Je me permet de relancer le sujet car cela fait trois jours maintenant que je galère sur cette histoire de son je n'en peux plus.

Pourriez-vous s'il vous plait m'aider à suivre le tuto proposé sur :
https://github.com/heikomat/linux/tree/ … and_manual

Voici mon post d'hier sur ce sujet :
https://forum.ubuntu-fr.org/viewtopic.p … #p22031936

Par avance je vous en remercie...

Réponse de Caribou22 > [Non Résolu] Pas de son sur mon Notebook X206H :

Le 06/01/2019, Caribou22 a écrit :

Bonsoir smile

Tu t'es déjà servi d'un terminal ?
La procédure à faire dans une fenêtre de terminal. Il faut entrer successivement entrer ces commandes en ayant une connexion Internet active :

wget -qO- https://gist.github.com/heikomat/3fe272431b44b580c933bfb901a92257/raw | bash
sudo dpkg --install LINUX_IMAGE_DEB_PACKAGE.deb
sudo dpkg --install LINUX_HEADERS_DEB_PACKAGE.deb
sudo apt install pulseaudio
sudo apt install linux-firmware
sudo mkdir --parents /usr/share/alsa/ucm/chtcx2072x
cd /usr/share/alsa/ucm/chtcx2072x
sudo wget "https://raw.githubusercontent.com/heikomat/linux/cx2072x/cx2072x_fixes_and_manual/chtcx2072x/HiFi.conf"
sudo wget "https://raw.githubusercontent.com/heikomat/linux/cx2072x/cx2072x_fixes_and_manual/chtcx2072x/chtcx2072x.conf"
sudo sed --in-place --regexp-extended --expression='s/;?\s*realtime-scheduling\s*=\s*(yes|no)/realtime-scheduling = no/g' /etc/pulse/daemon.conf
sudo reboot

Et ça devrait marcher !

Dernière modification par xubu1957 (Le 07/01/2019, à 07:08)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne