Contenu | Rechercher | Menus

Annonce

Ubuntu Party les 18 et 19 mai 2019 à Paris
Grand rendez-vous tout public organisé par Ubuntu-FR, avec install-party, ateliers et conférences.
Venez y (re)découvrir ou faire découvrir le Libre et Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/02/2019, à 15:36

oliver2004

Installation Postfix/Dkim/Dspam/Dovecot - petits soucis...

Bonjour à tous,
J'ai suivi le tuto du lien https://linuxfr.org/news/heberger-son-courriel qui explique comment installer Postfix/Dkim/Dspam/Dovecot sur son serveur.
J'avais tenté une installation postfix avec saslauthd mais bruno était intervenu dans le topic posté sur les petits soucis rencontrés alors et m'avait conseillé de parier sur une installation avec dovecot en suivi le lien cité.

Pluseurs thèmes.
Je suis sur OVH en ce qui concerne mes domaines et je ne peux publier la clef publique dans le DNS... impossible de valider... ça je vais le voir avec OVH.
Ensuite, le paquet dspam ne semble pas exister, je ne le trouve pas, impossible donc de l'installer... j'ai donc zapé cette étape, ce qui doit être la cause des erreurs qui sont générées ensuite.

D'abord, je n'ai pas d'erreur apparente lors du redémarrage de Postfix et de Dovecot, par contre, je ne peux redémarrer Dkim .

$ sudo service dkim restart
Failed to restart dkim.service: Unit dkim.service not found.

Ou peut-être est ce normal ?
[EDIT] Pardon, cette partie est OK, le service était opendkim non pas dkim... c'est donc ok, j'ai redémarré

Je tente un envoi par telnet via le port 587 comme défini dans les configuration du tuto:

$ telnet localhost 587
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 domaine.com ESMTP Postfix (Ubuntu)
ehlo domaine.com
250-domaine.com
250-PIPELINING
250-SIZE 10485760
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 SMTPUTF8

500 5.5.2 Error: bad syntax
MAIL FROM: oliver@gmail.com
530 5.7.0 Must issue a STARTTLS command first

500 5.5.2 Error: bad syntax

Ça a l'air de bien démarrer mais ensuite, impossible d'aller en avant ?
Et ce que je ne vois pas dans la liste des 250, c'est 250-AUTH qui n'y est pas...

J'ai tenté un envoi par php, les logs me renvoient ceci :

Feb 16 09:38:58 vps102968 postfix/pickup[7112]: 3F10E2373DC: uid=33 from=<www-data>
Feb 16 09:38:58 vps107868 postfix/cleanup[7135]: warning: connect to Milter service unix:/var/run/opendkim/opendkim.sock: No such file or directory
Feb 16 09:38:58 vps107868 postfix/cleanup[7135]: 3F10E2373DC: milter-reject: CONNECT from localhost[127.0.0.1]: 4.7.1 Service unavailable - try again later; from=<www-data@server1.domaine.com>
Feb 16 09:38:58 vps107868 postfix/pickup[7112]: 3FC3F2373DC: uid=33 from=<www-data>
Feb 16 09:38:58 vps107868 postfix/cleanup[7135]: warning: connect to Milter service unix:/var/run/opendkim/opendkim.sock: No such file or directory
Feb 16 09:38:58 vps107868 postfix/cleanup[7135]: 3FC3F2373DC: milter-reject: CONNECT from localhost[127.0.0.1]: 4.7.1 Service unavailable - try again later; from=<www-data@server1.domaine.com>

Le socket unix:/var/run/opendkim/opendkim.sock a pourtant bien été modifié à local:/var/spool/postfix/var/run/opendkim/opendkim.sock,
du coup le service est unvailable...

Dernière modification par oliver2004 (Le 16/02/2019, à 16:30)


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne

#2 Le 16/02/2019, à 16:27

oliver2004

Re : Installation Postfix/Dkim/Dspam/Dovecot - petits soucis...

Après le redémarrage de Dkim, les deux mails envoyés par php avant redémarrage à ma boîte mail sont arrivés, ils devaient être en fil d'attente ouf, c'est un pas... par contre, ça n'arrive pas sur gmail... roll

Avec connexion sur telnet sur le port 587 :

$ telnet localhost 587
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 domaine.com ESMTP Postfix (Ubuntu)
MAIL FROM: oli@gmail.com
530 5.7.0 Must issue a STARTTLS command first

Envoyé via php, certains mails partent et arrivent, comme celui-ci :

Feb 16 10:16:37 vps107868 postfix/pickup[7447]: 09C472373DE: uid=33 from=<www-data>
Feb 16 10:16:37 vps107868 postfix/cleanup[7630]: 09C472373DE: message-id=<20190216151637.09C472373DE@domaine.com>
Feb 16 10:16:37 vps107868 postfix/qmgr[7448]: 09C472373DE: from=<www-data@server1.domaine.com>, size=3483, nrcpt=1 (queue active)
Feb 16 10:16:44 vps107868 postfix/smtp[7631]: 09C472373DE: to=<clarisse@mail.com>, relay=mx1.mail.ovh.net[188.165.36.237]:25, delay=7.2, delays=0.03/0.01/6.6/0.57, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 441tyN0MMfz847G9)
Feb 16 10:16:44 vps107868 postfix/qmgr[7448]: 09C472373DE: removed

Et d'autres non : Connexion refusée, je ne sais pourquoi ?

Feb 16 10:20:18 vps107868 postfix/qmgr[7448]: 837982373DF: from=<>, size=6214, nrcpt=1 (queue active)
Feb 16 10:20:18 vps107868 postfix/lmtp[7646]: connect to 127.0.0.1[127.0.0.1]:2424: Connection refused
Feb 16 10:20:18 vps107868 postfix/lmtp[7646]: 837982373DF: to=<www-data@server1.domaine.com>, relay=none, delay=353, delays=353/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:2424: Connection refused)
Feb 16 10:20:50 vps107868 postfix/pickup[7447]: 490492373DE: uid=33 from=<www-data>
Feb 16 10:20:50 vps107868 postfix/cleanup[7652]: 490492373DE: message-id=<20190216152050.490492373DE@domaine.com>
Feb 16 10:20:50 vps107868 postfix/qmgr[7448]: 490492373DE: from=<www-data@server1.domaine.com>, size=3483, nrcpt=1 (queue active)
Feb 16 10:20:57 vps107868 postfix/smtp[7653]: 490492373DE: to=<oliver@mail.com>, relay=mx1.mail.ovh.net[188.165.36.237]:25, delay=7.2, delays=0.03/0.01/7.2/0, dsn=5.6.7, status=bounced (SMTPUTF8 is required, but was not offered by host mx1.mail.ovh.net[188.165.36.237])
Feb 16 10:20:57 vps107868 postfix/cleanup[7652]: 84B472373E1: message-id=<20190216152057.84B472373E1@domaine.com>
Feb 16 10:20:57 vps107868 postfix/bounce[7654]: 490492373DE: sender non-delivery notification: 84B472373E1
Feb 16 10:20:57 vps107868 postfix/qmgr[7448]: 84B472373E1: from=<>, size=6214, nrcpt=1 (queue active)
Feb 16 10:20:57 vps107868 postfix/qmgr[7448]: 490492373DE: removed
Feb 16 10:20:57 vps107868 postfix/lmtp[7646]: connect to 127.0.0.1[127.0.0.1]:2424: Connection refused
Feb 16 10:20:57 vps107868 postfix/lmtp[7646]: 84B472373E1: to=<www-data@server1.domaine.com>, relay=none, delay=0.01, delays=0.01/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:2424: Connection refused)

Et en ce qui concerne Gmail : NETWORK UNREACHABLE... je vois que ça se connecte sur le port 25 et non 587 ?? C'est normal ?

Feb 16 10:23:18 vps107868 postfix/pickup[7447]: 3CB5E2373DE: uid=33 from=<www-data>
Feb 16 10:23:18 vps107868 postfix/cleanup[7661]: 3CB5E2373DE: message-id=<20190216152318.3CB5E2373DE@domaine.com>
Feb 16 10:23:18 vps107868 postfix/qmgr[7448]: 3CB5E2373DE: from=<www-data@server1.domaine.com>, size=3471, nrcpt=1 (queue active)
Feb 16 10:23:18 vps107868 postfix/smtp[7663]: connect to gmail-smtp-in.l.google.com[2607:f8b0:400c:c06::1a]:25: Network is unreachable
Feb 16 10:23:19 vps107868 postfix/smtp[7663]: 3CB5E2373DE: to=<oyhud@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.141.26]:25, delay=1.6, delays=0.02/0.01/0.72/0.89, dsn=2.0.0, status=sent (250 2.0.0 OK  1550330599 j21si1582342uap.232 - gsmtp)
Feb 16 10:23:19 vps107868 postfix/qmgr[7448]: 3CB5E2373DE: removed

En fait toutes les connexions se font au travers du port 25 et non 587... hmm
Le port d'écoute ne devrait pas être le 587 de façon automatique ?

Dernière modification par oliver2004 (Le 16/02/2019, à 16:35)


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne

#3 Le 21/02/2019, à 11:52

bruno

Re : Installation Postfix/Dkim/Dspam/Dovecot - petits soucis...

Tu ne peux pas utiliser telnet pour tester l'envoi avec submission car cela requiert une connexion TLS.
Tu peux le faire avec :

openssl s_client -quiet -starttls smtp -connect localhost:587  

De toute façons ce type de test ne sert qu'à vérifier les réponses du serveur. Il vaut mieux faire les test depuis une autre machine en utilisant un client de courriel correctement configuré.

Pour le reste je ne peux rien dire sans voir la configuration. Mais cette erreur :

SMTPUTF8 is required, but was not offered by host

indique que des caractères UTF-8 sont utilisés dans l'adresse de l'expéditeur. C'est probablement la faute du script PHP mais tu peut toujours jouer avec les paramètres de postfix : http://www.postfix.org/SMTPUTF8_README.html

En ligne

#4 Le 21/02/2019, à 15:43

oliver2004

Re : Installation Postfix/Dkim/Dspam/Dovecot - petits soucis...

bruno a écrit :

Tu ne peux pas utiliser telnet pour tester l'envoi avec submission car cela requiert une connexion TLS.
Tu peux le faire avec :

openssl s_client -quiet -starttls smtp -connect localhost:587  

De toute façons ce type de test ne sert qu'à vérifier les réponses du serveur. Il vaut mieux faire les test depuis une autre machine en utilisant un client de courriel correctement configuré.

Pour le reste je ne peux rien dire sans voir la configuration. Mais cette erreur :

SMTPUTF8 is required, but was not offered by host

indique que des caractères UTF-8 sont utilisés dans l'adresse de l'expéditeur. C'est probablement la faute du script PHP mais tu peut toujours jouer avec les paramètres de postfix : http://www.postfix.org/SMTPUTF8_README.html

Bonjour bruno,
Merci pour le coup de main smile
J'ai testé ceci :

$ openssl s_client -quiet -starttls smtp -connect localhost:587
depth=0 C = PE, ST = Cusco, L = Cusco, O = Hello, CN = Olivier, emailAddress = monmail@domaine.com
verify error:num=18:self signed certificate
verify return:1
depth=0 C = PE, ST = Cusco, L = Cusco, O = Hello, CN = Olivier, emailAddress = monmail@domaine.com
verify return:1
250 SMTPUTF8
MAIL FROM: oli@gmail.com
250 2.1.0 Ok
RCPT TO: unautremail@domaine.com                                                                                                
554 5.7.1 <localhost[127.0.0.1]>: Client host rejected: Access denied

Le port 587 est ouvert en IN et OUT dans le parefeu, mais access denied...

Je vais jeter un oeil sur les caractères UTF8.

Tu as besoin de quoi par rapport à la configuration ?

Dernière modification par oliver2004 (Le 21/02/2019, à 15:51)


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne

#5 Le 21/02/2019, à 16:01

bruno

Re : Installation Postfix/Dkim/Dspam/Dovecot - petits soucis...

Si tu as suivi le tuto à la lettre, avec pour submission :

smtpd_client_restrictions=permit_sasl_authenticated,reject

c'est normal. Il faut que tu soit authentifié (utilisateur, mot de passe pour pouvoir utiliser submission). Encore un fois, fais tes tests depuis une autre machine avec un client mail et examine en même temps les logs du serveur (/var/log/mail.log)

En ligne

#6 Le 21/02/2019, à 17:20

oliver2004

Re : Installation Postfix/Dkim/Dspam/Dovecot - petits soucis...

bruno a écrit :

Si tu as suivi le tuto à la lettre, avec pour submission :

smtpd_client_restrictions=permit_sasl_authenticated,reject

c'est normal. Il faut que tu soit authentifié (utilisateur, mot de passe pour pouvoir utiliser submission). Encore un fois, fais tes tests depuis une autre machine avec un client mail et examine en même temps les logs du serveur (/var/log/mail.log)

Ok, je comprends, mais pour faire des tests depuis une autre machine, il me faut avoir une adresse mail de configurée, avec un passwd ?

[Edit] Ok, je crois que je vais trouver mon bonheur ici : https://wiki.debian-fr.xyz/Configuratio … uveau_mail

[Edit 2] Ouais, bof, je sais pas si c'est si actualisé... du coup, ça n'envoie plus rien maintenant... sad
Pas évident un serveur de mail...

Dernière modification par oliver2004 (Le 21/02/2019, à 18:50)


Bureaux: Ubuntu Serveur Edition 16.04 LTS, Kubuntu sur portables Compaq CQ42, Lubuntu sur portable HP 550, Kubuntu sur DELL Inspiron 14...
Mon laptop: Kubuntu sur DELL
Déjà 10 ans que toutes les machines sont LINUX dans mon entreprise...

Hors ligne