Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/03/2019, à 08:39

DonutMan75

NAS sort de veille malgré autofs ?

Bonsoir à tous,
j'ai un NAS synology sur mon réseau auquel j'accède depuis mon poste sous Ubuntu 18.04 grâce à un montage Samba.
Mon NAS est paramétré pour se mettre en veille après une période d'inactivité de 10 minutes.
Autrefois, tout était géré par fstab. C'était fonctionnel mais :

  1. la connection Samba s'effectuait à chaque redémarrage, sortant le NAS de son sommeil,

  2. le démarrage d'Ubuntu était ralenti (malgré l'option _netdev, bien que je doute que cela ait un quelconque effet sur la vitesse de démarrage).

J'ai donc choisi de passer par autofs.
Tout se passe bien, le démarrage est plus rapide et rien n'est monté sans que je cherche à accéder aux répertoires cibles MAIS... je remarque systématiquement une sortie de veille de mon NAS peu de temps après le login.

Je n'ai aucune idée de ce à quoi c'est du... J'ai regardé les logs system par défaut et je n'ai rien trouvé qui soit susceptible de scanner le réseau ou quelque chose du genre (mais peut-être les logs ne sont-ils pas assez détaillés ?)

Après démarrage et sans action de ma part, mon NAS n'est pas monté ainsi que l'illustre ce mount effectué juste après le login :

$ sudo mount -vvv | grep -E "(diskstation|192)"
/etc/auto.mnt on /diskstation type autofs (rw,relatime,fd=6,pgrp=1784,timeout=30,minproto=5,maxproto=5,indirect,pipe_ino=31980)

Par ailleurs, je n'ai rien qui semble papoter avec le NAS :

$ netstat -A inet | grep 192.168.0.xx
$

Des idées de ce qui pourrait causer ce comportement ? Ou bien des pistes pour trouver ?

Merci à vous et bonne journée smile

Donut

Hors ligne

#2 Le 12/03/2019, à 09:53

Brunod

Re : NAS sort de veille malgré autofs ?

Une piste sans certitude : il me semble qu'il y a un process qui scanne et indexe les fichiers accessibles
Je ne sais pas si c'est toujours d'actualité.
https://www.commentcamarche.net/faq/784 … ans-ubuntu
Perso j'ai opté pour un montage manuel uniquement en cas de besoin.
Si tu utilises samba, je suppose que d'autres pc que ton linux peuvent y accéder : ils sont bien arrêtés lors du réveil du nas ?


Windows est un système d'exploitation de l'homme par l'ordinateur. Linux, c'est le contraire...
39 pc linux convertis

Hors ligne

#3 Le 12/03/2019, à 10:17

moko138

Re : NAS sort de veille malgré autofs ?

1) Juste après une sortie de veille indésirable du NAS, que retourne

mount | tail -2 ; echo; sudo cat /var/log/auth.log

?

2) Un logiciel d'indexation... ?


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#4 Le 13/03/2019, à 09:12

DonutMan75

Re : NAS sort de veille malgré autofs ?

Bonjour à vous deux,
merci pour vos idées !

Brunod, oui il n'y a que le pc ubuntu qui est allumé à ce moment là. En effet, je pourrai remettre le montage samba dans fstab en noauto pour vérifier si le problème vient d'autofs (et/ou d'une interférence avec autofs) ou bien d'un processus tout à fait autre qui scannerait le réseau (j'avais pensé à un dhcpdiscover, ça vous paraît plausible ??)

Sinon je n'ai pas retrouvé sous 18.04 les options d'indexation dont il est question dans l'article que tu cites.
Néanmoins, je me suis orienté vers la fonction d'indexation locate.
Dans le fichier /etc/updatedb.conf, il est possible d'exclure de la recherche d'indexation des répertoires (PRUNEPATHS) et/ou des systèmes de fichiers (PRUNEFS).
Par défaut,, il n'indexe pas les partitions samba (cifs) mais je ne sais pas comment ça se goupille avec autofs (surtout que l'option ghost, qui laisse un répertoire vide en local en l'absence de tout montage, est activé). Du coup dans le doute, j'ai rajouté le chemin du montage dans PRUNEPATHS

$ cat /etc/updatedb.conf
PRUNE_BIND_MOUNTS="yes"
# PRUNENAMES=".git .bzr .hg .svn"
# Donut 2019-03-13 : ajout de /diskstation dans les répertoires exclus de la recherche (PRUINEPATHS)
PRUNEPATHS="/tmp /var/spool /media /var/lib/os-prober /var/lib/ceph /home/.ecryptfs /var/lib/schroot /diskstation"
PRUNEFS="NFS nfs nfs4 rpc_pipefs afs binfmt_misc proc smbfs autofs iso9660 ncpfs coda devpts ftpfs devfs devtmpfs fuse.mfs shfs sysfs cifs lustre tmpfs u    sbfs udf fuse.glusterfs fuse.sshfs curlftpfs ceph fuse.ceph fuse.rozofs ecryptfs fusesmb"

Je verrai bien si ça change quelque chose au prochain reboot...
Chose curieuse, il est dit dans le man de updatedb deux choses :

man updatedb a écrit :

updatedb is usually run daily by cron(8) to update the default database.
(...)
FILES
       /var/lib/mlocate/mlocate.db
              The database updated by default.

Le fichier /var/lib/mlocate/mlocate.db a été modifié récemment, preuve que updatedb tourne bien :

$ ll /var/lib/mlocate/mlocate.db
-rw-r----- 1 root mlocate 39421814 mars  13 07:39 /var/lib/mlocate/mlocate.db

Néanmoins, je ne trouve aucune crontab associée à updatedb :

$ crontab -l
no crontab for donut
$ sudo crontab -l
[sudo] Mot de passe de donut : 
no crontab for root

moko138, voici le retour des commandes demandées :

$ mount | tail -2
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/var/lib/snapd/snaps/core_6531.snap on /snap/core/6531 type squashfs (ro,nodev,relatime,x-gdu.hide)
$ sudo cat /var/log/auth.log
Mar 13 07:33:24 donux systemd-logind[1202]: New seat seat0.
Mar 13 07:33:24 donux systemd-logind[1202]: Watching system buttons on /dev/input/event1 (Power Button)
Mar 13 07:33:24 donux systemd-logind[1202]: Watching system buttons on /dev/input/event0 (Power Button)
Mar 13 07:33:24 donux systemd-logind[1202]: Watching system buttons on /dev/input/event3 (Logitech G203 Prodigy Gaming Mouse)
Mar 13 07:33:24 donux systemd-logind[1202]: Watching system buttons on /dev/input/event4 (EST Gaming keyboard)
Mar 13 07:33:24 donux systemd-logind[1202]: Watching system buttons on /dev/input/event5 (EST Gaming keyboard)
Mar 13 07:33:24 donux systemd-logind[1202]: Watching system buttons on /dev/input/event6 (EST Gaming keyboard)
Mar 13 07:33:24 donux gdm-launch-environment]: pam_unix(gdm-launch-environment:session): session opened for user gdm by (uid=0)
Mar 13 07:33:24 donux systemd: pam_unix(systemd-user:session): session opened for user gdm by (uid=0)
Mar 13 07:33:24 donux systemd-logind[1202]: New session c1 of user gdm.
Mar 13 07:33:27 donux polkitd(authority=local): Registered Authentication Agent for unix-session:c1 (system bus name :1.28 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8)
Mar 13 07:35:20 donux gdm-password]: pam_unix(gdm-password:session): session opened for user donut by (uid=0)
Mar 13 07:35:20 donux systemd: pam_unix(systemd-user:session): session opened for user donut by (uid=0)
Mar 13 07:35:20 donux systemd-logind[1202]: New session 2 of user donut.
Mar 13 07:35:24 donux polkitd(authority=local): Registered Authentication Agent for unix-session:2 (system bus name :1.85 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8)
Mar 13 07:35:42 donux gnome-keyring-daemon[2764]: couldn't allocate secure memory to keep passwords and or keys from being written to the disk
Mar 13 07:35:43 donux gnome-keyring-daemon[2764]: asked to register item /org/freedesktop/secrets/collection/login/3, but it's already registered
Mar 13 07:35:44 donux gnome-keyring-daemon[2764]: asked to register item /org/freedesktop/secrets/collection/login/3, but it's already registered
Mar 13 07:36:27 donux pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Mar 13 07:36:27 donux pkexec[4147]: donut: Executing command [USER=root] [TTY=unknown] [CWD=/home/donut] [COMMAND=/usr/lib/update-notifier/package-system-locked]
Mar 13 07:37:46 donux dbus-daemon[2785]: [session uid=1000 pid=2785] Failed to activate service 'org.gnome.zeitgeist.SimpleIndexer': timed out (service_start_timeout=120000ms)

Hors ligne