Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/04/2019, à 18:10

Grompf

Paquets SNAP sous machine virtuelle ?

Bonjour,

Je m'amuse parfois à essayer des distributions linux sous machine virtuelle, par curiosité.
J'ai eu toutes sortes d'ennuis avec la Ubuntu-Mate 19.04, qui semblaient liés aux paquets snap.
Mais en fait, il semble que ce soit le fait même d'utiliser snapd sous Virtual Box ou sous Gnome-Boxes qui cause problème : https://forum.ubuntu-fr.org/viewtopic.p … #p22078366

Est-ce que d'autres ici ont eu des problèmes en utilisant des paquets snap dans une machine virtuelle ?


Lenovo Thinkpad X220 i5 sous Debian Mate - stable
Lenovo Thinkpad T510 sous Linux Mint Mate
Lenovo Thinkpad X230 i5 sous Debian Mate - testing

Hors ligne

#2 Le 07/04/2019, à 04:02

LukePerp

Re : Paquets SNAP sous machine virtuelle ?

Bonjour,
Pourrais tu donner des détails. Quels snaps tester pour reproduire ton problème ? Quels phénomènes observes tu ?


Desktop : Ubuntu Mate 18.04 - Intel i5 - 8 Go - Dual boot Windows 7 pour jouer
Laptop asus : Ubuntu Mate 18.04 - Intel i5 - 4 Go
Vieux laptop de 2005 : Bodhi Linux - Pentium M - 436 Mo

Hors ligne

#3 Le 07/04/2019, à 13:50

Grompf

Re : Paquets SNAP sous machine virtuelle ?

Bonjour,

J'ai décris tout ça dans le post que j'ai mis en lien dans mon premier message.
J'ai refais quelques essais en essayant de rajouter hello-world : ça ne change pas grand chose.

Sur Manjaro Mate (TuxNVape) et OpenSuse Tumbleweed Mate, y'a rien à faire. Je n'ai aucun résultat. Je peux bien installer snapd, mais ensuite c'est de toutes manières impossible d'installer hello-world. Et j'ai toujours le même retour à la commande "snap version".
Avec Ubuntu-Mate 19.04, j'ai réinstallé snapd après coup, avec le plugin pour Gnome-Software (sur une installation dans laquelle j'avais rajouté Gnome-Software et où j'avais désinstaller les paquets snap ainsi que snapd)... Et là ça marche. S'agit-il d'un bug corrigé entre-temps (rappel : nous parlons d'une version bêta) ? Parce que mes essais étaient partis de là, et il n'y avait pas moyen d'utiliser snapd.
Avec Debian Testing Mate j'arrive à utiliser snap en ligne de commande, à installer un paquet snap : j'ai essayé avec VLC. Pas besoin de hello-world. Sauf que VLC n'apparaît pas dans mon menu ensuite.
Avec KDE Neon, j'arrive finalement à utiliser snap en ligne de commande. Et le soft installé (VLC) encore apparaît correctement dans le menu. En revanche impossible d'intégrer Snapd à Discover, malgré le plugin adapté.
J'ai essayé avec Debian Testing KDE et c'est pareil que pour KDE Neon. En ligne de commande ça semble jouer, mais impossible de faire apparaître les paquets snap dans Discover.

Voilà... Tout ça semble très aléatoire. Il ne s'agit probablement pas d'1 problème, mais de plusieurs. Remarquons que je n'ai rien vu de bizarre en essayant Flatpak sous machine virtuelle.

Important : Il s'agit d'une remarque, d'une observation, d'une discussion. Pas d'une demande d'aide. Donc, que personne ne se casse la tête pour moi. Mais je serais curieux de savoir si ce problème est documenté quelque part.


Lenovo Thinkpad X220 i5 sous Debian Mate - stable
Lenovo Thinkpad T510 sous Linux Mint Mate
Lenovo Thinkpad X230 i5 sous Debian Mate - testing

Hors ligne