Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/07/2019, à 22:33

deude

[Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Bonjour à tous,

Je rencontre une grosse difficulté qui semble à priori anodine après tout ce que j'ai traversé pour en arriver là ! lol

Novice il y a encore quelques semaines, j'ai finalement réussi à installer un serveur Mail sur mon VPS SSD Ovh sous Ubuntu 16.04. J'ai configuré le tout à l'aide de ce tuto : https://www.tictech.info/post/mail_preparation

On est donc en présence d'un serveur sous apache2, avec Postfix, Dovecot et un beau Roundcube qui fonctionne parfaitement. Par rapport au tuto, j'ai ajouté un certificat Certbot, un peu de spamassassin et tous les certificats qui vont bien (DKIM and co).

Mon problème est le suivant : si tout fonctionne parfaitement sur Roundcube avec accès depuis mon sous domaine mail.mondomaine.com, impossible de configurer le tout correctement sur un outil de mail externe ! Il est primordial pour moi d'avoir un suivi sur Smartphone ou sur une appli sur PC pour avoir des notifications à chaque nouveau mail notamment. J'ai essayé plusieurs Applis sans succès (Gmail, Outlook, K9 sur Mobile, Thunderbird sur PC), les paramètres ne sont jamais bons malgré plusieurs essais.

Voici les données qui fonctionnent bien sur Roundcube :

IMAP : ssl://mail.mondomaine.com
Port : 143 (default je crois)

SMTP : tls://mail.mondomaine.com
Port : 587

Or sur les différentes application, je ne peux mettre les ssl:// et tls://, j'entre donc mail.mondomaine.com et sélectionne SSL ou STARTTLS, mais encore une fois rien ne fonctionne.

Je suis donc à la recherche d'une solution miracle si quelqu'un peut me dire ce qu'il en ait, si je suis passé à côté de quelque chose d'essentiel qui fait que ça ne fonctionne qu'en local via Roundcube sur mon serveur ... Ou s'il y a une méthode pour connaître les bons paramètres à entrer sur les logiciels de mail  ?

Bonne fin de journée !

Dernière modification par deude (Le 01/08/2019, à 19:47)

Hors ligne

#2 Le 31/07/2019, à 03:45

Vobul

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Essaie de te connecter sur tondomain.com pas le mail subdomain qui est celui où le serveur apache sert ton webmail.


Vobul

Hors ligne

#3 Le 31/07/2019, à 07:23

bruno

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Bonjour,

Le tuto que tu indiques me semble un peu ancien (php5 …) et la configuration assez incomplète et peu sécurisée.

Tu dis que Roundcube fonctionne parfaitement mais arrives-tu à envoyer et recevoir des courriels depuis Roundcube ?
Ton serveur répond-il de l'extérieur sur les port 25 (smtp), 587 (submission) et 143 (imap) ?

Hors ligne

#4 Le 31/07/2019, à 09:56

deude

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Merci à tous les deux pour vos retours !

Vobul a écrit :

Essaie de te connecter sur tondomain.com pas le mail subdomain qui est celui où le serveur apache sert ton webmail.

Tenté, j'ai la même erreur sur thunderbird qu'avec le mail.mondomaine.com lorsque je tente d'envoyer un mail, mais avec une IP qui ne semble pas être la bonne : Cannot connect to SMTP server <IP différente>, connect error 10061.
A savoir que mondomaine.com redirige vers mondomaine.fr et que mail.mondomaine.com accueil mon Roundcube, donc je pense que ce n'est pas la bonne méthode que d'utiliser simplement mondomaine.com.

bruno a écrit :

Bonjour,

Le tuto que tu indiques me semble un peu ancien (php5 …) et la configuration assez incomplète et peu sécurisée.

Tu dis que Roundcube fonctionne parfaitement mais arrives-tu à envoyer et recevoir des courriels depuis Roundcube ?
Ton serveur répond-il de l'extérieur sur les port 25 (smtp), 587 (submission) et 143 (imap) ?

Oui, j'envoie et je reçois parfaitement depuis Roundcube, avec un 10/10 sur Mail tester. Pour le tutoriel, après en avoir utilisé plusieurs c'est le seul que j'ai réussi ... Je suis néanmoins sur PHP 7.2 et j'ai fais quelques ajouts comme évoqué sur mon premier message, je ne sais pas si c'est suffisant en terme de sécurité mais les différents tutoriels que j'ai pu voir semblait utilisé les mêmes technos (Postfix, Dovecot, ...). Par ailleurs, comment être sur que mon serveur répond sur les ports 25, 587 et 143 depuis l'extérieur ?

Dernière modification par deude (Le 31/07/2019, à 09:57)

Hors ligne

#5 Le 31/07/2019, à 10:20

bruno

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Depuis une machine sous linux :

Test du port 25 smtp :

telnet example.com smtp

Test du port 587 submission :

telnet example.com 587

ou si TLS est requis :

openssl s_client  -starttls smtp -connect example.com:587 

Test du protocole imap non sécurisé sur le port 143 :

telnet example.com 143

ou avec mutt :

mutt -f imap://toto@example.com@example.com

Dans ton tuto je n'ai vu à aucun moment de configuration TLS avec génération de certificats, ni pour postfix ni pour dovecot (pour pouvoir utiliser des protocoles sécurisés imaps ou pop3s).

Vérifie aussi bien tes enregistrement DNS : MX, A, AAAA (si IPv6) SPF, DKIM

Dernière modification par bruno (Le 31/07/2019, à 10:22)

Hors ligne

#6 Le 31/07/2019, à 21:59

deude

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Merci pour le retour ! :)

Pour info j'ai suivi ces tutoriels pour ce qui concerne TLS et les SPF / DKIM en faisant ma petite popote :
https://www.adminmalin.fr/chiffrement-d … t-postfix/
https://www.malekal.com/postfix-spf-dkim/
https://www.digitalocean.com/community/ … ian-wheezy

J'ai fais les tests indiqués depuis ma connexion VPS :

Test du port 25 smtp domaine.com :
Résultat :

Connected to domaine.com.
Escape character is '^]'.
220-redirect.ovh.net smtp2
220 redirect.ovh.net smtp2

Test du port 25 smtp mail.domaine.com :
Résultat :

Connected to mail.domaine.com.
Escape character is '^]'.
220 mail.domaine.com ESMTP Postfix (Ubuntu)

Test du port 587 submission :

telnet domaine.com 587

:
Résultat :

telnet: Unable to connect to remote host: Connection refused

Test :

telnet mail.domaine.com 587

:
Résultat :

Connected to mail.domaine.com.
Escape character is '^]'.
220 mail.domaine.com ESMTP Postfix (Ubuntu)

Test :

openssl s_client  -starttls smtp -connect example.com:587 

:
Résultat :

Erreur 

Test :

openssl s_client  -starttls smtp -connect mail.example.com:587 

:
Résultat :

CONNECTED(00000003)
depth=2 O = Digital Signature Trust Co., CN = DST Root CA X3
verify return:1
depth=1 C = US, O = Let's Encrypt, CN = Let's Encrypt Authority X3
verify return:1
depth=0 CN = mail.domaine.com
verify return:1

et tout ce qui va bien, les clés, etc.

Test :

telnet example.com 143

:
Résultat :

telnet: Unable to connect to remote host: Connection refused

Test :

telnet mail.example.com 143

:
Résultat :

Connected to mail.domaine.com.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE STARTTLS AUTH=PLAIN AUTH=LOGIN] Dovecot ready.
mutt -f imap://toto@example.com

:
Mutt non installé, j'ai installé le package mais il me demande ensuite de créer un dossier donc j'ai abandonné pour le moment.

Puis, lorsque je fais les même tests avec Telnet installé sur ma machine Windows 10 :
Le résultat est le même pour toutes les commandes, que ce soit pour mail.exemple.com ou pour exemple.com :

Impossible d'ouvrir une connexion à l'hôte, sur le port [port de l'essai]: Echec lors de la connexion.

Il s'agirait donc d'un blocage depuis une connexion externe ?

Dernière modification par bruno (Le 01/08/2019, à 07:35)

Hors ligne

#7 Le 01/08/2019, à 07:34

bruno

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

deude a écrit :

J'ai fais les tests indiqués depuis ma connexion VPS

C'est à dire ? Si tu as fais ces test directement sur le serveur cela n'a aucun interêt. Le serveur fonctionne puisqu'il arrive à envoyer et recevoir des courriel via Roundcube.

Si les test échouent depuis une autre machine (ton poste sous Windows) c'est effectivement qu'il y a un blocage.
Il faut donc vérifier la présence d'un pare-feu sur le serveur :

sudo iptables -L -n

et :

bruno a écrit :

Vérifie aussi bien tes enregistrement DNS : MX, A, AAAA (si IPv6) SPF, DKIM

Pour cela tu as l'horrible nslookup sous Windows ou tu peux utiliser un service web comme : http://www.kloth.net/services/dig.php

Hors ligne

#8 Le 01/08/2019, à 13:29

deude

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Merci encore pour le coup de main wink

Effectivement, j'avais cru comprendre que ça ne servait pas à grand chose depuis mon serveur, mais ça confirmait que tout était fonctionnel à ce niveau là, pour mail.mondomaine.com.

Pour :

sudo iptables -L -n

La partie qui me semble intéressante :

TABLISHED
ufw-logging-deny  all  --  0.0.0.0/0            0.0.0.0/0            ctstate INVALID
DROP       all  --  0.0.0.0/0            0.0.0.0/0            ctstate INVALID
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0            icmptype 3
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0            icmptype 4
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0            icmptype 11
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0            icmptype 12
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0            icmptype 8
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            udp spt:67 dpt:68
ufw-not-local  all  --  0.0.0.0/0            0.0.0.0/0
ACCEPT     udp  --  0.0.0.0/0            224.0.0.251          udp dpt:5353
ACCEPT     udp  --  0.0.0.0/0            239.255.255.250      udp dpt:1900
ufw-user-input  all  --  0.0.0.0/0            0.0.0.0/0

Chain ufw-user-input (1 references)
target     prot opt source               destination
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:22
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            udp dpt:22
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            multiport dports 80,443 /* 'dapp_Apache%20Full' */
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:25
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            udp dpt:25
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:12301
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            udp dpt:12301
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:17789
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            udp dpt:17789

Sinon j'ai toujours du source et du destination 0.0.0.0/0, est-ce normal ? Je vois que le port 25 est censé être en Accept mais il ne fonctionne quand même pas sur le telnet mail.mondomaine.com smtp, donc le problème ne vient pas de là ?

Les tests avec Kloth.net (merci pour l'outil !) :

Mx :

 ; <<>> DiG 9 <<>> @localhost mail.mondomaine.com MX
 ; (1 server found)
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55219
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
 
 ;; QUESTION SECTION:
 ;mail.mondomaine.com.	IN	MX
 
 ;; AUTHORITY SECTION:
 mondomaine.com.	300	IN	SOA	dns20.ovh.net. tech.ovh.net. 2019072603 86400 3600 3600000 300
 
 ;; Query time: 13 msec
 ;; SERVER: 127.0.0.1#53(127.0.0.1)
 ;; WHEN: Thu Aug  1 13:16:14 2019
 ;; MSG SIZE  rcvd: 96

A :

; <<>> DiG 9 <<>> @localhost mail.mondomaine.com A
 ; (1 server found)
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17021
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
 
 ;; QUESTION SECTION:
 ;mail.mondomaine.com.	IN	A
 
 ;; ANSWER SECTION:
 mail.mondomaine.com. 3142	IN	A	XX.XX.XX.XX
 
 ;; Query time: 0 msec
 ;; SERVER: 127.0.0.1#53(127.0.0.1)
 ;; WHEN: Thu Aug  1 13:19:02 2019
 ;; MSG SIZE  rcvd: 58

DKIM & SPF OK confirmé par Mail-Tester.

EDIT :

Test du mail avec https://dnslookup.fr :

Tests SMTP  
Les champs MX possèdent les serveurs SMTP suivants :
MX 1 mail.mondomain.com. <=> XX.XX.XX.XX [GB] : 220 mail.mondomaine.com ESMTP Postfix (Ubuntu)  nmap
Le domaine possède les champs SPF suivants : 
v=spf1 ip4:xx.xx.xx.xx include:mx.ovh.com ~all"
(Pour vérifier si la liste des serveurs est exhaustive : Cf. FAQ #15)

Il y a 1 tests non validés :
Le domaine n'accepte pas l'adresse postmaster@mondomaine.com.

Tests DNS  
Il y a 2 tests non validés :
Le SOA du domaine n'est pas correct
Un seul MX, risque d'indisponibilité 

Afficher la réponse DNS  
Serveur ayant répondu => ns20.ovh.net. <=> xxx.xxx.xxx.xxx [FR] [13 ms]
Enregistrements MX
Domaine	TTL	Classe	Type	Poids	Serveur
domaine.com.	3600	IN	MX	1	mail.domaine.com.
Enregistrements NS
Domaine	TTL	Classe	Type	Serveur
domaine.com.	3600	IN	NS	ns20.ovh.net.
domaine.com.	3600	IN	NS	dns20.ovh.net.
Enregistrements SOA
Domaine	TTL	Classe	Type	Détail du SOA
domaine.com.	3600	IN	SOA
Serveur DNS maître	dns20.ovh.net.
Contact email	tech@ovh.net
Serial	2019072603
Refresh	86400
Retry	3600
Expire	3600000
Minimum TTL	300
Enregistrements CNAME
Alias	TTL	Classe	Type	Nom d'hôte cible
Aucun enregistrement CNAME
Enregistrements A
Nom d'hôte	TTL	Classe	Type	Adresse IP
domaine.com.	3600	IN	A	xxx.xxx.xx.x
www.domaine.com.	3600	IN	A	xxx.xxx.xx.x
Enregistrements TXT
Domaine	TTL	Classe	Type	Détail du TXT
domaine.com.	60	IN	TXT	"4|https://www.domaine.fr"
domaine.com.	60	IN	TXT	"v=spf1 ip4:xx.xx.xx.xx include:mx.ovh.com ~all"

Dernière modification par bruno (Le 01/08/2019, à 14:53)

Hors ligne

#9 Le 01/08/2019, à 14:52

bruno

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Réessaie en désactivant ton pare-feu :

sudo ufw disable
sudo iptables -X

Ou bien ajoute des règles pour autoriser les connexion entrantes sur les ports 25,587 et 143 ( et 465 si tu veux faire du smtps et 993 si tu veus faire du imaps)

P.S. : inutile de citer intégralement le message précédent, merci.

Dernière modification par bruno (Le 01/08/2019, à 14:53)

Hors ligne

#10 Le 01/08/2019, à 16:34

deude

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

C'était bien ça ... Je me sens bien c*n de pas avoir tester tout de suite, pour je ne sais quelle raison j'étais persuader que ce n'était pas ça ...

Merci pour ta patience et pour ton aide bruno wink

Hors ligne

#11 Le 01/08/2019, à 16:52

bruno

Re : [Résolu] Serveur Mail Postfix et Dovecot : Configuration Smartphone ?

Avec plaisir wink
Si ton problème est résolu, je t'invite à modifier ton premier message en ajoutant [Résolu] devant le titre.

Hors ligne