Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 01/08/2020, à 20:42

ludique

Re : [Résolu] Pb connexion NAS Synology

La j'ai bien merdé.
Je suis passé sur un autre PC.
Celui sur lequel  je travaillais ne démarre plus j'ai du planté le fstab. si j'en crois les messages obtenu il doit y avoir une entrée en double.

Et je ne sais pas comment corriger ca dans l'état ou il est actuellement.

Hors ligne

#27 Le 01/08/2020, à 20:51

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Si tu as un LiveCD/LiveUSB sous la main, tu peux démarrer sur la session live, monter la partition qui est normalement utilisée pour le système et accéder au fstab pour le modifier.

Sinon, en démarrant la session recovery depuis les options avancées de GRUB, tu devrais aussi pouvoir faire la même chose mais en ligne de commande.

Sur l'écran de boot où c'est bloqué, tu ne peux pas faire ctrl + C pour arrêter la tentative de montage et continuer (je ne sais pas si ça marche dans ce genre de cas) ?

Dernière modification par abelthorne (Le 01/08/2020, à 20:53)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#28 Le 01/08/2020, à 21:13

ludique

Re : [Résolu] Pb connexion NAS Synology

J'ai l'impression que ca ne fonctionne pas trop avec un clavier sans fil. une fois que je lance le mode recovery je ne peux plus rien faire.

je vais charger charger un image et tenter de trouver une clé usb.

Hors ligne

#29 Le 01/08/2020, à 22:20

ludique

Re : [Résolu] Pb connexion NAS Synology

J'ai corriger le fstab avec une image iso. Il n'y aplus de message concernant une double entrée.

Mais ce na va pas mieux :
Tentative de démarrage normal
https://ibb.co/6gXm4n0

Tentative de démarrage générique
https://ibb.co/vdGDDC6

Tentative de démarrage sans échec
https://ibb.co/qk5S5Hq

Je ne sais plus quoi faire.

Dernière modification par ludique (Le 01/08/2020, à 22:23)

Hors ligne

#30 Le 02/08/2020, à 09:28

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Je comprends pas bien la différence entre les deux premières captures, tu as l'air d'être dans le mode recovery dans les deux.

Est-ce que tu pourrais booter sur un LiveCD, monter la partition qui sert au système et donner le contenu actuel de son fstab ?


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#31 Le 02/08/2020, à 10:17

ludique

Re : [Résolu] Pb connexion NAS Synology

Bon, hier je commencais à fatiguer et je copiais tout ce que tu me donnais sans réfléchir. Du coup je ne me suis pas apercu que dans ta dernière préconisation il manquait la mention cifs.
Et ca on dirait qu'il aime pas beaucoup.

Ce matin j'ai fais du ménage dans tout ca et c'est reparti.

Maintenant ca ne monte toujours pas an automatique.
mais une fois le montage effectué avec sudo, je peux directement ajouter des fichiers.

Hors ligne

#32 Le 02/08/2020, à 10:35

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Oups. Ah oui, merde, j'ai effacé le cifs par erreur en recopiant mes options. Désolé.
(Et c'est plutôt important, c'est le système de fichiers à utiliser pour le point de montage.)

Pour le montage au boot, que donne comme retour la commande suivante ?

systemctl status systemd-networkd-wait-online

Dernière modification par abelthorne (Le 02/08/2020, à 10:37)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#33 Le 02/08/2020, à 10:53

ludique

Re : [Résolu] Pb connexion NAS Synology

Ca ne s'arrète jamais ce truc ca répond ca en boucle :


$ systemctl status systemd-networkd-wait-online
● systemd-networkd-wait-online.service - Wait for Network to be Configured
   Loaded: loaded (/lib/systemd/system/systemd-networkd-wait-online.service; dis
   Active: inactive (dead)
     Docs: man:systemd-networkd-wait-online.service(8)
lines 1-4/4 (END)

Hors ligne

#34 Le 02/08/2020, à 11:03

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Ça devrait juste t'afficher cette sortie et te rendre la main. Mais il manque la fin de la deuxième ligne, qui est coupée à "dis".
Je pense que le service est bien activé comme il faut mais dans le doute :

sudo systemctl enable systemd-networkd-wait-online

Ensuite, redémarre et vérifie si les montages se montent au boot (mais c'est peu probable que ça change, le service ayant l'air d'être correctement chargé à la base).


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#35 Le 02/08/2020, à 11:19

ludique

Re : [Résolu] Pb connexion NAS Synology

Non ils ne sont pas montés

Pour les messages, oui c'est bizarre il sont répétés en boucle. A chaque fois avec une lettre en plus au bout d'un moment le message est complet (cf ci-dessous avant le dernier reboot)

● systemd-networkd-wait-online.service - Wait for Network to be Configured
   Loaded: loaded (/lib/systemd/system/systemd-networkd-wait-online.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:systemd-networkd-wait-online.service(8)
~

Maintenant c'est un peu différent. Toujours le même principe le message apparaît petit à petit. Mais à la fin on a ca :

● systemd-networkd-wait-online.service - Wait for Network to be Configured
   Loaded: loaded (/lib/systemd/system/systemd-networkd-wait-online.service; enabled; vendor preset: enabled)
   Active: active (exited) since Sun 2020-08-02 11:14:48 CEST; 12min ago
     Docs: man:systemd-networkd-wait-online.service(8)
  Process: 970 ExecStart=/lib/systemd/systemd-networkd-wait-online (code=exited, status=0/SUCCESS)
 Main PID: 970 (code=exited, status=0/SUCCESS)

août 02 11:14:48 bobo12 systemd[1]: Starting Wait for Network to be Configured...
août 02 11:14:48 bobo12 systemd-networkd-wait-online[970]: ignoring: lo
août 02 11:14:48 bobo12 systemd[1]: Started Wait for Network to be Configured.
~

Dernière modification par ludique (Le 02/08/2020, à 11:29)

Hors ligne

#36 Le 02/08/2020, à 11:29

abelthorne

Re : [Résolu] Pb connexion NAS Synology

On peut encore tester d'autres choses mais là, je suis en roue libre, je cherche des infos sur des problèmes similaires, ce ne sont pas des choses que j'ai testées moi-même.
Essaie les options suivantes sur tes partages dans le fstab : x-systemd.automount,x-systemd.mount-timeout=240,x-systemd.idle-timeout=3600

C'est à mettre en plus des autres options :

//192.168.1.17/Jean/	/media/bobo12/Nas_Jean	cifs	credentials=/etc/nas-credentials,vers=2.0,iocharset=utf8,uid=1000,gid=1000,x-systemd.automount,x-systemd.mount-timeout=240,x-systemd.idle-timeout=3600 0 2

Au passage, ce serait sans doute mieux de mettre l'IP directement plutôt que "Gargamelle", parce que comme tout le problème a l'air de venir du réseau qui n'est pas actif au moment du montage du fstab, la déclaration d'un alias dans le fichier hosts ne doit pas vraiment aider.


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#37 Le 02/08/2020, à 11:41

ludique

Re : [Résolu] Pb connexion NAS Synology

On dirait que la roue libre à du bon.  Ce coup ci tout fonctionne.
Si je comprends bien  ce qui a été ajouté permet juste d'attendre un peu avant de monter les partages. C'est ca ?

Et la, je me demande si ce n'est pas l'activation de mon VPN au démarrage qui peut avoir ce genre d'incidence sur la disponibilité du réseau.

Hors ligne

#38 Le 02/08/2020, à 11:54

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Oui, ça rajoute un délai pour le montage.

Concernant ton VPN, il est lancé au démarrage de la session (après l'écran de connexion), je suppose ? Si c'est le cas, il ne devrait pas avoir d'incidence sur la disponibilité du réseau au boot.

En relisant le sujet depuis le début, je me rends compte que je t'avais fait supprimé l'option _netdev avant de tester l'utilisation de l'IP au lieu de l'alias. C'est possible que ça puisse fonctionner avec la combinaison des deux (et que le problème à l'origine vienne surtout de l'alias). Si tu veux faire un test supplémentaire, tu peux essayer les options suivantes :

//192.168.1.17/Jean/	/media/bobo12/Nas_Jean	cifs	_netdev,credentials=/etc/nas-credentials,vers=2.0,iocharset=utf8,uid=1000,gid=1000 0 2

Est-ce que par hasard ça fonctionne ou il y a vraiment besoin des options x-systemd ?

Dernière modification par abelthorne (Le 02/08/2020, à 11:55)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#39 Le 02/08/2020, à 12:28

ludique

Re : [Résolu] Pb connexion NAS Synology

Non ca ne fonctionne pas. il faut bien ajouter un délai avant le montage. Je remet la version précédente. Et je passe ca en résolu.

Merci beaucoup pour ton aide précieuse et le temps passé. J'avais beau chercher je n'aurais jamais réussi à trouver ca seul.

Hors ligne