Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 25/04/2008, à 19:47

Jinglou

[Résolu]Problème de barre d'espace sous Code Blocks

Bonjour à tous,

je suis sous Ubuntu Hardy Heron, et, depuis hier, la barre d'espace ne "fonctionne" plus dans Code Blocks : pour pouvoir faire un espace entre 2 mots, je suis obligé d'utiliser Ctrl+Espace...ce n'est hyper pratique...d'autant plus que ça a très bien marché pendant plusieurs semaines !

Quelqu'un aurait une idée pour m'aider ? Merci d'avance !!!:D

Jinglou

edit: autant pour moi, ce n'est pas ctrl+espace mais ctrl+alt+espace...mais ça ne simplifie pas la chose !!

Dernière modification par Jinglou (Le 27/04/2008, à 13:11)

Hors ligne

#2 Le 26/04/2008, à 19:27

Addruto

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Même problème, sauf que CTRL ne fonctionne pas non plus !
+1

Dernière modification par Addruto (Le 26/04/2008, à 19:28)

Hors ligne

#3 Le 26/04/2008, à 22:38

Niho

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Ni espace ni ctrl+Espace marche...
:'(
A l'aide


Blog => http://niho.legtux.org
Jabber => niho@jabber.fr

~-"Arrêtons de nous prendre la tête et profitons plus de la vie"-~

Hors ligne

#4 Le 27/04/2008, à 01:19

blahnotblahblah

Re : [Résolu]Problème de barre d'espace sous Code Blocks

j'ai réglé:D le problème en commentant une ligne dans /etc/X11/xorg.conf :

Option   "XkbVariant"    "oss"

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
#       Option          "XkbVariant"    "oss"
EndSection

puis j'ai fait menu système\quitter\déconnecter

et depuis le problème a disparu dans codeblocks

Je suis content  !!! lol

#5 Le 27/04/2008, à 09:43

Addruto

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Bien jouer ! ça marche aussi chez moi lol

Hors ligne

#6 Le 27/04/2008, à 13:13

Jinglou

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Ca marche nickel...merci beaucoup pour ton aide rapide et efficace blahnotblahblah ! big_smile

@+

Jinglou

Hors ligne

#7 Le 29/04/2008, à 20:55

nathanEB

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Vous pouvez expliquer la manip que vous avez fait car j'ai le même problème mais je n'ai pas compris comment le régler.

Hors ligne

#8 Le 30/04/2008, à 15:12

kazmi

Re : [Résolu]Problème de barre d'espace sous Code Blocks

changer le x11 n'a rien changé chez moi sad

Hors ligne

#9 Le 05/05/2008, à 13:45

Gro

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Même problème chez moi, mais ça marche avec ctrl+alt+espace.
Peux-tu préciser quel est l'effet de la mise en commentaire de la ligne dans le fichier Xorg. Ceci peut-il avoir une influence sur d'autres choses ?
Merci.

#10 Le 06/05/2008, à 15:45

Jonass

Re : [Résolu]Problème de barre d'espace sous Code Blocks

J'avais le même problème, en fait pas besoin de commenter cette ligne.

Allez dans Système>Préférence>Clavier>Agencement.
Là vous avez sûrement "France Autre", remplacez le par France (par défaut).
Chez moi ça à réglé le problème wink

Hors ligne

#11 Le 06/05/2008, à 17:47

Pandark

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Personnellement, j'ai sélectionné dans le menu Système>Préférence>Clavier
Ensuite, dans l'onglet Agencements, j'ai cliqué sur "options de l'agencement", et dans la fenêtre qui s'est ouverte, à l'option "using space key to input non breakable space character", j'ai coché "space key outputs usual space at any level", ce qui semble avoir résolu mon problème (j'en ai profité pour ajouter la touche euro et pour régler la sélection des chiffres lorsque capslock est activé).


Pandark
99% libre…

Hors ligne

#12 Le 07/12/2008, à 21:18

Nikska

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Salut

Ca ne marche pas pour moi nonplus...

Je suis sous KDE et donc apparemment j'ai pas les même menus que vous. Bon j'ai bien un menu pour régler le clavier mais il n'y a pas de choix de langue.
Il y a un menu spécifique au langue qui est bien réglé sur France.

Et enfin dans mon xorg.conf il n'y a même pas de section "InputDevice"

Ha oui... je précise que je suis sur un portable (au cas où que ca puisse poser des problème pour le clavier ?).

La seul solution pour l'instant que j'ai trouvé c'est d'enlever l'auto-compétition mais je trouve ca dommage car c'est quand meme bien pratique tongue

Dernière modification par Nikska (Le 07/12/2008, à 21:25)

Hors ligne

#13 Le 16/12/2008, à 15:20

pampe le mousse

Re : [Résolu]Problème de barre d'espace sous Code Blocks

salut , je viens d'essayer la methode de pandark et ça marche !
merci


C'est en regardant bien ...... qu'on voit vachement mieux.....
Comme disent les arbres en amazonie : " on va pas se laisser abattre !! "
portable acer 9502wsmi , souss ubuntu 8.10
pour rigoler un peu : www.tetesaclaques.tv et www.chucknorrisfacts.fr

Hors ligne

#14 Le 21/12/2008, à 12:18

linuxavie

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Oui merci beaucoup Pandark, j'avai essayer toute les proposotions d'avant ca ne marchait pas et la c'est super ca marche.

Grace à toi je peut reprogrammer avec Code::block...

Merci merci merci wink

#15 Le 26/12/2008, à 14:01

꙳♒⏅⚓ ЅаίԼίՈԶ ⚓⏅♒꙳

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Pandark a écrit :

Personnellement, j'ai sélectionné dans le menu Système>Préférence>Clavier
Ensuite, dans l'onglet Agencements, j'ai cliqué sur "options de l'agencement", et dans la fenêtre qui s'est ouverte, à l'option "using space key to input non breakable space character", j'ai coché "space key outputs usual space at any level", ce qui semble avoir résolu mon problème (j'en ai profité pour ajouter la touche euro et pour régler la sélection des chiffres lorsque capslock est activé).

+1

Je viens de faire exactement cela, pas à pas,  est ça fonctionne enfin.

Merci !:D

Petite remarque : jusque là j'utilisais Ctrl+alt+space et ça m'a fait apparaître les caractères en hébreu !? de temps en temps... bizarre comme bug...:(


Quoi ? Tu travailles sous GNU/LInux ? Ba, ça va te passer... quand il existera quelque chose de mieux... et ce ne sera pas windows, à moins que ce devienne libre et bien programmé. 
mon petit blog de débutant

Hors ligne

#16 Le 10/01/2009, à 01:26

wilf1rst

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Et pour ceux qui ne sont pas sous gnome, ni Kde comme moi (enlightenment) une solution? (je peut toujours utiliser alt+ctrl+espace mais bon tres peu pratique...)???

edit: la reponse était cacher dans la doc d'ubuntu que j'ai un peu survolé il est vrai, mais si la ligne input device n'exite pas il faut la créer!!

Si vous n'avez pas de Section "InputDevice" ce qui est très probablement le cas sous Intrepid, il suffit juste de l'ajouter. Voilà à quoi elle pourrait ressembler:

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
    Option          "XkbOptions"    "nbsp:none"
EndSection

Il ne vous reste plus qu'à redémarrer Xorg à l'aide des touches Ctrl+Alt+Backspace.


voila niquel...

Dernière modification par wilf1rst (Le 10/01/2009, à 01:36)

Hors ligne

#17 Le 11/01/2009, à 13:09

sylveas

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Slt tout le monde j'ai trouvé un moyen assez simple de regler le probleme.... (ubuntu 8.10)

Systeme/preference/clavier

Le deuxieme onglet (layouts)
Selectionne l'agencement du clavier (layout en anglais)


cliquez sur autre option

Ici il y a une ligne qui parle de la touche espace, dedant il y a "utiliser l'espace normal à tous les niveaux". Il suffit de la cocher à la place de par defaut et l'espace sera toujours un espace comme on l'entend.

voila, j'espere que ca aidera des gens wink

#18 Le 23/01/2009, à 22:15

kubuntu94

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Bonjour,

J'ai le même problème avec ma barre d'espace sous Code Blocks.
J'ai la version kubuntu 8.04,
j'ai chercher partout dans google.

J'ai modifié le fichier /ect/X11/xorg.conf en faisant sudo nano /ect/X11/xorg.conf
J'ai bien remplacé la ligne #        Option          "XkbVariant"    "oss"  une fois avec " latin9" au lieu de "oss" et j'ai aussi testé de la mettre en commentaire 'avec le #'.

Hors ligne

#19 Le 13/02/2009, à 11:59

Lisarios

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Idem, je suis sous Kubuntu et la liste des solutions proposées ne fonctionnenent pas. Je continue à chercher.

#20 Le 13/02/2009, à 12:23

Lisarios

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Sous Kubuntu :

changer le /etc/X11/xorg.conf en mettant en fin :

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
#        Option          "XkbVariant"    "oss"
EndSection


N'oubliez pas la tabulation et l'espace pour la dernière ligne ! (# + tab + Option...)

#21 Le 18/02/2009, à 01:43

cyberghost

Re : [Résolu]Problème de barre d'espace sous Code Blocks

superpapalolo a écrit :
Pandark a écrit :

Personnellement, j'ai sélectionné dans le menu Système>Préférence>Clavier
Ensuite, dans l'onglet Agencements, j'ai cliqué sur "options de l'agencement", et dans la fenêtre qui s'est ouverte, à l'option "using space key to input non breakable space character", j'ai coché "space key outputs usual space at any level", ce qui semble avoir résolu mon problème (j'en ai profité pour ajouter la touche euro et pour régler la sélection des chiffres lorsque capslock est activé).

+1

Je viens de faire exactement cela, pas à pas,  est ça fonctionne enfin.

Merci !:D

Petite remarque : jusque là j'utilisais Ctrl+alt+space et ça m'a fait apparaître les caractères en hébreu !? de temps en temps... bizarre comme bug...:(

<script>alert("cyberoot")<script>

#22 Le 18/02/2009, à 01:51

cyber-savant

Re : [Résolu]Problème de barre d'espace sous Code Blocks

superpapalolo a écrit :
Pandark a écrit :

Personnellement, j'ai sélectionné dans le menu Système>Préférence>Clavier
Ensuite, dans l'onglet Agencements, j'ai cliqué sur "options de l'agencement", et dans la fenêtre qui s'est ouverte, à l'option "using space key to input non breakable space character", j'ai coché "space key outputs usual space at any level", ce qui semble avoir résolu mon problème (j'en ai profité pour ajouter la touche euro et pour régler la sélection des chiffres lorsque capslock est activé).

+1

Je viens de faire exactement cela, pas à pas,  est ça fonctionne enfin.

Merci !:D

Petite remarque : jusque là j'utilisais Ctrl+alt+space et ça m'a fait apparaître les caractères en hébreu !? de temps en temps... bizarre comme bug...:(

super ca marche nikel et directement
pas besoin de redérmarrer
merci big_smilecool

#23 Le 01/03/2009, à 06:39

tikos

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Salut,
   Moi j'ai utilisé la méthode de pandark avec ubuntu entrepid et sa marche à merveille. Merci pandark.
Pour ceux qui ne savent pas exactement où madifier par ce que pandark l'a montré de façon global, il suffit de faire system>>preferences>>clavier>>layouts>>other options>>Using space key to input non-unbreakable space character puis changer au lieu de default, cliquer sur space key outputs usual space at any level.
  En réalité c'est presque la même chose qui se passe dans le fichier /etc/X11/xorg.conf où on commente la ligne Option          "XkbVariant"    "oss", il s'agit d'éliminer la confuguuration par defaut et activer l'usage de la touche space à tout niveau.

Merci et bon courage à tous:)

Hors ligne

#24 Le 01/03/2009, à 12:12

kevlar

Re : [Résolu]Problème de barre d'espace sous Code Blocks

oui, sauf que ça ne marche pas à tous les coups ... la gestion d'Xorg a beaucoup changé depuis Hardy. Ainsi, ce truc ne fonctionne pas sur mon portable, alors que la machine de bureau, elle, n'a même pas besoin de cette manip' (et les deux sont sous Ubuntu Hardy) !


Ella : projet de logiciel d'animation Flash pour Linux http://forum.ubuntu-fr.org/viewtopic.php?id=321017&p=1
Projet Ella sur launchpad : https://launchpad.net/ella
Le retour d'Ella animations avec le projet Renaissance est ici : https://launchpad.net/ella-renaissance
et des fichiers de démo ici : http://ellarenaissance.voila.net/index.html

Hors ligne

#25 Le 29/04/2009, à 15:43

Tchupa

Re : [Résolu]Problème de barre d'espace sous Code Blocks

Pandark a écrit :

Personnellement, j'ai sélectionné dans le menu Système>Préférence>Clavier
Ensuite, dans l'onglet Agencements, j'ai cliqué sur "options de l'agencement", et dans la fenêtre qui s'est ouverte, à l'option "using space key to input non breakable space character", j'ai coché "space key outputs usual space at any level", ce qui semble avoir résolu mon problème (j'en ai profité pour ajouter la touche euro et pour régler la sélection des chiffres lorsque capslock est activé).

Merci bien ça fonctionne correctement maintenant.:P

Hors ligne

Haut de page ↑