Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 04/01/2005, à 03:33

bEN

[Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

Hello,
Help! ... Un ptit coup de main ne serait pas de refus... :\

J'essaie d'installer Ubuntu (Warty) sur mon portable Dell (Latitude CPt S500GT), sans succès.


J'ai essayé de lancer l'installateur en mode 'standard', avec plusieurs paramètres:
boot: linux acpi=off vga=771 ide=nodma noapic nolapic

mais ça bloque après la détection du cdrom, lorsqu'une série de fichiers sont chargés.

J'ai également essayé en mode 'boot:expert':
boot: expert acpi=off vga=771 ide=nodma noapic nolapic
boot: expert vga=771 pci=noacpi ide=nodma ... etc
(bon, j'ai tout essayé, ainsi que hw-detect/start_pcmcia=false, etc, ... résultat identique à chaque fois)
------------------------------
Et voici ce que ça donne (en expert), à l'étape de détection CD-Rom:

[.] Détecter et monter le cédérom
Impossible de charger certains modules

Les modules du noyau Linux nécessaires pour certains de vos périphériques ne sont pas encore disponibles. Si vous continuez l'installation, ces modules pourront peut-être devenir accessibles plus tard.

Les modules indisponibles, et les périphériques qui en ont besoin sont les suivants:
agpgart (Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge),
xircom_cb (Xircom Cardbus Ethernet 10/100),
ide-mod (Linux IDE driver),
ide-probe-mod (Linux IDE probe driver),
ide-detect (Linux IDE detection),
ide-floppy (Linux IDE floppy).

Ensuite, ça continue (étape suivante):

[!] Charger des composants de l'installateur à partir du cédérom

Une erreur s'est produite lors de la lecture des données du cédérom. Veuillez vérifier que le cédérom est bien présent dans le lecteur. Si l'opération échoue à nouveau, vous devriez vérifier l'intégrité du cédérom.

La copie d'un fichier du cédérom a échoué. Faut-il réessayer?
<Oui>  <Non>

Evidemment, le CD est bien dans le lecteur CD-Rom!
J'en arrive à l'étape de vérification du CD d'install Ubuntu:

[!] Contrôler l'intégrité du(des) cédéroms

Le cédérom que vous avez inséré n'est pas un cédérom Ubuntu valide.
Veuillez changer de disque.
<Continuer>

N'ayant pas encore reçu mes CD "officiels", j'ai utilisé une image ISO, avec vérification du checksum: état ok ; dans le doute, j'ai re-téléchargé sur un autre FTP et gravé un 2ème ISO! Idem, il me dit que le CD n'est pas valide... mais je pense que le problème vient vraiment d'ailleurs...
(Cfr ce topic portables "Latitude CPx" sur le forum Ubuntu anglais: http://ubuntuforums.org/showthread.php?t=2948 )

Dernière précision: j'ai essayé avec le CD Ubuntu WARTY LIVE, et j'ai aussi un problème au lancement (freeze), sauf en mode 'nofail' (qui démarre avec tous les périph. désactivés: noagp, nodma, noacpi, etc). Là tout se lance sans problème, et ça fonctionne parfaitement!


J'ai essayé d'être complet... Si quelqu'un peut m'aider ce serait (très) sympa ; attention, je suis un newbie Linux à 99%, mais je suis persévérant big_smile
merci de m'avoir lu.

Dernière modification par bEN (Le 06/01/2005, à 19:18)

Hors ligne

#2 Le 05/01/2005, à 18:30

bEN

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

(petit up)

Personne n'a essayé une install avec un portable Dell, série Latitude CPx ?

J'ai beau indiquer les paramètres acpi=off et ide=nodma , ça continue à bloquer sad

(sous-question: il est possible d'installer Ubuntu depuis le Live CD? ça semble mon dernier espoir...)

Hors ligne

#3 Le 05/01/2005, à 23:51

krumli

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

Nop désolé, j'essayerais la semaine prochaine sur mon portable: IBM X31...

Hors ligne

#4 Le 06/01/2005, à 10:25

yeKcim

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

Toshiba P20-103, installation sans probleme (voir http://yeknan.free.fr).

Je vais quand meme pas en acheter un autre juste pour tes beaux yeux.


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#5 Le 06/01/2005, à 16:03

bEN

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

Merci pour vos réponses...

> (voir http://yeknan.free.fr).
Oui justement, ton site m'a pas mal aidé hier soir (partitionage, etc) ; car je viens de réussir à installer Ubuntu cette nuit (terminé ce matin à 8h!)...
et ça roule d'enfer!

Je vais mettre un petit message avec la méthode exacte à appliquer, car en fait le problème du cdrom qui bloque à l'install (cdrom IDE non détecté) n'était vraiment pas simple à résoudre! il semblerait que je ne sois pas le seul dans le cas, et c'est d'ailleurs un bug officiel (repris sur bugzilla.ubuntu.com).

Hors ligne

#6 Le 06/01/2005, à 19:14

bEN

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

PROBLEME: Le lecteur CD-Rom est détecté, mais inaccessible au moment de charger l'install
================================================================

Il semblerait que ce soit un bug avec les lecteurs cd-rom/dvd IDE sur système avec disque SATA

https://bugzilla.ubuntu.com/show_bug.cgi?id=1440
("ATAPI CD-ROM not detected in system with SATA")


SOLUTION:
========

Tout d'abord un petit update du BIOS ne fait pas de tort (pour mon Latitude CPt S500GT, je suis passé du A05 à A16, on sent la différence), même si chez moi ça n'a rien résolu à posteriori: http://support.euro.dell.com/ (sélectionner FlashBIOS Updates)
-----

Donc en fait, il y a moyen de contourner le problème à l'install, en tapant quelques lignes de codes (voir + bas) ; ça marche impecc! Par contre, il semblerait que le cdrom continue à ne pas être détecté ensuite. Sur le lien + bas, quelqu'un explique (en anglais) comment y remédier en modifiant  le fichier /etc/mkinitrd/modules (qui définit quels modules sont chargés au moment du initrd). Personnellement, après l'installation mon cdrom a été détecté par Ubuntu sans aucun problème, ni modification de fichier (je dois être chanceux?).


LIEN (l'explication du bug, en anglais):
https://bugzilla.ubuntu.com/show_bug.cgi?id=1440
Les points importants se trouvent à la fin (commentaires #42 et #43).

EN RÉSUMÉ:
==========
1. boot up as normal
2. Choose Language
3. Skip to tty2 by hitting alt-F2
4. do:
insmod /lib/modules/2.6.xxxxx/kernel/drivers/cdrom/cdrom.ko
insmod /lib/modules/2.6.xxxxx/kernel/drivers/ide/ide-core.ko
insmod /lib/modules/2.6.xxxxx/kernel/drivers/ide/ide-generic.ko
insmod /lib/modules/2.6.xxxxx/kernel/drivers/ide/ide-cd.ko
5. Return to tty1 by hitting alt-F1
6. Continue as usual loading other modules after the above are in place.

(-> où "2.6.xxxxx" est égal à "2.6.8.1-3-386" pour une installation de Warty sur une machine X86)

=============================================


si le cdrom n'est pas détecté au redémarrage après l'install (attention, je n'ai pas essayé cette méthode!?):

"This worked successfully to get the install finished. However, now it
appears that the installer has not configured /etc/modules (or some such)
correctly and the same problem is exhibited by the installed system."

"1. Open /etc/mkinitrd/modules (which defines what modules are loaded on mounting
the initrd)
2. Add these lines (to get it to load the ide cdrom modules early) and save:

   ide-generic
   ide-cd
   cdrom

3. At a command line type this command to make your new initrd.

   sudo mkinitrd -o /boot/initrd.img-2.6.8.1-3-386-new

4. Open /boot/grub/menu.1st and add a new entry near the bottom as follows:

   title           Ubuntu, kernel 2.6.8.1-3-386 (new!)
   root            (hd0,0)
   kernel          /boot/vmlinuz-2.6.8.1-3-386 root=/dev/sda1 ro quiet splash
   initrd          /boot/initrd.img-2.6.8.1-3-386-new
   savedefault
   boot

5. Reboot and at the grub prompt, quickly hit <ESC> and select the "(new!)" boot
   option.  If it has worked, you should see a device like hda appears in /dev .
   If you have any problem booting, just go back to the default grub boot option.

I have found that the cds so far don't automount.  I've had to drop to a shell
prompt and do:

  mount /media/cdrom


(...) "

Dernière modification par bEN (Le 06/01/2005, à 19:22)

Hors ligne

#7 Le 15/01/2005, à 22:46

Djiss

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

yeKcim a écrit :

Toshiba P20-103, installation sans probleme (voir http://yeknan.free.fr).

Je vais quand meme pas en acheter un autre juste pour tes beaux yeux.

Sympa comme reflexion ...
T'es toujours aussi cynique ?

#8 Le 16/01/2005, à 11:56

maillotte

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

j'essaie de taper les lignes de commandes prectées et il me sort un gentil "acces denied"
"insmod" c'est install mode?
il demande un attribut?
merci devos reponse

#9 Le 16/01/2005, à 16:56

bEN

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

Il m'est difficile de t'aider plus (je suis newbie sous Linux), peut-être que d'autres auront une réponse....? sinon regarde dans les liens cités (en anglais).

- Est-ce que tu as bien utilisé cette méthode dans l'ordre défini + haut?
- Tu as bien remplacé "2.6.xxxxx" par la version du kernel, soit "2.6.8.1-3-386" (dans mon cas, soit sur un PC x86 avec Ubuntu Warty)?

Hors ligne

#10 Le 16/01/2005, à 22:15

yeKcim

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

Djiss a écrit :

Sympa comme reflexion ...
T'es toujours aussi cynique ?

C'était juste une boutade, pas de quoi en faire une réflexion philosophique.


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#11 Le 17/01/2005, à 00:19

bEN

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

Merci de soulever la boutade en question... (je ne l'avais pas fait, volontairement): c'est vrai que je me suis dit que yeKcim s'était levé du pied gauche ce matin-là wink (un petit smiley additionnel n'aurait pas fait de tort quoi...). Mais bon, y'a pas de soucis, et surtout y'a rien à reprocher à quelqu'un comme lui qui aide autant la communauté! a+ smile

Hors ligne

#12 Le 09/09/2005, à 21:27

Yaen

Re : [Résolu]-[laptop] installateur freeze sur Dell Latitude CPt S500GT

bEN a écrit :

(petit up)

Personne n'a essayé une install avec un portable Dell, série Latitude CPx ?

J'ai beau indiquer les paramètres acpi=off et ide=nodma , ça continue à bloquer sad

(sous-question: il est possible d'installer Ubuntu depuis le Live CD? ça semble mon dernier espoir...)

j'ai tenté une live install sur un latitude : le Dell il est texan et il couche avec un mec de Redmond donc y a peut-être des petites choses pas très catholiques sous couvert lol


Je joue à HL2, CSS, Stalker... avec mon pingouin d'amour.

Hors ligne