Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#51 Le 10/03/2009, à 14:43

Claire Zerbinette

Re : Anki : un outil d'apprentissage des langues

Bonjour ! smile
j'ai répondu à ta question ici :
http://forum.ubuntu-fr.org/viewtopic.php?pid=2484805#p2484805

#52 Le 26/03/2009, à 14:12

Sysko le prospecteur

Re : Anki : un outil d'apprentissage des langues

en fait vu que  Anki utilise   QT et non Gnome  ( au contraire de la plupart des applications de Ubuntu )  ,  il ne fonctionne pas directement avec scim   ( ainsi que toutes les applications issus de Kubuntu  , skype ou autre écrit avec QT )

donc pour résoudre le problème il faut installer  scim-bridge-client-qt4  et  lancer les applications avec la commande suivante
dans un terminal

QT_IM_MODULE=scim-bridge  anki  ( ou autre)

après il est possible de  ne plus avoir à taper  QT_IM_MODULE=scim-bridge  en le mettant dans votre fichier   ~/.bashrc
vous rajoutez à la fin de ce fichier

export QT_IM_MODULE=scim-bridge

(par contre  il faut lancer anki depuis le terminal )
voila en espérant que cela vous aide

Qui plus est si vous voulez j'ai créer un  deck  contenant l'ensemble des mots du HSK  niveau élémentaire  + audio + phrase d'exemple pour une bonne partie des mots , donc si cela vous intéresse

je reste disponible pour plus d'infos

Dernière modification par Sysko le prospecteur (Le 26/03/2009, à 14:17)


Projet tatoeba : projet collaboratif visant à créer un corpus de phrases d'exemples traduites dans le plus de langues possibles

Hors ligne

#53 Le 27/03/2009, à 04:54

elpepe

Re : Anki : un outil d'apprentissage des langues

Merci Sysko pour ces précieuses info !

à ++ smile

Hors ligne

#54 Le 07/04/2009, à 05:42

elpepe

Re : Anki : un outil d'apprentissage des langues

Salut à tous smile

Une bonne nouvelle ! Enregistrer l'audio avec anki sous ubuntu intrepid, c'est possible !

Avant d'éditer la doc ubuntu fr et celle d'anki, j'aimerai avoir un petit feedback afin de vérifier si ça marche bien pour tout le monde, et ne mettre que l'essentiel. Merci à vous si vous testez !!! Mieux vaut faire un petit backup au cas où avant de faire ces manips (j'ai pas eu de problèmes mais on sait jamais...).


1. Vérifier que vous ne pouvez pas enregistrer de sons avec Anki en utilisant ubuntu 8.10 (normalement non, car anki utiliserait une fonctionnalité de sox (normalisation) qui ne n'est pas dans la version par défaut d'ubuntu hardy de sox : la 14.0.1 alors que la version requise par Anki est la 14.1 ou supérieure).


2. S'assurer d'avoir désinstallé toutes version de sox précédemment installé (Attention ! La désinstallation de sox va peut-être entraîner la désinstallation d'autres paquets, veuillez noter les paquets qui vont être désinstallés en vue de les réinstaller plus tard) :

$ sudo apt-get remove --purge sox

3. Télécharger la version de sox à cette http://downloads.sourceforge.net/sox/sox-14.2.0.tar.gz?modtime=1226179484&big_mirror=0

4. Décompresser le fichier téléchargé ou vous voulez
Sous linux on installe habituellement les programmes rajoutés manuellement dans le repertoire /opt. Mais ce n'est pas une obligation. N'oubliez pas que vous aurez besoin des droits d'administration pour installer vos programmes dans ce répertoire.

5. En console se rendre dans le répertoire sox-14.2.0 que vous venez de décompresser (modifier le chemin pour l'adapter à votre cas) :

$ cd chemin/vers/sox-14.2.0

6. Compiler Sox dans /usr :

$ ./configure --prefix=/usr && make && sudo make install

(note du tuto d'origine destiné au programme smile : Par défaut ubuntu installe les programmes dans /usr/bin, mais smile cherche sox dans /usr, c'est pour cette raison que nous sommes obligés de compiler sox avec l'option –prefix=/usr )

7BIS. QUESTION A POUR LES TESTEURS : pouvez-vous enregistrer l'audio ? quand j'avais essayé, non.

7. Redémarrez Ubuntu.

8BIS QUESTION B : pouvez-vous enregistrer l'audio ?

9. Si ça marche pas essayez d'installer ceci :

$ sudo apt-get install libqt4-opengl-dev libqt4-dev libqt4-webkit

9BIS QUESTION C  : sans redémarrer c'est bon ?

10. Redémarrez Ubuntu.

11. Ça devrait être bon smile Bon le son est un peu bizarre genre guerre des étoiles quand c'est du silence, mais ça va smile QUESTION D : Avez aussi le son un peu bizarre ? Avez-vous une astuce pour arranger ça ? Rmrq : J'avais fait record noise.
Merci pour votre feedback !!!

Note et QUESTION E : quand je lance anki avec la console j'ai ce message quand j'enregistre l'audio, l'avez vous aussi ?
mplayer: could not connect to socket
mplayer: No such file or directory

Dernière modification par elpepe (Le 07/04/2009, à 07:35)

Hors ligne

#55 Le 07/04/2009, à 18:36

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Salut Elpepe!

De mémoire, j'aurais dit que la méthode sox ne marche que pour l'ancienne méthode d'enregistrement audio, celle basée sur une extension. J'aurais dit que la nouvelle est basé sur python-pyaudio. Mais j'ai peut-être loupé un épisode.

mplayer: could not connect to socket
mplayer: No such file or directory

Pas grave. Cela le fait avec tous les fichiers que je lance depuis la ligne de commande. Ces informations disparaissent avec l'option -nolirc.

Hors ligne

#56 Le 07/04/2009, à 18:52

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Ah mais je suis bête. Tu m'avais dit que l'enregistrement ne fonctionnait pas malgré python-pyaudio. Mais que vient faire sox ici?

Hors ligne

#57 Le 07/04/2009, à 18:54

alteo_gange

Re : Anki : un outil d'apprentissage des langues

En effet, sox est dans le README. Je n'ai rien dit.

Hors ligne

#58 Le 07/04/2009, à 19:09

elpepe

Re : Anki : un outil d'apprentissage des langues

Salut Alteo smile

Et oui et apparemment tous nos malheurs pour utiliser l'enregistrement avec anki viennent de sox : la version par défaut d'intrepid et sox 14.0.1 je crois (cf. dans synaptic en mettant sox), alors qu'il faut version > ou = à sox 14.1 par rapport à un paramètre de normalisation que demande anki. Une des méthodes de résolution est donc d'installer une version sox supérieure, ce que propose de faire les explications ci-dessus. Espérons que la 9.04 d'ubuntu proposera un sox 14.1 ou supérieur pour que cela fonctionne sans toutes ces étapes smile.

à bientôt wink

Hors ligne

#59 Le 07/04/2009, à 19:18

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Ah mince, t'es là. J'allais supprimé mes précédents messages en toute discrétion. roll

L'idéal serait de compiler 14.1, d'en faire un paquet (ou deux avec le 64 bits) et de l'ajouter à un dépôt deb. Est-ce que le sox de Jaunty est compatible avec celui d'Intrepid? Mais c'est compliqué. Il faut aussi voir voir si ça ne bloquerait pas au niveau des dépendances de dépendances, c'est-à-dire des dépendances de sox.

Hors ligne

#60 Le 07/04/2009, à 19:48

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Mince! "Front", "Reverse", "Back"... ne sont pas traduits. Damien n'a pas dû utiliser gettext dessus. Tu te charges de la réclamation?

Hors ligne

#61 Le 08/04/2009, à 09:03

elpepe

Re : Anki : un outil d'apprentissage des langues

Salut Alteo, voilà c'est réclamé smile

Lecteurs de ce post, si vous avez un peu de temps, n'hésitez pas à tester la procédure pour rendre possible l'enregistrement avec anki (cf. plus haut), en répondant aux 5 questions, comme ça après on pourra la mettre sur la doc ubuntu et d'anki wink Merci !!

Hors ligne

#62 Le 08/04/2009, à 13:59

elpepe

Re : Anki : un outil d'apprentissage des langues

voilà la réponse :
That's right. They are user defined fields, not fields in the program

J'ai pas tilté sur le coup (je m'étais aussi posé la question), mais en effet on défini le nom de ces champs dans les propriétés du modèle (onglet general & fields > fields).

A bientôt smile

Hors ligne

#63 Le 09/04/2009, à 06:23

samf

Re : Anki : un outil d'apprentissage des langues

Salutation à la grande et excellente communauté Ubuntu.Fr,
(c'est pas un gag, je pense vraiment ce que je dis smile)

J'avais posté un topic pour rechercher un logiciel de cartothèque linguistique. YannUbuntu m'a très bien conseillé et me voilà parmi vous.

Je viens d'installer Anki 0.9.5.7 et je vais essayer de m'en servir. En ma qualité de débutant (eh oui, c'est aussi une qualité car avec des yeux nouveaux on ne voit pas de la même manière) je vous tiendrais au courant de mes pérégrinations.

1ère: En allant sur la documentation Ubuntu, j'ai rencontré un petit problème.
On me propose d'ajoutez la ligne suivante à mon /etc/apt/sources.list :
deb http://download.tuxfamily.org/polyglotte/deb intrepid. Ce que j'ai fait et enregistré.
Ensuite exécutez la commande suivante dans un terminal :
sudo wget http://download.tuxfamily.org/polyglotte/deb/polyglotte.key.asc -O- | sudo apt-key add -
Mais là il me demande mon mot de passe 4 fois de suite.......en me disant que je me suis trompé??????? c'est peut-être moi, mais pour d'autres commandes ça marche.

De guerre lasse, je suis passé par le synaptic et alors il m'a dit que la ligne que j'avais rajoutée dans etc/apt/source.liste n'était pas reconnue. Je l'ai supprimée et j'ai installer depuis le paquet.

Ça marche, je me lance. Prochaine nouvelles dans dix jours, je vais en vacances, il n'y a pas de wifi sur la plage et le notebook n'aime pas le sable lol.

Bon week-end Pascal.

PS: Désolé pour les liens dans les lignes de commandes, je n'ai pas réussi à les supprimer hmm

Dernière modification par samf (Le 09/04/2009, à 06:32)


Escusé moua les fotes d'hortografe, jé ratez mon baque...    MERCI

Ubuntu 10.04 LTS (Lynx Lucide) - Noyau Linux 2.6.32-26-generic - Gnome 2.30.2 - Ooo 3.0.2 - Python 2.5.2 - Gedit 2.30.03 (Autocomplete 0.9.6 - Better Python Console) - Firefox 3.6.13 etc.

Hors ligne

#64 Le 09/04/2009, à 07:12

elpepe

Re : Anki : un outil d'apprentissage des langues

Salut Samf !
Bonnes vacances et bienvenue dans la communauté francophone ubunterienne d'Anki big_smile

Hors ligne

#65 Le 09/04/2009, à 09:30

samf

Re : Anki : un outil d'apprentissage des langues

Mes pérégrinations (2ème)

Si j'ai réussi à contourner mon premier problème, celui-ci je ne sais pas quoi faire.

J'ai ouvert trois fenêtres Anki: -Un paquet -Police et Couleurs -Propriétés du modèle

Voir mon PrintScreen:

mini_318104AnkiNeFermePlus.png

Et c'est là que le problème arrive......:P , je ne peux plus fermer l'application ????????

Auriez-vous une solution?

Merci

PS: pour ma configaration, voir ma signature.


Escusé moua les fotes d'hortografe, jé ratez mon baque...    MERCI

Ubuntu 10.04 LTS (Lynx Lucide) - Noyau Linux 2.6.32-26-generic - Gnome 2.30.2 - Ooo 3.0.2 - Python 2.5.2 - Gedit 2.30.03 (Autocomplete 0.9.6 - Better Python Console) - Firefox 3.6.13 etc.

Hors ligne

#66 Le 09/04/2009, à 13:22

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Salut Sam.

samf a écrit :

sudo wget http://download.tuxfamily.org/polyglotte.key.asc -O- | sudo apt-key add -

Pourquoi télécharger la clé en administrateur (= pourquoi utiliser un sudo devant wget)?

samf a écrit :

On me propose d'ajoutez la ligne suivante à mon /etc/apt/sources.list :
deb http://download.tuxfamily.org/polyglotte/deb intrepid. Ce que j'ai fait et enregistré

C'est:

deb http://download.tuxfamily.org/polyglotte/deb intrepid contrib

Tu peux réessayer?

Dernière modification par alteo_gange (Le 09/04/2009, à 13:24)

Hors ligne

#67 Le 09/04/2009, à 13:34

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Salut elpepe.

elpepe a écrit :

voilà la réponse :
That's right. They are user defined fields, not fields in the program

J'ai pas tilté sur le coup (je m'étais aussi posé la question), mais en effet on défini le nom de ces champs dans les propriétés du modèle (onglet general & fields > fields).

A bientôt smile

Je te répondrai sur la liste d'Anki.

Pour ton test audio, désolé, mais je ne possède pas encore de casque-micro.
PS: à partir de quel prix peut-on en avoir de corrects (niveau entrée et sortie audio)?

Hors ligne

#68 Le 09/04/2009, à 14:05

samf

Re : Anki : un outil d'apprentissage des langues

alteo_gange a écrit :

Salut Sam.
Tu peux réessayer?

Oui, mais je ne sais pas si c'est ok après l'avoir installé avec synaptic....

Mea culpa pour l'oubli du "contrib" en fin de ligne.... (cette fichue manie de ne pas lire les consignes jusqu'au bout roll)

Voici la réponse de ma console:

Sam:~$ wget http://download.tuxfamily.org/polyglotte.key.asc -O- | sudo apt-key add -
[sudo] password for samuel: --2009-04-09 13:57:59--  http://download.tuxfamily.org/polyglotte.key.asc
Résolution de download.tuxfamily.org... 88.191.250.18
Connexion vers download.tuxfamily.org|88.191.250.18|:80... connecté.
requête HTTP transmise, en attente de la réponse... 404 Not Found
2009-04-09 13:57:59 ERREUR 404: Not Found.

J'ai pas vraiment le temps de désinstaller, mais dès que je le fais, je te tiens au courant.

Merci


Escusé moua les fotes d'hortografe, jé ratez mon baque...    MERCI

Ubuntu 10.04 LTS (Lynx Lucide) - Noyau Linux 2.6.32-26-generic - Gnome 2.30.2 - Ooo 3.0.2 - Python 2.5.2 - Gedit 2.30.03 (Autocomplete 0.9.6 - Better Python Console) - Firefox 3.6.13 etc.

Hors ligne

#69 Le 09/04/2009, à 14:26

elpepe

Re : Anki : un outil d'apprentissage des langues

Salut Alteo,

alteo_gange a écrit :

PS: à partir de quel prix peut-on en avoir de corrects (niveau entrée et sortie audio)?

désolé j'ai pas trop d'idée... Il y a quelques temps j'en avais un 5€ (maintenant j'utilise celui qui est intégré dans l'ordi), et c'est vrai que ça vaut pas les bons gros micro qu'il y a par exemple pour un karaoké ou pour la scène. Le son est cependant très propre après une retouche avec audacity.

Hors ligne

#70 Le 09/04/2009, à 18:42

alteo_gange

Re : Anki : un outil d'apprentissage des langues

samf a écrit :

cette fichue manie de ne pas lire les consignes jusqu'au bout roll

wget http://download.tuxfamily.org/polyglotte/deb/polyglotte.key.asc -O- | sudo apt-key add -

Hors ligne

#71 Le 09/04/2009, à 19:18

killersky4

Re : Anki : un outil d'apprentissage des langues

Salut,

je viens de découvrir Anki , j'ai testé un peu avec un dictionnaire d'origine ca ma l'air trés pratique !:D
je l'ai installé directement avec depuis synaptic avec les depots de depart j'ai pas eu de problème ( je suis en 0.9.9.4 par contre je sais pas si la derniere version apporte beaucoup de nouveauté ...) je me suis servis de apt-get pour qu'il gere aussi les mise a jours tout seul mais je sais si il le fait quand meme pour des paquets installé par d'autre moyen ...
je vais  partir a la recherche d'" un jeux de cartes" pour apprendre le japonais si je trouve pas je tenterai des conversion de stardict (m'enfin c'est mieux d'avoir un dictionnaire avec des mots sélectionné pour leur utilité )
et aussi "un jeux de carte" pour apprendre les hirigana/katakana/kanjis mais bon pour ca la langue importe peu ca devrait etre plus simple .

Enfin bref j'écrivais surtout pour vous dire que j'arrivais parmi vous et pour remercier ce qui bosse pour la traduction et pour faciliter l'utilisation de ce logiciel !

A bientot:D

edit : j'ai trouvé kanatest pour les hirigana/katakana et une page qui liste tout les jeux de cartes dispo par contre en francais j'ai trouvé qu'un jeux allemand sad

Dernière modification par killersky4 (Le 09/04/2009, à 19:34)


"Celui qui est prêt à sacrifier un peu de liberté pour obtenir un peu de sécurité ne mérite ni l'une ni l'autre." Benjamin Franklin

Hors ligne

#72 Le 09/04/2009, à 19:50

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Salut killersky4. Les dernières versions d'Anki apportent beaucoup de nouveautés.

Tu peux trouver des paquets tout prêt sur le site officiel. Mais ce n'est pas forcément le meilleur moyen d'apprendre. Le mieux est souvent de se les construire à partir de ressources pédagogiques (cours, livres, audios...).

En ce qui concerne les mises à jour de logiciels, celles des dépôts officiels font surtout des corrections de bogue (sauf changement de distribution, bien sûr). Un dépôt dédié à un logiciel ou à un groupe de logiciels permet d'en faire de plus conséquentes.

Hors ligne

#73 Le 09/04/2009, à 19:51

alteo_gange

Re : Anki : un outil d'apprentissage des langues

Je vais essayer de retenir les caractéristiques d'un nouveau langage... informatique avec Anki!

Hors ligne

#74 Le 09/04/2009, à 20:17

killersky4

Re : Anki : un outil d'apprentissage des langues

Merci pour tes réponses je vais peut etre me lancé dans la traduction de jeux de cartes il y en a en anglais pour apprendre le japonais qui ont l'air tres bien fait (différent niveaux ect...)

et je vais passé a la derniere version de anki par contre j'ai pas compris l'avantage/difference de la Méthode du dépôt externe par rapport au .deb du site officiel ?


"Celui qui est prêt à sacrifier un peu de liberté pour obtenir un peu de sécurité ne mérite ni l'une ni l'autre." Benjamin Franklin

Hors ligne

#75 Le 09/04/2009, à 20:32

samf

Re : Anki : un outil d'apprentissage des langues

Merci alteo_gange,

Je ne m'explique pas comment j'ai pu louper un morceau central de la ligne de commande... alors que j'ai passé par le copier-coller.

M'enfin, j'ai recommencé, et cette fois en ayant désinstallé Anki qui venait du paquet synaptic.

Voilà le résultat:
mini_527376InstallAnki.png

pas très concluant....

Je vais donc réinstaller le paquet pour explorer ce logiciel pendant les vacances de Pâques, vu que je prend l'avion demain à la première et que je n'aurais peut-être pas de wifi.

Bonne Pâques

alteo_gange a écrit :

Je vais essayer de retenir les caractéristiques d'un nouveau langage... informatique avec Anki!

Je me suis mis à étudier Python, et je comptais bien faire des fiches programmations.

Bon courage.

Dernière modification par samf (Le 09/04/2009, à 20:35)


Escusé moua les fotes d'hortografe, jé ratez mon baque...    MERCI

Ubuntu 10.04 LTS (Lynx Lucide) - Noyau Linux 2.6.32-26-generic - Gnome 2.30.2 - Ooo 3.0.2 - Python 2.5.2 - Gedit 2.30.03 (Autocomplete 0.9.6 - Better Python Console) - Firefox 3.6.13 etc.

Hors ligne

Haut de page ↑