Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 07/01/2006, à 18:21

itoine

Re : e17 CVS

bon le script se lance, mais le telechargement se lance pas ...

Telechargement des sources de e17
Login sur le CVS de e17
Essai 1/5
Login sur CVS de e17 OK

Telechargement des sources de enlightenment (cela risque de prendre du temps)
Essai 1/5
Essai 2/5
Essai 3/5
Essai 4/5
Essai 5/5
La commande s'est mal passee, veuillez consulter le fichier de log /home/itoine/E17/execution.log pour plus de details

Temps d'execution : 0h 1m 24s

il y aurait trop de monde?

Hors ligne

#27 Le 07/01/2006, à 18:23

niguss

Re : e17 CVS

sudo: ./compil-e17.py

T'es sûr que c'est ça la commande ?
moi j'avais fait sudo python compil-e17.py

Hors ligne

#28 Le 07/01/2006, à 18:26

itoine

Re : e17 CVS

oui ca doit etre ca, c'est celle du tutoriel et ca a l'air de marcher chez moi (mis a part le telechargement des cvs)

par contre faut pas oublie de le rendre executable

chmod +x compil-e17.py

Hors ligne

#29 Le 07/01/2006, à 18:31

toma222

Re : e17 CVS

Oui, pour le téléchargement apparemment on en est tous au même point (le cvs doit être KO, donc patience...). Désolé de pas avoir penser à mettre dans le tuto qu'il fallait rendre le script exécutable, c'est corrigé maintenant).

Hors ligne

#30 Le 07/01/2006, à 18:33

itoine

Re : e17 CVS

merci, mais tu n'as vraiment pas a t'excuser... smile

Dernière modification par itoine (Le 07/01/2006, à 18:33)

Hors ligne

#31 Le 07/01/2006, à 19:33

Daymarvi

Re : e17 CVS

Ce qui est bizarre, c'est que l'acces au cvs par le web fonctionne, mais quand on tape la commande en shell ca ne marche pas.

Patience donc smile

#32 Le 07/01/2006, à 21:51

itoine

Re : e17 CVS

sinon une petite question :
il y en a pour combien de temps pour telecharger les cvs et compiler le tout? (j'ai un sonoma 2GHz 1Go de RAM)

c'est pour savoir, des fois que les cvs remarchent ce soir, jusqu'a quelle heure je peux lancer le script sans me retrouver coincer et pas pouvoir me coucher smile

Hors ligne

#33 Le 07/01/2006, à 23:21

toma222

Re : e17 CVS

Sur une machine comme ça ça devrait aller assez vite. Je me suis fait coincer comme ça hier soir sur mon Duron 900 où la compil a été plus longue que prévue. Mais avec mon 2600+, je mets 15-20 min je pense (mais en même temps je chronomètre pas donc peut-être plus, peut-être moins). De toute façon, comme c'est parti, je pense pas qu'on retrouve les CVS aujourd'hui.

Hors ligne

#34 Le 07/01/2006, à 23:45

toma222

Re : e17 CVS

Ca semble reparti pour le CVS !!!!!!! Tous à vos compil wink.

EDIT : On fait pas la course, je suis sur un Duron 900...

Dernière modification par toma222 (Le 07/01/2006, à 23:47)

Hors ligne

#35 Le 08/01/2006, à 01:54

niguss

Re : e17 CVS

je viens de commencer à compiler e_modules : sudo ./autogen.sh se passe bien mais pas make, il me dit :"make***: pas de cible spécifiée et aucun makefile n'a été trouvé. Arrêt"
Quelqu'un saurait pourquoi ? en effet il n'y a pas de fichier make dans le dossier.

Dernière modification par niguss (Le 08/01/2006, à 01:55)

Hors ligne

#36 Le 08/01/2006, à 02:03

niguss

Re : e17 CVS

Dois-je aller dans chaque dossier et faire make et make install ? enfin dans chaque dossier, pour les modiles que je voudrais utiliser ?

Hors ligne

#37 Le 08/01/2006, à 02:54

niguss

Re : e17 CVS

ok ça marche en allant dans chaque dossier pour chaque module désiré.

Hors ligne

#38 Le 08/01/2006, à 11:55

itoine

Re : e17 CVS

c'est bon, j'ai pu lancer le script ce matin pour faire une installation  complete. ca n'a pris que 20min max pour telecharger et compiler les sources.

un petit coup de genmenu et hop, tout marche, c'est super beau smile meme pas besoin de "tuner", c'est beau d'origine smile

par contre, parce que tout n'est quand meme pas parfait wink, les polices sont moins belle que sous gnome, par exemple sous firefox...
je pourrai faire une capture d'ecran pour vous montrer, mais je pense que vous voyez ce que je veux dire. alors si vous savez comment modifier ca, merci smile

Hors ligne

#39 Le 08/01/2006, à 12:20

dawar

Re : e17 CVS

itoine a écrit :

bon le script se lance, mais le telechargement se lance pas ...

[...]
La commande s'est mal passee, veuillez consulter le fichier de log /home/itoine/E17/execution.log pour plus de details

Temps d'execution : 0h 1m 24s

il y aurait trop de monde?

Hum, la fin du message est pourtant claire... Qui y'a t'il dans les dernières lignes de execution.log ? Mince, c'est écrit en français et plutot limpide : si vous avez des problème avec la compilation de E17, donnez la fin de execution.log et non le message générique qui est le même quelque soit l'erreur smile


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#40 Le 08/01/2006, à 12:27

lut!n

Re : e17 CVS

@ itoine : il faut charger gnome-settings-daemon au demarrage de e17 et normalement c'est bon (en tout cas chez moi ca marche), je crois que les réglages incluent aussi les polices

Dernière modification par lut!n (Le 08/01/2006, à 14:44)

Hors ligne

#41 Le 08/01/2006, à 13:00

itoine

Re : e17 CVS

lut!n a écrit :

@ itoine : il faut charger gnome-settings-daemon au demarrage de e17 et normalement c'est bon (en tout cas chez moi ca marche), je crois que les réglages incluent aussi les polices

et comment on fait ca? sad

Hors ligne

#42 Le 08/01/2006, à 13:39

dawar

Re : e17 CVS

Bon, j'ai pas mal de difficultés a compiler la chose, voici quelques astuces qui m'ont permis d'aller plus loin. Pour mon erreur "../../src/lib/.libs/libedje.so: undefined reference to `eet_data_descriptor2_new'" c'est parce qu'il me restait une vieille copie de eet installée en .deb.

Enfin, a priori il faut automake 1.7 sinon ça ne passe pas... Ni avec la 1.4, ni avec la 1.8...


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#43 Le 08/01/2006, à 14:12

itoine

Re : e17 CVS

pour charger gnome-settings-deamon, j'ai trouve ca sur le forum, par Ratur

Pour les problemes de firefox pas beau, de polices, etc ... je l'ai résolu en chargeant le programme gnome-settings-daemon au démarrage de E17.
Pour se faire, tu peux aller dans configuration > Eap Editor. La tu va pouvoir creer un executable pour gnome-settings-daemon . Pour le nom et l'icone, tu met ce que tu veux wink

Ensuite tu va dans l'éditeur de menu de E17, dans la section startup, et tu y glisses l'icone nouvellement créée.

pour l'instant j'ai créé l'icone, mais je ne trouve pas ce qu'il appelle "l'editeur de menu"...

Hors ligne

#44 Le 08/01/2006, à 14:16

lut!n

Re : e17 CVS

si tu as compilé e_utils ==> terminal ==> entangle (poursupprimer une icone c'est clic droit, piur l'ajouter c'est glisser-deposer de la liste de gauche) wink

Dernière modification par lut!n (Le 08/01/2006, à 14:22)

Hors ligne

#45 Le 08/01/2006, à 14:21

itoine

Re : e17 CVS

ok merci
mais elle est monstrueuse la liste a gauche?
il y a une astuce pour retrouver facilement qq chose?

Hors ligne

#46 Le 08/01/2006, à 14:26

lut!n

Re : e17 CVS

facilement je sais pas, j'ai jamais réussi mad
par contre un conseil : ton as dans ton home/user/.e/e/applications/
plusieurs dossiers nommés all (contenant toutes .eap), bar, restart, startup
chacun de ces repertoires contiennet un fichier .order
il te suffit de rajouter dans ce fichier le nom du fichier .eap que tu souhaites lancer au démarrage (dans ton cas, tu crées un .order dans startup, et tu y ajoutes le gnome-settings-daemon.eap que tu as créé dans le dossier all)
voila big_smile tu verras c'est nettement plus pratique quand ta liste de entangle est tres longue


[mode chieur] tu pourrais m'envoyer les sources de e_modules s'il te plait roll [/mode chieur]

Hors ligne

#47 Le 08/01/2006, à 14:37

itoine

Re : e17 CVS

si tu me dis ou je les trouve les sources que tu veux, pas de probleme smile
perso j'ai utilise le script, alors je sais pas ou elles sont...

Hors ligne

#48 Le 08/01/2006, à 14:44

lut!n

Re : e17 CVS

elles sont dans /repertoire_de_telechargement_de_ton_script/apps/e_modules
merci beaucoup tongue lutin44_tne at yahoo dot fr

Hors ligne

#49 Le 08/01/2006, à 14:54

itoine

Re : e17 CVS

c parti, dis moi si c ca que tu voulais

sinon moi j'ai encore un probleme, je ne retrouve pas l'icone créer dans le dossier all

pour info quand j'ai créer l'icone, j'ai simplement lancé "eap editor" puis tapé "gnome-settings-deamon" dans appsname et executable

Hors ligne

#50 Le 08/01/2006, à 15:02

lut!n

Re : e17 CVS

je ne sais pas, je ne me suis jamis servi de eap editor .....
je vais te donner la methode que j'utilisais (peut etre pas la meilleure, mais elle a le merite de marcher wink)
tu fais dans un terminal

cd ~/.e/e/applications/all
e_util_eapp_edit nom_du_fichier_desire.eap

voila big_smile, dis moi si ca te va ...

Hors ligne