Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1101 Le 25/02/2008, à 12:54

Tiki10

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Et bien tu commences pas te logguer, et puis tu reconfigure ton serveur xorg avec la commande dpkg-reconfigure xerver-xorg. Pour revenir en arrière, choisis " ATI " comme carte graphique.
Une fois la configuration terminée, redemarre le serveur X avec soit " ctrl+alt+backspace", soit avec la commande sudo /etc/init.d/gdm start


Tiki

Hors ligne

#1102 Le 25/02/2008, à 13:17

nelyo

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

je viens de réinstaller mon Ubuntu
Je suis un jeune linuxien
Je cherche la méthode et le bon driver pour ma carte graphique ATI Radeon x1300 PRO

Hors ligne

#1103 Le 25/02/2008, à 18:27

pierluc

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Procédure d'installation manuelle:

1- Tu active les dépots universe et machin chouette dans synaptic:
     - Aller dans: système/Administration/Gestionnaire de paquets Synaptic
     - Puis, dans Synaptic; Paramètre/Dépots
     - Deuxième onglets, tu coche tout. (fait aussis un tour dans les autres onglets pour paramétrer les mises à jours automatiques...)

2- Télécharger le pilotes Catalyst 8.2 ici:
http://ati.amd.com/support/drivers/linux/linux-radeon.html

3- Mettre le pilote dans vôtre dossier personnel de la partition home.

4- Faire un clic droit sure le pilote puis propriété. Dans l'onglet permission tu coche la case qui permet l'exécution.

4- Lancer cette commande pour générer les paquets debian nécessaire à l'installation:

./ati-driver-installer-8-02-x86.x86_64.run --buildpkg Ubuntu

5- Ça vas te créer 4 paquets .deb. Tu commence par installer xorg-driver-fglrx_8.455.2-0ubuntu1_i386.deb car tout les paquets en dépendes. Si tu ne l'installe pas en premier il ira chercher la vieille version sure le serveur d'Ubuntu.

6- S'il t'offre de télécharger des dépendances tu accepte.

7- Puis, tu installe les autres paquets de la même façon dans l'ordre que tu veut.

8- Finalement tu lance cette commande pour configurer ton xorg.conf:

sudo aticonfig --initial -f

9- Tu redémarre ta machine.

10- Tape fgl_glxgears dans le terminal pour voir si le 3D fonctionne correctement.

Dernière modification par pierluc (Le 01/03/2008, à 00:37)


Porte-Folio: http://pearluc.wordpress.com
Linux, là où la main de l'homme n'a jamait mit pied.
Capitaine Patnaud, Émission Dans une galaxie près de chez vous
Pour rire: www.tetesaclaques.tv

Hors ligne

#1104 Le 25/02/2008, à 19:38

nelyo

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Quand tu dis :"Tu active les dépots universe et machin chouette dans synaptic"
On fait comment  ?
Désolé je débute

Hors ligne

#1105 Le 25/02/2008, à 20:23

nelyo

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Je viens de tester
c'est nickel
je dirais même Wouahou !!!
Et surtout : merci pierluc

le seul petit souci c'est que pour l'instant 
tvtime ne veut toujours pas se lancer

Dernière modification par nelyo (Le 25/02/2008, à 20:30)

Hors ligne

#1106 Le 04/03/2008, à 22:29

slayer03

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour,
je compte installé XGL pour compiz, je voulais déjà savoir si c'est bien les drivers proprio qu'il faut?
J'ai une ati mobility 9700 et Kubuntu 7.10, est voici mon xorg.conf, est ce que c'est bon pour mettre compiz? Est ce que j'ai besoin de Catalyst?

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"oss"
	Option		"XkbOptions"	"lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Logitech Cordless Click! Plus"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "Buttons" "5"
    Option         "ZAxisMapping" "4 5"
    Option         "ButtonMapping" "1 2 3 6 7"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizEdgeScroll"	"0"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
	Driver		"fglrx"
	Busid		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]"
	Monitor		"Écran générique"
	Defaultdepth	24
	SubSection "Display"
		Modes		"1400x1050"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice    "Logitech Cordless Click! Plus"    "CorePointer"
	
	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection
Section "Module"
	Load		"glx"
EndSection
Section "Extensions"
	Option		"Composite"	"0"
EndSection
jo@kubuntu:~$ glxgears
13326 frames in 5.0 seconds = 2665.110 FPS
10458 frames in 5.0 seconds = 2091.524 FPS
10445 frames in 5.0 seconds = 2086.523 FPS
10452 frames in 5.0 seconds = 2088.730 FPS
jo@kubuntu:~$

Ubuntu 9.10 et Windows XP SP3
Xbook XB7v2 : centrino M735 1,7ghz, 1024 Mo de Ram, ATI Radeon 9700 mobility 128Mo, DD Samsung 80Go. Multifonction Brother DCP-340CW

Hors ligne

#1107 Le 05/03/2008, à 20:59

slayer03

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

up


Ubuntu 9.10 et Windows XP SP3
Xbook XB7v2 : centrino M735 1,7ghz, 1024 Mo de Ram, ATI Radeon 9700 mobility 128Mo, DD Samsung 80Go. Multifonction Brother DCP-340CW

Hors ligne

#1108 Le 22/03/2008, à 10:20

saso

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

bonjour
j'ai éffectué la méthode de pierluc pour installer ma ati radeon X1400 sur un toshiba satellite A100 - 768 mais sans succées j'aimerai savoir si quelqu'un pourrait m'aider ? merci

#1109 Le 22/03/2008, à 12:19

SkeRoy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

j'ai installé une X1300 la semaine dernière.
Perso je n'arrive jamais avec aticonfig, je fais toujours à l'ancienne, un bon

sudo dpkg-reconfigure xserver-xorg

ça a toujours marché !

Dernière modification par SkeRoy (Le 22/03/2008, à 12:20)


== Debian Lenny == {Linux User #422949}

Hors ligne

#1110 Le 30/03/2008, à 19:10

sipi

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Comme demandé j'affiche les resultats après manip

    j'ai une ati xpress1100 à 128mo, 1028 de ram, et un core 2 duo à 1.80Ghz
    display driver version 8.37.06

    glxgears=> 1100fps contre 600 avant les manip
    fgl_glxgears=> 140fps contre  rien vue que ca se lancé pas


merci beaucoup à toi Kagou
grace à toi je peux enfin passer au jeux 3D wink


6pi

Hors ligne

#1111 Le 26/04/2008, à 20:22

dlebon13

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Salut les amis,
Je dispose d'une carte graphique ATI Radeon X1650 pour laquelle j'ai essayé d'installer le pilote ATI (xorg) et le logiciel Catalyst par Synaptic sur Ubuntu 8.04 mais au moment de redemarrer (et après que le system m'ais demandé login et pass) plus rien sauf un écran blanc et ce même après plusieurs essais!!! (Nota: Avec cette même carte, en effectuant la même procedure sous Ubuntu 7.10 le system n'a pas voulu démarrer!!) Alors que faire? Dois-je changer de carte graphique, attendre de nouvelles mises à jour ou faire le deuil de la haute résolution sous Ubuntu?:( Merci d'éclairer ma lanterne.

Hors ligne

#1112 Le 26/04/2008, à 23:57

SkeRoy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

tiens, même symptôme que pour la X300 de mon beau frère.

Au final c'était des mauvaises options dans le xorg.conf, mais je ne sais plus lesquelles...


== Debian Lenny == {Linux User #422949}

Hors ligne

#1113 Le 02/05/2008, à 19:19

François Lemoigne

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour à tous
J'ai le même souci que précemment expliqué dans ce tuto. C'est à dire que mon PC se déconnecte quand il se met en veille. En suivant le tuto, ça marche bien sauf qu'ensuite je n'ai plus internet (plus de détection de ma box) et que le défilement des pages est très saccadé.

Si quelqu'un avait une solution... ou pouvait m'aider... je débute dans linux (2 mois d'ancienneté !)

Ma config :
Portable Keynux Ymax SN
Système d'exploitation : Ubuntu Gutsy 7.10
Processeur Intel Core 2 duo T7700 - 2.40 Ghz
Mémoire : 4096 Mo SO-DIMM RAM DDR-2 / 667 Mhz (2 x 2048 Mo)
Carte ATI Mobily RADEON HD 2400 XT à 256 Mo dédiés

J'oubliais :

lsmod | grep fglrx
fglrx                1795328  24


Merci d'avance !

Fr3nzy

#1114 Le 04/05/2008, à 10:39

Dark-Sham

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour,

Est-ce normal que le pilote propriétaire ne soit pas disponible sous Hardy ? C'est ce que me dit envyng quand je lui demande de me l'installer...


Script de sauvegarde/restauration APT

Ubuntu 8.04 "Hardy Heron"
CPU : AMD Athlon XP 2800+ ; GPU : ATI Radeon 9250/9200 Series ; RAM : 2 Gigots + 512 Mégots ; Carte mère : Asus A7N8X-E Deluxe

Hors ligne

#1115 Le 04/05/2008, à 16:46

Nizarus

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Dark-Sham a écrit :

Bonjour,

Est-ce normal que le pilote propriétaire ne soit pas disponible sous Hardy ? C'est ce que me dit envyng quand je lui demande de me l'installer...

Non il est bel est bien disponible sous hardy, je les certifie sur la tête de ma X1300 pro smile tu peut passer directement par le gestionnaire de pilotes.

Hors ligne

#1116 Le 04/05/2008, à 17:19

Mathox

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour à tous

Voila bientot 4 jours que j'essaye d'installé mon ATI X1600 (512mo en AGP x4),OS : Ubuntu Hardy
j'ai essayer divers tutos mais aucun n'a fonctionner , j'en suis à ma 4 résinstallation complete roll
Mais je ne sais plus quoi faire , une fois les drivers Ati proprio installé mon ubuntu ne demarre plus .
Je suis donc obliger de reconfigurer mon xorg à chaque fois.
J'ai également essayer envyng  mais même problème

Merci d'avance

Dernière modification par Mathox (Le 04/05/2008, à 17:23)

Hors ligne

#1117 Le 04/05/2008, à 17:52

dekans

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Pareil pour moi, j'ai une install de hardy qui date du WE dernier,
le gestionaire de pilotes propriétaire ne prend pas en charge ma carte ATI, et je n'arrive pas à avoir l'accélération graphique malgré une bonne dizaine de tentatives.

J'abandonne, pas d'accélération graphique sous hardy pour ma radeon mobility un point c'est tout.


dekans@jabber.kubuntu-fr.org

Hors ligne

#1118 Le 04/05/2008, à 18:46

Nizarus

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Dans les versions précédente ce toto ma aidé pour configurer ma X1300 pro :
http://wiki.cchtml.com/index.php/Ubuntu … tion_Guide

Hors ligne

#1119 Le 04/05/2008, à 18:54

Mathox

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Je vais tester  ,
j'aimerais tellement profiter du bureau 3d big_smile

edit
Bon je viens de réessayé ; après avoir configuré le xorg ( sudo aticonfig --initial -f)
Reboot et écran noir après chargement d'ubuntu
Obliger de reconfigurer le xorg par defaut pour redemarrer

@+

Dernière modification par Mathox (Le 04/05/2008, à 19:12)

Hors ligne

#1120 Le 04/05/2008, à 19:13

Neo-MatriX

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Salut,

Avec ATI, j'ai jamais pu profiter des effets bureau 3D avec ma 9600pro trop de freeze... malgré les pilote installés correctement !


Activité volcanique dans le monde : Catastrophes naturelles  : Réseau OCP

Hors ligne

#1121 Le 04/05/2008, à 19:20

Mathox

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

salut,

Oué cest sur peut etre que je le désactiverais si il ya a trop de freeze mais pour le moment je n'arrive pas à installer correctement les pilotes!

Hors ligne

#1122 Le 05/05/2008, à 11:53

lolonene

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour a tous,

@ Mathox : j'ai le même problème d'écran noir au démarrage après l'installation des drivers 3d ATI.

Peut tu m'indiquer la procédure pour reconfigurer le xorg par défaut. Vu que je n'ai qu'un écran noir je ne voit pas.

Merci


Ordi Bureau HP processeur Intel Core i5-2300 CPU @ 2.80GHz × 4 6Go RAM 64 Bits carte graphique GeForce GT 420/PCI/SSE2 with cuba dual boot Win 7 / ubuntu 12.04 (upgrade car impossibilité de faire une nouvelle installation)
eeepc 1005HA-M dual boot XP home Ubuntu 12.04 (installation "neuve")

Hors ligne

#1123 Le 05/05/2008, à 18:55

Mathox

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Tu à quoi comme carte ?

le seul moyen (que j'ai trouvé) helas c'est le recovery mode !
Selectionner Xfix
il retablira la derniere version stable de ton xorg
ensuite selectionne :resume normal boot
ensuite dans un terminal :
sudo dpkg-reconfigure xserver-xorg

je vois que ca mais en même temps ca fait qu' une semaine que je suis sous linux
donc merci de me corriger si les infos sont fausses merci

Dernière modification par Mathox (Le 05/05/2008, à 18:58)

Hors ligne

#1124 Le 06/05/2008, à 18:49

lolonene

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Merci pour l'info,
Je suis passé d'un écran noir à un écran blanc donc pas moyen d'acceder à la console, je vais donc pencher pour une troisième réinstallation. avec ce coup ci pas d'installation du driver ATI 3d.
Pour info ma carte est une Sapphire x1650 pro 512Mo AGP 8x

Dernière modification par lolonene (Le 06/05/2008, à 18:51)


Ordi Bureau HP processeur Intel Core i5-2300 CPU @ 2.80GHz × 4 6Go RAM 64 Bits carte graphique GeForce GT 420/PCI/SSE2 with cuba dual boot Win 7 / ubuntu 12.04 (upgrade car impossibilité de faire une nouvelle installation)
eeepc 1005HA-M dual boot XP home Ubuntu 12.04 (installation "neuve")

Hors ligne

#1125 Le 06/05/2008, à 19:18

Mathox

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bizard   j'ai l'impression que  Hardy a du mal à prendre en charge les cartes ATI ,
J'éspere qu"il va y avoir un correctif de la part d'ATI
En tout cas j'en suis à ma 6 ème réinstalation
lol
@++

Dernière modification par Mathox (Le 06/05/2008, à 19:44)

Hors ligne

Haut de page ↑