Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#126 Le 23/05/2005, à 20:25

Olivier V

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour,

Super votre tuto !

AMD 64 3700+
1 Go RAM
ATI Radeon Mobilityn 9700 128 Mo
drivers version 8.08.25

$  glxgears
7053 frames in 5.0 seconds = 1410.600 FPS
7992 frames in 5.0 seconds = 1598.400 FPS
7986 frames in 5.0 seconds = 1597.200 FPS
$ fgl_glxgears
1353 frames in 5.0 seconds = 270.600 FPS
1584 frames in 5.0 seconds = 316.800 FPS
1585 frames in 5.0 seconds = 317.000 FPS
1581 frames in 5.0 seconds = 316.200 FPS


Olivier V

#127 Le 24/05/2005, à 19:40

Olivier V

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour,

Super votre tuto ! Encre merci.

Olivier V

$ glxgears
6593 frames in 5.0 seconds = 1318.600 FPS
7992 frames in 5.0 seconds = 1598.400 FPS
7991 frames in 5.0 seconds = 1598.200 FPS
7992 frames in 5.0 seconds = 1598.400 FPS
7989 frames in 5.0 seconds = 1597.800 FPS
$ fgl_glxgears
1431 frames in 5.0 seconds = 286.200 FPS
1583 frames in 5.0 seconds = 316.600 FPS
1589 frames in 5.0 seconds = 317.800 FPS
1583 frames in 5.0 seconds = 316.600 FPS
1584 frames in 5.0 seconds = 316.800 FPS


ATI Radeon 9700 128 Mo
AMD 64 3700+
1 Go RAM

#128 Le 27/05/2005, à 07:53

Latem

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Hello

yeah, super ça marche....

glxgear env. 620fps
fgl_glxgear env. 3000fps

AMD Athlon 2400+ @ 2600+
1GB Ram
ATI Radeon 9700 pro 128 MB , légèrement overclocké mais je sais plus de combien
Driver 8.08.25
big_smile
Bon maintenant je peux m'attaquer au dual-screen et à ma carte son externe tongue

PS: super le tuto.... big_smile

#129 Le 27/05/2005, à 09:01

samsan

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

hahah de la balle !

glxgears : 15960 frames in 5.0 seconds = 3192.000 FPS
fgl_glxgears : 3277 frames in 5.0 seconds = 655.400 FPS

9800 pro 128
athlon 3000+
512 ram

Hors ligne

#130 Le 27/05/2005, à 15:17

newportable

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

PM 2ghz
Ati mobility fire gl T2
1go ddr PC2700

adrien@ubuntu:~ $ glxgears
5850 frames in 5.0 seconds = 1170.000 FPS
6629 frames in 5.0 seconds = 1325.800 FPS
6614 frames in 5.0 seconds = 1322.800 FPS
6657 frames in 5.0 seconds = 1331.400 FPS
6669 frames in 5.0 seconds = 1333.800 FPS

adrien@ubuntu:~ $ fgl_glxgears
1336 frames in 5.0 seconds = 267.200 FPS
1612 frames in 5.0 seconds = 322.400 FPS
1634 frames in 5.0 seconds = 326.800 FPS
1634 frames in 5.0 seconds = 326.800 FPS
1635 frames in 5.0 seconds = 327.000 FPS

Hors ligne

#131 Le 27/05/2005, à 22:38

JimBo

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Super Tuto !!! Merci big_smile

Mes (pôvres) scores :

Driver de base (ATI) :
glxgears
    749 frames in 5.0 seconds = 149.800 FPS
fgl_glxgears
    X Error of failed request:  BadMatch (invalid parameter attributes)
      Major opcode of failed request:  145 (GLX)
      Minor opcode of failed request:  5 (X_GLXMakeCurrent)
      Serial number of failed request:  33
      Current serial number in output stream:  33

Driver Version : 8.08.25 (fglrx):
glxgears
    3190 frames in 5.0 seconds = 638.000 FPS
fgl_glxgears
    614 frames in 5.0 seconds = 122.800 FPS

Sur mon PC :
Athlon XP1800+ 512Mo
ATI Radeon9200SE 128Mo (MSI)

Hors ligne

#132 Le 27/05/2005, à 22:45

coffee

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

gé les meme avec meme conf


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#133 Le 28/05/2005, à 11:37

topgun

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

J'ai les mêmes perfs avec Athlon xp 2400+ et 512 Mb RAM noname comme quoi le proço il influe pas beaucoup hmm
Et bien sûr la même carte vidéo ATI Radeon 9200 SE

3888 frames in 5.0 seconds = 777.600 FPS
3899 frames in 5.0 seconds = 779.800 FPS
3886 frames in 5.0 seconds = 777.200 FPS
3893 frames in 5.0 seconds = 778.600 FPS
3898 frames in 5.0 seconds = 779.600 FPS
3884 frames in 5.0 seconds = 776.800 FPS
3882 frames in 5.0 seconds = 776.400 FPS

707 frames in 5.0 seconds = 141.400 FPS
693 frames in 5.0 seconds = 138.600 FPS
710 frames in 5.0 seconds = 142.000 FPS
709 frames in 5.0 seconds = 141.800 FPS
702 frames in 5.0 seconds = 140.400 FPS
710 frames in 5.0 seconds = 142.000 FPS

Dernière modification par topgun (Le 30/05/2005, à 12:07)

Hors ligne

#134 Le 01/06/2005, à 00:15

Percy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

salut smile

voilà, j'ai suivi ce HOWTO, et "ça marche pas" (tm)

j'ai fait la première étape, j'ai redémarré, j'ai eu un écran bleu (^^) moche, qui me disait que X avait pas pu démarrer. j'ai donc dit ok, j'ai édité mon fichier xorg.conf via vim, puis j'ai fait startx, j'ai lu la suite du tutoriel, donc j'ai rajouté les modules et l'option "UseInternalTruc", j'ai rebooté, et hop, X pas mieux smile

j'ai noté qu'au démarrage, il y avait ce message:
[fglrx:firegl_init]:*ERROR device not found (je suis pas sur de la syntaxe, c'est fait de tête évidemment smile ).

bon, je suis noob, mais pas au point de pas comprendre que ça a déconné là big_smile par contre, suffisamment pour pas savoir quoi faire...

donc je viens tristement demander de l'aide, si possible smile

merci d'avance !

EDIT: je rajoute ma config, hésitez pas à demander si j'oublie des trucs, j'ai pas l'habitude de demander de l'aide, je me débrouille normalement big_smile
laptop sony vaio PCG-K215B
CPU: Celeron 2.8 GHz
RAM: 512 Mo
carte: ATI Radeon IGP 340M
OS: Ubuntu 5.04 (Hoary)

voilà mes scores actuels sous glxgears
640 frames in 5.0 seconds = 128.000 FPS
565 frames in 5.0 seconds = 113.000 FPS
678 frames in 5.0 seconds = 135.600 FPS
565 frames in 5.0 seconds = 113.000 FPS

fgl_glxgears marche pas:
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  144 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  33
  Current serial number in output stream:  33

hop j'ajoute un autre truc, le résultat de fglrxinfo:
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

Dernière modification par Percy (Le 01/06/2005, à 00:45)

Hors ligne

#135 Le 01/06/2005, à 09:25

ZeBob

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

et ton xorg.conf il donne quoi, essaye de refaire la manip expliquée par Monsieur Stemp ici : http://forum.ubuntu-fr.org/viewtopic.php?id=5808

Dernière modification par ZeBob (Le 01/06/2005, à 12:35)

Hors ligne

#136 Le 01/06/2005, à 12:27

Percy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

ok merci, je vais tester et tenir au courant smile

Hors ligne

#137 Le 01/06/2005, à 15:01

Percy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

bon, ben ça marche toujours pas big_smile

le lien que tu m'as filé contient le post de Stemp, qui fait référence à un autre tutoriel. j'ai donc suivi ce tutoriel-là, qui n'a pas marché. j'ai ensuite testé la méthode de Stemp, qui a été un échec aussi.
dans les deux cas, le problème vient lors de l'étape "sudo sh make_install.sh": il y a une erreur, la même que dans mon log de boot.

[fglrx:firegl_init]:*ERROR* device not found !

voilà smile

j'ai trouvé ce tutoriel:
http://www.linuxquestions.org/questions/answers/179

qui semble s'appliquer à la même carte que moi (ATI Radeon IGP 340M, pour laptop donc). le problème c'est que quand je suis les instructions du CVS, le serveur me refuse l'accès (connection failed), après m'avoir demandé un mot de passe. sachant que ça me fait la même chose quand j'essaie d'accéder au serveur CVS de transgaming.org (pour cedega), je commence à me demander si le firewall de mon campus ne bloquerait pas la connexion sur le port 2401 (je crois). si quelqu'un a des renseignements sur ça (est-ce que par hasard les deux serveurs sont morts, ou alors ça vient bien de moi), je suis preneur aussi smile

merci

Hors ligne

#138 Le 01/06/2005, à 19:24

KEISER1080

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Es ce que QQ à reussi à metre en pratique cette procedure pour une ati X700 pci express
Je suis debutant en linux et le live cd ne passe pas (pas de X)

#139 Le 01/06/2005, à 20:51

Toinou

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

glxgears : de 1147.200 FPS à 4553.800 FPS
fgl_glxgears : 237.400 FPS à 577.200 FPS
driver ATI 8.08.25
Pentium IV M 1.4
512 RAM
Carte ATI mobility 9700 M10 128Mo (portable)

#140 Le 02/06/2005, à 08:53

afx

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour tout le monde

gouby a écrit :

salut vous tous

contrairement à la majorité il a fallu que j'aill jusqu'a la solution finale pour que mes fps passent le 200:/

par contre je ne peut pas acceder à la gestion de la résolution d'écran, j'ai une erreure de type: Le serveur X ne supporte pas l'extension XRandR. Le changement de résolution à la volée n'est pas disponible.

J'ai moi aussi été jusqu'au bout du tuto et l'accélération semble fonctionner Tux aussi

root@ubuntu:/home/afx # fgl_glxgears
2729 frames in 5.0 seconds = 545.800 FPS
3198 frames in 5.0 seconds = 639.600 FPS
3195 frames in 5.0 seconds = 639.000 FPS
3186 frames in 5.0 seconds = 637.200 FPS

root@ubuntu:/home/afx # glxgears
13408 frames in 5.0 seconds = 2681.600 FPS
16293 frames in 5.0 seconds = 3258.600 FPS
16294 frames in 5.0 seconds = 3258.800 FPS
16289 frames in 5.0 seconds = 3257.800 FPS



Mais malgré reboot et compagnnie le changement de resolution a chaud est proscrit


"Le serveur X ne supporte pas l'extension XRandR.
Le changement de résolution à la volée n'est pas disponible":(:(
Une idée?


carte Radeon 9800Pro de chez Hercules

Dernière modification par afx (Le 02/06/2005, à 08:54)


La théorie, c'est quand on sait tout et que rien ne fonctionne.
La pratique, c'est quand tout fonctionne et que personne ne sait pourquoi.
Ici, nous avons réuni théorie et pratique : Rien ne fonctionne... et personne ne sait pourquoi

Hors ligne

#141 Le 04/06/2005, à 20:53

jlf

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Marche nickel sur un Inspiron 8600 (Portable)

glxgears : 1540 FPS
fgl_glxgears : 307 FPS
Radeon Mobility M10 (9600) - 128M RAM
Pentium M - 1,6 ghz - 512M RAM

#142 Le 06/06/2005, à 00:18

Percy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

toujours personne qui a une idée pour mon problème ? smile

Hors ligne

#143 Le 06/06/2005, à 00:26

Stemp

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Essaie de créer un autre post, là c'est quand même un Tutoriel (How-to ! beurkkk)
De toutes façons (attention ça va pas te faire plaisir), la 3d ne fonctionne pas avec l'igp 340 sad

cf : http://www.ubuntuforums.org/showthread.php?t=13230
http://www.ubuntuforums.org/showthread.php?t=24976


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#144 Le 06/06/2005, à 13:27

forever71000

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

voilà, j'ai changer de config, cm nforce2+barton, pour cm asrock k8upgrade 760gx(sis) + A64 2800+.
J'avais auparavant installer les drivers ati sur mon ancienne config sans soucis avec ce tuto, mais la j'ai refais pareil, et ca marche pas!!!
Au démarrage, paf écran noir, plus qu'as rebooter en mode recovery pour remettre ati au lieu de fglrx dans mon xorg.conf
Voici mon modules:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fglrx
agpgart
sis-agp
ide-cd
ide-disk
ide-generic
lp
mousedev
psmouse

# Generated by sensors-detect on Sun Jun  5 01:24:30 2005
# I2C adapter drivers
i2c-isa
# I2C chip drivers
w83627hf

ainsi que mon xorg.conf:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
#	Load	"extmod"
SubSection "extmod"
        Option    "omit xfree86-dga"
    EndSubSection
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr-latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
        Option          "Buttons"               "7"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon 9800 Pro (R350 NH)"
	Driver		"ati"
        Option          "UseInternalAGPGART" "no"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"L1730S"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. Radeon 9800 Pro (R350 NH)"
	Monitor		"L1730S"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

si vous voyez une erreur, dites moi...

Hors ligne

#145 Le 07/06/2005, à 22:29

forever71000

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

je désepère, j'ai essayer les derniers drivers ati, c pareil, désinstaller puis remis les autres tjs pareil...
je désespère là!!!











vds 9800pro....

Hors ligne

#146 Le 08/06/2005, à 12:46

sksbir

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

@forever71000 : "UseInternalAGPGART" , il faut que tu essayes avec "yes" et "no", c'est décrit dans la procédure de départ comme étant une action à effectuer seulement si ça ne marche pas avec yes (moi, j'ai dû le faire)...


Mais surtout, et par égard pour celui qui fait le suivi de ce topic : met la suite de ton probleme dans un topic indépendant, avec le résultat de tes tests, le résultat de la commande dmesg, etc...

A ce sujet , lire 3 cases plus haut:

Stemp a écrit :

Essaie de créer un autre post, là c'est quand même un Tutoriel ..........

Dernière modification par sksbir (Le 08/06/2005, à 12:51)

Hors ligne

#147 Le 09/06/2005, à 10:59

Percy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

je vais me débrouiller, mais juste pour signaler que poster nos problèmes ici, ça paraissait pas une si mauvaise idée, à en croire le post original:

Kagou a écrit :

Si vous avez des remarques/infos/problèmes/astuces merci de les faire partager sur ce post afin d'augmenter ce HOW-TO

anyway, merci à tous pour l'aide, et encore bravo pour ce tuto, qui apparemment marche pour tout le monde sauf les abrutis qui ont acheté des laptop pourris (c'est notre faute remarque wink )

Hors ligne

#148 Le 13/06/2005, à 15:46

Doogy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Salut !
Sais pas si ces sont de bon score

Pentium 2.4Ghz
Ati radeon 9550

eric@charlotte:~$ fgl_glxgears
865 frames in 5.0 seconds = 173.000 FPS
1445 frames in 5.0 seconds = 289.000 FPS
1429 frames in 5.0 seconds = 285.800 FPS
eric@charlotte:~$ glxgears
3039 frames in 5.0 seconds = 607.800 FPS
3752 frames in 5.0 seconds = 750.400 FPS
3752 frames in 5.0 seconds = 750.400 FPS
eric@charlotte:~$

Votre avis !

Dernière modification par Doogy (Le 13/06/2005, à 15:48)


Avant de conquerir le monde, met un pied devant l'autre!!!
(Nico)

Hors ligne

#149 Le 14/06/2005, à 09:34

oborandy

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Bonjour,

juste pour vous informer que les nouveaux pilotes ATI Proprietary Linux x86 Drivers for XFree86 / X.Org Version 8.14.13 sont disponibles.

Il y a maintenant un installer automatique d'intégré mais est-ce que cela s'applique à ubuntu ?

Hors ligne

#150 Le 14/06/2005, à 09:42

Stemp

Re : [HOW-TO] : Installation des drivers 3d propriétaires pour ATI Radeon

Salut,

Oui, même s'il est toujours préférable de passer par apt -- Synaptic


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

Haut de page ↑