Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 02/09/2008, à 11:08

Mike Yavel

Problème avec timidity

Bonjour,

J'essaie de lire un fichier .mid avec Timidity mais voici sa réponse:

pbtimiditynb0.th.jpg

Pouvez-vous m'aider ?

D'avance, merci.

PS: les lignes noires et blanches en travers de l'écran sont dues au fait que j'ai du assembler une par une des captures d'écran car je n'arrivais pas à faire un copier-coller du contenu de la fenêtre...

Dernière modification par Mike Yavel (Le 02/09/2008, à 11:10)


Ubuntu 8.04
AMD Athlon XP 1600+
2 Go de RAM

Hors ligne

#2 Le 03/09/2008, à 16:45

scouix

Re : Problème avec timidity

Salut,

Ce n'est pas franchement une réponse à ton post mais pour copier ou coller du texte présent dans un terminal du doit faire "Ctrl+Maj+C" ou "Ctrl+Maj+V", et non pas Ctrl+C et Ctrl+V. ça t'évitera surement de galérer en faisant des copies d'écran...!

Désolé de pas pouvoir t'aider plus...!

Stan

Hors ligne

#3 Le 04/09/2008, à 20:15

Mike Yavel

Re : Problème avec timidity

scouix a écrit :

Salut,

Ce n'est pas franchement une réponse à ton post mais pour copier ou coller du texte présent dans un terminal du doit faire "Ctrl+Maj+C" ou "Ctrl+Maj+V", et non pas Ctrl+C et Ctrl+V. ça t'évitera surement de galérer en faisant des copies d'écran...!

Désolé de pas pouvoir t'aider plus...!

Stan

Oui, j'avais essayé avec Maj+Ctrl+C mais ça ne fonctionnait pas...

Dernière modification par Mike Yavel (Le 04/09/2008, à 20:17)


Ubuntu 8.04
AMD Athlon XP 1600+
2 Go de RAM

Hors ligne

#4 Le 26/09/2008, à 09:06

Mike Yavel

Re : Problème avec timidity

up !


Ubuntu 8.04
AMD Athlon XP 1600+
2 Go de RAM

Hors ligne

#5 Le 27/09/2008, à 09:59

银河系

Re : Problème avec timidity

Salut ,

en fait le "no instrument mapped to tone bank 0" veut dire qu'il ne trouve pas de bank de son et donc plus précisément de soundfont . Il faut que tu en installes une , par exemple pour faire simple , tu installes : fluidsynth , fluid-soundfont-gm , fluid-soundfont-gs et freepats .

Dernière modification par milkyway (Le 27/09/2008, à 10:05)

Hors ligne

#6 Le 28/09/2008, à 00:14

Mike Yavel

Re : Problème avec timidity

OK. merci. Je teste ça dès demain.


Ubuntu 8.04
AMD Athlon XP 1600+
2 Go de RAM

Hors ligne

#7 Le 28/09/2008, à 10:26

Mike Yavel

Re : Problème avec timidity

Visiblement, il y a encore des erreurs ( et le fichier n'est pas lu )
Seulement voila, je n'arrive pas à faire de copier-coller des messages d'erreurs ( la console interne à Timidity ne fait que quelques lignes de haut ). Auriez-vous une astuce pour que je puisse vous faire part des messages d'erreur ?


Ubuntu 8.04
AMD Athlon XP 1600+
2 Go de RAM

Hors ligne

#8 Le 28/09/2008, à 12:12

银河系

Re : Problème avec timidity

Effectivement , je n'arrive pas non plus à faire de copier-coller de la console de Timidity ...

Sinon , pourrais-tu copier ce que contient le fichier /etc/timidity/timidity.cfg ?

Hors ligne

#9 Le 28/09/2008, à 13:49

Mike Yavel

Re : Problème avec timidity

# Instrument configuration file for timidity
# $Id: timidity.cfg,v 1.7 2005/09/03 19:26:03 hmh Exp $

# You can change just about every option in TiMidity++ using
# This config file.  Please refer to the timidity.cfg(5) manpage
# for more details

## If you have a slow CPU, uncomment these:
#opt EFresamp=d        #disable resampling
#opt EFvlpf=d        #disable VLPF
#opt EFreverb=d        #disable reverb
#opt EFchorus=d        #disable chorus
#opt EFdelay=d        #disable delay
#opt anti-alias=d    #disable sample anti-aliasing
#opt EWPVSETOZ        #disable all Midi Controls
#opt p32a        #default to 32 voices with auto reduction
#opt s32kHz        #default sample frequency to 32kHz
#opt fast-decay        #fast decay notes

## If you have a moderate CPU, try these:
#opt EFresamp=l
#opt EFreverb=g,42
#opt EFchorus=s
#opt s32kHz
#opt p64a

# Disabling some of the Midi Controls can help with the CPU usage a lot.
# The same goes to the VLPF, sample anti-aliasing and effects such as
# reverb and chorus

# By default, try to use the instrument patches from freepats:

source /etc/timidity/freepats.cfg


Ubuntu 8.04
AMD Athlon XP 1600+
2 Go de RAM

Hors ligne

#10 Le 29/09/2008, à 12:19

银河系

Re : Problème avec timidity

Arf ... désolé pourtant cela me parait bon , je ne vois vraiment pas sad

Essaies peut-être de regarder dans la doc :
http://doc.ubuntu-fr.org/midi

Il y a aussi cette page qui est intéressante :
http://lerautal.free.fr/midi/midi-avec-linux.html

Dernière modification par milkyway (Le 29/09/2008, à 12:21)

Hors ligne

#11 Le 26/08/2010, à 11:56

Deuchnord

Re : Problème avec timidity

Bonjour,

J'ai presque le même problème que Mike Yavel, à part que, chez moi, le morceau est lu.
Cependant, certains instruments ne sont pas joués (ce qui concorde avec l'erreur No instrument mapped to tone bank 0).
Voici les détails de l'erreur fournis par le Terminal :

No instrument mapped to tone bank 0, program 49 - this instrument will not be heard
No instrument mapped to tone bank 0, program 52 - this instrument will not be heard
No instrument mapped to tone bank 0, program 89 - this instrument will not be heard
No instrument mapped to drum set 0, program 83 - this instrument will not be heard

A noter qu'avec l'interface graphique en plus, deux instruments ont disparu de la liste et peuvent être joués :

No instrument mapped to tone bank 0, program 89 - this instrument will not be heard
No instrument mapped to drum set 0, program 83 - this instrument will not be heard

J'ai installé les paquets fluidsynth, fluid-soundfont-gm, fluid-soundfont-gs et freepats, mais le constat est le même : les instruments ne sont pas trouvés sad

Une idée ?

Dernière modification par Deuchnord (Le 26/08/2010, à 11:56)


- Maman, fais-moi un sandwich.
- Tu as oublié le mot magique...
- sudo maman, fais-moi un sandwich.
Ma configuration.

Hors ligne

#12 Le 23/12/2012, à 20:18

OC-spam

Re : Problème avec timidity

Deuchnord a écrit :

J'ai installé les paquets fluidsynth, fluid-soundfont-gm, fluid-soundfont-gs et freepats, mais le constat est le même : les instruments ne sont pas trouvés sad

Regarde le fichier de configuration /etc/timidity/timidity.cfg et vérifie qu'il charge les samples que tu as installés. Par exemple, le mien (sous Debian) contient :

source /etc/timidity/fluidr3_gm.cfg
source /etc/timidity/fluidr3_gs.cfg

Hors ligne

#13 Le 24/12/2012, à 14:55

golgot200

Re : Problème avec timidity

Bonjour,

Je viens réinstaller timidity, mais ne le trouvant pas top sur mon matos et sur la 12.10 en 64 bit. Lecture du fichier commençant à la 5 ème secondes et quelques grésillements ...
Donc pour une lecture simple je viens d'installer Audacious 3.3.3 et le soundfont PC51f.sf2. Quelques réglages dans les modules externes et le tour est joué.
Son impeccable.
Si ça peut t'aider ...

Dernière modification par golgot200 (Le 24/12/2012, à 15:02)


"L’ultime question … L’intelligence a besoin de la Bêtise pour s’affirmer, La Beauté a besoin de la Laideur pour resplendir, Le Courage naît dans la Peur, Les Forts impressionnent au milieu des Faibles, Mais au final,…Qui a donc besoin d’autant de connards ?"

Hors ligne

Haut de page ↑