Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 23/09/2008, à 20:42

bonhomme lego

désactivé le touchpad quand souris externe branché

Je voudrais savoir s'il est possible que le touchpad se désactive automatiquement lorsque l'on branche une souris externe?

et bien sur remise en fonctionnement quand on débranche la souris


aqua-univers.com

Hors ligne

#2 Le 30/09/2008, à 18:56

bonhomme lego

Re : désactivé le touchpad quand souris externe branché

ce n'est pas possible?


aqua-univers.com

Hors ligne

#3 Le 30/09/2008, à 21:55

Denkisama

Re : désactivé le touchpad quand souris externe branché

Peut-être en cherchant du côté de synaptics (http://doc.ubuntu-fr.org/touchpad).
A priori y a pas mal d'options. J'avais installé ça sur Gutsy et il y avait moyen de bloquer le touchpad. Resterait plus qu'à trouver si y a moyen de déclencher ça en fonction de la présence ou non d'une souris usb.

J'ai pas trop le temps de chercher en ce moment mais je suis aussi intéressé par la solution

Hors ligne

#4 Le 30/09/2008, à 22:13

spatz

Re : désactivé le touchpad quand souris externe branché

Perso j'ai une touche sur mon pc pour le bloquer, je pense qu'il en est de même pour les autres. smile


PLOP ! Blogueur ! Râleur ! Agnostique ! Architecte ! Floodeur ! Gentil ! Chiant ! Fourbe ! Crâneur ! GNU/Windows/Linuxien ! Machiavélique ! Beau ! Républicain ! Intelligent ! Bosseur ! Très Prétentieux ! Scientifique ! Frimeur ! Étudiant !  De bonne foi ! Perverti ! Ubunteros ! Grand ! Sociable! Altruiste ! Provoc' ! Censé !

Hors ligne

#5 Le 01/10/2008, à 11:33

Denkisama

Re : désactivé le touchpad quand souris externe branché

En effet, il suffit de rajouter la ligne

Option	"SHMConfig"	"true"

dans la partie synaptics du xorg.conf et maintenant la touche multimédia correspondant au touchpad fonctionne.

Reste que si la question portait précisément sur le fait que ça se fasse tout seul quand une souris usb est branchée, le problème n'est pas entièrement résolu.

Hors ligne

#6 Le 03/10/2008, à 20:22

bonhomme lego

Re : désactivé le touchpad quand souris externe branché

je viens d'essayer, sans succès,

tu peut détailler un peu stp, je suis nouveaux sur ubuntu et je suis vite perdu

merci d'avance


aqua-univers.com

Hors ligne

#7 Le 03/10/2008, à 21:10

Denkisama

Re : désactivé le touchpad quand souris externe branché

Je ne peux guère faire plus détaillé que la doc (rappel: http://doc.ubuntu-fr.org/touchpad)

La partie pour désactiver le touchpad c'est

*      Pour activer la touche de désactivation du touchpad, ajoutez cette ligne:

Option    "SHMConfig"    "true"

Pour rajouter ça il faut

*      Ouvrez un terminal
    *      Lancez la commande suivante pour sauvegarder votre configuration actuelle:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

    *      Ensuite éditez le fichier /etc/X11/xorg.conf

Pour éditer tu peux le faire avec un éditeur de texte comme nano et donc

sudo nano /etc/X11/xorg.conf

(autre solutions: http://doc.ubuntu-fr.org/tutoriel/comment_editer_un_fichier)

En espérant que ça suffise  wink

Hors ligne

#8 Le 03/10/2008, à 22:27

bonhomme lego

Re : désactivé le touchpad quand souris externe branché

ca ne marche toujours pas,
j'ai ca

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "oss"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
EndSection

Section "InputDevice"
    Identifier      "Custom-Mouse"
    Driver          "evdev"
    Option          "SendCoreEvents"             "true"
    Option          "Name"                       "A4Tech RF USB Mouse"
    Option          "Phys"                       "usb-*/input0"
    Option          "XAxisButtons"               "6 7"
    Option          "YAxisMapping"               "4 5"
    Option          "Buttons"                    "7"
    Option          "ButtonMapping"              "1 2 3 7 6"
EndSection


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "oss"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
EndSection

Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option          "HorizEdgeScroll"       "0"
        Option          "SHMConfig"             "true"
EndSection

Section "Device"
        Identifier      "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Configured Mouse"
        InputDevice     "Custom-Mouse
        InputDevice     "Synaptics Touchpad"
EndSection

Dernière modification par bonhomme lego (Le 03/10/2008, à 22:27)


aqua-univers.com

Hors ligne

#9 Le 04/10/2008, à 02:14

Denkisama

Re : désactivé le touchpad quand souris externe branché

Bon bah a priori concernant le touchpad j'ai la même chose.
Essaie avec une interface graphique (ksynaptics ou gsynaptics si tu es sous gnome) des fois que ce soit la touche multimédia qui serait pas reconnue.
Comme ça il doit y avoir cette fonction activable d'un clic de souris, ça permettra de voir si c'est le touchpad qui peut pas s'éteindre ou la touche multimédia correspondante qui est pas reconnue.

Y a aussi moyen de regarder directement si la touche est détectée ou non en suivant cette doc: http://doc.ubuntu-fr.org/clavier_multimedia

Après, si ça vient de la touche qui n'est pas détectée mais que ça marche via une interface graphique, doit y avoir moyen d'associer ça à une autre touche.

Hors ligne

#10 Le 23/02/2009, à 22:11

onevan

Re : désactivé le touchpad quand souris externe branché

tien va voir ici
http://www.atlas95.com/blog/2007/10/02/configurer-son-touchpad-sous-ubuntu/
fait attention il inverse touchpad_desactiver et desactiver touchpad

Hors ligne

#11 Le 27/02/2009, à 23:29

bonhomme lego

Re : désactivé le touchpad quand souris externe branché

super ce liens,

je vais m'y pancher par contre depuis j'ai changer de souris

j'ai une logitech nano.... avec le tout petit usb qui est donc constamment sur mon pc, ce qui va poser des soucis je pense


aqua-univers.com

Hors ligne

Haut de page ↑