Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 26/01/2006, à 12:37

zediouke

Installation Lexmark C510 : Erreur Java !

Comme c'est mon premier message sur ce forum, que je fréquente pourtant assiduement depuis plusieurs mois, j'en profite pour saluer tout le monde et adresser à beaucoup d'entre vous un grand merci pour leur aide précieuse !

Trêve de mondanités, je vous expose mon problème :

Dans le cadre de mon boulot, j'ai installé un poste (Celeron 333MHz) avec Xubuntu 5.10 (noyau 2.6.12-10).
Il est connecté à un domaine NT (contrôlé, au passage, par un PDC sous Ubuntu Server 5.10 qui marche impec' cool) sur lequel est disponible une imprimante réseau Lexmark C510.
J'ai donc téléchargé et installé sur ce poste, les pilotes Debian pour cette imprimante :  http://downloads.lexmark.com/cgi-perl/d … rchLang=fr.
Jusqu'ici tout va bien...

Pour créer l'imprimante et la file d'impression associée, il faut exécuter les scripts mkdevice puis mkqueue installés dans /usr/lexprint/bin.

J'exécute tout d'abord :

sudo sh /usr/lexprint/bin/mkdevice -d LXKDEFD89 -i 192.168.10.154

où "LXKDEFD89" est le nom donné à l'imprimante, l'autre paramètre étant l'adresse IP sur le réseau.
Ce premier script fonctionne sans problème.

J'exécute ensuite :

sudo sh /usr/lexprint/bin/mkqueue -q LexmarkC510 -d LXKDEFD89 -p 10LC510 -l automatic

où "LexmarkC510" est le nom donné à la file, "LXKDEFD89" le nom de l'imprimante créée précédemment, "10LC510" est le code du pilote, et "automatic" est le langage utilisé par l'imprimante.
Durant son exécution, ce script me génère l'erreur suivante :

Error occurs during initialization of VM
Unable to load native library : libjvm.so : cannot open shared object file : No such file or directory

Ca sent l'erreur Java et pourtant j'ai installé la dernière version du JRE (1.5) disponible chez Sun sad, et sans file d'impression, impossible d'utiliser l'imprimante...

Merci de votre aide !

NB : nous aimerions installer d'autre postes sous Ubuntu, mais si l'imprimante réseau n'est pas accessible, ça ne se fera sûrement pas... et ce sera bien dommage car c'est un excellent système !

Hors ligne