Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 26/01/2006, à 20:44

Choupinou-pinette

Le droit fantôme

Bonjour à tous !
Il est des mystères dont on se passerait bien. J'ai un server ftp qui roule avec proftpd, et jusqu'à hier tout allait pour le mieux. 2 utilisateurs, dont un qui a les droits pour l'upload... et ça marchait très bien. La racine du server est sur une partition fat32. Le problème est que je ne peux rien uploader depuis internet. Depuis ma machine, ok, mais sinon non. Je récupère la liste du répertoire mais quand je veux mettre un fichier sur le server, il me dit "erreur critique de transfert" (depuis Filezilla). Pour le download, tout va bien.
Commençant à avoir un semblant d'expérience sous Ubuntu, je me suis penché sur la question des droits en écriture. Et là ... seuls moi même et les membres du groupe users ont le droit w. Les autres, non. Du coup, mon uploader (adminftp), dont j'ignore le groupe, ne peut pas y écrire ... n'est-ce pas ?
La description du problème vous semble-t-elle réaliste ? Est-ce résolvable ?
Est-ce un problème de proftp ?

Si vous savez comment je peux me sortir de là ... merci !


Faut pas prendre les enfants du bon dieu pour des canards sauvages

Hors ligne

#2 Le 29/01/2006, à 17:50

kikdijon

Re : Le droit fantôme

Et bien, je dirais qu'il suffit, soit de donner les droits d'écriture à 'other', soit de donner l'appartenance  du dossier à adminftp.

  Pour cela, fait:

sudo chown adminftp:users le_repertoire

, si tu ne veux modifier que les droits du repertoire (ce qui existe dedans conservera donc les anciens droits, et tu pourras les changer individuellement), ou alors:

sudo chown -R adminftp:users le_repertoire

, si tu veux changer tous les droits d'un coup.

  A noter que le type fat ne gère pas les permissions, et c'est au montage qu'elles sont déterminées. Il te faudra donc surement par le suite modifier /etc/fstab en mettant l'uid de adminftp plutot que celui de ton utilsateur habituel (fais 'id adminftp' pour connaitre son uid).


blog : http://blog.olivier-elmekki.com
site professionnel : http://olivier-elmekki.com

Hors ligne

#3 Le 29/01/2006, à 23:58

Choupinou-pinette

Re : Le droit fantôme

Je te remercie pour ta réponse. En fait, quand je tape ce que tu m'indiques, il me dit "Permission non accordée" ...
Je n'ai pas retouché le uid du fstab car je ne maîtrise pas trop ça encore. J'ai tout simplement passé mon dossier d'upload sur une partition etx3 bien linuxienne, avec une gestion saine des droits et là ça marche... Parceque sinon, rien à faire, même en mettant le Umask de la partition fat 32 à 000, je ne peux pas écrire dedans via le net.
Progressivement je vais formater mes partitions NTFS en fat32 et en ext3, comme ça on va gagner du temps !!
Linux c'est vraiment la classe ... quand ça marche.


Faut pas prendre les enfants du bon dieu pour des canards sauvages

Hors ligne

#4 Le 30/01/2006, à 00:37

charo

Re : Le droit fantôme

C'est normal, par défaut on ne peut ecrire sur un disque dur formater en ntfs. Ils existent cependant des modules pour ecrire dessus mais l'utilisation est périlleuse.

#5 Le 30/01/2006, à 02:01

kikdijon

Re : Le droit fantôme

hum, il s'agissait bien ici de fat32 et non pas de ntfs si j'ai bien suivi

La racine du server est sur une partition fat32.

Si tu as un message 'permission non accordée' alors même que tu utilises sudo, c'est que tu as monté ta partition avec des permissions très restrictives...

  Cette partition, tu la montes manuellement ou dans fstab? Il faut savoir aussi qu'une partition fat ou ntfs que tu montes sans lui passer de paramètres UID et GID appartiendra par défaut à l'utilisateur qui l'a montée (c'est-à-dire root, sauf si tu en fait en sorte qu'un user puisse monter une partition).

  Il est important que tu passes les options UID, GID et rw au montage


blog : http://blog.olivier-elmekki.com
site professionnel : http://olivier-elmekki.com

Hors ligne

#6 Le 30/01/2006, à 22:37

Choupinou-pinette

Re : Le droit fantôme

oui oui, mes partitons NTFS sont en lecture seule.
Voici les options que j'ai mis dans le /etc/fstab en ce qui concerne ma partition fat32 :

vfat rw,user,auto,gid=100,uid=1000,umask=000,iocharset=utf8,codepage=850	0	0

Il me semble que c'est correct ... Comme il ne s'agit que d'un ftp privé, la solution que j'ai trouvé me convient pour l'instant, même si ma partition ext3 est assez réduite (mon système étant pensé pour Windows ... pour l'instant tongue ).
Voyez vous ce qui peut provoquer cette incapacité à gérer ma fat32 ?


Faut pas prendre les enfants du bon dieu pour des canards sauvages

Hors ligne

#7 Le 31/01/2006, à 00:56

kikdijon

Re : Le droit fantôme

Essaie en mettant uid= l'id de adminftp
  Tu devrais peut-être aussi regarder dans dmesg si le montage c'est bien passé...


blog : http://blog.olivier-elmekki.com
site professionnel : http://olivier-elmekki.com

Hors ligne

Haut de page ↑