Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr (premières livraisons mi-mai)

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

M.A.J. en cours du forum possibilité de bug, nous faisons le maximum pour les résoudre au plus vite

#1 Le 01/02/2006, à 10:47

bobousse

glade-perl

bonjour  à tous

je viens d'installer glade-perl qui permet de générer un code source en perl mais quand je le lance

glade2perl-2

il me retourne cette erreur suivante

 
Can't locate Gtk2/Window.pm in @INC (@INC contains: ./ /etc/perl /usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /Glade/Two/Run.pm line 25.
BEGIN failed--compilation aborted at /Glade/Two/Run.pm line 25.
Compilation failed in require at /Glade/Two/App.pm line 29.
BEGIN failed--compilation aborted at /Glade/Two/App.pm line 29.
Compilation failed in require at /Glade/Two/Generate.pm line 32.
BEGIN failed--compilation aborted at /Glade/Two/Generate.pm line 32.
Compilation failed in require at /usr/bin/glade2perl-2 line 13.
BEGIN failed--compilation aborted at /usr/bin/glade2perl-2 line 13.

que faire!!!!!

je n'y connais vraiment rien dans ce domaine

merci de vos futures réponses qui je l'espère pourront m'aider

Hors ligne

#2 Le 01/02/2006, à 19:39

bobousse

Re : glade-perl

non persone n'a de solutions

je ne suis quand meme pas le seul programmeur perl du forum!!!

Hors ligne

#3 Le 02/02/2006, à 09:00

thx1138

Re : glade-perl

bobousse a écrit :

je ne suis quand meme pas le seul programmeur perl du forum!!!

En tout cas, moi j'ai jamais fait de Perl. C, C++, Python et Java, oui, mais Perl non smile


They did not know it was impossible, so they did it - Mark Twain

Hors ligne

#4 Le 02/02/2006, à 12:51

ToinS

Re : glade-perl

C'est tres simple !
L'erreur te dit qu'il te manque le module GTk pour perl.

Je pense que tu sais que glade est un outils pour creer des IHM avec la librairie GTK. Donc il est tout a fait normal que perl en ai besoin !

Solution :
installer perl-Gtk comme ça :

* soit via apt-get ( mais je ne sais pas si le paquet est dispo)

* soit en telechargeant directement le module Gtk.pm sur le site du CPAN

voici le lien vers le module :: http://search.cpan.org/~mlehmann/Gtk-Perl-0.7009/

Pour installer un module perl s'est toujours la même chose. (explication : http://cpan.org/modules/INSTALL.html )

Voilà !

Dernière modification par ToinS (Le 02/02/2006, à 12:52)


Antoine Farnault
antoine [at] afarno . com
http://afarno.com
JID: af@jabber.org

Hors ligne