Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash vient d'être divulguée, il est recommandé de mettre à jour son système (plus de détails)

*** 28 sept. nouvelle mise à jour (4.2-2ubuntu2.5 ou 4.3-7ubuntu1.4) *** pour mettre à jour, lancez dans un terminal :
sudo apt-get update ; sudo apt-get upgrade bash

#1 Le 02/02/2006, à 11:46

mwana

[ Résolu !] Ecran de veille, mortel!

Bonjour,

Je suis sous Ubuntu, qui ne fonctionne pas trop mal d'ailleurs, mais j'ai un problème que je n'arrive pas à solutionner, malgré quelques recherches sur ce forum.
J'ai une ATI Radeon 9200, et mon PC fonctionne très bien, le seul problème, est que quand je veux essayer de configurer l'écran de veille, il suffit que je rentre dans l'interface de configuration pour que tout se freeze, et là plus moyen de faire quoi que ce soit.
Obligé de rebooter par l'UC.
Qqu'un a une idée?

Dernière modification par mwana (Le 07/02/2006, à 12:52)

Hors ligne

#2 Le 02/02/2006, à 11:48

yeKcim

Re : [ Résolu !] Ecran de veille, mortel!

Ouvres l'interface de configuration de l'economisateur d'écran en ligne de commande pour nous dire si tu peux avoir un message d'erreur.


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#3 Le 02/02/2006, à 12:21

mwana

Re : [ Résolu !] Ecran de veille, mortel!

Désolé de mon ignorance,

mais quelle est la commande?

Merci

Hors ligne

#4 Le 02/02/2006, à 12:52

yeKcim

Re : [ Résolu !] Ecran de veille, mortel!

Fait un clic droit sur le raccourci dans le menu pour l'ajouter au bureau ou au tableau de bord. Tu regardes les propriétés de ce lien nouvellement créé et tu sauras. A moins bien sur qu'il soit directement possible de regarder les propriétés dans le menu, mais je crois que ce s'est pas le cas.


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#5 Le 02/02/2006, à 18:22

mwana

Re : [ Résolu !] Ecran de veille, mortel!

Merci yekcim,


J'ai fait comme tu as dit, la commande :

xscreensaver-demo

Ca m'a affiché la fenêtre de configuration et ca a freezé là-dessus, obligé de rebooter pour repartir. Je crois que je vais supprimer carrément le screensaver, ou bien réinstaller tous les paquets nécessaires, mais à 56 kbs...
A titre indicatif, ce même xscreensaver fonctionnait sous Kaella, que j'ai abandonnée car me paraissant trop "touffue" pour le novice que je suis.

A plus...

Hors ligne

#6 Le 02/02/2006, à 21:27

HoPHP

Re : [ Résolu !] Ecran de veille, mortel!

Solution de secours alors.

Afin de récupérer ton log (ce que te hurle le programme avant de s'éteindre dans un feu d'artifices de souffrances atroces), lance la commande comme ça:

$ cd
$ xcreensaver-demo > xscreensaver-demo.log

Ça va te créer un fichier "xscreensaver-demo.log" dans ton dossier utilisateur que tu pourras lire en toute tranquilité une fois redémarré.

@+, HoPHP


Merci de ne pas jeter d'arguments aux trolls qui se trouvent dans la fosse.
HoPHP est mort, vive OdyX

Hors ligne

#7 Le 03/02/2006, à 00:02

mwana

Re : [ Résolu !] Ecran de veille, mortel!

Je comprends pas,

Le programme ne m'a rien hurlé. Il m'a bien crée un fichier log, mais il était absolument vide.
Pas un mot d'explication, pas une ligne. Quelle ingratitude!
Je suis à l'écoute d'autres explications qui seront les bienvenues.

Merci.

PS : Je vérifierai ce week end sur un autre poste équipé en Nvidia si le problème est le même.

Hors ligne

#8 Le 03/02/2006, à 02:45

sksbir

Re : [ Résolu !] Ecran de veille, mortel!

En suivant ce principe, il faudrait taper
xcreensaver-demo > xscreensaver-demo.log 2>&1

Mais aussi, il faudrait regarder le contenu des fichiers récents dans /var/log, notamment Xorg.0.log

Hors ligne

#9 Le 06/02/2006, à 12:24

mwana

Re : [ Résolu !] Ecran de veille, mortel!

Bonjour,

De retour sur ma machine, toujours avec le même problème. J'ai regardé le fichier xorg.0.log, mais c'est de l'hébreu pour moi, je uis noyé sous les infos et je ne sais pas quoi chercher.
Y a t'il moyen de désactiver l'écran de veille?

Merci de votre aide...et à bientôt.

Hors ligne

#10 Le 07/02/2006, à 02:14

sksbir

Re : [ Résolu !] Ecran de veille, mortel!

mwana a écrit :

.............Y a t'il moyen de désactiver l'écran de veille?

Sans passer par l'interface graphique, j'imagine...

Donc, oui, il y a moyen : Il faut éditer le fichier .xscreensaver présent dans ton home.
Le paramètre timeout = le délai avant qu'il ne se mette en route. Je suppose qu'en mettant 23:59:59, il n'est pas près de démarrer...

Ceci dit, dans ce fichier, il y a aussi une option verbose qui est à false, et qu'il serait peut-etre intéressant de mettre à true pour voir si ça ne laisse pas des traces dans les fichiers logs....

Hors ligne

#11 Le 07/02/2006, à 11:58

mwana

Re : [ Résolu !] Ecran de veille, mortel!

Bonjour,

En bidouillant et travaillant par élimination, j'ai désactivé le paquet "xscreensaver gl", et mon écran de veille fonctionne, sauf avec les écrans prévus pour Open Gl, bien sûr.
mais ce qui me chiffonne, c'est que ces mêmes écrans fonctionnaient sous Kaela, avec le même PC, donc la même carte graphique. Y aurait-il une librairie Open Gl qui serait manquante dans Ubuntu?
Je continue à chercher, si tu as une piste....

A plus tard.


Après désinstallation et réinstallation totale du Xscreensaver, ça fonctionne, mais il faut que je reste en mode "only one screensaver" au lieu de "random".

le principal, c'est que ça fonctionne.
Encore merci à tous.

Dernière modification par mwana (Le 07/02/2006, à 12:50)

Hors ligne

Haut de page ↑