Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1301 Le 21/10/2011, à 13:45

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Il existe un rapport de bug sur ce plantage
https://bugs.launchpad.net/ubuntu/+sour … ug/879054/

Le bug existant avec midori et epiphany cela doit bioen être un probleme webkit

Hors ligne

#1302 Le 21/10/2011, à 14:14

drefhill

Re : Webkit, Midori et Epiphany-webkit

As tu bien ces PPAs ?
http://ppa.launchpad.net/webkit-team/pp … eiric/main
http://ppa.launchpad.net/midori/ppa/ubuntu/oneiric/main

Et les paquets ci dessous installé ?
webkit.png
Pas certain que le paquet Python soit utlile, je crois que je l'avais installé pour faire fonctionner un programme de Poker qui est programmé en Python.


Linux Mint 13 32bits    sur   HP mini 2140                                               
Puce graphique Mobile Intel GMA 950          Chipset Mobile Intel 945GSE Express        CPU intel Atom N270 32bits
Disque dur SEAGATE 2,5'' 250 go + 4 go ssd 32 mo 7200 tr/min - hybride/sata ii - momentus xt
LinuxMint 13 64bits + Cinnamon

Hors ligne

#1303 Le 21/10/2011, à 14:42

georgesG

Re : Webkit, Midori et Epiphany-webkit

Hâte qu'il soit corrigé !

Hors ligne

#1304 Le 21/10/2011, à 15:07

frenchy82

Re : Webkit, Midori et Epiphany-webkit

pour midori j'utilise bien le ppa de dev

Pour webkit, la version d'oneiric est plus recente que celle du ppa cité.
J'ai tout de meme testé avec celle du depot mais c'est le même résultat

georgesG : Tu confirmes le même bug?

Hors ligne

#1305 Le 22/10/2011, à 21:41

Stemp

Re : Webkit, Midori et Epiphany-webkit

La version 1.6.1 du PPA ne change rien ?


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1306 Le 23/10/2011, à 06:25

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Non, cela plante toujours au même endroit (même si j'ai réussi a ouvrir un site du launchpad ne fois ou deux)
Maintenant j'ai des messages d'erreur

(midori:2340): Pango-WARNING **: font_face status is: no error has occurred

(midori:2340): Pango-WARNING **: scaled_font status is: invalid matrix (not invertible)
midori: /build/buildd/cairo-1.10.2/src/cairo-surface.c :1287 : cairo_surface_set_device_offset:  L'assertion « status == CAIRO_STATUS_SUCCESS » a échoué.
Abandon

Hors ligne

#1307 Le 23/10/2011, à 07:34

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Il y a pas mal de remontés avec ce message d'erreur sur le net

Cela pourrait être lié au paquet libcrypt11 de oneiric sur certaines config
En reprenant celui de natty cela semble bien fonctionner mais cela n'est pas à faire car on se retrouve avec plein de paquets cassés.

Hors ligne

#1308 Le 23/10/2011, à 08:15

Stemp

Re : Webkit, Midori et Epiphany-webkit

frenchy82 a écrit :

Il y a pas mal de remontés avec ce message d'erreur sur le net

Cela pourrait être lié au paquet libcrypt11 de oneiric sur certaines config
En reprenant celui de natty cela semble bien fonctionner mais cela n'est pas à faire car on se retrouve avec plein de paquets cassés.

Et la version de precise ?


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1309 Le 23/10/2011, à 08:33

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Pas mieux mais merci quand même
Cela ressemnle assez a ce bug
http://us.generation-nt.com/answer/bug- … 86951.html

Hors ligne

#1310 Le 23/10/2011, à 11:11

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Non la seule solution pour le moment est de récuperer le paquet de natty, de modifier le fichier control et de l'installer.
Et là, midori marche nickel

Hors ligne

#1311 Le 24/10/2011, à 18:01

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Stemp les dernieres maj de midori dev ne semble pas s'insatller sur les postes pour une dépendance non satisfaite
libjavascriptcoregtk-1.0-0

Sauf erreur de ma part, Ce paquet ne semble pas être dispo dans les depos oneiric

Hors ligne

#1312 Le 24/10/2011, à 20:16

Stemp

Re : Webkit, Midori et Epiphany-webkit

frenchy82 a écrit :

Stemp les dernieres maj de midori dev ne semble pas s'insatller sur les postes pour une dépendance non satisfaite
libjavascriptcoregtk-1.0-0

Sauf erreur de ma part, Ce paquet ne semble pas être dispo dans les depos oneiric

Quel est exactement l'erreur ? Car les paquets libjavascriptcoregtk* sont maintenant créés par le paquet source webkit.
Ils se trouvent donc dans les dépôts du PPA.

libjavascriptcoregtk-1.0-0-dbg_1.6.1-3~oowkt1_amd64.deb (18.0 MiB)
libjavascriptcoregtk-1.0-0-dbg_1.6.1-3~oowkt1_i386.deb (18.4 MiB)
libjavascriptcoregtk-1.0-0_1.6.1-3~oowkt1_amd64.deb (947.0 KiB)
libjavascriptcoregtk-1.0-0_1.6.1-3~oowkt1_i386.deb (1020.4 KiB)
libjavascriptcoregtk-1.0-dev_1.6.1-3~oowkt1_amd64.deb (35.9 KiB)
libjavascriptcoregtk-1.0-dev_1.6.1-3~oowkt1_i386.deb (36.2 KiB)
libjavascriptcoregtk-3.0-0-dbg_1.6.1-3~oowkt1_amd64.deb (18.0 MiB)
libjavascriptcoregtk-3.0-0-dbg_1.6.1-3~oowkt1_i386.deb (18.4 MiB)
libjavascriptcoregtk-3.0-0_1.6.1-3~oowkt1_amd64.deb (947.0 KiB)
libjavascriptcoregtk-3.0-0_1.6.1-3~oowkt1_i386.deb (1020.4 KiB)
libjavascriptcoregtk-3.0-dev_1.6.1-3~oowkt1_amd64.deb (35.9 KiB)
libjavascriptcoregtk-3.0-dev_1.6.1-3~oowkt1_i386.deb (36.2 KiB)

«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1313 Le 24/10/2011, à 20:23

frenchy82

Re : Webkit, Midori et Epiphany-webkit

oui, cela fonctionne si on utilise le ppa webkit en plus du ppa de midori
Mais sans le ppa weblik, midoti ne peut pluis être mis à jour/

Hors ligne

#1314 Le 24/10/2011, à 21:32

Stemp

Re : Webkit, Midori et Epiphany-webkit

***************************
***** IMPORTANT *****
***************************
If you use this repository, you'll also need WebKit-team PPA :
https://launchpad.net/~webkit-team/+archive/ppa

Si on veut les dernières versions, il faut aussi en accepter les petits désagréments wink
Mais !! Tu peux recréer ton paquet toi même avec dpkg-source/dpkg-buildpackage ou même debuild.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1315 Le 25/10/2011, à 04:14

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Merci pour ces infos Stemp smile

Dernière modification par frenchy82 (Le 25/10/2011, à 04:14)

Hors ligne

#1316 Le 31/10/2011, à 14:20

nknico

Re : Webkit, Midori et Epiphany-webkit

Y a-t-il un moyen de faire fonctionner flash avec epiphany 3 ??


Nico

Hors ligne

#1317 Le 31/10/2011, à 19:03

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Y a-t-il un moyen de faire fonctionner flash avec epiphany 3 ??

Pas trouvé non plus.

Par contre la mise à jour de midori semble régler le problème du correcteur orthographique. Elle souligne toujours les mots avec accents en rouge mais la correction est maintenant correcte.

Hors ligne

#1318 Le 03/11/2011, à 13:48

Stemp

Re : Webkit, Midori et Epiphany-webkit

nknico a écrit :

Y a-t-il un moyen de faire fonctionner flash avec epiphany 3 ??

http://forums.gentoo.org/viewtopic-t-87 … 23a559605e ?


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1319 Le 03/11/2011, à 20:17

nknico

Re : Webkit, Midori et Epiphany-webkit

Stemp a écrit :
nknico a écrit :

Y a-t-il un moyen de faire fonctionner flash avec epiphany 3 ??

http://forums.gentoo.org/viewtopic-t-87 … 23a559605e ?

Je veux bien, si tu m'expliques comment utiliser emerge sous ubuntu. wink


Nico

Hors ligne

#1320 Le 03/11/2011, à 20:48

Stemp

Re : Webkit, Midori et Epiphany-webkit

nknico a écrit :

Je veux bien, si tu m'expliques comment utiliser emerge sous ubuntu. wink

sudo apt-get install emerge

Non ? lol

Bon sinon, le problème avec flash/epiphany c'est que flash est une appli gtk2 et epiphany gtk3, comme c'est le même process ça plante.
Il faut donc (même en i386) utiliser nspluginwrapper.

Il faut donc installer pacman ou yaourt puis se diriger vers la documentation ArchLinux wink

Epiphany/Flash


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1321 Le 03/11/2011, à 21:18

nknico

Re : Webkit, Midori et Epiphany-webkit

Ok en installant nspluginwrapper et en faisant un coup de :

nspluginwrapper -v -n -a -i

ça marche.


J'ajouterai ça a la doc du site dès que j'ai un moment.

Dernière modification par nknico (Le 03/11/2011, à 21:32)


Nico

Hors ligne

#1322 Le 04/11/2011, à 01:29

Stemp

Re : Webkit, Midori et Epiphany-webkit

nknico a écrit :

J'ajouterai ça a la doc du site dès que j'ai un moment.

Tu peux même me remercier, ça ne me vexera pas tongue


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1323 Le 06/11/2011, à 15:37

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

J'essaie d'installer Midori 0.4.1 sous Ubuntu 10.04LTS, et voici ce que me donne la compilation:

compilerreur.jpg

Uploaded with ImageShack.us

et lorsque je vais voir dans Synaptic, voici ce que j'obtiens:

synaptic.jpg

Uploaded with ImageShack.us

Quelqu'un peut-il m'aider à me sortir de là, en mauvais débutant que je suis je ne comprends pas ce qui manque !...

Mille mercis,

Dernière modification par Nounours18200 (Le 06/11/2011, à 15:44)

Hors ligne

#1324 Le 06/11/2011, à 16:14

Stemp

Re : Webkit, Midori et Epiphany-webkit

Ça me fait un peu de peine de voir quelqu'un compiler Midori, mais bon big_smile

Sinon ton problème est que tu n'as pas installé le paquet contenant les fichiers de développement, libwekit-dev wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1325 Le 07/11/2011, à 16:59

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

Ça me fait un peu de peine de voir quelqu'un compiler Midori, mais bon

ça me fait un entrainement à la compilation sur ma 10.04LTS...! ... et à la galère qui continue :

Lorsque j'essaie d'installer libwebkit-dev, j'ai une erreur de dépendance:

Echec de la sélection de tous les paquets à installer ou à mettre à jour
Les paquets suivants contiennent des dépendances non résolues; Assurez-vous que tous les dépôts soient ajoutés et activés dans les préférences.

libwebkit-dev:
Dépend : libsoup2.4-dev mais ne doit pas être installé

Et bien sûr si j'essaie d'installer libsoup2.4-dev, ça s'enchaîne avec Libgnutls-dev:
ibsoup-->Libgnutls-dev

libgnutls-dev:
  Dépend : libgnutls26 (=2.8.5-2) mais 2.12.3-1 doit être installé
Dépend : libgcrypt11-dev mais ne doit pas être installé
Dépend : libtasn1-3-dev mais ne doit pas être installé

comme je fais mes classes, qu'est-ce que cela signifie ? et comment contourner... (enfin si vous avez un peu de temps pour un débutant qui fait ses classes...)

Mille mercis,

Hors ligne

Haut de page ↑