Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1326 Le 07/11/2011, à 19:45

drefhill

Re : Webkit, Midori et Epiphany-webkit

Bonjour
Je viens de faire une mise a jour qui m'a propose une mise a niveau partielle, je l'ai faite ca m'a dit qu'il falais pour cela desinstaler Midori, j'ai pas trop compris le rapport mais j'ai validé pensant que ca le reinstallerais a la fin, mais non ca ne me l'a pas reinstallé et maintenant quand je veut le reinstaller via synaptic ca me demande de deinstaller tout un tas de truc qui n'ont rien a voir du style Banshe Gimp Gwibber emesene Ubuntu-desktop python etc.... et j'en passe vraiment beaucoup
13351209.png

Ca serait pas un Virus ?

Dernière modification par drefhill (Le 10/11/2011, à 20:26)


Linux Mint 13 32bits    sur   HP mini 2140                                               
Puce graphique Mobile Intel GMA 950          Chipset Mobile Intel 945GSE Express        CPU intel Atom N270 32bits
Disque dur SEAGATE 2,5'' 250 go + 4 go ssd 32 mo 7200 tr/min - hybride/sata ii - momentus xt
LinuxMint 13 64bits + Cinnamon

Hors ligne

#1327 Le 07/11/2011, à 22:39

Stemp

Re : Webkit, Midori et Epiphany-webkit

Nounours18200 a écrit :

libgnutls-dev:
  Dépend : libgnutls26 (=2.8.5-2) mais 2.12.3-1 doit être installé
Dépend : libgcrypt11-dev mais ne doit pas être installé
Dépend : libtasn1-3-dev mais ne doit pas être installé

10.04 LTS c'est bien Lucid Lynx ?
Parce que, effectivement, tu as un problème de dépôts.
En gros  libgnutls-dev demande la même version de libgnutls26 à savoir la 2.8.5-2.
Et dans tes dépôts tu as la version 2.12.3-1 ! Donc ça ne peux pas fonctionner.

Essaye avec la commande

apt-cache policy libgnutls26

de voir d'où vient cette version exotique.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1328 Le 07/11/2011, à 22:41

Stemp

Re : Webkit, Midori et Epiphany-webkit

drefhill a écrit :

Ca serait pas un Virus ?

Non, ça serait plutôt à cause de ma mise à jour de webkit hmm


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1329 Le 08/11/2011, à 00:32

drefhill

Re : Webkit, Midori et Epiphany-webkit

et il y aurais une solutions ? parce que lorsque je souhaite réinstaller Midori ca me propose/oblige a desinstaller vraiment beaucoup de logiciels.
Epiphany et Chromium qui utilisent tout les 2 webkit fonctionnent bien.

Dernière modification par drefhill (Le 08/11/2011, à 00:38)


Linux Mint 13 32bits    sur   HP mini 2140                                               
Puce graphique Mobile Intel GMA 950          Chipset Mobile Intel 945GSE Express        CPU intel Atom N270 32bits
Disque dur SEAGATE 2,5'' 250 go + 4 go ssd 32 mo 7200 tr/min - hybride/sata ii - momentus xt
LinuxMint 13 64bits + Cinnamon

Hors ligne

#1330 Le 08/11/2011, à 01:07

Stemp

Re : Webkit, Midori et Epiphany-webkit

drefhill a écrit :

et il y aurais une solutions ? parce que lorsque je souhaite réinstaller Midori ca me propose/oblige a desinstaller vraiment beaucoup de logiciels.
Epiphany et Chromium qui utilisent tout les 2 webkit fonctionnent bien.

Malheureusement, il va falloir attendre un petit peu la nouvelle version de midori (0.4.2) qui devrait arriver sous peu.
Le mainteneur Debian a uploadé la nouvelle version de webkit sans se rendre compte qu'elle pétait l'API et que certains logiciels comme Midori et Claw-mails pouvaient planter très gravement.
L'attente ne devrait pas durer très longtemps, désolé.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1331 Le 08/11/2011, à 01:32

drefhill

Re : Webkit, Midori et Epiphany-webkit

ok merci alors je vais attendre :-( j'espere que je ne vais pas perdre mon profil, mots de passe,favoris onglets ouvert etc...


Linux Mint 13 32bits    sur   HP mini 2140                                               
Puce graphique Mobile Intel GMA 950          Chipset Mobile Intel 945GSE Express        CPU intel Atom N270 32bits
Disque dur SEAGATE 2,5'' 250 go + 4 go ssd 32 mo 7200 tr/min - hybride/sata ii - momentus xt
LinuxMint 13 64bits + Cinnamon

Hors ligne

#1332 Le 08/11/2011, à 01:42

Stemp

Re : Webkit, Midori et Epiphany-webkit

drefhill a écrit :

ok merci alors je vais attendre :-( j'espere que je ne vais pas perdre mon profil, mots de passe,favoris onglets ouvert etc...

Normalement non, c'est une suppression de paquet, pas une purge. Mais malheureusement si c'est le cas, tu pourras engueuler le responsable des PPAs webkit et midori wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1333 Le 08/11/2011, à 22:01

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

10.04 LTS c'est bien Lucid Lynx ?

Je confirme que c'est bien la 10.04LTS Lucid Lynx, plus toute jeune certes, va peut-être falloir songer à upgrader, mais elle me va bien...


Parce que, effectivement, tu as un problème de dépôts.
En gros  libgnutls-dev demande la même version de libgnutls26 à savoir la 2.8.5-2.
Et dans tes dépôts tu as la version 2.12.3-1 ! Donc ça ne peux pas fonctionner.

Essaye avec la commande

apt-cache policy libgnutls26

de voir d'où vient cette version exotique.

Tu es sûr de ta commande ??? voilà ce qu'elle me répond:

Stemp a écrit :

elodie@elodie-desktop:~$ sudo apt -cache policy libgnutls26
[sudo] password for elodie:
apt: invalid flag: -cache
Usage: apt <apt and javac options> <source files>
where apt options include:
  -classpath <path>          Specify where to find user class files and annotation processor factories
  -cp <path>                 Specify where to find user class files and annotation processor factories
  -d <path>                  Specify where to place processor and javac generated class files
  -s <path>                  Specify where to place processor generated source files
  -source <release>          Provide source compatibility with specified release
  -version                   Version information
  -help                      Print a synopsis of standard options; use javac -help for more options
  -X                         Print a synopsis of nonstandard options
  -J<flag>                   Pass <flag> directly to the runtime system
  -A[key[=value]]            Options to pass to annotation processors
  -nocompile                 Do not compile source files to class files
  -print                     Print out textual representation of specified types
  -factorypath <path>        Specify where to find annotation processor factories
  -factory <class>           Name of AnnotationProcessorFactory to use; bypasses default discovery process
See javac -help for information on javac options.

je ne vois pas d'options acceptées  ressemblant à "-cache" donc à toi de me dire !

Dernière modification par Nounours18200 (Le 08/11/2011, à 22:01)

Hors ligne

#1334 Le 08/11/2011, à 22:09

Stemp

Re : Webkit, Midori et Epiphany-webkit

apt-cache pas apt -cache wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1335 Le 10/11/2011, à 23:08

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

apt-cache pas apt -cache

T'as le droit de dire que je suis nul ! big_smile


Et voici le réssultat:

elodie@elodie-desktop:~$ sudo apt-cache policy libgnutls26
[sudo] password for elodie:
libgnutls26:
  Installé : 2.12.3-1
  Candidat : 2.12.3-1
Table de version :
*** 2.12.3-1 0
        100 /var/lib/dpkg/status
     2.8.5-2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ lucid/main Packages
elodie@elodie-desktop:~$

ça éclaire ?

Hors ligne

#1336 Le 10/11/2011, à 23:53

Stemp

Re : Webkit, Midori et Epiphany-webkit

Comme tu peux le voir, la version installée est la 2.12.3-1 alors que les dépôts lucid n'ont que la 2.8.5-2 !
Soit tu as tenté une mise à jour vers une version nouvelle d'Ubuntu, soit tu as installé cette version de libgnutls26 à la main.

En tout cas il faut revenir à la bonne version.

Malheureusement n'utilisant plus un système Debian/Ubuntu, je suis un peu rouillé et ne me souviens pas de la méthode pour «downgrader» un paquet.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1337 Le 11/11/2011, à 15:53

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

En tout cas il faut revenir à la bonne version.

Malheureusement n'utilisant plus un système Debian/Ubuntu, je suis un peu rouillé et ne me souviens pas de la méthode pour «downgrader» un paquet.

Synaptic permet (en étant connecté admin) de sélectionner libgnutls26 "pour une suppression complète", donc je devrais pouvoir l'enlever, puis ensuite la réinstaller, mais comment être sûr d'installer la bonne version  2.8.5-2  de libgnutls26 ?

Thanks

Dernière modification par Nounours18200 (Le 11/11/2011, à 15:54)

Hors ligne

#1338 Le 11/11/2011, à 16:27

Stemp

Re : Webkit, Midori et Epiphany-webkit

Nounours18200 a écrit :

Synaptic permet (en étant connecté admin) de sélectionner libgnutls26 "pour une suppression complète", donc je devrais pouvoir l'enlever, puis ensuite la réinstaller, mais comment être sûr d'installer la bonne version  2.8.5-2  de libgnutls26 ?
Thanks

La version installée n'existe qu'en local, en toute logique si tu la supprime la version normale devrait être installée par Synatic. Malheureusement libgnutls26 doit être utilisé par d'autres paquets et ça risque d'être chiant à désinstaller. M'enfin, ça devrait être possible big_smile


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1339 Le 11/11/2011, à 19:01

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

Purée, si ça continue je sens que je vais tenter d'installer un autre navigateur de secours que Modori...

Bon, y a-t-il un moyen de savoir si d'autres paquets l'utilisent avant de tenter de la désinstaller : histoire que j'évite de mettre davantage de bazar en la désinstallant....

et merci pour votre patience !  smile

Hors ligne

#1340 Le 11/11/2011, à 22:08

Stemp

Re : Webkit, Midori et Epiphany-webkit

Installe aptitude et puis :

sudo aptitude install libgnutls26=2.8.5-2

Dernière modification par Stemp (Le 11/11/2011, à 22:10)


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1341 Le 12/11/2011, à 20:03

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

Installe aptitude et puis :

sudo aptitude install libgnutls26=2.8.5-2

Bon ça progresse, mais ça plante toujours lorsque je lance ./waf configure, voici ce que j'obtiens:

elodie@elodie-desktop:/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1$ ./waf configure
Checking for program gcc or cc           : /usr/bin/gcc
Checking for program cpp                 : /usr/bin/cpp
Checking for program ar                  : /usr/bin/ar
Checking for program ranlib              : /usr/bin/ranlib
Checking for gcc                         : ok 
Checking for program valac               : /usr/bin/valac
Checking for gobject-2.0                 : yes
Checking for gthread-2.0                 : yes
Checking for program version valac >= 0.1.6 : ok 0.8.0
Checking for program glib-genmarshal        : /usr/bin/glib-genmarshal
Checking for program glib-mkenums           : /usr/bin/glib-mkenums
Checking for program msgfmt                 : /usr/bin/msgfmt
Checking for program intltool-merge         : /usr/bin/intltool-merge
Checking for header locale.h                : yes
Checking for program rsvg-convert           : /usr/bin/rsvg-convert
Checking for unique-1.0 >= 0.9              : yes
Checking for libnotify >=                   : yes
Checking for library m                      : yes
Checking for gmodule-2.0 >= 2.8.0           : yes
Checking for gthread-2.0 >= 2.8.0           : yes
Checking for gio-2.0 >= 2.16.0              : yes
Checking for x11 >=                         : yes
Checking for header X11/extensions/scrnsaver.h : not found
Checking for library Xss                       : not found
Checking for gtk+-2.0 >= 2.10.0                : yes
Checking for webkit-1.0 >= 1.1.17              : Package webkit-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `webkit-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'webkit-1.0' found
/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1/wscript:164: error: the configuration failed (see '/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1/_build_/config.log')
elodie@elodie-desktop:/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1$

Il semble donc qu'il y ait encore des composants manquants:

Checking for header X11/extensions/scrnsaver.h : not found
Checking for library Xss                       : not found
Checking for webkit-1.0 >= 1.1.17              : Package webkit-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `webkit-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'webkit-1.0' found

Le guide Stemp est toujours là ?...

Mille mercis

Hors ligne

#1342 Le 12/11/2011, à 21:46

Stemp

Re : Webkit, Midori et Epiphany-webkit

Tu es sûr d'avoir installé le paquet libwekit-dev ?


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1343 Le 13/11/2011, à 13:05

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

Après vérification par Synaptic, libwebkit-dev n'est effectivement pas installé (c'est le seul à ne pas l'être parmi tous ceux commençant par libwebkit...)....

Losque je demande à Synaptic de l'installer, re-problème:

libwebkit-dev:
Dépend : libsoup2.4-dev mais ne doit pas être installé

Et si je veux installer libsoup2.4-dev, voici ce que mon pote Synaptic me répond:

libsoup2.4-dev:
Dépend : libgnutls-dev mais ne doit pas être installé

Et s'il me prenait l'idée d'installler libgnutls-dev, voici :

libgnutls-dev:
Dépend : libgcrypt11-dev mais ne doit pas être installé
Dépend : libtasn1-3-dev mais ne doit pas être installé

Grrr ça devient un jeu que de compiler Midori  !... va-t-on abandonner ou va-t-on y arriver ?? tongue

Hors ligne

#1344 Le 13/11/2011, à 13:23

Stemp

Re : Webkit, Midori et Epiphany-webkit

On en revient au même problème que le précédent problème avec libgnutls mais cette fois-ci avec libgcrypt11 et/ou libtasn1-3-dev.
Une version incompatible a du être installée.

Donc on réutilise apt-cache policy pour voir quelle version est installée.

apt-cache policy libgnutls-dev

puis

apt-cache policy libgcrypt11-dev

et

apt-cache policy libtasn1-3-dev

Trouve la version fautive (ce n'est d'ailleurs peut-être pas le paquet -dev) et downgrade à la version normale avec sudo aptitude install lepaquet=version
.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1345 Le 15/11/2011, à 18:41

Stemp

Re : Webkit, Midori et Epiphany-webkit

drefhill a écrit :

ok merci alors je vais attendre :-( j'espere que je ne vais pas perdre mon profil, mots de passe,favoris onglets ouvert etc...

Les versions i386 pour Oneiric et Natty doivent être disponibles.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1346 Le 15/11/2011, à 21:25

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

Trouve la version fautive (ce n'est d'ailleurs peut-être pas le paquet -dev) et downgrade à la version normale avec sudo aptitude install lepaquet=version

OK je me doutais que tu me dises ceci, mais commen dois-je faire pour trouver la version fautive ? j'avoue que je ne sais pas, même si ensuite c'est pas sorcier de recommencer avec aptitude...

Merci

Hors ligne

#1347 Le 15/11/2011, à 21:48

Stemp

Re : Webkit, Midori et Epiphany-webkit

Nounours18200 a écrit :

OK je me doutais que tu me dises ceci, mais commen dois-je faire pour trouver la version fautive ? j'avoue que je ne sais pas, même si ensuite c'est pas sorcier de recommencer avec aptitude...Merci

Exécute les trois apt-cache policy demandés, tu auras le numéro de version installé et celui disponible dans les dépôts.

Comme le premier que tu avais fait :

elodie@elodie-desktop:~$ sudo apt-cache policy libgnutls26
[sudo] password for elodie: 
libgnutls26:
  Installé : 2.12.3-1
  Candidat : 2.12.3-1
Table de version :
*** 2.12.3-1 0
        100 /var/lib/dpkg/status
     2.8.5-2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ lucid/main Packages

Si tu regardes la table de version tu vois que la version installée est 2.12.3-1 alors que celle des dépôts est 2.8.5-2

Si ce ne sont pas les mêmes alors cette version est fautive wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1348 Le 16/11/2011, à 21:44

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

Merci Stemp, ça a bien progressé puisque j'ai pu installer les bonnes versions manquantes.

Il me reste désormais 3 paquets que "./waf configure" ne trouve pas, mais que je n'arrive pas à identifer par Synaptic (ils ont peut-être un autre nom ou je ne sais pas les identifier). Voici ce que le ./waf configure me donne à présent :

elodie@elodie-desktop:/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1$ ./waf configure
Checking for program gcc or cc           : /usr/bin/gcc
Checking for program cpp                 : /usr/bin/cpp
Checking for program ar                  : /usr/bin/ar
Checking for program ranlib              : /usr/bin/ranlib
Checking for gcc                         : ok 
Checking for program valac               : /usr/bin/valac
Checking for gobject-2.0                 : yes
Checking for gthread-2.0                 : yes
Checking for program version valac >= 0.1.6 : ok 0.8.0
Checking for program glib-genmarshal        : /usr/bin/glib-genmarshal
Checking for program glib-mkenums           : /usr/bin/glib-mkenums
Checking for program msgfmt                 : /usr/bin/msgfmt
Checking for program intltool-merge         : /usr/bin/intltool-merge
Checking for header locale.h                : yes
Checking for program rsvg-convert           : /usr/bin/rsvg-convert
Checking for unique-1.0 >= 0.9              : yes
Checking for libnotify >=                   : yes
Checking for library m                      : yes
Checking for gmodule-2.0 >= 2.8.0           : yes
Checking for gthread-2.0 >= 2.8.0           : yes
Checking for gio-2.0 >= 2.16.0              : yes
Checking for x11 >=                         : yes
Checking for header X11/extensions/scrnsaver.h : not found
Checking for library Xss                       : not found
Checking for gtk+-2.0 >= 2.10.0                : yes
Checking for webkit-1.0 >= 1.1.17              : yes
Checking for libsoup-2.4 >= 2.25.2             : yes
Checking for libsoup-2.4 >= 2.27.90            : yes
Checking for libsoup-2.4 >= 2.29.3             : yes
Checking for libsoup-2.4 >= 2.29.91            : yes
Checking for libxml-2.0 >= 2.6                 : yes
Checking for sqlite3 >= 3.0                    : Package sqlite3 was not found in the pkg-config search path.
Perhaps you should add the directory containing `sqlite3.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sqlite3' found
/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1/wscript:164: error: the configuration failed (see '/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1/_build_/config.log')
elodie@elodie-desktop:/media/SATA_06/SOURCES_L/Midori_0.4.1_navigateur_internet/midori-0.4.1$

Les 3 erreurs restantes semblent être:
Checking for header X11/extensions/scrnsaver.h : not found
Checking for library Xss                       : not found
No package 'sqlite3' found

Mais au travers de Synaptic, il n'est pas clair pour moi d'identifier quoi installer...

Merci "Stemp le patient"...:):)

Hors ligne

#1349 Le 17/11/2011, à 07:55

Stemp

Re : Webkit, Midori et Epiphany-webkit

Il manque libsqlite3-dev et libxss-dev


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#1350 Le 18/11/2011, à 21:54

Nounours18200

Re : Webkit, Midori et Epiphany-webkit

et bien oui, c'est comme ça qu'on passe pour un benêt (que je suis) puisque je cherchais "sqlite3" et "Xss" et non pas libsqlite3 et libxss....

Mais au moins j'aurai appris pour le futur !

Mille mercis Stemp smile:)

Hors ligne

Haut de page ↑