Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 29/12/2008, à 09:37

tk62

probleme souris logitech [RESOLU]

bonjour a tous.

voila, je vous explique mon probleme, j'ai une souris logitech mediaplay, qui marchait tres bien avec btnx sous hardy mais sous intrepid, il n'y a plus btnx, mais le module lmcpm_usb est deja integré.
le probleme, c'est que les boutons multimedia ne marchent que lorsque je fais un

 sudo rmmod usbhid

que je debranche /rebranche ma souris
pourtant j'ai bien modifié le fichier modules.dep. jusqu'a hier je n'avais pas besoin de faire ces manipulations.
comment faire pour que usbhid ne "touche" pas du tout a ma souris.

voici les resultats de quelques commandes utiles lorsque les boutons marchent:

aymeric@Tk-0:~$ lsmod | grep lmpcm 
lmpcm_usb              12800  0 
usbcore               148848  9 usbhid,xpad,usblp,lmpcm_usb,usb_storage,libusual,ehci_hcd,ohci_hcd

aymeric@Tk-0:~$ dmesg | grep MediaPlay
[   25.138699] lmpcm_usb: v0.5.5:USB Logitech MediaPlay Cordless Mouse driver

et voici un lsmod quand ca marche pas :

aymeric@Tk-0:~$ lsmod | grep lmpcm
lmpcm_usb              12800  0 
usbcore               148848  9 xpad,lmpcm_usb,usblp,usb_storage,usbhid,libusual,ehci_hcd,ohci_hcd

donc apparement, ca marche que quand usbhid est lancé avant lmpcm_usb, j'essaie de modifier les dependances dans le modules.dep mais sans succes.

voila, merci a tous pour votre aide.

Dernière modification par tk62 (Le 31/12/2008, à 20:08)

Hors ligne

#2 Le 31/12/2008, à 16:16

tk62

Re : probleme souris logitech [RESOLU]

un petit up, personne n'a de solution a mon probleme ? big_smile

Hors ligne

#3 Le 31/12/2008, à 20:08

tk62

Re : probleme souris logitech [RESOLU]

bon, bah c'est bon j'ai trouvé tout seul...

pour ceux que ca interessent :

ajouter

rmmod lmpcm_usb
rmmod usbhid
modprobe lmpcm_usb
modprobe usbhid

dans /etc/rc.local avant le "exit 0"

maintenant votre souris (du moins la mienne tongue) reconnait les boutons multimedia des le demarage.

Hors ligne

Haut de page ↑