Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 04/01/2009, à 10:00

Arby

[ résolu ]Problème Webcam hp

Voilà je suis passé récemment sous Ubuntu (hier ^^) et j'aimerais pouvoir utiliser ma Webcam de mon ordi hp intégré ...

J'ai vu qu'il fallait faire un lsusb et cez moi ça donne ça :

Bus 005 Device 002: ID 05ca:1810 Ricoh Co., Ltd

Après je suis un peu perdu...

Si vous pouvais éclairer ma lanterne ce serait bien sympa...

J'ai essayé de trois trucs ( Ekiga et même ce tuto http://doc.ubuntu-fr.org/ricoh-webcam-r5u870 mais je bloque à ce code

gpg --recv-keys 0xBA62BC7E 

gpg --export -a 0xBA62BC7E | sudo apt-key add -

car ça me donne :

gpg: pas de serveur de clés connu (utilisez l'option --keyserver)
gpg: la réception depuis le serveur de clés a échoué: mauvaise adresse (URI)

)

J'espère que vous pourrez m'aider...

D'avance merci et svp, n'utilisez pas un vocabulaire trop poussé...je débute ^^

Dernière modification par Arby (Le 11/01/2009, à 22:34)

Hors ligne

#2 Le 04/01/2009, à 10:56

vince06fr

Re : [ résolu ]Problème Webcam hp

Sous quel version d'ubuntu es-tu? car comme précisé dans la doc, Le pilote ne fonctionne plus avec les noyaux 2.6.26 et plus. Pour savoir quel est ta version du noyau :

uname -r

Ensuite, si tu es sous intrepid, un bug de gstreamer empeche les applications webcam basés sur gstreamer de fonctionner correctement, il faut rajouter un dépot à ton sources.list :

sudo gedit /etc/apt/sources.list

tu rajoutes à la fin du fichier les lignes suivante :

## Dépôts libv4l pr bug gstreamer webcam
deb http://ppa.launchpad.net/lool/ubuntu intrepid main
#deb-src http://ppa.launchpad.net/lool/ubuntu intrepid main

tu sauvegarde et tu mets à jour :

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install lib32v4l-0 libv4l-0

Afin de faire fonctionner ta webcam il existe une solution développé par le développeur du pilote et qui ne nécessite pas d'être compiler avec le noyau (voir ici)

Si tu n'es pas très fort en anglais voilà ce qu'il faut faire :
Dans un premier temps on installe mercurial qui est un outil de distribution de code sources (on peut aussi télécharger directement les sources à l'adresse http://bitbucket.org/ahixon/r5u87x/

sudo apt-get install mercurial

On crée un dossier webcam dans lequel on téléchargera les sources du driver

$ cd 
$ mkdir webcam
$ cd webcam
$ hg clone http://bitbucket.org/ahixon/r5u87x/

On se rend dans le repertoire qu'on vient de télécharger avec mercurial et on compile

$ cd r5u87x
$ make

Pour demarrer le driver

$ ./loader

Il peut etre nécessaire de re-modprobe uvcvideo pour faire fonctionner le driver, c'est moi c'est le cas et j'ai creé un petit script qui me démare correctement le driver :
edite ou cree le fichier r5u87x.sh et colles-y le code suivant

#!/bin/bash
###################################################################################
# ahixon / r5u87x                                                                 #
#A bunch of userspace tools to help manage cameras based on Ricoh R5U87x chipsets.#
#Clone URL : http://bitbucket.org/ahixon/r5u87x/ (size: 173.2 KB)                 #
###################################################################################

# annulation des droits root
sudo -k

# se rendre dans le repertoire de r5u87x
cd
cd ~/webcam/r5u87x

#Demande des droits root
if zenity --entry --title="Demande de privileges" --text="Enter your password:" --hide-text | sudo -S mkdir 'privileges'
 then 
 	sudo rm -r privileges
 else
    zenity --error --text="Sorry, bad password"
    exit
fi

# activation du driver
sudo ./loader
sudo modprobe -r uvcvideo
sudo modprobe uvcvideo

zenity --info --text="Le driver est activé, la webcam devrait fonctionner"

exit 0

rends le fichier executable et tu n'a plus qu'à le lancer pour activer le driver

Dernière modification par vince06fr (Le 04/01/2009, à 11:28)

Hors ligne

#3 Le 04/01/2009, à 17:17

kiki8862

Re : [ résolu ]Problème Webcam hp

Bonjour à tous
J'ai un problème pour installer ma webcam. J'utilise ubuntu 8.10 depuis peu de temps grâce à mon père. Lui ne sachant pas non plus comment faire pour obtenir une image webcam, je vous demande donc pour avoir une réponse au plus rapidement.
Lorsque je lance l'icône de webcam avec aMSN, il me demande le démarrage de l'assistant en me mettant par défaut un périphérique v4I2: CIF Single Chip, le canal par défaut est pac207, à cet endroit-là, un carré prévu à l'effet de l'affichage de la webcam ne s'affiche guerre. Ensuite, sur l'étape 2, c'est la page de réglage mais rien n'est affiché. En étape 3, c'est la demande de paramètre audio mais je n'ai pas de micro donc cette étape ne m'interrese pas.
Dans l'attente d'une réponse favorable et pas très complexe, merci à vous d'une grande aide.
Kiki8862.

Hors ligne

#4 Le 04/01/2009, à 17:25

kiki8862

Re : [ résolu ]Problème Webcam hp

Dans l'attente d'une réponse favorable et pas très complexe dans l'explication*, merci à vous pour cette grande aide.
Kiki8862.
Pour information, je vous laisse mon adresse mail : kristel_nogre@hotmail.fr.
Merci encore.

Hors ligne

#5 Le 04/01/2009, à 18:10

Arby

Re : [ résolu ]Problème Webcam hp

Alors je commence par le début...

Mon noyau est :

2.6.27-9-generic

Après j'ai un tit problème sur la fin...
Comme je créais un ficier ^et comme je le rend exécutable...

En tt cas merci pour ta reponse rapide

Hors ligne

#6 Le 04/01/2009, à 19:54

vince06fr

Re : [ résolu ]Problème Webcam hp

Tu es sous hardy heron?? en tout cas la version du noyau est effectivement superieur à la 2.6.26...

Pour creer le fichier sur le bureau:

$ gedit ~/Bureau/r5u87x.sh

Si tu es sous kubuntu, tu remplace gedit par kate

Pour rendre ton fichier exécutable :

chmod a+x ~/Bureau/r5u87x.sh

sous ubuntu, avec nautilus, il est aussi possible de rendre exécutable un fichier au clic droit-> propriété-> permission-> cocher autoriser l'exécution du fichier comme un programme

Dernière modification par vince06fr (Le 04/01/2009, à 19:57)

Hors ligne

#7 Le 05/01/2009, à 19:33

Arby

Re : [ résolu ]Problème Webcam hp

J'ai fait tout ce que tu m'as demandé, il y a même écris que le driver était actif et que la cam devait fonctionner mais ce n'est pas le cas...

Hors ligne

#8 Le 05/01/2009, à 20:10

vince06fr

Re : [ résolu ]Problème Webcam hp

Tu teste ta webcam avec quel logiciel??
essaie après avoir activé le driver :

$  gst-launch-0.10 v4l2src ! video/x-raw-yuv, width=640, height=480 ! xvimagesink

Hors ligne

#9 Le 05/01/2009, à 20:15

Arby

Re : [ résolu ]Problème Webcam hp

Avec amsn

xavier@xavier-comput:~$ gst-launch-0.10 v4l2src ! video/x-raw-yuv, width=640, height=480 ! xvimagesink
Définition du pipeline à PAUSED...
ERREUR : le pipeline refuse de se mettre en pause.
ERREUR : de l'élément /GstPipeline:pipeline0/GstV4l2Src:v4l2src0 : Impossible d'identifier le périphérique « /dev/video0 ».
Information de débogage supplémentaire :
v4l2_calls.c(463): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
system error: Aucun fichier ou dossier de ce type
Définition du pipeline à NULL...
Libération du pipeline (FREE)...

Voilà ce que ça me donne quand je rentre ton code


Edit : Je ne sais pas si ça peut aider mais j'ai le droit à :

sudo: ./loader: command not found

Quand je lance le fichier r5u87x.sh dans le terminal...

Dernière modification par Arby (Le 05/01/2009, à 23:32)

Hors ligne

#10 Le 06/01/2009, à 00:44

vince06fr

Re : [ résolu ]Problème Webcam hp

oui, apperement, il y a une merde dans le script, essaye :

$ cd
$ cd webcam/cd r5u87x
$ sudo ./loader
$ sudo modprobe -r uvcvideo
$ sudo modprobe uvcvideo
$ gst-launch-0.10 v4l2src ! video/x-raw-yuv, width=640, height=480 ! xvimagesink

Hors ligne

#11 Le 06/01/2009, à 07:26

Arby

Re : [ résolu ]Problème Webcam hp

xavier@xavier-comput:~/webcam/r5u87x$ sudo ./loader
[sudo] password for xavier: 
sudo: ./loader: command not found

sad:(:(:(

Hors ligne

#12 Le 06/01/2009, à 19:10

vince06fr

Re : [ résolu ]Problème Webcam hp

renvoie moi le retours de :

$ cd ~
$ ls

Dernière modification par vince06fr (Le 06/01/2009, à 19:11)

Hors ligne

#13 Le 06/01/2009, à 20:08

Arby

Re : [ résolu ]Problème Webcam hp

Voilà

xavier@xavier-comput:~$ cd ~
xavier@xavier-comput:~$ ls
amsn_received  Documents  easycam2-core.deb  Examples  Modèles  Public  webcam
Bureau         dwhelper   easycam2-gtk.deb   Images    Musique  Vidéos

EDIT :

je suis aller dans la cam pour voir :

xavier@xavier-comput:~$ cd webcam
xavier@xavier-comput:~/webcam$ ls
r5u87x

Dernière modification par Arby (Le 06/01/2009, à 20:11)

Hors ligne

#14 Le 06/01/2009, à 21:04

vince06fr

Re : [ résolu ]Problème Webcam hp

Bon et maintenant

$ cd ~/webcam/r5u87x
$ ls

Hors ligne

#15 Le 06/01/2009, à 21:07

Arby

Re : [ résolu ]Problème Webcam hp

xavier@xavier-comput:~/webcam/r5u87x$ ls
config.h  loader.c  loader.h.gch  README         ucode
docs      loader.h  Makefile      recode-fw.scm

Hors ligne

#16 Le 06/01/2009, à 21:08

vince06fr

Re : [ résolu ]Problème Webcam hp

c'est bien ce qu'il me semble, la compilation n'estpas faite: fait

make

Hors ligne

#17 Le 06/01/2009, à 21:10

Arby

Re : [ résolu ]Problème Webcam hp

yikes:o:o:o:o:o
Courage ...

avier@xavier-comput:~/webcam/r5u87x$ make
cc -g -Wall -DHAVE_CONFIG_H  `pkg-config --cflags glib-2.0 libusb` -c loader.c loader.h
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
Package libusb was not found in the pkg-config search path.
Perhaps you should add the directory containing `libusb.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libusb' found
loader.c:28:18: error: glib.h: Aucun fichier ou dossier de ce type
loader.c:29:25: error: glib/gstdio.h: Aucun fichier ou dossier de ce type
loader.c:30:17: error: usb.h: Aucun fichier ou dossier de ce type
In file included from loader.c:32:
loader.h:42: erreur: expected declaration specifiers or ‘...’ before ‘gint’
loader.c:38: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
loader.c:39: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘force_clear’
loader.c:40: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘no_load’
loader.c:42: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
loader.c:43: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘dump_ucode’
loader.c:45: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘entries’
loader.c:64: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
loader.c:82: erreur: expected declaration specifiers or ‘...’ before ‘gint’
loader.c: In function ‘find_device’:
loader.c:84: erreur: ‘gint’ undeclared (first use in this function)
loader.c:84: erreur: (Each undeclared identifier is reported only once
loader.c:84: erreur: for each function it appears in.)
loader.c:84: erreur: expected ‘;’ before ‘i’
loader.c:88: attention : implicit declaration of function ‘usb_get_busses’
loader.c:88: attention : assignment makes pointer from integer without a cast
loader.c:89: erreur: déréférencement d'un pointeur de type incomplet
loader.c:92: erreur: déréférencement d'un pointeur de type incomplet
loader.c:92: erreur: déréférencement d'un pointeur de type incomplet
loader.c:94: erreur: ‘i’ undeclared (first use in this function)
loader.c:95: erreur: déréférencement d'un pointeur de type incomplet
loader.c:96: erreur: déréférencement d'un pointeur de type incomplet
loader.c:98: erreur: ‘version’ undeclared (first use in this function)
loader.c: Hors de toute fonction :
loader.c:113: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘r5u87x_ucode_upload’
loader.c:195: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘r5u87x_ucode_status’
loader.c:212: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘r5u87x_ucode_version’
loader.c:231: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘r5u87x_ucode_enable’
loader.c:248: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘r5u87x_ucode_clear’
loader.c:270: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘load_firmware’
loader.c:397: erreur: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘main’
loader.h:21:18: error: glib.h: Aucun fichier ou dossier de ce type
loader.h:42: erreur: expected declaration specifiers or ‘...’ before ‘gint’
make: *** [loader.o] Erreur 1

Hors ligne

#18 Le 06/01/2009, à 21:20

vince06fr

Re : [ résolu ]Problème Webcam hp

ok, je vois il y a une erreur de compilation, apperement la bibliotheque glib2.0 n'est pas installée, donc, fait :

$ sudo apt-get install libglib2.0-dev
$ make

Hors ligne

#19 Le 06/01/2009, à 21:38

Arby

Re : [ résolu ]Problème Webcam hp

xavier@xavier-comput:~$ sudo apt-get install libglib2.0-dev
[sudo] password for xavier: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  libglib2.0-doc
Les NOUVEAUX paquets suivants seront installés :
  libglib2.0-dev
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 910ko dans les archives.
Après cette opération, 3695ko d'espace disque supplémentaires seront utilisés.
Réception de : 1 http://fr.archive.ubuntu.com intrepid-updates/main libglib2.0-dev 2.18.2-0ubuntu2 [910kB]
910ko réceptionnés en 3s (230ko/s)     
Sélection du paquet libglib2.0-dev précédemment désélectionné.
(Lecture de la base de données... 120313 fichiers et répertoires déjà installés.)
Dépaquetage de libglib2.0-dev (à partir de .../libglib2.0-dev_2.18.2-0ubuntu2_i386.deb) ...
Traitement des « déclenchements (triggers) » pour « man-db »...
Paramétrage de system-tools-backends (2.6.0-1ubuntu1.1) ...
 * Starting System Tools Backends system-tools-backends                         invoke-rc.d: initscript system-tools-backends, action "start" failed.
dpkg : erreur de traitement de system-tools-backends (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de libglib2.0-dev (2.18.2-0ubuntu2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 system-tools-backends
E: Sub-process /usr/bin/dpkg returned an error code (1)
xavier@xavier-comput:~$ make

dslé...mais le make je le lance ou??

Hors ligne

#20 Le 06/01/2009, à 22:37

vince06fr

Re : [ résolu ]Problème Webcam hp

Merde, là il ya une couille dans le potage puisqu'il t'es impossible d'installer le paquet libglib2.0-dev :

le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de libglib2.0-dev (2.18.2-0ubuntu2) ...
Des erreurs ont été rencontrées pendant l'exécution :
system-tools-backends
E: Sub-process /usr/bin/dpkg returned an error code (1)

Là je seche, peut etre faut il activer les dépots backport, chez moi ils sont activé...
sans cett lib, il n'est pas possible de compiler le driver
fait un

sudo apt-get remove --purge libglib2.0-dev

puis essaye de rajouter les depots backport (attention, l'ajout de ce depots pourrais mettre en cause la stabilité de ton système, chez moi aucun soucis mais je prefere prevenir wink )
Une fois le dépots rajouté tu fais

$sudo apt-get autoremove --purge
$sudo apt-get update
$ sudo apt-get install libglib2.0-dev

et tu me dis si tu as toujours l'erreur

Hors ligne

#21 Le 06/01/2009, à 23:43

Arby

Re : [ résolu ]Problème Webcam hp

Voilà alors là je t'ai tout balancé...
Mais je pense que dès le début il y a une erreur.

xavier@xavier-comput:~$ sudo apt-get remove --purge libglib2.0-dev
[sudo] password for xavier: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  libglib2.0-dev*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 3695ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? O
(Lecture de la base de données... 120489 fichiers et répertoires déjà installés.)
Suppression de libglib2.0-dev ...
Traitement des « déclenchements (triggers) » pour « man-db »...
Paramétrage de system-tools-backends (2.6.0-1ubuntu1.1) ...
 * Starting System Tools Backends system-tools-backends                         invoke-rc.d: initscript system-tools-backends, action "start" failed.
dpkg : erreur de traitement de system-tools-backends (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 system-tools-backends
E: Sub-process /usr/bin/dpkg returned an error code (1)
xavier@xavier-comput:~$ sudo apt-get autoremove --purge
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0o d'espace disque supplémentaires seront utilisés.
Paramétrage de system-tools-backends (2.6.0-1ubuntu1.1) ...
 * Starting System Tools Backends system-tools-backends                         invoke-rc.d: initscript system-tools-backends, action "start" failed.
dpkg : erreur de traitement de system-tools-backends (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 system-tools-backends
E: Sub-process /usr/bin/dpkg returned an error code (1)
xavier@xavier-comput:~$ sudo apt-get update
Réception de : 1 http://security.ubuntu.com intrepid-security Release.gpg [189B]
Ign http://security.ubuntu.com intrepid-security/main Translation-fr           
Réception de : 2 http://download.tuxfamily.org hardy-arakhne Release.gpg [197B]
Atteint http://fr.archive.ubuntu.com intrepid Release.gpg                      
Réception de : 3 http://fr.archive.ubuntu.com intrepid/main Translation-fr [398kB]
Ign http://ppa.launchpad.net intrepid Release.gpg                              
Ign http://ppa.launchpad.net intrepid/main Translation-fr                      
Ign http://security.ubuntu.com intrepid-security/restricted Translation-fr     
Ign http://security.ubuntu.com intrepid-security/universe Translation-fr       
Ign http://security.ubuntu.com intrepid-security/multiverse Translation-fr     
Ign http://download.tuxfamily.org hardy-arakhne/universe Translation-fr        
Réception de : 4 http://security.ubuntu.com intrepid-security Release [44,0kB] 
Réception de : 5 http://ppa.launchpad.net intrepid Release [27,6kB]            
Réception de : 6 http://download.tuxfamily.org hardy-arakhne Release [2707B]   
Ign http://download.tuxfamily.org hardy-arakhne Release                        
Réception de : 7 http://download.tuxfamily.org hardy-arakhne/universe Packages [13,2kB]
Réception de : 8 http://security.ubuntu.com intrepid-security/main Packages [46,1kB]
Ign http://ppa.launchpad.net intrepid/main Packages                            
Réception de : 9 http://ppa.launchpad.net intrepid/main Packages [1397B]       
Réception de : 10 http://security.ubuntu.com intrepid-security/restricted Packages [1785B]
Réception de : 11 http://security.ubuntu.com intrepid-security/main Sources [14,4kB]
Réception de : 12 http://security.ubuntu.com intrepid-security/restricted Sources [571B]
Réception de : 13 http://security.ubuntu.com intrepid-security/universe Packages [17,9kB]
Réception de : 14 http://security.ubuntu.com intrepid-security/universe Sources [2429B]
Réception de : 15 http://security.ubuntu.com intrepid-security/multiverse Packages [1330B]
Réception de : 16 http://security.ubuntu.com intrepid-security/multiverse Sources [584B]
Réception de : 17 http://fr.archive.ubuntu.com intrepid/restricted Translation-fr [4022B]
Réception de : 18 http://fr.archive.ubuntu.com intrepid/universe Translation-fr [339kB]
Réception de : 19 http://fr.archive.ubuntu.com intrepid/multiverse Translation-fr [63,0kB]
Réception de : 20 http://fr.archive.ubuntu.com intrepid-updates Release.gpg [189B]
Réception de : 21 http://fr.archive.ubuntu.com intrepid-updates/main Translation-fr [406kB]
Réception de : 22 http://fr.archive.ubuntu.com intrepid-updates/restricted Translation-fr [4026B]
Réception de : 23 http://fr.archive.ubuntu.com intrepid-updates/universe Translation-fr [531kB]
Réception de : 24 http://fr.archive.ubuntu.com intrepid-updates/multiverse Translation-fr [69,8kB]
Atteint http://fr.archive.ubuntu.com intrepid Release                          
Réception de : 25 http://fr.archive.ubuntu.com intrepid-updates Release [51,2kB]
Atteint http://fr.archive.ubuntu.com intrepid/main Packages                    
Atteint http://fr.archive.ubuntu.com intrepid/restricted Packages              
Atteint http://fr.archive.ubuntu.com intrepid/main Sources                     
Atteint http://fr.archive.ubuntu.com intrepid/restricted Sources               
Atteint http://fr.archive.ubuntu.com intrepid/universe Packages                
Atteint http://fr.archive.ubuntu.com intrepid/universe Sources                 
Atteint http://fr.archive.ubuntu.com intrepid/multiverse Packages              
Atteint http://fr.archive.ubuntu.com intrepid/multiverse Sources               
Réception de : 26 http://fr.archive.ubuntu.com intrepid-updates/main Packages [269kB]
Réception de : 27 http://fr.archive.ubuntu.com intrepid-updates/restricted Packages [3861B]
Réception de : 28 http://fr.archive.ubuntu.com intrepid-updates/main Sources [83,2kB]
Réception de : 29 http://fr.archive.ubuntu.com intrepid-updates/restricted Sources [1169B]
Réception de : 30 http://fr.archive.ubuntu.com intrepid-updates/universe Packages [34,2kB]
Réception de : 31 http://fr.archive.ubuntu.com intrepid-updates/universe Sources [6708B]
Réception de : 32 http://fr.archive.ubuntu.com intrepid-updates/multiverse Packages [3180B]
Réception de : 33 http://fr.archive.ubuntu.com intrepid-updates/multiverse Sources [1145B]
2443ko réceptionnés en 10s (231ko/s)                                           
Lecture des listes de paquets... Fait
W: GPG error: http://download.tuxfamily.org hardy-arakhne Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 7180CBD2BA62BC7E
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
xavier@xavier-comput:~$ apt-get update 
E: Impossible d'ouvrir le fichier verrou /var/lib/apt/lists/lock - open (13 Permission non accordée)
E: Impossible de verrouiller le répertoire de liste
xavier@xavier-comput:~$ sudo apt-get install libglib2.0-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  libglib2.0-doc
Les NOUVEAUX paquets suivants seront installés :
  libglib2.0-dev
0 mis à jour, 1 nouvellement installés, 0 à enlever et 6 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/910ko dans les archives.
Après cette opération, 3695ko d'espace disque supplémentaires seront utilisés.
Sélection du paquet libglib2.0-dev précédemment désélectionné.
(Lecture de la base de données... 120313 fichiers et répertoires déjà installés.)
Dépaquetage de libglib2.0-dev (à partir de .../libglib2.0-dev_2.18.2-0ubuntu2_i386.deb) ...
Traitement des « déclenchements (triggers) » pour « man-db »...
Paramétrage de system-tools-backends (2.6.0-1ubuntu1.1) ...
 * Starting System Tools Backends system-tools-backends                         invoke-rc.d: initscript system-tools-backends, action "start" failed.
dpkg : erreur de traitement de system-tools-backends (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de libglib2.0-dev (2.18.2-0ubuntu2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 system-tools-backends
E: Sub-process /usr/bin/dpkg returned an error code (1)

Là je dois y aller...demain reveil.
Je verrais demain mat' si il y a une rep de ta part sinon n'en avant 20 heure mini sad ..

Hors ligne

#22 Le 07/01/2009, à 00:00

vince06fr

Re : [ résolu ]Problème Webcam hp

peux-tu m'envoyer le contenu de ton sources.list?

Hors ligne

#23 Le 07/01/2009, à 07:30

Arby

Re : [ résolu ]Problème Webcam hp

je sais que c'est pénible ... mais c'est quelle commande??

Hors ligne

#24 Le 07/01/2009, à 18:08

vince06fr

Re : [ résolu ]Problème Webcam hp

sudo gedit /etc/apt/sources.list

Hors ligne

#25 Le 07/01/2009, à 20:10

Arby

Re : [ résolu ]Problème Webcam hp

# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://fr.archive.ubuntu.com/ubuntu/ intrepid main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ intrepid universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid universe
deb http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://fr.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu intrepid partner
# deb-src http://archive.canonical.com/ubuntu intrepid partner

deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb http://security.ubuntu.com/ubuntu intrepid-security universe
deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb http://download.tuxfamily.org/arakhne/ubuntu hardy-arakhne universe
## Dépôts libv4l pr bug gstreamer webcam
deb http://ppa.launchpad.net/lool/ubuntu intrepid main
#deb-src http://ppa.launchpad.net/lool/ubuntu intrepid main

Voilà

Hors ligne

Haut de page ↑