Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 09/04/2005, à 17:38

Sleeper

Mplayer pour les noobs..

Bonjour,

Suite à la lecture de ce post => http://forum.ubuntu-fr.org/viewtopic.php?id=1248 et à la lecture de beaucoup d'autres posts. Tapez mplayer dans Recherche et vous voila partit pour une journée de lecture.. yikes ...Et oui c'est un peu le gros bordel ont va dire..

J'entends parler de Mplayer par ci.. par la.. qu'il est le plus beau, le plus fort, le plus mieux.. Oui mais hmm ... Avant de pouvoir lire une video.. la route est longue.. Et je comptes bien y arriver un jour car j'ai vraiment envie de voir à quoi ca ressemble un Mlayer qu'on a reussi à installer et à configurer..

1. Installation

Franchement après avoir lu une tonnes d'articles décrivant chacun des modes d'installation différents je ne sais vraiment plus lequel choisir ? hmm

Entre certains membres qui disent que les .deb ne marche jamais, les autres qu'il vaut mieux le compiler sois même pour son kernel et Laurent (Ptit Belge comme moi tongue) qui propose une compilation d'un .deb..

Laurent a écrit :

Un petit conseil cependant avant de compiler : utilisez checkinstall

$sudo apt-get install checkinstall

donc, admettons qu'on en est déjà là:

$./configure --enable-gui
$make
$checkinstall -d

et là, un paquet .deb est créé dans le répertoire. Il reste à faire :

$sudo dpkg -i nomdupaquet

Sans oublier apt-get qui t'installe une belle liste de paquet dont xmms ??? pourquoi ne pas prendre que ces librairies si il les utilises ?

Et moi qui essaie de l'installer proprement en installant juste les paquets et librairies réelement nécessaire.. La console ne me dérange pas, les fichiers de configuration non plus.. Mais mon esprit à besoin d'être éclairé pour avoir la marche à suivre pour faire ça nickel !!!

Je a écrit :

Pour l'instant j'ai installé le paquet mplayer-686 via synaptic et il m'a installé une belle liste d'autres paquet. Je suis sous Hoary avec P3 500Mhz et ATI 3D Rage Pro (Date de 2000 avec driver générique ati). Personnelement je me fou d'avoir une gui. Par défaut la j'en ai une et je ne sais pas lire de vidéo. Sortie vidéo X11 (glxgears = 100 sad ) et audio ALSA. Au lancement => Error : New_Face failed. Maybe the front patch is wrong. Please supply the text font file (~/.mplayer/subfont.ttf)

2. Configuration

... hmm Pour ce qui est de la config je suis dans le noir complet.. Et je n'ai pas encore trouvé de tuto clair qui m'expliquerait bien la marche à suivre..

Merci pour votre aide..


Intel Core i5 750 : 4Go DDR : HD 2To : ATI HD4850 1Go DDR3 : SyncMaster 226bw
Pourquoi choisir GNU/Linux ? : Les commandes de base
Openbox : sur Ubuntu ou Debian, le tout en un script.

Hors ligne

#2 Le 09/04/2005, à 17:45

Sleeper

Re : Mplayer pour les noobs..

Pour l'instant en mode console quand je tapes $ mplayer vipere_au_poing.avi ça donne :

Console a écrit :

clement@p3:~/Documents/Videos/DivX $ mplayer vipere_au_poing.avi
MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium III Katmai/Pentium III Xeon Tanner (Family: 6, Stepping: 3)
Detected cache-line size is 32 bytes
MMX2 supported but disabled
CPUflags:  MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX SSE



Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission non accordée
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : Aucun fichier ou répertoire de ce type
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Aucun fichier ou répertoire de ce type
Failed to open LIRC support.
You will not be able to use your remote control.
Playing vipere_au_poing.avi.
AVI file format detected.
VIDEO:  [XVID]  576x240  24bpp  25,000 fps  858,2 kbps (104,8 kbyte/s)
Clip info:
Software: Nandub v1.0rc2
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 16000->176400 (128,0 kbit)
Selected audio codec: [mad] afm:libmad (libMAD MPEG layer 1-2-3)
==========================================================================
vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default


Intel Core i5 750 : 4Go DDR : HD 2To : ATI HD4850 1Go DDR3 : SyncMaster 226bw
Pourquoi choisir GNU/Linux ? : Les commandes de base
Openbox : sur Ubuntu ou Debian, le tout en un script.

Hors ligne

#3 Le 11/06/2005, à 22:01

O.

Re : Mplayer pour les noobs..

J'ai le même souci. En partie. Quand je lance "gmplayer", je me prends le message suivant :

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.

Je contourne la difficulté en faisant «sudo gmplayer»

Mais je préfèrerais ne pas en arriver là. Alors, c'est quoi le «system startup script» dans lequel il faut ajouter la formule magique ?


Erreur : pas de clavier détecté. Appuyer sur F1 pour continuer

Hors ligne

#4 Le 11/06/2005, à 22:07

laurent

Re : Mplayer pour les noobs..

Tu peux toujours essayer dans "Système -> Préférences -> Sessions". C'est vrai que c'est là que doit se trouver la solution.

Quelqu'un a vérifié si le bug était signalé?

@w3dev: si tu n'en as rien à faire du gui, fais comme moi: installe "mplayer-nogui", ça rox (plus rapide, plus souple...) Y'a qu'à associer les fichiers à mplayer par après et c'est bon (Alt+f=plein écran, espace = pause, esc=quitter, droite-gauche et haut-bas avance, recule)


Laurent, petit belge explorant la banquise

Hors ligne

Haut de page ↑