Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#26 Le 17/02/2006, à 00:25

bernez

Re : [Résolu] Latex

@coxx ton post 24 éclaircit l'horizon wink OK sur son fichier 13 c'est différent et ça marche mieux après ta modification cool
Il me semble même qu'en déplaçant \begin{document} avant \Institute c'est encore mieux. Il y a 3 ou 4 warning et 9 pages de dvi qui doivent satisfaire pépère wink


vyé kanari ka fè bonsoup.
Kenavo. A galon !

Hors ligne

#27 Le 17/02/2006, à 01:06

coxx

Re : [Résolu] Latex

Non, il ne faut pas mettre le \begin{document} avant le Institute puisque le Institute fait partie des entêtes d'un document Beamer de base, ça fait partie des normes. La solution propre est vraiment de rajouter des crochers ouvrants/fermant avec rien dedans dans la partie que je lui ai corrigé.


Monsieur K, de la chanson française parigote indépendante qui frappe fort !

Clips, paroles et sons disponibles sur le myspace de Monsieur K

Hors ligne

#28 Le 17/02/2006, à 11:43

pépère

Re : [Résolu] Latex

... de retour, désolé pour ce silence radio.

Je vais mettre résolé pour ce topic, mais c'est plutôt mitigé.

Désolé pour tout ça, mais j'affirme qu'il y a eu des trucs bizarres qui sont arrivés lors de mon changement gnome -> kde. Attention, ce n'est pas une critique vis à vis de kde, ou gnome, tout ça. C'est juste que je ne comprend pas ce qui s'est passé.

Sous gnome, quand j'ai essayé latex pour la première fois, quand je mettais ça au début de mon document :

\usepackage[T1]{fontenc}

Ca ne marchait pas, il y avait des signes bizarres à la place de mes lettres accentuées après la compilation. C'est pourquoi on m'avait conseillé d'utiliser ça :

\usepackage[utf8]{inputenc}

Et tout à marcher correctement après.

Mauvais surprise en passant à kde, les accents de mes fichiers .tex écrit sous gnome s'affiche mal. J'en conclus (mais je me trompe peut être, et même surement puisque je ne comprend pas grand chose) que par défaut, gnome et kde n'utilise pas le mm "format" pour les accents.

Pour que cela marche, j'ai remplacé les signes bizarres par des accents un par un, et remplacer utf8/inputenc par T1/fontenc, et là, le fichier s'est compilé... mais avec qq petits trucs enervants en plus.

Par exemple, dans une frame, j'avais inclu 4 graphiques qui doivent s'afficher les uns après les autres. J'ai créé ces graphiques de la mm taille, pour qu'ils soient parfaitement "allignés", les uns par rapport aux autres quand on les montres successivement.

\includegraphics<1>[scale=0.3]{/media/donnees/Diagnostic/Graphes/roc/roc1}
\includegraphics<2>[scale=0.3]{/media/donnees/Diagnostic/Graphes/roc/roc2}
\includegraphics<3>[scale=0.3]{/media/donnees/Diagnostic/Graphes/roc/roc3}
\includegraphics<4>[scale=0.3]{/media/donnees/Diagnostic/Graphes/roc/roc4}

Quand j'utilisais gnome et utf8/inputenc, ça me générait un truc parfait. Maintenant, mauvaise surprise : le second graphique est un peu décalé vers la droite par rapport au premier, le troisième un peu décalé par rapport au second, etc.

Franchement, je ne vois pas pourquoi ça fait ça maintenant, alors que ça fonctionnait avant. Je pense donc (mais je ne demande qu'à être contre dit, car je n'y connais pas grand chose) malgré tout ce qui a été dit, qu'il existe une différence quelque part entre les deux installations d'ubuntu et kubuntu et des divers pacquets servant à faire du latex, qui a engendré mes petits problèmes. J'aimerais bien en connaître l'origine, pour m'éviter ce genre de stress par la suite.

Je n'ai finalement pas réinstallé gnome. Je veux connaitre kde avant de faire un choix définitif. Je sais que des pb comme ça, c'est normal d'en rencontrer et qu'il faut insister un peu pour les régler. Je vais modifier mon fichier .tex pour avoir une présentation "présentable", ça sera un peu plus long que ce que j'avais prévu, mais tant pis...

Je tiens enfin à m'excuser du ton de mes messages. J'espère que je n'ai pas embêté trop de gens. J'étais stressé et un peu énervé, et je vous remercie de votre aide.

Ah euh, oui, un des pb venait aussi des crochets après \atbeginmachin. J'ai du les enlevé sans le faire exprès. Je les ai rajoutés, mais la compilation ne m'a généré un document qu'à partir du moment où j'ai corrigé mes lettres accentuées et utilisé fontenc.

Merci à tous.


Contre la récupération politicienne d'Ubuntu.

Hors ligne

#29 Le 17/02/2006, à 12:07

pépère

Re : [Résolu] Latex

Ah, un truc que j'ai pas vu tout de suite : les \subsubsection{soussoustitre} que j'avais mis ne fonctionne plus. LaTeX me dit :

ERROR: Undefined control sequence.

--- TeX said ---
1.370 \subsubsection
                              {Gold standard}

Inutile de dire que cela marchait avant...
De plus, je ne sais tjs pas pourquoi mes graphiques se décalent les un par rapport aux autres... Une idée ?


Contre la récupération politicienne d'Ubuntu.

Hors ligne

#30 Le 17/02/2006, à 15:42

coxx

Re : [Résolu] Latex

En fait, ça m'étonnerait fortement que ça aie marché un jour sous beamer, car \subsubsection ne fait pas partie des structures de contrôles de la classe beamer. Un subsubsection est absurde pour une présentation en slides, la structure n'est plus visible. Il y a des \section, des \subsection, et ensuite des frames avec des \titles et des \subtitles. C'est amplement suffisant comme structure.

Sinon, une petite remarque : je vois que tu as sauté une ligne entre \subsection et {Goldmachintruc}. Dans une classe article, ce code ne serait pas reconnu : l'argument {titre} doit être collé au \section ou au \subsection, sinon LaTeX les interprète comme deux individu séparés et le \section se retrouve tout seul, abandonné par son titre, et LaTeX génère une erreur. Ce n'est pas ton cas ici (la cause de l'erreur vient du fait que tu utilises une commande non reconnue par la classe Beamer), mais fais attention à la syntaxe quand même, c'est un language qui a une logique rigoureuse, il faut la respecter.

Pour tes images qui se décalent, peux te envoyer ici : tes entêtes beamer (tout ce qui précède le \begin{document} et le code correspondant à toute la frame où tes images se décallent. As tu aussi vérifié qu'ils avaient tous la même taille tes fichiers images ? En utilisant [width = nb de cm] plutôt que [scale = 0.3], déjà tu t'affranchirais du problème de fichiers image n'ayant pas la même taille à l'origine. J'ai tendance à préférer de loin de fixer la largeur plutôt que travailler avec des scales.
Autres questions : en quel format les fchiers images sont ils (ils n'ont pas d'extension dans le code que tu donnes) ? Ont ils une bounding box bien définie (ça ça dépend du format de fichier) ?

Dernière remarque : tes soucis n'ont absolument rien à voir avec ubuntu, ni kubuntu, mais uniquement avec LaTeX (enfin avec ton code LaTeX). Si tu souhaites des réponses rapides de plus de contributeurs (je travaille beaucoup avec LaTeX et la classe beamer, mais j'ai pas beaucoup de temps, j'ai un boulot smile ), il serait à mon avis plus approprié d'aller sur le forum de news fr.comp.text.tex à l'aide de ton lecteur de news préféré (ou depuis les newsgroups de google). Là tu as des spécialistes en bien plus grand nombre, dont des gens qui me surpassent de loin (l'auteur de la traduction française du TeXBook traine en permanence là bas par exemple). Là ce sont des problèmes simples que tu poses, mais comme je t'ai dit, je ne suis pas dispo en permanence et j'ai pas l'impression que ton topic attire des foules de spécialistes en Beamer, vu les réponses jusqu'à maintenant wink Continue toujours à me poser des questions si tu veux, mais je te garantis en rien que j'aurai le temps de regarder. (envoie quand même les renseignements que je t'ai demandés, pour ça je vais essayer de trouver le temps).

Dernière modification par coxx (Le 17/02/2006, à 16:35)


Monsieur K, de la chanson française parigote indépendante qui frappe fort !

Clips, paroles et sons disponibles sur le myspace de Monsieur K

Hors ligne

#31 Le 17/02/2006, à 19:23

pépère

Re : [Résolu] Latex

Merci coxx pour ton aide, je ne sais pas si le ton de mes messages quand ils sont lus expriment le fait que je suis sincèrement reconnaissant smile
Je sais que ce forum n'est peut être pas le plus approprié pour des questions latex, mais le ton d'ici est parfois plus agréable pour un débutant que dans un forum plus "spécialisé".

En ce qui concerne les subsubsection, je suis CERTAIN qu'ils sont gérés par beamer car :
- je l'ai fait et je peux t'en envoyer la preuve par une de mes présentations déjà compilée avec.
- à cause de ce pb, j'ai reconsulté la doc officielle de beamer, et subsubsection y est clairement référencée.

A propos du "retour chariot" du message d'erreur, il s'agit du message d'erreur que latex me donne. Je n'ai pas mis de retour chariot dans mon code.

Mes fichiersn image sont en format pdf. Je l'ai est créé en une seule fois avec le logiciel R. Ils ont la mm taille, et s'affichaient parfaitement aligné avant (je peux aussi t'envoyer ma présentation pour que tu vois que je n'affabule pas tongue )

Je ne veux accuser ubuntu ou kubuntu de rien. Je constate juste qu'un fichier .tex n'est plus lu de la mm façon lors de mon passage à kubuntu.

De plus, pour essayer de comprendre, j'ai réécris un nouveau document .tex sous emacs. Cela confirme le fait que ce n'est plus \usepackage[utf8]{inputenc} qui fonctionne mais \usepackage[T1]{fontenc}. Il existe donc bien une différence (et une solution qq part), ce qui ne sous entend pas un bug. Autre exemple, les accents de ce nouveau fichier .tex créé avec emacs et s'affichant correctement là, apparaissent avec des petits carré quand je l'ouvre avec Kile. Je n'ai pas constaté ça sous ubuntu. Je SAIS qu'il s'agit d'un pb de configuration quelque part, d'une erreur dans l'enregistrement de mon fichier, ou que sais je d'autre, mais tant que je ne saurais pas de quoi il s'agit, ni comment régler le pb, je ne peux que témoigner.

Encore une fois, ce n'est pas un débat sur "qu'est ce qui est mieux" entre gnome et kde, ubuntu et kubuntu. Je veux juste savoir comment finir ma présentation. J'affirme encore une fois que mon fichier ce compilait très bien avant, et ne se compile plus comme il faut maintenant, et que je ne comprend pas pourquoi.

Je vais suivre ton conseil et poser la question sur des forums spécifique à  latex, (en espérant ne pas me faire huer parce que je ne suis pas assez clair... hmm

Merci encore coxx... si tu as de nouvels idées, elles sont évidemment tjs les bienvenues.... big_smile

Dernière modification par pépère (Le 17/02/2006, à 19:31)


Contre la récupération politicienne d'Ubuntu.

Hors ligne

#32 Le 17/02/2006, à 20:16

coxx

Re : [Résolu] Latex

-> Pour les subsubsection, je suis pourtant quasiment sur d'avoir vu ça quelque part que dans beamer c'est une commande non reconnue. Si tu le dis. Toujours est-il que le section, subsection, et frametitle et framesubtitle tu auras une structure suffisamment marquée et claire pour que tout le monde la voie (je ne mets pas du tout en doute ta bonne foi, mais ça m'étonne énormément).

-> Pour information, entre ubuntu et kubuntu, les paquets tetex-base tetex-bin et tetex-extra, ainsi que beamer proviennent des mêmes dépôts, donc sont bel et bien des paquets de même version.

-> Ok pour le retour chariot

-> Regarde du côté des bounding box de tes fichiers images pdf. Sinon, pourrais tu poster tes entêtes ainsi que le frame entier qui pose problème ici pour voir ce que je peux faire (même sans les images, peut être que le pb vient de ta syntaxe, sûrement même).

-> Ubuntu et kubuntu sont de base supportés avec UTF-8, si tu ne l'as pas modifié (j'avais posté une astuce il y a un an, toujours très utilisée pour se débarasser de l'UTF-8 et passer à un système entièrement en ISO) sous ubuntu ni sous kubuntu, les deux systèmes ont le même système d'encodage de base.

-> Le problème des éditeurs est l'encodage dans lequel ils l'enregistrent et le lisent (je pense que emacs l'enregistre en UTF-8). Sous Kile, tu peux choisir l'encodage de lecture et d'enregistrement du fichier. Un fichier ouvert qui n'affiche pas correctement les caractères accentués vient seulement de la configuration respective d'enregistrment/édition des deux programmes utilisés. Regarde de ce côté. Pour ma part, j'utilise toujours T1 fontenc, et j'ouvre et j'enregistre tous mes fichiers en ISO euro, j'ai eu trop de mauvaises suprises avec l'UTF8, que j'ai relégué aux confins de mon système smile
Regarde donc dans les options de kile et de emacs, et ne travaille qu'à partir d'un seul éditeur, rien ne sert de disperser les risques de transition d'encodages smile (moi personnellement je suis amoureux de kile qui marche à merveille).

-> Pour configurer l'encodage de lecture et d'enregistrement, regarde du côté du menu "outil" -> encodage (après avoir vérifié dans quel encodage le fichier original a été enregistré (c'est indépendant un T1 fontenc ou du ucs utf8, c'est l'éditeur qui enregistre dans un certain encodage le fichier sans interpréter les balises dedans). Le problème, c'est que tu as du certainement faire plein d'aller retour entre plusieurs programmes et avoir des pertes d'accents. Choisis donc un programme d'édition, défninis clairement ta politique d'encodage du fichier .tex, et reste consistant avec. Si tu repars de ton fichier d'origine, remplace tous les caractères non reconnus par l'encodage en les caractères accentués réels, et enregistre le fichier dans l'encodage que tu as choisi. Ne t'amuse plus ensuite à ouvrir/enregistrer le document avec plusieurs encodages/programmes. Si ton projet est pressé, c'est pas le moment de s'amuser à ça.

-> En ce qui concerne le forum fr.comp.text.tex, il est assez convivial, et pour peu que la question soit bien posée avec un extrait du code .tex qui pose problème (ce qu'ils appellent un ECM, exemple complet minimal), tu auras des gens sympas qui te répondront sans problème smile

-> Pour la subsubsection, je suis intéressé que tu me donnes l'endroit exact de la doc où c'est indiqué, je l'ai épluchée rapidement et je n'ai rien trouvé.

Bon courage.


Monsieur K, de la chanson française parigote indépendante qui frappe fort !

Clips, paroles et sons disponibles sur le myspace de Monsieur K

Hors ligne

#33 Le 17/02/2006, à 22:41

pépère

Re : [Résolu] Latex

Pour les subsubsection :
http://www.tug.org/tex-archive/macros/l … rguide.pdf

à la page 79 (il en déconseille l'utilisation, mais ça marche smile

là, je vais arrêter les frais pour aujourd'hui... je regarderai tes conseils demain à tête reposée... Merci pour tout...


Contre la récupération politicienne d'Ubuntu.

Hors ligne

#34 Le 17/02/2006, à 23:56

coxx

Re : [Résolu] Latex

J'ai vu que sur fr.comp.text.tex on avait répondu clairement et gentiment à tes problèmes (Prakasch et Josselin sont extrèmement compétents, je pense qu'il t'ont tout dit sur ce qui est propre au problème tex en soit). Pour l'encodage, comme je t'ai dit, c'est une question d'éditeur et de choix de format d'encodage, c'est pas spécifique à tex.

En ce qui concerne le lien que tu me donnes, c'est le user guide de beamer 3.06. La version actuelle sur ubuntu est 3.01. Et les subsubsections ne sont pas dans le user guide de beamer 3.01 (qui est dans ton architecture, enregistré dans un fichier compressé : /usr/share/doc/latex-beamer/beameruserguide.pdf.gz (ça pourra te servir si jamais tu as besoin de doc sans avoir accès au net). J'ai fait une recherche, aucune ocurrence de subsubsection dans le user guide de notre version.

Donc comme je te disais, la version de beamer qu'on a avec ubuntu et/ou kubuntu (c'est la même version, latex-beamer provient du même dépôt) ne permet pas d'utiliser de /subsubsection. De toutes façons, même si c'était possible, c'est pas beau dans une présentation en slides, ça s'y prète mal (le "I strongly discourage the subsubsection in presentations. If you do not use them, you will give a better presentation" est assez similaire à ce que je te dis. D'autant qu'aparemment ces subsubsections ne sont supportées que depuis la toute dernière version de beamer, qu'on a pas sous breezy, comme dit plus haut).

Voilà, tu as toutes les clés en main entre ce que je t'ai répondu et ce qu'on t'a dit sur f.comp.text.tex pour avancer dans ton boulot ! smile

Dernière modification par coxx (Le 18/02/2006, à 00:12)


Monsieur K, de la chanson française parigote indépendante qui frappe fort !

Clips, paroles et sons disponibles sur le myspace de Monsieur K

Hors ligne

#35 Le 20/02/2006, à 10:08

pépère

Re : [Résolu] Latex

Heureux de pouvoir annoncer un "résolu" !!

Merci bcp coxx pour toute ton aide.

Bilan :
1) j'ai du malencontreusement convertir mon fichier .tex (que j'avais écrit en utf8) en iso. Je ne sais pas encore comment j'ai fait, mais c'est une des causes du pb.
2) sur ubuntu, j'avais installé la version 3.06 de beamer (merci coxx pour ton dernier post wink ). Elle ne se comporte pas de la mm manière que celle disponible via synaptic : les \subsubsection marchent, les [] à la fin de \AtBeginSubsection ne sont plus nécessaires, et mes graphiques sont bien alignés d'une diapo à l'autre (ce qui n'était pas le cas avec la version antérieure... peut être qu'une autre syntaxe est nécessaire pour arriver à ce résultat, je sais pas).
3) J'avais conserver une version de mon .tex en utf8 dans ma clef usb... Il y a donc une forme d'intelligence dans ma petite tête creuse hmm

Donc, tout ce caca nerveux était entièrement ma faute... désolé big_smile

Merci bcp ubuntu/kubuntu !


Contre la récupération politicienne d'Ubuntu.

Hors ligne

#36 Le 20/02/2006, à 10:16

pépère

Re : [Résolu] Latex

PS : histoire de contribuer un tout petit peu pour que ce post ne serve pas qu'à moi : pour installer la dernière version de beamer, il faut la télécharger ici : http://prdownloads.sourceforge.net/late … z?download

Vous dézippez le fichier, vous appelez le répertoire obtenu "beamer" pour que ça soit plus clair.
Vous coller ce répertoire dans le dossier /usr/share/texmef/tex/latex (de mémoire, à vérifier). Il faut le faire avec les droits administrateur :

sudo cp -r /chemin/beamer /usr/share/texmef/tex/latex/

Puis on fait un

sudo texhash

J'enfonce une porte ouverte, mais bon, voilà. tongue


Contre la récupération politicienne d'Ubuntu.

Hors ligne