Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 10/04/2005, à 15:12

Ephack

[Résolu] w32codecs?

Juste pour être sûr et éviter de continuer à chercher pour rien : les architectures 64bits sont privées de w32codecs, n'est-ce pas? Est-ce qu'il y a un moyen de contourner cela? Je n'ai par exemple pas essayé d'installer mplayer. Est-ce que cela me permettrait de visionner enfin mes vidéos? Si oui, quel logiciel me conseillez-vous?

Hors ligne

#2 Le 10/04/2005, à 21:15

Zb0rG

Re : [Résolu] w32codecs?

install VLC tongue c'est bien c'est une bonne alternative je pense...

Hors ligne

#3 Le 11/04/2005, à 22:59

Ephack

Re : [Résolu] w32codecs?

Je crois que je suis maudit du point de vue des lecteurs multimédias. J'avais pourtant réussi à apprivoiser Kaffeine sous Mandrake/KDE, mais mplayer avait toujours refusé de fonctionner. Même problème avec Ubuntu : mplayer, comme vlc, se lancent bien, mais plantent au moment d'ouvrir un fichier, que ce soit un mp3 ou une vidéo. Pourtant, les mp3 fonctionnent avec le lecteur de base de gnome...

Quelqu'un a-t-il une idée d'où cela pourrait provenir?

Hors ligne

#4 Le 12/04/2005, à 10:58

sylque

Re : [Résolu] w32codecs?

et vers là il n'y à rien qui pourrait t'interesser,regarde tout en bas...
http://ubuntu.ttoine.net/sourcelist.html


portable AMD 64 / Gusty
1Go RAM
ATI 9600-9700

Hors ligne

#5 Le 13/04/2005, à 22:31

Ephack

Re : [Résolu] w32codecs?

Mouis, alors effectivement, j'ai rajouté les deux dépôts indiqués en bas de la page... J'ai essayé d'installer mplayer, mais sans succès... Y'a vraiment que Totem qui fonctionne correctement (mis à part le fait que wincodecs32 ne s'installe pas bien sûr). Par contre, j'ai voulu faire une "mise à jour intelligente" par la suite, en conservant ces fameux deux dépôts. S'en est suivit un long téléchargement, suivi d'une installation avec message d'erreur. Au démarrage suivant de l'ordinateur : horreur : le noyau était planté! Message d'erreur : 'kernel panic : attempt to kill init!' Rien à faire, même en mode réparation : il a fallut que je réinstalle tout. C'est pas bien grave, je venais d'installer Ubuntu deux jours avant wink

Mais donc mplayer fonctionne sans problème chez tout le monde?

Hors ligne

#6 Le 14/04/2005, à 22:01

chatmoa

Re : [Résolu] w32codecs?

Y a un truc de bizarre !
J'arrive tout droit de chez suse et me restant une partition jamais utilisée ( Windows ) qui a été mise la par erreur par l'assembleur pour faire ses tests ( je préfere me justifier afin que les choses soient clair ! big_smile)

Toujours est t'il que j'ai sur une autre partoche une suse amd64 et que je regarde sans probleme tous les avi possibles avec kaffeine.
Je me souviens avoir eu un probleme au debut mais j'ai trouvé une solution !
J'ai trouvé un package rpm ( pas bien utile dans ce nouveau monde ) source des w32.
Celui la d'ailleurs : w32codec-all-20050216-0.pm.0.src.rpm

Puis je l'ai compilé et installé et le tour était joué, donc ce doit etre réalisable avec (k)ubuntu aussi ?
Non ?

A vrai dire je ne connais pas encore très bien les .deb, j'ai installé la kubuntu pas plus tard que ce soir.
Mais ca me plait, et c'est sacrément rapide !!!! big_smile

J'y pense je vais me remettre sous suse et récuperer les sources et en faire un .deb, si je trouve comment faire !

Si ququn pouvais me guider en 3,4 lignes comment faire !
Ce s'rait chouette cool

Hors ligne

#7 Le 16/04/2005, à 08:00

siko

Re : [Résolu] w32codecs?

Tient je viens aussi de SuSE tongue

Il existe le programme alien pour installer des programmes binaire au format rpm entre autre.

#8 Le 19/04/2005, à 17:32

Ephack

Re : [Résolu] w32codecs?

Moi aussi ça fonctionnait sous Mandrake, mais je crois que les logiciels installés par ces distributions ne sont en fait pas des versions 64bits, ce qui fait qu'ils peuvent utiliser les codecs 32bits. J'ai essayé d'installé le package w32codecs-all... avec alien, mais j'obtient comme toute réponse que l'architecture 64bits n'est pas supportée, chose assez logique. Le "all" ne se rapporte pas à l'architecture je pense, mais plutôt au fait que tous les codecs nécessaires sont inclus.

Hors ligne

#9 Le 29/04/2005, à 04:30

titoucha

Re : [Résolu] w32codecs?

Oui c'est exacte le all veux juste dire que le paquet contient tous les codecs et ils ne fonctionnent qu'en 32 bits. hmm

Hors ligne

#10 Le 16/05/2005, à 22:36

Anduze

Re : [Résolu] w32codecs?

Bonjour,

Ca marche super la lecture de DVD avec gxine, plus besoin du codecs w32

A+

Hors ligne

#11 Le 17/05/2005, à 17:23

Ephack

Re : [Résolu] w32codecs?

Et celle des .avi et .wmv aussi? C'est surtout ça le problème en fait...

Hors ligne

#12 Le 08/06/2005, à 21:13

Anduze

Re : [Résolu] w32codecs?

Bonjour,

Désolée pour ce temps de réponse si long. La seule chose que j'ai fait avec gxine, c'est de lire un DVD pris au hazard... Depuis, j'ai réinstallée une 32 bits car mon imprimante ne comprennait pas le 64 bits...
Bonne chance.

Hors ligne

#13 Le 05/08/2005, à 16:32

Vicks

Re : [Résolu] w32codecs?

J'ai trouvé ce truc, ça peut servir à qqn ou "comment faire fonctionner les codecs w32 avec le moteur xine et ce depuis une version 64bits"...

http://ubuntuforums.org/showthread.php?t=54399

Y'a rien de plus simple...

Dernière modification par Vicks (Le 05/08/2005, à 16:33)

Hors ligne

#14 Le 05/08/2005, à 18:29

Ephack

Re : [Résolu] w32codecs?

EEEEEEnnnnnnooooooorrrrrrrmmmmmmeeeeee!!!!!! cool

Merci, c'est génial! Simple et efficace, les solutions comme je les aime!

Allez-y tous, ça marche vraiment!

Hors ligne

#15 Le 05/08/2005, à 18:44

Ephack

Re : [Résolu] w32codecs?

Pour ceux qui sont allergiques à la langue de Sheakespeare (et chaque fois que j'écris ce nom, je me rends compte combien l'orthographe anglaise est encore mystérieuse pour moi wink ) ou tout simplement qui veulent aller plus vite, voici une transcription du message original (que vous pouvez donc trouver dans le message deux lignes plus haut). Je me suis permis de faire quelques changements, pour refléter ce que j'avais fait moi (les différences sont minimes) :

2) Installez “xine-ui” et “totem-xine” avec Synaptic ou tapez en ligne de commande :

sudo apt-get install xine-ui ; totem-xine

3) Créez le répertoire dans lequel vous voulez mettre les codecs (/usr/lib/win32 dans mon cas)

sudo mkdir /usr/lib/win32

4) Téléchargez les codecs sur ce site dans le répertoire que vous venez de créer :
http://www.mplayerhq.hu/homepage/design7/dload.html
(téléchargez juste l'archive “essential codecs package”)

5) Ouvrez la console (“Konsole” si vous utilisez KDE, “Terminal” si vous utilisez GNOME) et suivez les étapes suivantes :

a) Allez dans le répertoire où vous avez téléchargé le fichier

cd /usr/lib/win32/

b) Tapez maintenant, en supposant que le fichier téléchargé s'appelle “essential-20050412.tar.bz2” :

sudo tar jxvf essential-20050412.tar.bz2

c) Si comme moi vous allez utiliser xine pour la première fois, il est bon de lancer une fois le programme pour que xine crée lui-même son répertoire de configuration. Normalement, il existe une icône "Lecteur vidéo Totem" dans le menu "Applications -> Son et Vidéos". Refermez Totem avant de continuer.

d) Puis, si vous utilisez KDE :

kate /home/~MON_PROFIL/.xine/config

Ou si vous utilisez GNOME :

gedit /home/~MON_PROFIL/.xine/config

(Attention à ne pas oublier le “.” devant le mot “xine”)

e) Ajoutez la ligne suivante à la fin du fichier (chez moi, j'ai dû créer le fichier) :

decoder.external.win32_codecs_path:/usr/lib/win32

Ceci est l'exemple du fichier de l'auteur :

# percentage of skipped frames to tolerate
# numeric, default: 10
#engine.performance.warn_skipped_threshold:10

# allow implicit changes to the configuration (e.g. by MRL)
# bool, default: 0
#misc.implicit_config:0

decoder.external.win32_codecs_path:/usr/lib/win32

f) Sauvegardez le fichier (oui, écraser) et quittez.

g) Relancez xine (si vous l'utilisiez)


Voilà! Un grand merci à l'auteur original et à Vicks de l'avoir signalé!

Dernière modification par Ephack (Le 01/11/2005, à 18:56)

Hors ligne

Haut de page ↑