Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 26/02/2006, à 11:39

andjurka

probleme install libwxgtk2.6-0_2.6.1.2-2_i386.deb

bonjour voila mon probleme j'essaye d'installer Amule et j'ai pas mal de problemme de dependance.
la c'est la derniere et voila l'erreur lors du dpkg -i libwxgtk2.6-0_2.6.1.2-2_i386.deb:
root@Isengard:/home/andjurka/Desktop# dpkg -i libwxgtk2.6-0_2.6.1.2-2_i386.deb
(Lecture de la base de données... 92045 fichiers et répertoires déjà installés.)Dépaquetage de libwxgtk2.6-0 (à partir de libwxgtk2.6-0_2.6.1.2-2_i386.deb) ...
dpkg-deb (sous-processus) : lecture courte (short read) dans « buffer_copy » (impossible d'écrire dans le tube pour copie)
dpkg-deb: le sous-processus paste a retourné une erreur de sortie d'état 2
dpkg : erreur de traitement de libwxgtk2.6-0_2.6.1.2-2_i386.deb (--install) :
lecture courte (short read) dans « buffer_copy » (backend dpkg-deb pendant « ./usr/lib/libwx_baseu-2.6.so.0.0.0 »)
Des erreurs ont été rencontrées pendant l'exécution :
libwxgtk2.6-0_2.6.1.2-2_i386.deb


sinon j'ai aussi fait apt-get build-dep amule et j'obtien la meme erreur
que dois je fair?? y'a t il une version plus recente non buggé ou alors une manip toute bete?
merci d'avance bye smile

Hors ligne

#2 Le 26/02/2006, à 11:45

andjurka

Re : probleme install libwxgtk2.6-0_2.6.1.2-2_i386.deb

a oui sinon j'ai essayer d'installer xmule aussi et voila l'erreur :
==== Building xMule ====
== License(s): GPL
ClientCredits.cpp
ClientCredits.cpp: In member function ‘void CClientCredits::ShowCHandPK(uint32_t, unsigned char*, int)’:
ClientCredits.cpp:119: erreur: expected primary-expression before ‘for’
ClientCredits.cpp:119: erreur: expected `;' before ‘for’
ClientCredits.cpp:119: erreur: ‘i’ was not declared in this scope
ClientCredits.cpp:119: erreur: expected `;' before ‘)’ token
/usr/include/wx-2.6/wx/window.h: At global scope:
/usr/include/wx-2.6/wx/window.h:113: attention : inline function ‘virtual wxWindowList::~wxWindowList()’ used but never defined
/usr/include/wx-2.6/wx/window.h:113: attention : inline function ‘virtual wxWindowList::~wxWindowList()’ used but never defined
make[1]: *** [obj/ClientCredits.o] Erreur 1
make: *** [all] Erreur 2

bye

Hors ligne

#3 Le 26/02/2006, à 11:59

mézgue

Re : probleme install libwxgtk2.6-0_2.6.1.2-2_i386.deb

Tu trouveras un tuto français ici :
http://www.amule.org/wiki/index.php/Compilation_Installation-fr
il marche bien

sinon j'ai vu par ailleurs qu'un dépot existe :
#aMule compilé à partir des cvs avec le support du réseau centralisé Kadmelia
deb http://koti.mbnet.fi/~ots/ubuntu/ breezy/
deb-src http://koti.mbnet.fi/~ots/ubuntu/ breezy/

(à rajouter aux sources.list)
pas testé

salut


La dictature, c'est ferme ta gueule, la démocratie, c'est cause toujours.
Loup

Hors ligne

#4 Le 26/02/2006, à 12:02

andjurka

Re : probleme install libwxgtk2.6-0_2.6.1.2-2_i386.deb

salut merci bien smile
jvai tester tous sa
bye

Hors ligne

#5 Le 26/02/2006, à 12:40

andjurka

Re : probleme install libwxgtk2.6-0_2.6.1.2-2_i386.deb

re connaisez vous l'adresse de libwx_gtk-2.4
j'ai installer wxgtk mais sa ne marche pas
merci bye

Hors ligne

#6 Le 26/02/2006, à 20:35

mézgue

Re : probleme install libwxgtk2.6-0_2.6.1.2-2_i386.deb

ça remonte à 2 mois et c'était un peu galère :
autant que je me souvienne j'ai utilisé :
wxBase-2.6.2.tar.gz
wxGTK-2.6.2.tar.gz
wxWidgets-2.6.2.tar.gz
pour l'install de amule 2.1

wxWidgets 2.4.2 et libwx_gtk-2.4 (qui se trouve dans les dépôts universe, il me semble) posaient problème à cause de libcrypto

aussi j'ai tenté l'install en suivant la méthode "cependant aMule peut également être compilé en utilisant wxWidgets 2.5.x et les versions de Crypto++ plus récentes que la 5.1. A partir de la 2.0.0-rc6, vous n'avez même plus besoin de Crypto++."
sauf que ne trouvant pas wxWidgets 2.5.x, j'ai pris wxWidgets 2.6.2

bien faire gaffe à désinstaller auparavant tout les wxWidgets  'suivre pour celà la méthode indiquée
http://www.amule.org/wiki/index.php/How_to_uninstall_wxWidgets

bon courage


La dictature, c'est ferme ta gueule, la démocratie, c'est cause toujours.
Loup

Hors ligne

Haut de page ↑