Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 07/03/2009, à 18:57

AuraHxC

[RÉSOLU] Macbook 2,1 Intrepid clavier

Alors voilà, je viens de passer a intrepid ibex après un long moment sans linux sur mon macbook (enfin tout est relatif juste quelques mois vu que j'étais sur la version Hardy).

Sur la version Hardy, je n'avais aucun problème avec mon clavier. En effet, j'avais le arobase, dièse sur la touche en haut a gauche, les crochets et accolades avec la touche pomme+(touche parenthèse), le - et _ sur la touche correspondante sur le clavier macbook etc... Enfin bref un truc correspond complètement au clavier du macbook.

Et la je n'y arrive pas du tout, en modifiant le mapping avec l'interface gnome (section apple je choisis macbook intel et france).
J'ai voulu regarder dans le xorg.conf mais apparement il n'y a plus rien qui se passe dans ce fichier sachant que je n'ai plus rien du tout.

Donc j'aimerais savoir si quelqu'un peu me dire si il a réussi a faire ce que j'avais avant c'est à dire un clavier macbook comme je pouvais l'avoir sur Hardy.

Merci d'avance.

Dernière modification par AuraHxC (Le 09/03/2009, à 02:33)

Hors ligne

#2 Le 09/03/2009, à 01:56

AuraHxC

Re : [RÉSOLU] Macbook 2,1 Intrepid clavier

Personne n'aurait une idée donc pour se mapping clavier qui a toujours fonctionné il me semble.
Je continue mes recherches je verrais bien.

EDIT : En mettant modèle clavier Macbook/Macbook Pro (intl) et agencement france Apple-Macintosh, j'ai eu une erreur mais j'ai eu le mapping comme je voulais (le mapping que l'on a sur MacOSX sur un macbook). Après un redémarrage, de nouveau le message d'erreur mais par contre plus du tout le mapping... J'aimerais bien savoir ce que modifie l'interface "Clavier" comme fichier car peut être que de le faire à la main cela fonctionnerai mieux.

EDIT2 : Apparemment après plusieurs tests =>  il semblerait que la configuration suivante fonctionne sans erreur (après redémarrage cela fonctionne toujours sans erreur).

Modèle clavier : PC Générique 105 Touches (intl)
Agencement : France Apple-Macintosh
Options : Sélecteur niveau 3 => touche logo de gauche, le logo pomme en gros (mais vous pouvez mettre celui de droite bien sûr).

Maintenant j'arrive a faire @#<>{}[]|~ etc... comme on pourrait le faire sur MacOSX.

Je vais continuer mes configurations mais normalement tout devrait rouler correctement...

Dernière modification par AuraHxC (Le 09/03/2009, à 02:33)

Hors ligne

#3 Le 29/03/2009, à 11:59

JJG

Re : [RÉSOLU] Macbook 2,1 Intrepid clavier

Je lis avec attention parce qu'évidemment, j'ai le même soucis.

Cependant dans les options, j'ai la formulation en anglais. Je ne sais pas à quoi correspond "touche logo de gauche". Tu peux m'aider?


http://www.enseignelibre.be
Macbook Pro 13", unibody

Hors ligne

#4 Le 13/09/2009, à 17:38

lyondif02

Re : [RÉSOLU] Macbook 2,1 Intrepid clavier

Bonjour,

La question initiale est indiquée comme résolue. Voici toutefois une solution dans le cas d'une configuration : MacBook + Ubuntu 9.04 (Desktop Edition) -- information potentiellement utile pour l'indexation améliorée de la page.

Dans les propriétés du clavier, effectuer le paramétrage suivant :
- Modèle de clavier : (fabricant) Apple (modèle) Portable Apple ;
- Agencement : (pays) France (variante) Apple-Macintosh ;
- Options d'agencement :
-- Comportement des touches Alt/Logo : La touche Alt de gauche est échangée avec la touche Logo de gauche ;
-- Touche sélectionnant le 3e niveau : N'importe quelle touche Alt.

Avec ce paramétrage, on peut utiliser le clavier du MacBook comme avec Mac OS X : (imitation sans copier-coller de AuraHxC) @ # < > { [ } ] ~ æ œ €

Cordialement.
nha / Lyon / France.

Dernière modification par lyondif02 (Le 13/09/2009, à 17:39)

Hors ligne

Haut de page ↑