Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 04/05/2009, à 18:16

Arnaud75

Problème Blender 2.48a + Ubuntu 9.0.4

Bonjour

Tout est dans le titre mais je précise :

-Ma fenêtre modélisation se rafraîchie que dans sa moitié supérieur
-Tous les icones des menus ont disparus (mode sélection, mode fenétrage etc)
-Dans la fenêtre d'édition de matière, l'aperçu (la boule ou les autres) est tout écrasé
-Lorsque je fais un rendu dans la fenêtre centrale, le rendu est lui aussi tout écrasé

je suppose qu'il y en a d'autre.
J'ai desinstalé... ré-instalé. Rien ! toujours ces problèmes

Quelqu'un a t'il ces problèmes ?
ça vient de blender ? de la 9.0.4 ?


ps : Tout les autres logiciels (gimp, inkscap, krita...) fonctionnent a merveille.

Hors ligne

#2 Le 04/05/2009, à 20:49

pomalin

Re : Problème Blender 2.48a + Ubuntu 9.0.4

tu as quoi comme carte graphique? une intel?

Hors ligne

#3 Le 04/05/2009, à 21:49

kao_chen

Re : Problème Blender 2.48a + Ubuntu 9.0.4

Arnaud75 a écrit :

-Ma fenêtre modélisation se rafraîchie que dans sa moitié supérieur
-Tous les icones des menus ont disparus (mode sélection, mode fenêtrage etc)

Pense à désactiver compiz, ça ne fait pas toujours bon ménage avec Blender.

Arnaud75 a écrit :

-Dans la fenêtre d'édition de matière, l'aperçu (la boule ou les autres) est tout écrasé
-Lorsque je fais un rendu dans la fenêtre centrale, le rendu est lui aussi tout écrasé

Il me semble que c'est une histoire de trame. Tu fait un rendu de type vidéo et il te manque une trame (1 ligne sur 2) dans ton rendu.
Il faut que tu fouille dans tes settings de rendu. Essaye le bouton "fields" dans l'onglet "Render".

Hors ligne

#4 Le 05/05/2009, à 10:47

Arnaud75

Re : Problème Blender 2.48a + Ubuntu 9.0.4

oui oui j'ai bien une carte intel interne (GMA 950 je crois)

Sinon pour le rendu il fonctionne très bien lorsque je le lance dans un fenêtre externe, la déformation se fait juste quand je le lance dans la fenêtre active.

en fait j'ai l'impression que mes fenêtres sont écrasées et entre ces "fenêtres écrasé" le réaffichage ne se fait pas.

j'ai l'impression que je suis le seul à avoir ce problème (ce qui me rassure un peu)

Hors ligne

#5 Le 05/05/2009, à 13:27

pomalin

Re : Problème Blender 2.48a + Ubuntu 9.0.4

ok, alors pour la carte intel même abec compiz désactivé ça fonctionne pas, donc, il faut désactiver dri.
Ce que je me suis fait pour utiliser blender sur mon dell mini 9, c'est un script nautilus qui bascule d'un xorg à l'autre et redémarre ma session gnome, un peu con, mais comme ça si je veux lancer blender, je désactive dri, sinon, je l'utilise.
Et donc, pour désactiver dri, c'est pas dur, il suffit d'éditer ton xorg.conf.

gksudo gedit /etc/X11/xorg.conf

Dans la section device tu rajoutes l'option DRI "false" donc :

Section "Device"
Identifier "Configured Video Device
Option "DRI" "false"
EndSection

pour ma part j'ai mis dans un xorg.conf.nodri  et le réglage par défaut sans la ligne désactivant false dans un xorg.conf.dri.
J'ai fait deux scripts nautilus (c'est sûrement faisable en un seul mais j'ai fais au plus simple pour moi)

#! /bin/bash

gksudo cp /etc/X11/xorg.conf.nodri /etc/X11/xorg.conf
gnome-session-save --kill
#! /bin/bash

gksudo cp /etc/X11/xorg.conf.dri /etc/X11/xorg.conf
gnome-session-save --kill

Je les ais nommés respectivement xorg.nodri  et xorg.dri    rendus exécutables. et voilà clic droit sur le bureau je bascule en dri ou nodri pour lancer blender.

Hors ligne

#6 Le 07/05/2009, à 12:12

Arnaud75

Re : Problème Blender 2.48a + Ubuntu 9.0.4

Grand merci à pomalin !

ça fonctionne

Par contre pour le code nautilus je sais pas ou le placer et ce que je dois faire (?)

(je suis tout nouveau sous Ubuntu et j'ai du m    al à ma rendre compte de qui fait quoi)

Hors ligne

#7 Le 07/05/2009, à 13:59

pomalin

Re : Problème Blender 2.48a + Ubuntu 9.0.4

tu dois mettre les deux scripts dans le dossier nautilus-scripts qui se trouve dans le dossier caché gnome2 de ton home.
Donc, Raccourcis>dossier personnel       ctrl+h   pour afficher les fichiers/dossiers cachés, tu trouve gnome2, dedans tu trouves le dossier nautilus-scripts, tu places tes deux scripts dedans, tu les sélectionne, clic droit, permissions, tu coches autoriser l'éxécution du fichier comme un programme pour les deux.

Ensuite, pour passer d'une config à l'autre tu n'auras plus qu'a faire un clic droit sur ton bureau, tu auras un menu scripts, et dedans, tu auras xorg.dri, et xorg.nodri.

Si je ne suis pas clair n'hésite pas.

Hors ligne

#8 Le 07/05/2009, à 21:30

pomalin

Re : Problème Blender 2.48a + Ubuntu 9.0.4

j'ai oublié de dire, si c'est pas clair, que tu dois avoir un xorg.conf.dri avec le xorg par défaut, c'est à dire sans la ligne Option "DRI" "false", et un xorg.conf.nodri avec la ligne Option "DRI" "false" dans ton dossier /etc/X11.
Pour se faire, tu lance la première commande, gksudo gedit /etc/X11/xorg.conf  tu rajoutes la ligne dri false, tu enregistres sous avec comme nom xorg.conf.nodri, tu effaces la ligne avec dri false, et tu enregistres sous le nom xorg.conf.dri. Sinon les scripts ne fonctionnenront pas. Quand tu lances le script, une boîte de dialogue va apparaître te demandant si tu veux fermer la session ou changer d'utilisateur, choisis ferme la session.
Voilà.

Hors ligne

#9 Le 16/06/2009, à 01:10

Wijdenes

Re : Problème Blender 2.48a + Ubuntu 9.0.4

euhhh.......
J'ai pas tout compri (ils sont peinible ces debutants...:P)
C'est quoi DRI?

#10 Le 18/06/2009, à 13:36

pomalin

Re : Problème Blender 2.48a + Ubuntu 9.0.4

J'ai une nouvelle solution ici:

http://forum.ubuntu-fr.org/viewtopic.ph … 2#p2736862

Et DRI c'est direct rendering.

Hors ligne

Haut de page ↑