Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 09/05/2009, à 16:03

benux_50

[Résolu] Impossible de régler la sensibilité de la souris

Bonjour à tous,

Je viens d'installer Ubuntu 9.4 sur mes 2 ordinateurs (un fixe et un portable). J'ai fait une installation complète à partir du live CD.

Sous Ubuntu 8.10, ma souris fonctionnait normalement. Je pouvais régler l'accélération et la sensibilité dans Système > Préférences > Souris.

Depuis que je suis sous Ubuntu 9.4, ma souris Arc Mouse de Microsoft (sans fil) est devenue trop rapide. Et le réglage de la sensibilité n'a aucun effet : au minimum ou au maximum, la vitesse est toujours la même. Seul le réglage de l'accélération a un effet sur la souris.

J'ai le même problème avec mes 2 souris (une sans fil Arc Mouse et une filaire Wheel Mouse Optical de Microsoft) et avec mes 2 ordinateurs.

Existe-t-il un autre moyen de modifier la sensibilité de la souris ?

Merci de vos réponses.

Dernière modification par benux_50 (Le 19/05/2009, à 21:03)

Hors ligne

#2 Le 09/05/2009, à 23:13

Ungars

Re : [Résolu] Impossible de régler la sensibilité de la souris

Salut, peux tu nous faire parvenir ton xorg.conf ?


Essaye désespérément d' installer une distribution Linux sur son Compaq CQ58
www.forum-plugcomputer.net

Hors ligne

#3 Le 10/05/2009, à 14:40

benux_50

Re : [Résolu] Impossible de régler la sensibilité de la souris

Bonjour Ungars,

Voici le contenu de mon xorg.conf :

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
    DefaultDepth    24
EndSection

Section "Module"
    Load    "glx"
EndSection

Section "Device"
    Identifier    "Configured Video Device"
    Driver    "nvidia"
    Option    "NoLogo"    "True"
EndSection

Hors ligne

#4 Le 10/05/2009, à 17:26

benux_50

Re : [Résolu] Impossible de régler la sensibilité de la souris

Après de nombreux réglages, je comprends un peu mieux d'où vient mon problème.

Dans Système > Préférences > Souris, le réglage de la sensibilité modifie en réalité le seuil (threshold en anglais) à partir duquel l'accélération est activée. C'est la distance en pixels que le pointeur doit parcourir pour que l'accélération soit activée. Et dans mon cas, le réglage de la sensibilité fonctionne bien.

En résumé, les réglages Système > Préférences > Souris fonctionnent normalement.
Ce qui ne va pas, c'est en fait la vitesse de ma souris (sans accélération).

Je viens de faire un test avec le live CD d'Ubuntu 8.10. Si je mets l'accélération au minimum, la souris est vraiment très lente ! Sur Ubuntu 9.4, avec l'accélération au minimum, la souris est encore trop rapide.

Peut-être existe-t-il un réglage dans xorg.conf.
J'ai fait quelques essais, pour l'instant sans succès.

Hors ligne

#5 Le 10/05/2009, à 23:34

Ungars

Re : [Résolu] Impossible de régler la sensibilité de la souris

Fait une sauvegarde de ton xorg.conf, au cas ou, et rajoute ça :

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"

Redémarre ton serveur X, et dis nous...

  Tu nous dit d' avoir le même problème avec la souris filaire, as tu débranché l' autre souris pendant ce temps là ? Essaye de faire un essai, debrance la souris Micorsoft, et redémarre ta machine, seulement avec la filaire branchée.

  Après en faisans un dpkg reconfigure, je ne sais pas s' il y a une rubrique pour la souris, si oui peut etre changer de pilote.

  Bonne soirée !


Essaye désespérément d' installer une distribution Linux sur son Compaq CQ58
www.forum-plugcomputer.net

Hors ligne

#6 Le 12/05/2009, à 21:38

benux_50

Re : [Résolu] Impossible de régler la sensibilité de la souris

Bonsoir Ungars,

Merci de ta réponse.

J'ai essayé de modifier xorg.conf comme tu me l'as conseillé. Ca ne change rien.

J'ai fait des essais avec mes autres souris (en débranchant la souris sans fil) et en redémarrant ma machine.
Ma souris filaire Logitech LX3 Optical Mouse est 2 fois moins rapide que ma souris sans fil Arc Mouse. C'est mieux, mais encore trop rapide à mon goût.
Ma souris filaire Microsoft Wheel Mouse Optical est carrément trop lente. C'est moins gênant qu'une souris trop rapide, puisqu'il est possible de compenser avec l'accélération.

Je n'avais pas souvenir que la vitesse du curseur était influencée par le type de souris utilisé, avec les versions précédentes d'Ubuntu. J'étais plutôt habitué à une vitesse standard, quel que soit le type de souris.

J'ai essayé la commande gksudo dpkg-reconfigure xserver-xorg. Il ne se passe rien. Je tape peut-être la mauvaise commande.

Hors ligne

#7 Le 13/05/2009, à 19:37

neeteex

Re : [Résolu] Impossible de régler la sensibilité de la souris

benux_50 a écrit :

J'ai essayé la commande gksudo dpkg-reconfigure xserver-xorg. Il ne se passe rien. Je tape peut-être la mauvaise commande.

Comme j'ai le même problème (souris trop rapide depuis essai de btnx) j'ai essayé cette commande : il semble que ce soit pour l'affichage vidéo, pas pour la souris... En tout cas sur ma machine.

Merci d'alimenter les pistes envisagées, j'essaierai de m'en inspirer, voire d'en proposer si je vois qqchose ailleurs...

Hors ligne

#8 Le 14/05/2009, à 16:02

Ungars

Re : [Résolu] Impossible de régler la sensibilité de la souris

Sur un xorg.conf d' une autre distribution, j' ai une rubrique "mouse" avec différent reglage possible. Peut etre faut il creuser de ce coté là :

 # **********************************************************************
# This file was generated by videoconfig (Zenwalk Xorg configuration tool)
# If you changed your video card or monitor, please run videoconfig again
# from runlevel 3. Don't modify this file yourself until you know what you do ;)
# **********************************************************************


# **********************************************************************
# Files section -- This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"
	RgbPath      "/usr/share/X11/rgb"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************

Section "Module"
	Load  "synaptics"
	Load  "glx"
	Load  "extmod"
	Load  "xtrap"
	Load  "record"
	Load  "GLcore"
	Load  "dbe"
	Load  "dri"
	Load  "freetype"
	Load  "type1"
EndSection

# **********************************************************************
# Server flags section
# **********************************************************************

Section "ServerFlags"
#    Option     "NoTrapSignals"
#    Option     "DontVTSwitch"
#    Option     "DontZap"
#    Option     "DontZoom"
#    Option     "DisableVidModeExtension"
#    Option     "AllowNonLocalXvidtune"
#    Option     "DisableModInDev"
#    Option     "AllowNonLocalModInDev"
#    Option      "blank time"    "10"    # 10 minutes
#    Option      "standby time"  "20"
#    Option      "suspend time"  "30"
#    Option      "off time"      "60"

# Option   "EstimateSizesAggresively" "0"

EndSection


# **********************************************************************
# DRI section
# **********************************************************************

Section "dri"
# Access to OpenGL ICD is allowed for all users:
    Mode 0666
# Access to OpenGL ICD is restricted to a specific user group:
#    Group 100    # users
EndSection


# **********************************************************************
# Extensions section
# **********************************************************************

Section "Extensions"
        Option "Composite" "Enable"
EndSection


# **********************************************************************
# Keyboard section
# **********************************************************************

Section "InputDevice"
	Identifier	"Keyboard1"
	Driver	"kbd"
#	Option     "Protocol"      "Xqueue"
#	Option     "AutoRepeat"    "500 5"
#	Option     "Xleds" "1 2 3"
#	Option     "XkbDisable"

	Option     "XkbRules"      "xorg"
	Option     "XkbModel"      "pc105"
	Option     "XkbLayout"     "fr"
#	Option     "XkbVariant"    "us"
	Option     "XkbOptions"    ""
EndSection


# **********************************************************************
# Pointers section
# **********************************************************************

Section "InputDevice"

# Identifier and driver
	Identifier "Mouse1"
	Driver	     "mouse"
	Option	     "Protocol" "Auto"
	Option	     "Device" "/dev/mouse"
#	Option     "Protocol" "Xqueue"
#	Option     "BaudRate" "9600"
#	Option     "SampleRate"	"150"
#	Option     "Emulate3Buttons"
#	Option     "Emulate3Timeout" "50"
#	Option     "ChordMiddle"
	Option     "ZAxisMapping" "4 5"
EndSection

Section "InputDevice" 
	Identifier    "Pad1" 
	Driver        "synaptics" 
	Option           "Protocol" "auto-dev" 
	Option           "Device" "/dev/tp1" 
	Option        "LeftEdge"      "1700" 
	Option        "RightEdge"     "5300" 
	Option        "TopEdge"       "1700" 
	Option        "BottomEdge"    "4200" 
	Option        "FingerLow"     "25" 
	Option        "FingerHigh"    "30" 
	Option        "MaxTapTime"    "180" 
	Option        "MaxTapMove"    "220" 
	Option        "VertScrollDelta" "100" 
	Option        "MinSpeed"      "0.09" 
	Option        "MaxSpeed"      "0.18" 
	Option        "AccelFactor"   "0.0015" 
	Option        "SHMConfig"     "on" 
EndSection 


# **********************************************************************
# Monitor section
# **********************************************************************

Section "Monitor"
	Identifier     "Monitor1"
     VendorName "SEC"
     ModelName "4545"

	Modeline "1280x800_60.004" 68.940000 1280 1296 1344 1408 800 801 804 816 -HSync -VSync	
	
     HorizSync 31.5 - 50.0
     VertRefresh 40-90
	     Option "UseEdidFreqs" "1"

	Option "ReducedBlanking"
	
EndSection


# **********************************************************************
# Graphic devices section
# **********************************************************************

# Any number of graphic devices sections may be present

Section "Device"
	Identifier     "Videocard1"
	VendorName  "Intel Corporation"
	BoardName   "Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
	Driver     "intel"
	BusID       "PCI:0:2:0"
	Option "RenderAccel" "true"
	Option "XaaNoOffscreenPixmaps" "on"
EndSection

# **********************************************************************
# Screen section
# **********************************************************************

Section "Screen"
    Identifier  "Videoconfig"
    Device      "Videocard1"
    Monitor     "Monitor1"

   DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes "1280x800_60.004" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes "1280x800_60.004" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes "1280x800_60.004" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes "1280x800_60.004" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

# **********************************************************************
# ServerLayout section
# **********************************************************************

Section "ServerLayout"
	Identifier		"Simple Layout"
	Screen			"Videoconfig"
	InputDevice		"Mouse1" "CorePointer"
	InputDevice		"Pad1" "SendCoreEvents"
	InputDevice		"Keyboard1" "CoreKeyboard"
EndSection

Essaye de faire des modifs dans un premier temps avec ça, en n' oubliant pas de redémarrer ton serveur X à chaque fois (et de faire une sauvegarde quelque part au cas ou) .

  Je suis incapable de te dire pourquoi cette rubrique n' apparait pas sous Ubuntu ou Debian.

  Bon courage, tiens nous au courant...


Essaye désespérément d' installer une distribution Linux sur son Compaq CQ58
www.forum-plugcomputer.net

Hors ligne

#9 Le 14/05/2009, à 17:05

G&L WeB

Re : [Résolu] Impossible de régler la sensibilité de la souris

Bonjour à tous.

J'avais exactement le même problème sous debian lenny et squeeze sur mes autres ordinateurs avec la arc mouse. Et j'ai trouvé comment le régler (temporairement du moins) : il suffit d'attendre que le serveur x aie démarrer pour brancher le récepteur, et là, la souris est tout a fait réglable sans le moindre soucis. Je ne sais pas d'ou viens ce problème, mais je ne suis pas sur que ce bon et loyal serveur x y soit pour quelque chose, mais plutôt la reconnaissance de la souris au boot.

Enfin voilà, celà te permettera d'utiliser ta souris normalement, même si, je l'avoue, il est assez lourd de débrancher / rebrancher le récepteur à chaque fois.

+

#10 Le 14/05/2009, à 17:08

G&L WeB

Re : [Résolu] Impossible de régler la sensibilité de la souris

Ah et pour info, cette méthode fonctionne sous Ubuntu 9.4 (d'où je poste le message)

+

big_smile

#11 Le 14/05/2009, à 18:40

neeteex

Re : [Résolu] Impossible de régler la sensibilité de la souris

De mon côté, toutes les manip sur Xorg se soldent par un plantage vidéo au redémarrage du serveur X.

Pour ce qui est de brancher la souris après démarrage, pas d'effet.

Hors ligne

#12 Le 16/05/2009, à 06:57

neeteex

Re : [Résolu] Impossible de régler la sensibilité de la souris

J'ai trouvé une solution plutôt inatendue : depuis que j'ai réglé la sensibilité de ma souris sur le jeu "openarena", je peux à nouveau régler acceleration et sensibilité normalement ! donc pour moi c'est résolu. Si vous voulez essayer, installez http://doc.ubuntu-fr.org/openarena

Une fois installé, lancez le jeu->openarena. Ensuite, pour afficher la console,  vous devez faire ALT-GR + 2  (touche "~"). Il ne reste plus qu'à entrer la commande

/sensitivity 5

, à nouveau  ALT-GR + 2  pour quitter la console, une petite partie pour la route, et votre souris sera comme neuve (oui, enfin si ça marche aussi bien que pour moi hein  wink )

Hors ligne

#13 Le 16/05/2009, à 11:12

Ungars

Re : [Résolu] Impossible de régler la sensibilité de la souris

Est ce que ton xorg.conf s' en est trouvé modifié ?


Essaye désespérément d' installer une distribution Linux sur son Compaq CQ58
www.forum-plugcomputer.net

Hors ligne

#14 Le 16/05/2009, à 12:32

neeteex

Re : [Résolu] Impossible de régler la sensibilité de la souris

Très bonne question et je viens de vérifier: rien n'a bougé dans /etc/X11/xorg.conf

Moi pas comprendre hmm

Hors ligne

#15 Le 16/05/2009, à 13:33

Ungars

Re : [Résolu] Impossible de régler la sensibilité de la souris

Oui, c' est bizarre, sur certaines distributions il y a plus de rubriques dans l' xorg.conf, sur Debian et Ubuntu. Peut etre que quelqu' un a une réponse, ça m' intéresse...


Essaye désespérément d' installer une distribution Linux sur son Compaq CQ58
www.forum-plugcomputer.net

Hors ligne

#16 Le 17/05/2009, à 21:42

benux_50

Re : [Résolu] Impossible de régler la sensibilité de la souris

Bonsoir à tous,

Ungars, j'ai tenté de modifier xorg.conf comme tu l'as conseillé. Comme Neeteex, la modification provoque un plantage vidéo au redémarrage du serveur X (changement de résolution,...) et ne corrige pas le problème de souris.

G&L WeB, j'ai testé ta méthode qui consiste à attendre que le serveur X ait démarré pour brancher ma souris, sans succès.

Neeteex, je n'ai pas encore essayé la méthode "OpenArena". Elle est inhabituelle, mais prometteuse !

J'ai fait quelques recherches sur xorg.conf. Il semblerait que depuis Ubuntu 8.04, le fichier xorg.conf se réduise comme peau de chagrin, pour se réduire au strict minimum dans Ubuntu 9.04. L'explication vient du fait que les développeurs ont choisi une autre méthode pour configurer les périphériques. Une erreur dans xorg.conf pouvant entraîner des catastrophes, nous ne sommes plus trop sensés le modifier. Il semble maintenant exister une reconnaissance automatique des périphériques au démarrage d'Ubuntu (c'est là que la souris serait mal reconnue).
Il est possible de configurer manuellement les périphériques avec HAL (ne me demandez pas ce que ça veut dire). Pour cela, il faut créer un fichier .fdi avec un éditeur de texte dans /etc/hal/fdi/policy. Le répertoire contient déjà un fichier preference.fdi qui peut servir de modèle.
L'avantage du système HAL est qu'une modification ne nécessite pas de redémarre le serveur X. Il suffit de débrancher puis de rebrancher le périphérique.

Il ne reste plus qu'à trouver quoi mettre dans ce fichier fdi. Je continue de chercher et je vous tiens au courant.

P.S. Neeteex, peux-tu regarder si OpenArena a créé un fichier fdi dans /etc/hal/fdi/policy ?

Hors ligne

#17 Le 17/05/2009, à 22:06

neeteex

Re : [Résolu] Impossible de régler la sensibilité de la souris

benux_50 a écrit :

P.S. Neeteex, peux-tu regarder si OpenArena a créé un fichier fdi dans /etc/hal/fdi/policy ?

J'ai bien ce fichier mais sa date de modif est antérieure à... l'existence de cette machine !

Je te le mets quand même au cas où ça puisse t'aider :

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<!-- 
  Some examples how to use hal fdi files for system preferences 
  You can either uncomment the examples here or put them in a seperate .fdi
  file.
-->
<deviceinfo version="0.2">
<!-- 
  The following shows how to hint gnome-volume-manager and other programs 
  that honor the storage.automount_enabled_hint to not mount non-removable
  media.
-->

  <device>
    <match key="storage.hotpluggable" bool="false">
      <match key="storage.removable" bool="false">
        <merge key="storage.automount_enabled_hint" type="bool">false</merge>
      </match>
    </match>
  </device>


</deviceinfo>

Hors ligne

#18 Le 17/05/2009, à 22:42

benux_50

Re : [Résolu] Impossible de régler la sensibilité de la souris

OK. Il s'agit du contenu du fichier preference.fdi. J'ai le même fichier que toi.
Il nous reste maintenant à créer un fichier mouse.fdi du même type.

HAL signifie "Hardware Abstraction Layer". C'est tout ce que j'ai trouvé pour l'instant !

Hors ligne

#19 Le 18/05/2009, à 21:20

benux_50

Re : [Résolu] Impossible de régler la sensibilité de la souris

J'ai trouvé une solution permettant de ralentir la souris avec le système HAL.

Dans /etc/hal/fdi/policy, créez un fichier mouse.fdi avec l'éditeur de texte.
Recopiez le contenu ci-dessous :

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
        <match key="info.capabilities" contains="input.mouse">
        <merge key="input.x11_driver" type="string">evdev</merge>
        <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
             <merge key="input.x11_driver" type="string">mouse</merge>
               <merge key="input.x11_options.Sensitivity" type="string">.2</merge>
               <merge key="input.x11_options.Device" type="string">/dev/input/mice</merge>
               <merge key="input.x11_options.Resolution" type="string">1200</merge>
               <merge key="input.x11_options.SampleRate" type="string">800</merge>
               <merge key="input.x11_options.Protocol" type="string">IMPS/2</merge>
        </match>
    </match>

  </device>
</deviceinfo>

Enregistrez le fichier. Débranchez votre souris puis rebranchez-la.

Chez moi ça fonctionne : ma souris est devenue très lente. Il suffit de régler l'accélération dans Système > Préférences > Souris.
Dites-moi si ça marche chez vous et si le résultat vous convient. Si la souris est trop lente, vous pouvez modifier le fichier mouse.fdi en corrigeant la 7e ligne (contenant le mot Sensitivity) : remplacez .2 par une valeur plus élevée (.3 ou .4 par exmple). Je n'ai pas testé les autres paramètres (Resolution, SampleRate,...).

Hors ligne

#20 Le 03/12/2009, à 21:53

lolo92

Re : [Résolu] Impossible de régler la sensibilité de la souris

Cette manip. fonctionne aussi chez moi.
Depuis que je suis passé de 8.10 à 9.10 ma souris était trop rapide.
MAIS, depuis cette manip. je ne peux plus utiliser les boutons "up" et "down" de ma souris Logitech nano correspondants à "page suivante" et "page précédente" dans firefox.
Si quelqu'un sait où se trouve se paramètre à régler, je suis preneur.

Merci bien.

Dernière modification par lolo92 (Le 03/12/2009, à 22:48)


Toulousaing'
Sony VGN-NS12M 2Ghz RAM:3Go HD:250Go ATI HD3450
Dual-boot: VISTA + 10.04 + Virtualbox (Win7)

Hors ligne

#21 Le 11/03/2010, à 11:19

CutDaMuzik

Re : [Résolu] Impossible de régler la sensibilité de la souris

Salut,

Merci Benux_50 pour l'astuce : ça a marché pour la Razer Diamondback 3G que je viens d'acheter. J'ai essayé par d'autres moyens avant de tomber sur cette méthode notamment  le xset qui permet de réduire considérablement la sensibilité, mais pas suffisamment...

Malheureusement j'ai le même souci que lolo92, les boutons "page suivante" et "page précédente" ne fonctionnent plus. J'ai essayé de reconfigurer la souris avec l'utilitaire "btnx", sans succès...

Quelqu'un a t il réussi à contourner ce problème ?

Hors ligne

#22 Le 13/03/2010, à 13:32

CutDaMuzik

Re : [Résolu] Impossible de régler la sensibilité de la souris

Salut à tous,

lolo92, j'ai trouvé la solution à notre problème :

il faut modifier le fichier mouse.fdi : le paramètre "Protocol" doit être "ExplorerPS/2" au lieu de "IMPS/2" :
Il faut donc remplacer :

<merge key="input.x11_options.Protocol" type="string">IMPS/2</merge>

par :

<merge key="input.x11_options.Protocol" type="string">ExplorerPS/2</merge>

Une fois ceci changé il suffit de débrancher et rebrancher la souris : ça fonctionne !

Hors ligne

#23 Le 02/05/2010, à 17:38

benux_50

Re : [Résolu] Impossible de régler la sensibilité de la souris

Bonjour à tous,

Je viens d'installer Ubuntu 10.04 Ludic Lynx. Parmi les nouveautés de la distribution, HAL n'est plus utilisé. Le fichier mouse.fdi n'a donc plus aucun intérêt... sad

Je vous soumets une solution alternative, ne faisant pas appel à HAL, permettant de modifier manuellement la vitesse de la souris :

- ouvrez un terminal (Applications > Accessoires > Terminal)
- étape 1, tapez :

xinput list

La liste de vos périphérique apparaît. Dans cette liste, cherchez la ligne correspondant à votre souris. Dans mon cas, avec la souris Arc Mouse de Microsoft, il s'agit de la ligne "Microsoft Microsoft® 2.4GHz Transceiver v5.0" (si vous avez un doute, débranchez votre souris, retapez "xinput list" et cherchez la ligne qui a disparu de la liste).

- étape 2, tapez :

xinput list-props '[nom de votre souris]'

Vous remplacerez [nom de votre souris] par le nom trouvé à l'étape précédente. Si le nom de votre souris est trop long à taper, utilisez la souris pour faire un copier-coller : sélectionnez le nom de votre souris, puis cliquez avec la molette.
Cette commande fait apparaitre la liste des options qui s'appliquent à votre souris. Recherchez une option évoquant la vitesse de la souris. Dans mon cas, l'option à modifier est "Device Accel Constant Deceleration" et la valeur par défaut est 1.

- étape 3, tapez :

xinput set-prop '[nom de votre souris]' '[nom de l'option]' [valeur]

Vous remplacerez [nom de l'option] par le nom trouvé à l'étape précédente et [valeur] par un nombre.
Cette commande attribue une nouvelle valeur à la vitesse de la souris (ou plus précisément à la décélération de la souris, dans mon cas). Pour reprendre mon exemple, j'ai tapé :

xinput set-prop 'Microsoft Microsoft® 2.4GHz Transceiver v5.0' 'Device Accel Constant Deceleration' 1.7

La souris retrouve une vitesse normale. smile

- étape 4, automatiser cette commande à chaque démarrage du système.
Il existe un fichier caché dans votre dossier personnel qui s'appelle ".profile"
Utilisez le raccourci clavier "CTRL + H" pour faire apparaître les fichiers cachés (leur nom commence par .)
Double-cliquez sur ".profile" pour l'ouvrir. Recopiez la commande à la fin du fichier. Enregistrez le fichier. Le tour est joué ! big_smile

P.S. pour appliquer la commande à tous les utilisateurs, éditez le fichier /etc/profile (ce n'est pas un fichier caché).

Dernière modification par benux_50 (Le 02/05/2010, à 17:42)

Hors ligne

#24 Le 02/05/2010, à 20:23

Ungars

Re : [Résolu] Impossible de régler la sensibilité de la souris

Merci !


Essaye désespérément d' installer une distribution Linux sur son Compaq CQ58
www.forum-plugcomputer.net

Hors ligne

#25 Le 09/08/2010, à 14:25

mike57140

Re : [Résolu] Impossible de régler la sensibilité de la souris

Super Benux_50, tu m'as beaucoup aider. Merci.

Hors ligne

Haut de page ↑