Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/05/2009, à 13:33

achtungbaby

Freebox UPnP et pseudo nouveau service

Bonjour,

je suppose que vous avez entendu parler de l'armageddon du jour chez Free (enfin un pet foireux à mon sens). L'UPnP sur la Freebox.

Celui-ci permet de se passer du Freeplayer, en principe. Toutefois, il faut installer un logiciel UPnP sur le PC. Sous linux ça se gâte, j'en ai trouvé 2, et testé sans succès.

ushare

Après avoir installé et configuré ushare, j'accède au dossier configuré, sauf qu'il ne voit pas les sous dossier. Donc ça sert à rien. Les photos présentes sur la racine du dossier mettent une plombe à charger. Pas convaincu du tout.

xbmc
Installé, configuré. Je le vois bien depuis ma freebox HD... Pourtant je ne trouve rien. J'ai tenté de configurer des dossiers dans musique, rien, nada.

Soit je deviens vieux, soit c'est pas au point.

Si quelqu'un a réussi à faire fonctionner cette pseudo nouvelle fonctionnalité de la Freebox...

En tout cas, avec Freeplayer ça marche. hmm

Dernière modification par achtungbaby (Le 14/05/2009, à 13:34)

Hors ligne

#2 Le 14/05/2009, à 13:45

slasher_fun

Re : Freebox UPnP et pseudo nouveau service

Bonjour,

Pas encore eu le temps d'essayer, mais on me souffle mediatomb

Retours bienvenus smile

Hors ligne

#3 Le 14/05/2009, à 14:16

achtungbaby

Re : Freebox UPnP et pseudo nouveau service

Merci,

je vais tester celui la et je reviens.

Hors ligne

#4 Le 14/05/2009, à 14:39

achtungbaby

Re : Freebox UPnP et pseudo nouveau service

Installé,

alors ça a le mérite d'être ultra simple à utiliser. Mediatomb fonctionne sur le pc et on peut ajouter les sources qu'on veut.

Pour les vidéos, c'est ok, ça marche (ouf, au moins un truc qui marche).

Bémol : la Freebox HD ne reconnait pas les fichiers musicaux mp3 donc elles les voient pas. Les photos, il crée un dossier avec toutes les photos, ça vautre la freebox HD.

Via les dossiers, ça passe à un détail près : les photos sont ultra pixélisées yikes

Hors ligne

#5 Le 14/05/2009, à 15:03

Smip

Re : Freebox UPnP et pseudo nouveau service

Ah ben tu vois, ça marche smile ... donc c'est bien que tu deviens vieux big_smile

Hors ligne

#6 Le 14/05/2009, à 15:13

meiko

Re : Freebox UPnP et pseudo nouveau service

fonctionne pour moi aussi, par contre les vidéos .mkv ne passe pas encore


Frih Deh Bi De Uh !!!!!!!!!!!

Hors ligne

#7 Le 14/05/2009, à 15:18

Ed_from_Reims

Re : Freebox UPnP et pseudo nouveau service

achtungbaby a écrit :

Installé,
Pour les vidéos, c'est ok, ça marche (ouf, au moins un truc qui marche).

Tiens, chez moi avec mediatomb, les répertoires sont bien affichés, mais dès que je lance une vidéo, écran noir ...
As tu modifié quelque chose à ton fichier config.xml ? Comment sont mappés tes fichiers avi (si c'est bien sur un avi que tu as fais tes tests) ?

Merci du retour, ça doit faire 2h que je suis dessus ... sans succès

#8 Le 14/05/2009, à 15:36

maitryoda

Re : Freebox UPnP et pseudo nouveau service

bonjour,
Mediatomb est configuré pour ma PS3 et tourne nikel.
La freebox voit Mediatomb, mes dossiers partagés, mes photos mais ni videos ni mp3


Que la force soit avec toi jeune padawan!
Config: Core 2 Duo E6600 - P5WDH Deluxe
2Go Ram - MSI  X1950 256Mo PCIe
Ubuntu 12.10

Hors ligne

#9 Le 14/05/2009, à 15:52

legwoju

Re : Freebox UPnP et pseudo nouveau service

Bonjour à vous.
Je suis également en train de tester cette nouvelle fonctionnalité de la freebox.
Par contre, j'ai le message "Aucun périphérique détecté" (Périphériques réseau).

Je passe pas par le mode routeur de la freebox mais par un routeur netgear.
Problème de port à ouvrir peut etre ?
Si quelqu'un a une réponse, je suis preneur, et si j'ai du mieux, je viendrais poster.

Merci d'avance !!! big_smile

#10 Le 14/05/2009, à 16:04

maitryoda

Re : Freebox UPnP et pseudo nouveau service

Je pense qu'il y a effectivement un port à configurer.
    *
      49152 en udp et tcp
    *
      1900 en udp

voici la doc:
http://doc.ubuntu-fr.org/mediatomb

par contre je n'arrive pas à lire de fichiers autre que photo


Que la force soit avec toi jeune padawan!
Config: Core 2 Duo E6600 - P5WDH Deluxe
2Go Ram - MSI  X1950 256Mo PCIe
Ubuntu 12.10

Hors ligne

#11 Le 14/05/2009, à 16:13

legwoju

Re : Freebox UPnP et pseudo nouveau service

Re
J'ai autorisé les ports sur le pare-feu mais je ne les ai pas ouvert sur le routeur (accès de l'exterieur).

Bien entendu, reboot box + boitier HD, vérification que l'upnp est activé sur mon routeur.
Test de mediatomb et ushare nok.
Verif des fichiers config (vi + dpkg-reconfigure) et restart sans effet !
je sèche un peu.

sad pfff

Je continue !

#12 Le 14/05/2009, à 16:23

Ed_from_Reims

Re : Freebox UPnP et pseudo nouveau service

Ed_from_Reims a écrit :
achtungbaby a écrit :

Installé,
Pour les vidéos, c'est ok, ça marche (ouf, au moins un truc qui marche).

Tiens, chez moi avec mediatomb, les répertoires sont bien affichés, mais dès que je lance une vidéo, écran noir ...
As tu modifié quelque chose à ton fichier config.xml ? Comment sont mappés tes fichiers avi (si c'est bien sur un avi que tu as fais tes tests) ?

Merci du retour, ça doit faire 2h que je suis dessus ... sans succès

Bon, finalement, ça marche, ou plutôt ça marchotte. J'ai 2 fichiers divx encodés en xvid qui fonctionnent et pas à chaque lancement. Pour le reste des vidéos, un bel écran noir.

#13 Le 14/05/2009, à 16:33

maitryoda

Re : Freebox UPnP et pseudo nouveau service

Re
J'ai autorisé les ports sur le pare-feu mais je ne les ai pas ouvert sur le routeur (accès de l'exterieur).

Bien entendu, reboot box + boitier HD, vérification que l'upnp est activé sur mon routeur.
Test de mediatomb et ushare nok.
Verif des fichiers config (vi + dpkg-reconfigure) et restart sans effet !
je sèche un peu.

sad pfff

Il faut forwarder les port sur ton routeur netgear également sinon cela ne marchera pas. Au pire active le mode routeur de la freebox, et recopie les port ouverts sur ton netgear pour les mettre sur la freebox (hors ports mediatomb)

Dernière modification par maitryoda (Le 14/05/2009, à 16:36)


Que la force soit avec toi jeune padawan!
Config: Core 2 Duo E6600 - P5WDH Deluxe
2Go Ram - MSI  X1950 256Mo PCIe
Ubuntu 12.10

Hors ligne

#14 Le 14/05/2009, à 16:37

maitryoda

Re : Freebox UPnP et pseudo nouveau service

Ed_from_Reims a écrit :
Ed_from_Reims a écrit :
achtungbaby a écrit :

Installé,
Pour les vidéos, c'est ok, ça marche (ouf, au moins un truc qui marche).

Tiens, chez moi avec mediatomb, les répertoires sont bien affichés, mais dès que je lance une vidéo, écran noir ...
As tu modifié quelque chose à ton fichier config.xml ? Comment sont mappés tes fichiers avi (si c'est bien sur un avi que tu as fais tes tests) ?

Merci du retour, ça doit faire 2h que je suis dessus ... sans succès

Bon, finalement, ça marche, ou plutôt ça marchotte. J'ai 2 fichiers divx encodés en xvid qui fonctionnent et pas à chaque lancement. Pour le reste des vidéos, un bel écran noir.

Re, comment avez-vous fait? Y a-t-il des modif à faire dans le config.xml?

Merci d'avance,


Que la force soit avec toi jeune padawan!
Config: Core 2 Duo E6600 - P5WDH Deluxe
2Go Ram - MSI  X1950 256Mo PCIe
Ubuntu 12.10

Hors ligne

#15 Le 14/05/2009, à 16:55

Ed_from_Reims

Re : Freebox UPnP et pseudo nouveau service

maitryoda a écrit :

Re, comment avez-vous fait? Y a-t-il des modif à faire dans le config.xml?

Merci d'avance,

Je suis bien embêté pour répondre.
Je suis revenu au fichier config.xml du package d'origine.
Mais le comportement est étrange.
Cela marche avec une vidéo, mais si je l'arrête et relance, cela ne passe plus.
Et toutes les vidéos ne démarrent pas du premier coup.
Bref, je ne sais pas si c'est parce que je suis en wifi (70% de réception) ou si quelque chose d'autre pose problème, mais c'est pas utilisable chez moi en l'état.

#16 Le 14/05/2009, à 16:59

legwoju

Re : Freebox UPnP et pseudo nouveau service

Merci maitryoda
Je préférerais éviter de configurer le routeur de la box (serveur web, ftp, mail, samba)...
Je pourrais effectivement l'utiliser en mode routeur mais je n'ai pas la même facilité d'administration.
A moins qu'il y ait une IHM free que je ne connaisse pas et qui me permette d'intervenir à distance sans reboot de cette dernière.

Je ne vois pas pourquoi forwarder les ports sur le routeur vu que les flux sont interne à mon LAN?!
J'ai fait un nmap et vérifier mon iptables... RAS !

le boitier HD est il sur la même plage ? en changeant le masque, aurais je plus de chance ?

Si j'ai rien, je tenterais quand même de basculer sur le mode routeur de la free...
A voir
Merci merci

#17 Le 14/05/2009, à 17:07

maitryoda

Re : Freebox UPnP et pseudo nouveau service

legwoju a écrit :

Je ne vois pas pourquoi forwarder les ports sur le routeur vu que les flux sont interne à mon LAN?!
J'ai fait un nmap et vérifier mon iptables... RAS !

Désolé effectivement tu as raison, j'ai buggé ;-)
Je ne vois pas franchement d'où peut venir le problème, cela dépasse mes faibles compétences.
Désolé, bon courage pour résoudre ton problème


Que la force soit avec toi jeune padawan!
Config: Core 2 Duo E6600 - P5WDH Deluxe
2Go Ram - MSI  X1950 256Mo PCIe
Ubuntu 12.10

Hors ligne

#18 Le 14/05/2009, à 17:10

maitryoda

Re : Freebox UPnP et pseudo nouveau service

Ed_from_Reims a écrit :
maitryoda a écrit :

Re, comment avez-vous fait? Y a-t-il des modif à faire dans le config.xml?

Merci d'avance,

Je suis bien embêté pour répondre.
Je suis revenu au fichier config.xml du package d'origine.
Mais le comportement est étrange.
Cela marche avec une vidéo, mais si je l'arrête et relance, cela ne passe plus.
Et toutes les vidéos ne démarrent pas du premier coup.
Bref, je ne sais pas si c'est parce que je suis en wifi (70% de réception) ou si quelque chose d'autre pose problème, mais c'est pas utilisable chez moi en l'état.

Je pense que je vais rester sur ma config actuelle, mediatomb+PS3 mais peut être plus tard...quand le service sera au point (pour les video je ne sais pas mais pour les photos, cela ressemble à rien

Merci quand même


Que la force soit avec toi jeune padawan!
Config: Core 2 Duo E6600 - P5WDH Deluxe
2Go Ram - MSI  X1950 256Mo PCIe
Ubuntu 12.10

Hors ligne

#19 Le 14/05/2009, à 17:11

Smip

Re : Freebox UPnP et pseudo nouveau service

moi j'ai installé mediatomb et ajouter un répertoire de video ça marche direct.
Par contre je ne vois pas le mkv, je vais bricoler mediotomb pour ça smile

Hors ligne

#20 Le 14/05/2009, à 17:49

josian

Re : Freebox UPnP et pseudo nouveau service

J'ai installé la version Media tomb disponible sous Jaunty => OK
Au premier lancement je "vois" PC directory depuis le magneto Freebox HD, mais pas le contenu
j'ai modifié le répertoire Vidéos en Videos ( plus d'accentuation)
Au reboot, au lancement de Media Tomb, il me demande un pwd pour se loguer et ne reconnait pas le pwd utilisé au lancement Ubuntu , donc ne peut se loguer, etc ..
C'est tout pour le moment sad


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#21 Le 14/05/2009, à 18:10

Ed_from_Reims

Re : Freebox UPnP et pseudo nouveau service

josian a écrit :

J'ai installé la version Media tomb disponible sous Jaunty => OK
Au premier lancement je "vois" PC directory depuis le magneto Freebox HD, mais pas le contenu
j'ai modifié le répertoire Vidéos en Videos ( plus d'accentuation)
Au reboot, au lancement de Media Tomb, il me demande un pwd pour se loguer et ne reconnait pas le pwd utilisé au lancement Ubuntu , donc ne peut se loguer, etc ..
C'est tout pour le moment sad

le passwd, normalement tu l'as dans ton config.xml
<account user="mediatomb" password="mediatomb"/>
c'est pas ça ?

#22 Le 14/05/2009, à 18:22

airvb

Re : Freebox UPnP et pseudo nouveau service

bsr,
J'ai installé mediatomb sur un serveur sous jaunty .
un classique sudo pat-get install mediatomb

j'ai lancé mediatomb -h  ( headless)

c'est apparu ds la FB HD,
Ensuite j'ai pas bien compris comment on faisait pour ajouter spécifiquement les dossiers que l'on souhaite visionner...
Après tatonnement certains divx , xvid, passent ... avec la même facilité que si ils étaient sur le hd de la FB HD.
Les photos, certaines passent sans être pixellisées,  d'autres non, j'ai pas réussi à comprendre pourquoi
Les mp3 n'apparaissent pas ds les différentes arborescences .

les mp4 sont lus.
J'ai pas eu besoin d'activer le upnp ds la console de gestion , par cotnre je suis en mode routeur.
J'ai pas eu non plus besoin de forwarder des ports pour que cela fonctionne.

Bref entre la découverte de mediatomb et du newservice  free... ça patauge encore pas mal

Hors ligne

#23 Le 14/05/2009, à 18:29

legwoju

Re : Freebox UPnP et pseudo nouveau service

De retour de mes péripéties...
Bascule de la free en mode routeur, ushare et mediatomb fonctionne du premier coup !

Qualité ok mais réseau filaire, pas de wifi !

On verra plus tard en passant via mon routeur netgear.
Merci et bonne soirée

#24 Le 14/05/2009, à 19:04

abelthorne

Re : Freebox UPnP et pseudo nouveau service

Hop, je m'incruste ici pour mes problèmes avec cette fonction uPnP.

Je n'ai jamais compris comment configurer MediaTomb alors j'ai essayé gmediaserver (bof : partage reconnu aléatoirement, problèmes d'accès...) et uShare. Même problème de dossiers que vous avec ce dernier : il faut les ajouter manuellement.

En-dehors de ça, j'ai des problèmes avec les sous-titres (fichiers SRT) : les vidéos sont lues mais pas les s-t. Est-ce qu'avec MediaTomb ou XBMC vous avez le même problème ?

En ligne

#25 Le 14/05/2009, à 19:16

maitryoda

Re : Freebox UPnP et pseudo nouveau service

mediatomb marche super bien avec ma ps3, mais sur la freebox, je vois les dossiers, mais pas leur contenu (hors photos dont le rendu est vraiment crade cela dit en passant)


Que la force soit avec toi jeune padawan!
Config: Core 2 Duo E6600 - P5WDH Deluxe
2Go Ram - MSI  X1950 256Mo PCIe
Ubuntu 12.10

Hors ligne