Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 14/05/2009, à 21:17

abelthorne

Re : Freebox UPnP et pseudo nouveau service

Je viens d'installer XBMC pour voir et je n'arrive pas à le faire reconnaître par la Freebox. Je suis allé dans les paramètres, j'ai activé le serveur uPnP, ajouté des partages...

Il y a une manip particulière à faire ?

Hors ligne

#27 Le 14/05/2009, à 21:48

Mohegan

Re : Freebox UPnP et pseudo nouveau service

Pareil pour moi. Le serveur upnp de xbmc ne fonctionne pas avec Jaunty.

J'ai testé :
- mediatomb : fonctionne mais toutes les vidéos apparaissent dans le même dossier (ou sinon il faut développer l'arborescence). Ce n'est pas très pratique.
- ushare : fonctionne bien pour les vidéos. Par contre, je n'arrive pas à ajouter plus d'un dossier à la fois (les sous-dossiers sont toutefois bien reconnus).

Dans les deux cas, les photos ne fonctionnent pas très bien et les fichiers musicaux ne sont pas lisibles.

Je préfère ushare car il a l'avantage de garder l'arborescence du dossier sélectionné.

Cependant, quelques questions :
- les fichiers mkv fonctionnent-ils et si oui les sous-titres aussi ?
- les fichiers HD (mkv / mp4) saccadent-ils ?
- mon pc étant en wifi, est-il possible de sécuriser mon serveur upnp ?

De plus, les deux logiciels ne sont pas terribles pour ce qui est de la configuration. N'utilisant pas la fonction mediacenter de xbmc, ce logiciel me parait un peu lourd.

Si quelqu'un connait un autre logiciel, je suis preneur.


"Lorsqu’un adulte entre dans le monde des fables, il ne peut plus en sortir." Bouche Dorée

Hors ligne

#28 Le 14/05/2009, à 22:02

abelthorne

Re : Freebox UPnP et pseudo nouveau service

Mohegan a écrit :

- ushare : fonctionne bien pour les vidéos. Par contre, je n'arrive pas à ajouter plus d'un dossier à la fois (les sous-dossiers sont toutefois bien reconnus).

Les sous-dossiers sont reconnus ??? Si je rajoute un dossier, il ne m'affiche que les vidéos qui sont directement dedans et ne va pas chercher plus loin.

- les fichiers mkv fonctionnent-ils et si oui les sous-titres aussi ?

D'après ce que j'ai pu voir sur d'autres sites, les MKV ne fonctionnent pas. Déjà qu'ils ne sont pas vraiment supportés officiellement par la box (et pas avec n'importe quels flux dedans, parce que MKV tout court ne veut pas dire grand chose).

Pour les sous-titres, ils ne fonctionnent pas chez moi avec uShare (en fichiers à part).

- les fichiers HD (mkv / mp4) saccadent-ils ?

D'après un commentaire vu ailleurs, les fichiers HD saccadent si la connexion est en Wifi.

Si quelqu'un connait un autre logiciel, je suis preneur.

Il me semble que Mythbuntu/MythTV intègre un serveur uPnP. C'est aussi un media center mais si je me souviens bien on peut se passer du frontend et utiliser seulement le backend (en l'installant sur une version d'Ubuntu déjà en place, pas besoin d'installer la distribution complète bien sûr).

Dernière modification par abelthorne (Le 14/05/2009, à 22:11)

Hors ligne

#29 Le 14/05/2009, à 22:32

moreje

Re : Freebox UPnP et pseudo nouveau service

bonjour,
je suis sous jaunty.... j'ai installé xbmc.... mais rien à faire, la freebox ne voit rien!
quelqu un a t il réussi à faire marcher xbmc?
merci!


***************************
PC NUC Intel I5 - 12 Go RAM
Ubuntu 19.10 x64
+++++++++++++++++

Hors ligne

#30 Le 14/05/2009, à 22:59

achtungbaby

Re : Freebox UPnP et pseudo nouveau service

Pour xbmc, il faut aller dans l'icone de paramétrage, y'a des trucs à activer au niveau upnp. mais franchement en dehors du bel aspect graphique ça ne fonctionne pas des masses.

Hors ligne

#31 Le 14/05/2009, à 23:09

abelthorne

Re : Freebox UPnP et pseudo nouveau service

Oui, il faut aller dans uPnP et activer le serveur. Mais ça n'a pas l'air de fonctionner pour tout le monde (ma box ne le voit pas).

J'ai trouvé un tutoriel sur UniversFreebox (pour MacOS mais ça ne devrait pas changer grand chose) mais il n'indique rien en particulier.

Hors ligne

#32 Le 14/05/2009, à 23:10

Smip

Re : Freebox UPnP et pseudo nouveau service

J'ai trouvé ça pour les mkv mais je n'ai pas testé... je ne trouve pas le script à modifier...

http://soowei.com/2008/11/27/streaming-mkv-in-mediatomb-to-ps3/

Hors ligne

#33 Le 15/05/2009, à 00:02

josian

Re : Freebox UPnP et pseudo nouveau service

Pour MKV et MP3, ces problèmes semblent évoluert suivant les versions du firmeware  de la FB HD  . On est en 1.5.2 et 1.5.11 .Je vérifie plus tard avec mplayer

Dans l'instant, j'essaye de faire tourner mediatomb : Si je reste dans la session d'installation, je retrouve des vidéos et des photos ( j'ai pas vérifié ce qui est lisible).
MAIS, dès que je reboote ==> plus rien ne marche :
en lançant au terminal, il me signale
2009-05-14 23:48:23   ERROR: SQLITE3: (5) database is locked
Query:UPDATE "mt_autoscan" SET "touched"=0 WHERE "persistent"=1 AND "scan_mode"='timed'
error: database is locked

Si je lance par les 'applications' :
Firefox ...... pas trouvé /var/lib/mediatomb/mediatomb.html

J'ai pas pu vérifier, mais il semble que suivant le mode de création on obtienne des objets différents :
- avec "ajouter applications", le config.xml est dans etc/mediatomb
- avec Synaptic, il est dans ~/.mediatomb


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#34 Le 15/05/2009, à 09:47

abelthorne

Re : Freebox UPnP et pseudo nouveau service

Probablement un problème de droits sur le fichier de config et/ou dans les accès à la base MySQL. Il me semble plus logique que le fichier soit dans /etc (mais je ne l'ai pas encore réinstallé récemment).

Hors ligne

#35 Le 15/05/2009, à 10:08

nafan

Re : Freebox UPnP et pseudo nouveau service

maitryoda a écrit :

Je pense que je vais rester sur ma config actuelle, mediatomb+PS3...

Même chose de mon côté avec Ushare + PS3 : ça fonctionne nickel, alors je ne vais pas batailler avec une Beta-release sur la Freebox qui ne détecte pas le serveur...

Hors ligne

#36 Le 15/05/2009, à 10:08

sgabrielli

Re : Freebox UPnP et pseudo nouveau service

hello

pour moi, avec mise à jour des firmwares hier soir, le UPNP de XBMC fonctionne partiellement :
- je vois mes dossiers partagés mais pas les sous-dossiers
- les seuls fichiers visibles sont les .AVI

Hors ligne

#37 Le 15/05/2009, à 10:24

abelthorne

Re : Freebox UPnP et pseudo nouveau service

sgabrielli a écrit :

pour moi, avec mise à jour des firmwares hier soir, le UPNP de XBMC fonctionne partiellement :
- je vois mes dossiers partagés mais pas les sous-dossiers
- les seuls fichiers visibles sont les .AVI

Tu as configuré quelque chose en particulier pour XBMC : ouverture de ports, etc. ?

Pour les formats reconnus, c'est à priori normal : la Freebox ne gère rien d'autre (partiellement les MKV mais 1) ça dépend de ce qu'il y a comme flux dedans et 2) ça varie avec les firmwares : à un moment il fallait les renommer en AVI pour espérer pouvoir les lire).

Hors ligne

#38 Le 15/05/2009, à 10:32

sgabrielli

Re : Freebox UPnP et pseudo nouveau service

aucune config particuliere sur le routeur. J'ai juste vérifié que l'UPNP etait actif

La freebox gère bien les mp3 puisqu'on peut les lire via le free player.
Si on a pas accès à tous ses fichiers, l'interet est limité..

Hors ligne

#39 Le 15/05/2009, à 10:41

SD

Re : Freebox UPnP et pseudo nouveau service

En ce qui concerne les sous-titres séparées (.srt,...) et d'une manière générale le peu de formats reconnus, le problème vient de XBMC qui n'exporte en UPnP que très peu d'extensions/Mimetypes de fichiers.
C'est en dur dans le code source :

UPnP.cpp :

static const mimetype_extension_struct mimetype_extension_map[] = {
  71     {"mp3",  "audio/mpeg"},
  72     {"m4a",  "audio/mp4"},
  73     {"wma",  "audio/x-ms-wma"},
  74     {"wav",  "audio/x-wav"},
  75     {"wmv",  "video/x-ms-wmv"},
  76     {"asf",  "video/x-ms-asf"},
  77     {"vob",  "video/mpeg"},
  78     {"mpg",  "video/mpeg"},
  79     {"avi",  "video/avi"}, // PS3 needs this {"avi",  "video/x-msvideo"},
  80     {"divx", "video/x-msvideo"},
  81     {"xvid", "video/x-msvideo"},
  82     {"mkv",  "video/x-matroska"},
  83     {"gif",  "image/gif"},
  84     {"jpg",  "image/jpeg"},
  85     {"tbn",  "image/jpeg"},
  86     {"tif",  "image/tiff"},
  87     {NULL, NULL}
  88 };


A titre de comparaison, voici la liste des extensions/Mimetypes UPnP de Ushare :


mime.c :

const struct mime_type_t MIME_Type_List[] = {
  /* Video files */
  { "asf",   UPNP_VIDEO, "http-get:*:video/x-ms-asf:"},
  { "avc",   UPNP_VIDEO, "http-get:*:video/avi:"},
  { "avi",   UPNP_VIDEO, "http-get:*:video/avi:"},
  { "dv",    UPNP_VIDEO, "http-get:*:video/x-dv:"},
  { "divx",  UPNP_VIDEO, "http-get:*:video/avi:"},
  { "wmv",   UPNP_VIDEO, "http-get:*:video/x-ms-wmv:"},
  { "mjpg",  UPNP_VIDEO, "http-get:*:video/x-motion-jpeg:"},
  { "mjpeg", UPNP_VIDEO, "http-get:*:video/x-motion-jpeg:"},
  { "mpeg",  UPNP_VIDEO, "http-get:*:video/mpeg:"},
  { "mpg",   UPNP_VIDEO, "http-get:*:video/mpeg:"},
  { "mpe",   UPNP_VIDEO, "http-get:*:video/mpeg:"},
  { "mp2p",  UPNP_VIDEO, "http-get:*:video/mp2p:"},
  { "vob",   UPNP_VIDEO, "http-get:*:video/mp2p:"},
  { "mp2t",  UPNP_VIDEO, "http-get:*:video/mp2t:"},
  { "m1v",   UPNP_VIDEO, "http-get:*:video/mpeg:"},
  { "m2v",   UPNP_VIDEO, "http-get:*:video/mpeg2:"},
  { "mpg2",  UPNP_VIDEO, "http-get:*:video/mpeg2:"},
  { "mpeg2", UPNP_VIDEO, "http-get:*:video/mpeg2:"},
  { "m4v",   UPNP_VIDEO, "http-get:*:video/mp4:"},
  { "m4p",   UPNP_VIDEO, "http-get:*:video/mp4:"},
  { "mp4ps", UPNP_VIDEO, "http-get:*:video/x-nerodigital-ps:"},
  { "ts",    UPNP_VIDEO, "http-get:*:video/mpeg2:"},
  { "ogm",   UPNP_VIDEO, "http-get:*:video/mpeg:"},
  { "mkv",   UPNP_VIDEO, "http-get:*:video/mpeg:"},
  { "rmvb",  UPNP_VIDEO, "http-get:*:video/mpeg:"},
  { "mov",   UPNP_VIDEO, "http-get:*:video/quicktime:"},
  { "hdmov", UPNP_VIDEO, "http-get:*:video/quicktime:"},
  { "qt",    UPNP_VIDEO, "http-get:*:video/quicktime:"},
  { "bin",   UPNP_VIDEO, "http-get:*:video/mpeg2:"},
  { "iso",   UPNP_VIDEO, "http-get:*:video/mpeg2:"},

  /* Audio files */
  { "3gp",  UPNP_AUDIO, "http-get:*:audio/3gpp:"},
  { "aac",  UPNP_AUDIO, "http-get:*:audio/x-aac:"},
  { "ac3",  UPNP_AUDIO, "http-get:*:audio/x-ac3:"},
  { "aif",  UPNP_AUDIO, "http-get:*:audio/aiff:"},
  { "aiff", UPNP_AUDIO, "http-get:*:audio/aiff:"},
  { "at3p", UPNP_AUDIO, "http-get:*:audio/x-atrac3:"},
  { "au",   UPNP_AUDIO, "http-get:*:audio/basic:"},
  { "snd",  UPNP_AUDIO, "http-get:*:audio/basic:"},
  { "dts",  UPNP_AUDIO, "http-get:*:audio/x-dts:"},
  { "rmi",  UPNP_AUDIO, "http-get:*:audio/midi:"},
  { "mid",  UPNP_AUDIO, "http-get:*:audio/midi:"},
  { "mp1",  UPNP_AUDIO, "http-get:*:audio/mp1:"},
  { "mp2",  UPNP_AUDIO, "http-get:*:audio/mp2:"},
  { "mp3",  UPNP_AUDIO, "http-get:*:audio/mpeg:"},
  { "mp4",  UPNP_AUDIO, "http-get:*:audio/mp4:"},
  { "m4a",  UPNP_AUDIO, "http-get:*:audio/mp4:"},
  { "ogg",  UPNP_AUDIO, "http-get:*:audio/x-ogg:"},
  { "wav",  UPNP_AUDIO, "http-get:*:audio/wav:"},
  { "pcm",  UPNP_AUDIO, "http-get:*:audio/l16:"},
  { "lpcm", UPNP_AUDIO, "http-get:*:audio/l16:"},
  { "l16",  UPNP_AUDIO, "http-get:*:audio/l16:"},
  { "wma",  UPNP_AUDIO, "http-get:*:audio/x-ms-wma:"},
  { "mka",  UPNP_AUDIO, "http-get:*:audio/mpeg:"},
  { "ra",   UPNP_AUDIO, "http-get:*:audio/x-pn-realaudio:"},
  { "rm",   UPNP_AUDIO, "http-get:*:audio/x-pn-realaudio:"},
  { "ram",  UPNP_AUDIO, "http-get:*:audio/x-pn-realaudio:"},
  { "flac", UPNP_AUDIO, "http-get:*:audio/x-flac:"},

  /* Images files */
  { "bmp",  UPNP_PHOTO, "http-get:*:image/bmp:"},
  { "ico",  UPNP_PHOTO, "http-get:*:image/x-icon:"},
  { "gif",  UPNP_PHOTO, "http-get:*:image/gif:"},
  { "jpeg", UPNP_PHOTO, "http-get:*:image/jpeg:"},
  { "jpg",  UPNP_PHOTO, "http-get:*:image/jpeg:"},
  { "jpe",  UPNP_PHOTO, "http-get:*:image/jpeg:"},
  { "pcd",  UPNP_PHOTO, "http-get:*:image/x-ms-bmp:"},
  { "png",  UPNP_PHOTO, "http-get:*:image/png:"},
  { "pnm",  UPNP_PHOTO, "http-get:*:image/x-portable-anymap:"},
  { "ppm",  UPNP_PHOTO, "http-get:*:image/x-portable-pixmap:"},
  { "qti",  UPNP_PHOTO, "http-get:*:image/x-quicktime:"},
  { "qtf",  UPNP_PHOTO, "http-get:*:image/x-quicktime:"},
  { "qtif", UPNP_PHOTO, "http-get:*:image/x-quicktime:"},
  { "tif",  UPNP_PHOTO, "http-get:*:image/tiff:"},
  { "tiff", UPNP_PHOTO, "http-get:*:image/tiff:"},

  /* Playlist files */
  { "pls", UPNP_PLAYLIST, "http-get:*:audio/x-scpls:"},
  { "m3u", UPNP_PLAYLIST, "http-get:*:audio/mpegurl:"},
  { "asx", UPNP_PLAYLIST, "http-get:*:video/x-ms-asf:"},

  /* Subtitle Text files */
  { "srt", UPNP_TEXT, "http-get:*:text/srt:"}, /* SubRip */
  { "ssa", UPNP_TEXT, "http-get:*:text/ssa:"}, /* SubStation Alpha */
  { "stl", UPNP_TEXT, "http-get:*:text/srt:"}, /* Spruce */
  { "psb", UPNP_TEXT, "http-get:*:text/psb:"}, /* PowerDivX */
  { "pjs", UPNP_TEXT, "http-get:*:text/pjs:"}, /* Phoenix Japanim */
  { "sub", UPNP_TEXT, "http-get:*:text/sub:"}, /* MicroDVD */
  { "idx", UPNP_TEXT, "http-get:*:text/idx:"}, /* VOBsub */
  { "dks", UPNP_TEXT, "http-get:*:text/dks:"}, /* DKS */
  { "scr", UPNP_TEXT, "http-get:*:text/scr:"}, /* MACsub */
  { "tts", UPNP_TEXT, "http-get:*:text/tts:"}, /* TurboTitler */
  { "vsf", UPNP_TEXT, "http-get:*:text/vsf:"}, /* ViPlay */
  { "zeg", UPNP_TEXT, "http-get:*:text/zeg:"}, /* ZeroG */
  { "mpl", UPNP_TEXT, "http-get:*:text/mpl:"}, /* MPL */

  /* Miscellaneous text files */
  { "bup", UPNP_TEXT, "http-get:*:text/bup:"}, /* DVD backup */
  { "ifo", UPNP_TEXT, "http-get:*:text/ifo:"}, /* DVD information */

  { NULL, NULL, NULL}
};


Y'a pas photo.
Seul hic, Ushare n'existe que sous Linux.
Il faut donc trouver un Serveur UPnP sous Windows qui exwporte plus de formats de fichiers que XBMC, très limité sur cet aspect.

#40 Le 15/05/2009, à 10:46

abelthorne

Re : Freebox UPnP et pseudo nouveau service

SD a écrit :

Seul hic, Ushare n'existe que sous Linux.
Il faut donc trouver un Serveur UPnP sous Windows qui exwporte plus de formats de fichiers que XBMC, très limité sur cet aspect.

Quand on est sous Windows, oui. Mais comme ici tout le monde utilise Linux, pas de problème pour utiliser uShare. wink

Cela dit, en utilisant uShare, la Freebox ne m'affiche pas de sous-titres (SRT)...
Et, accessoirement, en partageant un dossier contenant des vidéos à divers formats avec uShare, la FB ne me listait que les AVI (dedans j'avais aussi un MP4, un OGV, un MOV et un WMV : aucun n'apparaissait dans la liste de la FB).

Il doit y avoir certaines limitations du côté du client uPnP de la FB mais lesquelles... ?

Dernière modification par abelthorne (Le 15/05/2009, à 10:48)

Hors ligne

#41 Le 15/05/2009, à 11:38

Ed_from_Reims

Re : Freebox UPnP et pseudo nouveau service

abelthorne a écrit :
SD a écrit :

Seul hic, Ushare n'existe que sous Linux.
Il faut donc trouver un Serveur UPnP sous Windows qui exwporte plus de formats de fichiers que XBMC, très limité sur cet aspect.

Quand on est sous Windows, oui. Mais comme ici tout le monde utilise Linux, pas de problème pour utiliser uShare. wink

Cela dit, en utilisant uShare, la Freebox ne m'affiche pas de sous-titres (SRT)...
Et, accessoirement, en partageant un dossier contenant des vidéos à divers formats avec uShare, la FB ne me listait que les AVI (dedans j'avais aussi un MP4, un OGV, un MOV et un WMV : aucun n'apparaissait dans la liste de la FB).

Il doit y avoir certaines limitations du côté du client uPnP de la FB mais lesquelles... ?

Il y a aussi une limitation coté Freebox.
En utilisant MediaTomb, on peut changer le type mime facilement, et j'ai fais quelques tests, elle n'en supporte pas beaucoup.

#42 Le 15/05/2009, à 11:51

fredalo

Re : Freebox UPnP et pseudo nouveau service

Bonjour,
Petite question : avez-vous perdu comme moi la possibilité de lire les MKV sur le dd de la box qui étaient avant lus ?

Hors ligne

#43 Le 15/05/2009, à 11:57

abelthorne

Re : Freebox UPnP et pseudo nouveau service

Je n'ai jamais testé les MKV sur la FB mais je crois bien avoir lu dans un commentaire sur UniversFreebox que depuis la mise à jour du firmware des gens avaient effectivement perdu cette fonctionnalité.

Hors ligne

#44 Le 15/05/2009, à 12:05

poirecahuete

Re : Freebox UPnP et pseudo nouveau service

maitryoda a écrit :

mediatomb marche super bien avec ma ps3, mais sur la freebox, je vois les dossiers, mais pas leur contenu (hors photos dont le rendu est vraiment crade cela dit en passant)

J'ai exactement le même comportement. Si tu as une soluce ...
Par contre pour lire les mkv, aucun problème !


Voici mon config.xml :

<?xml version="1.0" encoding="UTF-8"?>                
<config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">                                                                                                                        
<server>                                                                                                                                                     
<ui enabled="yes">                                                                                                                                           
<accounts enabled="no" session-timeout="30">                                                                                                                 
      <account user="mediatomb" password="mediatomb"/>                                                                                                       
</accounts>                                                                                                                                                  
</ui>                                                                                                                                                        
            <name>Malo tu pues du cul</name>                                                                                                                 
            <udn>uuid:eef9e7bf-b63f-4248-8add-a33086ac49d8</udn>                                                                                             
            <home>/etc/mediatomb/</home>                                                                                                                     
            <webroot>/usr/share/mediatomb/web</webroot>                                                                                                      
            <storage>                                                                                                                                        
              <sqlite3 enabled="yes">                                                                                                                        
                <database-file>mediatomb.db</database-file>                                                                                                  
              </sqlite3>                                                                                                                                     
              <mysql enabled="no">                                                                                                                           
                <host>localhost</host>                                                                                                                       
                <username>mediatomb</username>                                                                                                               
                <database>mediatomb</database>                                                                                                               
                <password>password</password>                                                                                                                
              </mysql>                                                                                                                                       
            </storage>                                                                                                                                       
            <protocolInfo extend="yes"/>                                                                                                                     
            <!--                                                                                                                                             
               Uncomment the lines below to get rid of jerky avi playback on the                                                                             
               DSM320 or to enable subtitles support on the DSM units                                                                                        
            -->                                                                                                                                              
            <!--                                                                                                                                             
            <custom-http-headers>                                                                                                                            
              <add header="X-User-Agent: redsonic"/>                                                                                                         
            </custom-http-headers>                                                                                                                           
                                                                                                                                                             
            <manufacturerURL>redsonic.com</manufacturerURL>                                                                                                  
            <modelNumber>105</modelNumber>                                                                                                                   
            -->                                                                                                                                              

            <!--
               <upnp-string-limit>101</upnp-string-limit>
            -->                                          
          </server>                                      
          <import hidden-files="no">                     
            <scripting script-charset="UTF-8">           
              <virtual-layout type="builtin"/>           
            </scripting>                                 
            <mappings>                                   
              <extension-mimetype ignore-unknown="no">   
                <map from="mp3" to="audio/mpeg"/>        
                <map from="ogg" to="application/ogg"/>   
                <map from="asf" to="video/x-ms-asf"/>    
                <map from="asx" to="video/x-ms-asf"/>    
                <map from="wma" to="audio/x-ms-wma"/>    
                <map from="wax" to="audio/x-ms-wax"/>    
                <map from="wmv" to="video/x-ms-wmv"/>    
                <map from="wvx" to="video/x-ms-wvx"/>    
                <map from="wm" to="video/x-ms-wm"/>      
                <map from="wmx" to="video/x-ms-wmx"/>    
                <map from="m3u" to="audio/x-mpegurl"/>   
                <map from="pls" to="audio/x-scpls"/>     
                <map from="flv" to="video/x-flv"/>       
                <map from="avi" to="video/x-divx"/>      
                <map from="divx" to="video/x-divx"/>     
                <map from="mkv" to="video/x-matroska"/>  
                <map from="mov" to="video/quicktime"/>   
                <map from="qt" to="video/quicktime"/>    
                                                         
                <map from="mpg" to="video/mpeg"/>        
                <map from="mpeg" to="video/mpeg"/>       
              </extension-mimetype>                      
              <mimetype-upnpclass>                       
                <map from="audio/*" to="object.item.audioItem.musicTrack"/>
                <map from="video/*" to="object.item.videoItem"/>           
                <map from="image/*" to="object.item.imageItem"/>           
              </mimetype-upnpclass>                                        
              <mimetype-contenttype>                                       
                <treat mimetype="audio/mpeg" as="mp3"/>                    
                <treat mimetype="application/ogg" as="ogg"/>               
                <treat mimetype="audio/x-flac" as="flac"/>                 
                <treat mimetype="image/jpeg" as="jpg"/>                    
                <treat mimetype="audio/x-mpegurl" as="playlist"/>          
                <treat mimetype="audio/x-scpls" as="playlist"/>            
                <treat mimetype="audio/x-wav" as="pcm"/>                   
                <treat mimetype="audio/L16" as="pcm"/>                     
                <treat mimetype="video/x-msvideo" as="avi"/>               
                <treat mimetype="video/mp4" as="mp4"/>                     
                <treat mimetype="audio/mp4" as="mp4"/>                     
                <treat mimetype="video/x-divx" as="avi"/>                  
              </mimetype-contenttype>                                      
            </mappings>                                                    
          </import>                                                        
          <transcoding enabled="yes">                                      
            <mimetype-profile-mappings>                                    
              <transcode mimetype="video/x-flv" using="vlcmpeg"/>          
              <transcode mimetype="application/ogg" using="vlcmpeg"/>      
              <transcode mimetype="application/ogg" using="oggflac2raw"/>  
              <transcode mimetype="audio/x-flac" using="audio-common"/>    
              <transcode mimetype="video/x-divx" using="video-thumbnail"/> 
              <transcode mimetype="video/x-matroska" using="video-common"/>
              <transcode mimetype="video/quicktime" using="video-common"/> 
            </mimetype-profile-mappings>                                   
            <profiles>                                                     
              <profile name="oggflac2raw" enabled="no" type="external">
                <mimetype>audio/L16</mimetype>
                <accept-url>no</accept-url>
                <first-resource>yes</first-resource>
                <accept-ogg-theora>no</accept-ogg-theora>
                <agent command="ogg123" arguments="-d raw -f %out %in"/>
                <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
              </profile>

              <profile name="vlcmpeg" enabled="yes" type="external">
                <mimetype>video/mpeg</mimetype>
                <accept-url>yes</accept-url>
                <first-resource>yes</first-resource>
                <accept-ogg-theora>yes</accept-ogg-theora>
                <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
                <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
              </profile>

              <profile name="video-thumbnail" enabled="yes" type="external">
                <mimetype>image/jpeg</mimetype>
                <accept-url>yes</accept-url>
                <thumbnail>yes</thumbnail>
                <resolution>128x128</resolution>
                <agent command="ffmpegthumbnailer" arguments="-i %in -o %out -s 128"/>
                <buffer size="524288" chunk-size="512" fill-size="1024"/>
              </profile>

              <profile name="audio-common" enabled="no" type="external">
                <mimetype>audio/x-wav</mimetype>
                <accept-url>yes</accept-url>
                <first-resource>yes</first-resource>
                <accept-ogg-theora>no</accept-ogg-theora>
                <agent command="mediatomb-transcode-audio" arguments="%in %out"/>
                <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
              </profile>

              <profile name="video-common" enabled="yes" type="external">
                <mimetype>video/mpeg</mimetype>
                <accept-url>yes</accept-url>
                <first-resource>yes</first-resource>
                <accept-ogg-theora>yes</accept-ogg-theora>
                <agent command="mediatomb-transcode-video-ffmpeg" arguments="%in %out"/>
                <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
              </profile>
            </profiles>
          </transcoding>
        </config>

#45 Le 15/05/2009, à 12:23

josian

Re : Freebox UPnP et pseudo nouveau service

@Sgabrielli :
J'ai chargé des MP3 directement dans le répertoire video de la FB HD => ils ne sont pas vus par la fonction "magneto" .
Toujours en chargeant directement les vidéos, OK pour  :
Un conteneur  MKV (XVID+AC3)
Un conteneur MPEG-TS(AVC+ACC)
Un conteneur MPEG-TS(MPG4+AC3)
FB HD 1.5.11 & FB ADSL 1.5.2

Après coupure et relance PC, mediatomb accepte de fonctionner cool

Les fichiers MKV, MP3 ne sont pas vus par la fonction "magneto"
Les conteneurs MPEG-TS sont lus  ; contenus : Divx,AVC,ACC,AC3,MPG4,MPG2
Il faut peut-être modifier le config.xml pour obtenir d'autres extensions, cf message SD #39 ; il y a une solution ??

Il n'y a plus de sous-repertoires dans vidéos ce qui est plus simple à gérer (??)


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#46 Le 15/05/2009, à 14:50

josian

Re : Freebox UPnP et pseudo nouveau service

Après tests : le lancement via le terminal est OK alors que le lancement via "applications" conduit à l'erreur database ?????????????


W XP et UBUNTU 10.04
  AMD 64 3000+ ATI HD 4650
FREEBOX V5  NIKON D70 Sony Ericsson W595s

Hors ligne

#47 Le 15/05/2009, à 15:15

zest66

Re : Freebox UPnP et pseudo nouveau service

bonjour

perso tout marche le plus simplement du monde avec mediatomb sauf les mp3
j'ai installé ushare mais ne sais pas comment ça marche
homeplayer reste encore a mes yeux bien supérieur


http://aber.over-blog.com/

Hors ligne

#48 Le 15/05/2009, à 15:27

abelthorne

Re : Freebox UPnP et pseudo nouveau service

josian a écrit :

Après tests : le lancement via le terminal est OK alors que le lancement via "applications" conduit à l'erreur database ?????????????

Faudrait voir à quoi ressemble le lanceur qu'il y a dans Applications pour voir la différence entre la commande utilisée et celle que tu tapes quand tu le lances manuellement.

Hors ligne

#49 Le 15/05/2009, à 16:43

abelthorne

Re : Freebox UPnP et pseudo nouveau service

Je crois savoir pourquoi la Freebox ne voit pas mon partage XBMC : pour la même raison qui l'empêchait de voir mon partage uShare au premier abord et le partage Mediatomb que je viens d'installer, à savoir la mauvaise interface utilisée par défaut (certainement eth0).

Comment dire à XBMC d'utiliser une autre interface pour le partage ? Je ne trouve rien dans ses options.

EDIT : tiens, je suis en train de faire des tests et je remarque qu'on peut changer la piste audio d'une vidéo via les options. Et là, il y a une option "sous-titres". À défaut de pouvoir lire les sous-titres en fichiers externes, peut-être que la FB peut lire ceux qui sont multiplexés dans le fichier ?
Étant donné que les MKV ne sont pas reconnus, quelqu'un a testé d'autres formats qui gèrent les sous-titres comme l'OGM (peu probable, encore moins répandu que le MKV) ou le DIVX (je parle du conteneur apparu avec le format 6, pas du codec vidéo) ?

Dernière modification par abelthorne (Le 15/05/2009, à 17:28)

Hors ligne

#50 Le 15/05/2009, à 17:37

airvb

Re : Freebox UPnP et pseudo nouveau service

Bon je persévère avec ubuntu 904 serveur et mediatomb.

J'ai bien les mp3, les photos, et les différents types de vidéo qui sont visibles lorsque j'utilise l'interface web du serveur.
Avec la FBHD, étonnamment les films apparaissent, par contre la musique mp3 nada.
Qt aux photos elles sont hyper pixellisées.

J'ai modifié le config.xml de mediatomb comme ça ( par contre le profil video common marche pas j'ai du le mettre en veille pour l'instant)

Si certains ont réussi avec mediatomb à lire des mp3, voir des photos correctement et visualiser des films...
merci de dire comment !:)

<?xml version="1.0" encoding="UTF-8"?>
<config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
  <server>
    <ui enabled="yes">
      <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>
    </ui>
    <name>RV-serveur-MediaTomb</name>
    <udn>uuid:87c0366c-cb9b-43fa-a03c-3715fcc7c519</udn>
    <home>/home/master/.mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage>
      <sqlite3 enabled="yes">
        <database-file>mediatomb.db</database-file>
      </sqlite3>
      <mysql enabled="no">
        <host>localhost</host>
        <username>mediatomb</username>
        <database>mediatomb</database>
      </mysql>
    </storage>
    <protocolInfo extend="no"/><!-- For PS3 support change to "yes" -->
    <!--
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
    -->
    <!--
    <custom-http-headers>
      <add header="X-User-Agent: redsonic"/>
    </custom-http-headers>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    -->
    <!-- Uncomment the line below if you have a Telegent TG100 -->
    <!--
       <upnp-string-limit>101</upnp-string-limit>
    -->
  </server>
  <import hidden-files="no">
    <scripting script-charset="UTF-8">
      <common-script>/usr/share/mediatomb/js/common.js</common-script>
      <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
      <virtual-layout type="builtin">
        <import-script>/usr/share/mediatomb/js/import.js</import-script>
      </virtual-layout>
    </scripting>
    <mappings>
      <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpeg"/>
        <map from="ogg" to="application/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="flv" to="video/x-flv"/>
        <!-- Uncomment the line below for PS3 divx support -->
        <!-- <map from="avi" to="video/divx"/> -->
        <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
        <!-- <map from="avi" to="video/avi"/> -->
      </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"/>
        <map from="video/*" to="object.item.videoItem"/>
        <map from="image/*" to="object.item.imageItem"/>
      </mimetype-upnpclass>
      <mimetype-contenttype>
        <treat mimetype="audio/mpeg" as="mp3"/>
        <treat mimetype="application/ogg" as="ogg"/>
        <treat mimetype="audio/x-flac" as="flac"/>
        <treat mimetype="image/jpeg" as="jpg"/>
        <treat mimetype="audio/x-mpegurl" as="playlist"/>
        <treat mimetype="audio/x-scpls" as="playlist"/>
        <treat mimetype="audio/x-wav" as="pcm"/>
        <treat mimetype="audio/L16" as="pcm"/>
        <treat mimetype="video/x-msvideo" as="avi"/>
      </mimetype-contenttype>
    </mappings>
  </import>
  <transcoding enabled="yes">
    <mimetype-profile-mappings>
    	<transcode mimetype="video/x-flv" using="vlcmpeg"/>          
   	<transcode mimetype="application/ogg" using="vlcmpeg"/>      
       <transcode mimetype="application/ogg" using="oggflac2raw"/>  
       <transcode mimetype="audio/x-flac" using="audio-common"/>    
       <transcode mimetype="video/x-divx" using="video-thumbnail"/> 
	<transcode mimetype="video/x-matroska" using="video-common"/>
       <transcode mimetype="video/quicktime" using="video-common"/>
	</mimetype-profile-mappings>
    <profiles>
<profile name="oggflac2raw" enabled="no" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ogg123" arguments="-d raw -f %out %in"/>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
      </profile>
<profile name="vlcmpeg" enabled="no" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
<profile name="video-thumbnail" enabled="yes" type="external">
     	<mimetype>image/jpeg</mimetype>
       <accept-url>yes</accept-url>
       <thumbnail>yes</thumbnail>
       <resolution>128x128</resolution>
       <agent command="ffmpegthumbnailer" arguments="-i %in -o %out -s 128"/>
       <buffer size="524288" chunk-size="512" fill-size="1024"/>
       </profile>
<profile name="audio-common" enabled="no" type="external">
       <mimetype>audio/x-wav</mimetype>
       <accept-url>yes</accept-url>
       <first-resource>yes</first-resource>
       <accept-ogg-theora>no</accept-ogg-theora>
	<agent command="mediatomb-transcode-audio" arguments="%in %out"/>
       <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
       </profile>
<!--profile name="video-common" enabled="yes" type="external"-->
       <!--mimetype>video/mpeg</mimetype-->
       <!--accept-url>yes</accept-url-->
       <!--first-resource>yes</first-resource-->
       <!--accept-ogg-theora>yes</accept-ogg-theora-->
       <!--agent command="mediatomb-transcode-video-ffmpeg" arguments="%in %out"/-->
       <!--buffer size="14400000" chunk-size="512000" fill-size="120000"/-->
       <!--/profile-->
    </profiles>
  </transcoding>
</config>

Hors ligne