Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#651 Le 12/05/2012, à 15:32

lynn

Re : Connexion VPN automatique (NetworkManager)

Salut Manu,

Malgré l'installation de la version 2.1.0 de VPNautoconnect, j'ai toujours le même bug

VPNautoconnect a écrit :

Le daemon ne répond pas le programme va se fermer automatiquement

Au début, ça ne le faisait qu'au démarrage du pc mais depuis, ça le fait aussi quand je déconnecte manuellement mon vpn.

A partir de là, impossible de relancer VPNautoconnect; Quand j'essaie, j'ai droit au même message...

Ca ne le fait pas systématiquement mais assez fréquemment.

Je suis prête à t'envoyer mes logs si tu en as besoin. smile

Merci de ton attention.

P.S: L'option du nombre de déconnexions à disparu de l'interface ? Si c'est le cas, c'est dommage. C'était bien pratique...


«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

Hors ligne

#652 Le 12/05/2012, à 20:16

ringostare

Re : Connexion VPN automatique (NetworkManager)

lynn a écrit :
VPNautoconnect a écrit :

Le daemon ne répond pas le programme va se fermer automatiquement

j'ai le même problème et comme on me l'avait dit il y a quelques pages, je relance le daemon ainsi :

sudo service lvpnc reload

c'est sur que c'est un peu chiant de le faire à chaque fois

lynn a écrit :

P.S: L'option du nombre de déconnexions à disparu de l'interface ? Si c'est le cas, c'est dommage. C'était bien pratique...

bien d'accord

Hors ligne

#653 Le 12/05/2012, à 20:26

Ansuz

Re : Connexion VPN automatique (NetworkManager)

lynn a écrit :

P.S: L'option du nombre de déconnexions à disparu de l'interface ? Si c'est le cas, c'est dommage. C'était bien pratique...

Oui, vraiment utile, en effet.


"Mieux vaut ne rien savoir que beaucoup savoir à moitié !"  Friedrich Nietzsche

Hors ligne

#654 Le 13/05/2012, à 21:24

Zoulou.4556

Re : Connexion VPN automatique (NetworkManager)

salut, je poste une petite info concernant l'hébergement des vpn à l'étranger, Pays-Bas : l’Internet libre et neutre est désormais inscrit dans la loi, Neutralité du Net : l'UE et la France doivent suivre l'exemple des Pays-Bas, ça peut servir pour certains qui ne savent pas quoi choisir quand il sagit de ses pays!

Dernière modification par Zoulou.4556 (Le 14/05/2012, à 06:36)

Hors ligne

#655 Le 14/05/2012, à 09:31

lynn

Re : Connexion VPN automatique (NetworkManager)

Dans l'interface de VPNautoconnect ( version 2.1.0 ), la partie "upload" n'est pas active alors que la partie "download" fonctionne. Je n'ai pas non plus de renseignement sur l'adresse mac; Ca m'indique 00:00:00:00:00:00 ...

Vous avez la même chose ou ça vient de chez moi ?


«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

Hors ligne

#656 Le 14/05/2012, à 18:05

Ansuz

Re : Connexion VPN automatique (NetworkManager)

lynn a écrit :

Dans l'interface de VPNautoconnect ( version 2.1.0 ), la partie "upload" n'est pas active alors que la partie "download" fonctionne. Je n'ai pas non plus de renseignement sur l'adresse mac; Ca m'indique 00:00:00:00:00:00 ...

J'obtiens la même chose lorsque le VPN est actif.
Par contre, sans VPN l'adresse MAC indique des valeurs.


"Mieux vaut ne rien savoir que beaucoup savoir à moitié !"  Friedrich Nietzsche

Hors ligne

#657 Le 15/05/2012, à 11:53

mastergb

Re : Connexion VPN automatique (NetworkManager)

lynn a écrit :

Salut Manu,

Malgré l'installation de la version 2.1.0 de VPNautoconnect, j'ai toujours le même bug

VPNautoconnect a écrit :

Le daemon ne répond pas le programme va se fermer automatiquement

Au début, ça ne le faisait qu'au démarrage du pc mais depuis, ça le fait aussi quand je déconnecte manuellement mon vpn.

A partir de là, impossible de relancer VPNautoconnect; Quand j'essaie, j'ai droit au même message...

Ca ne le fait pas systématiquement mais assez fréquemment.

Je suis prête à t'envoyer mes logs si tu en as besoin. smile

Merci de ton attention.

P.S: L'option du nombre de déconnexions à disparu de l'interface ? Si c'est le cas, c'est dommage. C'était bien pratique...

je veux bien tes fichiers de logs smile
êtes vous sur d'avoir la bonne interface correspondant au demon lors de l'installation 2.1.0.
j'ai peur que lors de l'installation l'interface soit déjà lancé et donc que le paquet n'ai pas pu mettre la bonne interface. Vosu pouvez verifier dans le menu "about" s'il s'agit bien de la 2.1
Le nombre de deconnexion n'a pas été implementé dans la V2.
Je vais le reintegrer smile

Dernière modification par mastergb (Le 15/05/2012, à 11:57)

Hors ligne

#658 Le 15/05/2012, à 12:05

mastergb

Re : Connexion VPN automatique (NetworkManager)

Ansuz a écrit :
lynn a écrit :

Dans l'interface de VPNautoconnect ( version 2.1.0 ), la partie "upload" n'est pas active alors que la partie "download" fonctionne. Je n'ai pas non plus de renseignement sur l'adresse mac; Ca m'indique 00:00:00:00:00:00 ...

J'obtiens la même chose lorsque le VPN est actif.
Par contre, sans VPN l'adresse MAC indique des valeurs.

Les interfaces VPN n'ont pas d'adresse MAC ca sera toujours comme ça smile

Hors ligne

#659 Le 15/05/2012, à 15:52

mastergb

Re : Connexion VPN automatique (NetworkManager)

ringostare > je sors une version corrective ce soir ou demain. Je viens normalement de trouver le bug wink

Hors ligne

#660 Le 02/06/2012, à 01:43

t0ma

Re : Connexion VPN automatique (NetworkManager)

Bonjour,

je viens d'installer vpnautoconnect et j'ai un petit souci : tout semble bien installé mais vpnautoconnect n'effectue aucune reconnexion. Je fais un petit récapitulatif de mes manipulations pour que vous puissiez m'aider et pour que ça puisse éventuellement servir à actualiser les pages de la documentation étant donné que les infos sont éparpillées sur 27 pages...

D'abord, quelques infos sur ma config (xubuntu 12.04):

$ uname -a
Linux thomas-Computer 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:51:22 UTC 2012 i686 athlon i386 GNU/Linux
$ dpkg -l | grep network-managerii  network-manager                        0.9.4.0-0ubuntu4.1                      network management framework (daemon and userspace tools)
ii  network-manager-gnome                  0.9.4.1-0ubuntu2                        network management framework (GNOME frontend)
ii  network-manager-pptp                   0.9.4.0-0ubuntu1                        network management framework (PPTP plugin core)
ii  network-manager-pptp-gnome             0.9.4.0-0ubuntu1                        network management framework (PPTP plugin GNOME GUI)

J'ai téléchargé la dernière version des sources sur sourceforge (2.0.5).
Puis j'ai installé les dépendances (information à mettre à jour dans la page de documentation) :

$ sudo apt-get install build-essential autotools-dev libpcap-dev libdbus-1-dev libcap-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev libappindicator-dev

J'ai compilé :

$./configure
$make
$sudo make install

Au lancement du programme, j'avais le message d'erreur suivant :

Le daemon ne répond pas le programme va se fermer automatiquement

Ce que j'ai réglé en relançant le démon :

$sudo service lvpnc reload

Voilà mes fichiers de configuration du pare feu (voir ce topic pour leur mise en place: http://forum.ubuntu-fr.org/viewtopic.ph … 7#p3492097 ). Ma connexion internet se fait sur eth1, mon IP locale est 192.168.0.10, l'IP de mon routeur est 192.168.0.254, ma plage d'IP est 192.168.0.10/20. J'ai modifié ces fichiers en conséquence (j'ai laissé interfaceVPN="ppp0" parce que je ne sais pas comment vérifier cette info) :

$ cat /etc/iproute2/rt_tables
#
# reserved values
#
255    local
254    main
253    default
0    unspec
#
# local
#
#1    inr.ruhep
1    connection
$ cat /etc/network/if-up.d/parefeu 
#!/bin/sh
#
set -e
if [ "$IFACE" = eth1 ]; then

/sbin/ip route add 192.168.0.10/20 dev eth1 src 192.168.0.10 table connection
/sbin/ip route add default via 192.168.0.254 table connection
/sbin/ip rule add from 192.168.0.10 table connection

fi
$ cat /etc/network/if-down.d/parefeu 
#!/bin/sh
#
set -e
if [ "$IFACE" = eth1 ]; then

/sbin/ip route del 192.168.0.10/20 dev eth1 src 192.168.0.10 table connection
/sbin/ip route del default via 192.168.0.254 table connection
/sbin/ip rule del from 192.168.0.10 table connection

fi

Et voilà mon script de lancement du pare feu :

$ cat /etc/init.d/parefeu 
#!/bin/sh
#
# Script de démarrage qui lance l'interface réseau internet
interfaceWWW="eth1"
interfaceVPN="ppp0"
localIP="192.168.0.10"
network="192.168.0.10/20"

# Rappel IPTables .
#
#           /----------\         /-------\         /-----------\
# IN--->---< PREROUTING >--->---< FORWARD >--->---< POSTROUTING >--->--OUT
#           \----------/         \-------/         \-----------/
#              \                                            /
#               \                                          /
#             /-----\         /-------------\         /------\
#            < INPUT >--->---< LOCAL PROCESS >--->---< OUTPUT >
#             \-----/         \-------------/         \------/

 start() {

# Dans cette partie, on met en place le firewall
#vidage des chaines
iptables -F
#destruction des chaines personnelles
#stratégies par défaut
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT

iptables -P INPUT DROP
iptables -P OUTPUT DROP
iptables -P FORWARD DROP


iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT 


#on accepte tout le reseau local :)
iptables -A INPUT -s $network -j ACCEPT
iptables -A OUTPUT -d $network -j ACCEPT
iptables -A FORWARD -s $network -j ACCEPT 

#on autorise toutes les connexion déja etabli
iptables -A OUTPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

#on accepte tout les debit sur le port 80 venant d'internet (serveur APACHE) et le port 22 venant d'internet (serveur SSH)
iptables -A INPUT -p TCP -m multiport --dports 80,22 -m state --state NEW  -i $interfaceWWW -j ACCEPT

#on autorise les connecion sortante vers le 1723 sur interfaceWWW pour initialiser les connexion VPN
iptables -A OUTPUT -p TCP --dport 1723 -m state --state NEW -o $interfaceWWW -j ACCEPT

#on accepte le protocol GRE sur le port interfaceWWW
iptables -A INPUT -p gre -i $interfaceWWW -j ACCEPT
iptables -A OUTPUT -p gre -o $interfaceWWW -j ACCEPT

#on autorise les connexions sortantes sur le VPN
iptables -A OUTPUT -m state --state NEW -o $interfaceVPN -j ACCEPT
#on ouvre le port 1250 sur la connexion VPN pour accepter torrent que j'ai mis sur 1250
iptables -A INPUT -p TCP --dport 1250 -m state --state NEW -i $interfaceVPN -j ACCEPT


#on autorise les connexion sortante vers le 25 sur interfaceWWW
iptables -A OUTPUT -p TCP --dport 25 -m state --state NEW -o $interfaceWWW -j ACCEPT



echo 0 > /proc/sys/net/ipv4/conf/all/rp_filter
echo 0 > /proc/sys/net/ipv4/conf/$interfaceWWW/rp_filter
ip rule add fwmark 0x1 table connection

#on fait passer les connections SMTP sur la connection internet standard
iptables -t mangle -A OUTPUT -p tcp -m multiport --dports 25 -j MARK --set-mark 0x1
iptables -t nat -A POSTROUTING -o $interfaceWWW -p tcp -m multiport --dports 25 -j SNAT --to $localIP


}
  
 stop() {

     iptables -P INPUT ACCEPT
     iptables -P FORWARD ACCEPT
     iptables -P OUTPUT ACCEPT
     iptables -F
 }
  
 case "$1" in
  start)
         start
         ;;
  
 stop)
         stop
         ;;
 restart)
         stop && start
         ;;
 *)
         echo "Usage $0 {start|stop|restart}"
         exit 1
 esac
  
 exit 0

Le pare feu fonctionne bien puisque quand mon VPN est déconnecté, je n'ai pas accès à internet et un ping sur www.google.fr ou son IP n'aboutit pas.
J'arrive à me connecter à mon VPN que le pare feu soit activé ou non ($ sudo /etc/init.d/parefeu start/stop).

Dans les préférences de vpnautoconnect, j'ai coché Suivre le parent et reconnecter et Reconnecter automatiquement après déconnexion manuelle.
J'ai créé un nouvel onglet pour mon VPN. Connexion parente : Ethernet automatique. Connexion VPN : Mon VPN

Si je déconnecte manuellement mon VPN, rien ne se passe. Les déconnexions intempestives ayant lieu au bout de plusieurs heures, je n'ai pas encore pu voir ce qui se passait.

Y a-t-il quelque chose d'autre à faire ?
Y a-t-il possibilité de connecter le VPN sans qu'il ne me demande le mot de passe du SU (avec Xubuntu donc sans trousseau si je ne me trompe pas) ?


Merci d'avance pour le temps que vous aurez pris pour lire ce message et pour vos réponses.


A bientôt.


Edit : ok, je suis un boulet, je viens de cocher la case Connecter automatiquement dans la config du VPN dans Network manager et ça fonctionne. Vu que cette fonction n'est pas implémentée, je pensais pas que c'était nécessaire...
Reste la question du mot de passe SU en suspend...

Dernière modification par t0ma (Le 02/06/2012, à 02:01)

Hors ligne

#661 Le 02/06/2012, à 09:33

Ansuz

Re : Connexion VPN automatique (NetworkManager)

Bonjour à tous,

Sachant que mon FAI m’attribue une adresse IP fixe, celle-ci est  bien évidemment toujours la même lorsque je teste sur la toile. ( http://www.mon-ip.com/ ou autre...)
Mais différente de mon adresse réelle lorsque vpnautoconnect et actif. (fixe également, normal jusque là)

Or, dans le contextuel de Vpnautoconnect, l'IP est complètement différente de celle relevée en ligne ? (est-ce en rapport avec bind9 ?)
J'aimerai bien comprendre la subtilité entre ces deux adresses.


"Mieux vaut ne rien savoir que beaucoup savoir à moitié !"  Friedrich Nietzsche

Hors ligne

#662 Le 07/06/2012, à 15:57

mastergb

Re : Connexion VPN automatique (NetworkManager)

t0ma a écrit :

Bonjour,

je viens d'installer vpnautoconnect et j'ai un petit souci : tout semble bien installé mais vpnautoconnect n'effectue aucune reconnexion. Je fais un petit récapitulatif de mes manipulations pour que vous puissiez m'aider et pour que ça puisse éventuellement servir à actualiser les pages de la documentation étant donné que les infos sont éparpillées sur 27 pages...

D'abord, quelques infos sur ma config (xubuntu 12.04):

$ uname -a
Linux thomas-Computer 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:51:22 UTC 2012 i686 athlon i386 GNU/Linux
$ dpkg -l | grep network-managerii  network-manager                        0.9.4.0-0ubuntu4.1                      network management framework (daemon and userspace tools)
ii  network-manager-gnome                  0.9.4.1-0ubuntu2                        network management framework (GNOME frontend)
ii  network-manager-pptp                   0.9.4.0-0ubuntu1                        network management framework (PPTP plugin core)
ii  network-manager-pptp-gnome             0.9.4.0-0ubuntu1                        network management framework (PPTP plugin GNOME GUI)

J'ai téléchargé la dernière version des sources sur sourceforge (2.0.5).
Puis j'ai installé les dépendances (information à mettre à jour dans la page de documentation) :

$ sudo apt-get install build-essential autotools-dev libpcap-dev libdbus-1-dev libcap-dev libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev libappindicator-dev

J'ai compilé :

$./configure
$make
$sudo make install

Au lancement du programme, j'avais le message d'erreur suivant :

Le daemon ne répond pas le programme va se fermer automatiquement

Ce que j'ai réglé en relançant le démon :

$sudo service lvpnc reload

Voilà mes fichiers de configuration du pare feu (voir ce topic pour leur mise en place: http://forum.ubuntu-fr.org/viewtopic.ph … 7#p3492097 ). Ma connexion internet se fait sur eth1, mon IP locale est 192.168.0.10, l'IP de mon routeur est 192.168.0.254, ma plage d'IP est 192.168.0.10/20. J'ai modifié ces fichiers en conséquence (j'ai laissé interfaceVPN="ppp0" parce que je ne sais pas comment vérifier cette info) :

$ cat /etc/iproute2/rt_tables
#
# reserved values
#
255    local
254    main
253    default
0    unspec
#
# local
#
#1    inr.ruhep
1    connection
$ cat /etc/network/if-up.d/parefeu 
#!/bin/sh
#
set -e
if [ "$IFACE" = eth1 ]; then

/sbin/ip route add 192.168.0.10/20 dev eth1 src 192.168.0.10 table connection
/sbin/ip route add default via 192.168.0.254 table connection
/sbin/ip rule add from 192.168.0.10 table connection

fi
$ cat /etc/network/if-down.d/parefeu 
#!/bin/sh
#
set -e
if [ "$IFACE" = eth1 ]; then

/sbin/ip route del 192.168.0.10/20 dev eth1 src 192.168.0.10 table connection
/sbin/ip route del default via 192.168.0.254 table connection
/sbin/ip rule del from 192.168.0.10 table connection

fi

Et voilà mon script de lancement du pare feu :

$ cat /etc/init.d/parefeu 
#!/bin/sh
#
# Script de démarrage qui lance l'interface réseau internet
interfaceWWW="eth1"
interfaceVPN="ppp0"
localIP="192.168.0.10"
network="192.168.0.10/20"

# Rappel IPTables .
#
#           /----------\         /-------\         /-----------\
# IN--->---< PREROUTING >--->---< FORWARD >--->---< POSTROUTING >--->--OUT
#           \----------/         \-------/         \-----------/
#              \                                            /
#               \                                          /
#             /-----\         /-------------\         /------\
#            < INPUT >--->---< LOCAL PROCESS >--->---< OUTPUT >
#             \-----/         \-------------/         \------/

 start() {

# Dans cette partie, on met en place le firewall
#vidage des chaines
iptables -F
#destruction des chaines personnelles
#stratégies par défaut
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT

iptables -P INPUT DROP
iptables -P OUTPUT DROP
iptables -P FORWARD DROP


iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT 


#on accepte tout le reseau local :)
iptables -A INPUT -s $network -j ACCEPT
iptables -A OUTPUT -d $network -j ACCEPT
iptables -A FORWARD -s $network -j ACCEPT 

#on autorise toutes les connexion déja etabli
iptables -A OUTPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

#on accepte tout les debit sur le port 80 venant d'internet (serveur APACHE) et le port 22 venant d'internet (serveur SSH)
iptables -A INPUT -p TCP -m multiport --dports 80,22 -m state --state NEW  -i $interfaceWWW -j ACCEPT

#on autorise les connecion sortante vers le 1723 sur interfaceWWW pour initialiser les connexion VPN
iptables -A OUTPUT -p TCP --dport 1723 -m state --state NEW -o $interfaceWWW -j ACCEPT

#on accepte le protocol GRE sur le port interfaceWWW
iptables -A INPUT -p gre -i $interfaceWWW -j ACCEPT
iptables -A OUTPUT -p gre -o $interfaceWWW -j ACCEPT

#on autorise les connexions sortantes sur le VPN
iptables -A OUTPUT -m state --state NEW -o $interfaceVPN -j ACCEPT
#on ouvre le port 1250 sur la connexion VPN pour accepter torrent que j'ai mis sur 1250
iptables -A INPUT -p TCP --dport 1250 -m state --state NEW -i $interfaceVPN -j ACCEPT


#on autorise les connexion sortante vers le 25 sur interfaceWWW
iptables -A OUTPUT -p TCP --dport 25 -m state --state NEW -o $interfaceWWW -j ACCEPT



echo 0 > /proc/sys/net/ipv4/conf/all/rp_filter
echo 0 > /proc/sys/net/ipv4/conf/$interfaceWWW/rp_filter
ip rule add fwmark 0x1 table connection

#on fait passer les connections SMTP sur la connection internet standard
iptables -t mangle -A OUTPUT -p tcp -m multiport --dports 25 -j MARK --set-mark 0x1
iptables -t nat -A POSTROUTING -o $interfaceWWW -p tcp -m multiport --dports 25 -j SNAT --to $localIP


}
  
 stop() {

     iptables -P INPUT ACCEPT
     iptables -P FORWARD ACCEPT
     iptables -P OUTPUT ACCEPT
     iptables -F
 }
  
 case "$1" in
  start)
         start
         ;;
  
 stop)
         stop
         ;;
 restart)
         stop && start
         ;;
 *)
         echo "Usage $0 {start|stop|restart}"
         exit 1
 esac
  
 exit 0

Le pare feu fonctionne bien puisque quand mon VPN est déconnecté, je n'ai pas accès à internet et un ping sur www.google.fr ou son IP n'aboutit pas.
J'arrive à me connecter à mon VPN que le pare feu soit activé ou non ($ sudo /etc/init.d/parefeu start/stop).

Dans les préférences de vpnautoconnect, j'ai coché Suivre le parent et reconnecter et Reconnecter automatiquement après déconnexion manuelle.
J'ai créé un nouvel onglet pour mon VPN. Connexion parente : Ethernet automatique. Connexion VPN : Mon VPN

Si je déconnecte manuellement mon VPN, rien ne se passe. Les déconnexions intempestives ayant lieu au bout de plusieurs heures, je n'ai pas encore pu voir ce qui se passait.

Y a-t-il quelque chose d'autre à faire ?
Y a-t-il possibilité de connecter le VPN sans qu'il ne me demande le mot de passe du SU (avec Xubuntu donc sans trousseau si je ne me trompe pas) ?


Merci d'avance pour le temps que vous aurez pris pour lire ce message et pour vos réponses.


A bientôt.


Edit : ok, je suis un boulet, je viens de cocher la case Connecter automatiquement dans la config du VPN dans Network manager et ça fonctionne. Vu que cette fonction n'est pas implémentée, je pensais pas que c'était nécessaire...
Reste la question du mot de passe SU en suspend...

Je n'ai pas eu le temps de tout lire mais déja utilise la dernière version disponible sur le ppa: https://launchpad.net/~barraudmanuel/+a … utoconnect

La 2.1 est dispo avec quelques corrections(source également dispo)

Hors ligne

#663 Le 07/06/2012, à 16:04

mastergb

Re : Connexion VPN automatique (NetworkManager)

Ansuz a écrit :

Bonjour à tous,

Sachant que mon FAI m’attribue une adresse IP fixe, celle-ci est  bien évidemment toujours la même lorsque je teste sur la toile. ( http://www.mon-ip.com/ ou autre...)
Mais différente de mon adresse réelle lorsque vpnautoconnect et actif. (fixe également, normal jusque là)

Or, dans le contextuel de Vpnautoconnect, l'IP est complètement différente de celle relevée en ligne ? (est-ce en rapport avec bind9 ?)
J'aimerai bien comprendre la subtilité entre ces deux adresses.

L'IP donnée par vpnautoconnect est l'ip de l'interface par default (default gateway)
Donc après tout dépend de ton fournisseur d'accès vpn. Certain donne directement une IP publique et d'autre une ip locale avec du NAT (grossièrement comme une box).

En console tu peut utiliser mon service getip.fr avec la commande suivante pour obtenir l'IP publique

curl getip.fr/ip

Dernière modification par mastergb (Le 07/06/2012, à 16:05)

Hors ligne

#664 Le 08/06/2012, à 10:32

ringostare

Re : Connexion VPN automatique (NetworkManager)

mastergb a écrit :

ringostare > je sors une version corrective ce soir ou demain. Je viens normalement de trouver le bug wink

ça c'est super... ça marche, merci beaucoup !

Dernière modification par ringostare (Le 08/06/2012, à 20:46)

Hors ligne

#665 Le 08/06/2012, à 15:42

bhubuntu

Re : Connexion VPN automatique (NetworkManager)

Je viens de réinstaller mon vpn sur Linux min 13 Maya
En reprenant ce que j'avais précédemment sur mint 12 Lisa à savoir
bind 9
vpnautoconnect 2.0 sous riseup.net qui fait d'ailleurs une promotion non mise à jour de ce logiciel ici
et le parefeu dans /etc/init.d/   donné par Manu
mon problème c'est que l'authentification du vpn chez riseup.net ne se fait pas au démarrage et la connection vpn échoue.
je suis d'abord obligé de faire un stop parefeu via

gksu /etc/init.d/parefeu stop

pour réussir l'authentification
si je relance le parefeu par restart via

gksu /etc/init.d/parefeu restart

  l'authentification reste bien en place et tout fonctionne correctement.

ci-dessous mon parefeu:

#!/bin/sh
#

# ce script de parefeu a été mis en place pour utiliser le vpn par exemple avec Riseup.net sur tun0 avec VPNautoconnect

# Script de démarrage qui lance l'interface réseau internet
interfaceWWW="eth0"
interfaceVPN="tun0"
localIP="192.168.1.2"
network="192.168.1.0/24"

# Rappel IPTables .
#
#           /----------\         /-------\         /-----------\
# IN--->---< PREROUTING >--->---< FORWARD >--->---< POSTROUTING >--->--OUT
#           \----------/         \-------/         \-----------/
#              \                                            /
#               \                                          /
#             /-----\         /-------------\         /------\
#            < INPUT >--->---< LOCAL PROCESS >--->---< OUTPUT >
#             \-----/         \-------------/         \------/

 start() {

# Dans cette partie, on met en place le firewall
#vidage des chaines
iptables -F
#destruction des chaines personnelles
#stratégies par défaut
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT

iptables -P INPUT DROP
iptables -P OUTPUT DROP
iptables -P FORWARD DROP


iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT 


#on accepte tout le reseau local :)
iptables -A INPUT -s $network -j ACCEPT
iptables -A OUTPUT -d $network -j ACCEPT
iptables -A FORWARD -s $network -j ACCEPT 

#on autorise toutes les connexion déja etabli

iptables -A OUTPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A OUTPUT -p icmp -o $interfaceWWW -j ACCEPT

#on accepte tous les debit sur le port 80 venant d'internet (serveur APACHE) et le port que j'ai mis sur 5876 (defaut 22) venant d'internet (serveur SSH)
iptables -A INPUT -p TCP -m multiport --dports 80,5876 -m state --state NEW  -i $interfaceWWW -j ACCEPT

#version pptp on autorise les connecion sortante vers le 1723 sur interfaceWWW pour initialiser les connexion VPN
#iptables -A OUTPUT -p TCP --dport 1723 -m state --state NEW -o $interfaceWWW -j ACCEPT

#version VPN on autorise les connecions sortantes vers le 1194 sur interfaceWWW pour initialiser les connexion VPN
#iptables -A OUTPUT -p TCP --dport 1194 -m state --state NEW -o $interfaceWWW -j ACCEPT
iptables -A OUTPUT -p TCP --dport 1194 -m state --state NEW -o $interfaceWWW -j ACCEPT
iptables -A OUTPUT -p UDP --dport 1194 -m state --state NEW -o $interfaceWWW -j ACCEPT

# tentative de réglage pour autoriser le scanner mais qui ne marche pas !
#iptables -A INPUT -i $interfaceWWW -m pkttype --pkt-type broadcast -j ACCEPT
#iptables -A OUTPUT -m pkttype --pkt-type unicast -d 224.0.0.0/4 -j ACCEPT

# tentative de réglage pour autoriser le scanner qui marche bien !
iptables -A INPUT -i $interfaceWWW -m pkttype --pkt-type broadcast -j ACCEPT
iptables -A OUTPUT -i $interfaceWWW -m pkttype --pkt-type broadcast -j ACCEPT



#on accepte le protocole GRE sur le port interfaceWWW
#iptables -A INPUT -p gre -i $interfaceWWW -j ACCEPT
#iptables -A OUTPUT -p gre -o $interfaceWWW -j ACCEPT

#on autorise les connexions sortantes sur le VPN
iptables -A OUTPUT -m state --state NEW -o $interfaceVPN -j ACCEPT
#on ouvre le port 1250 sur la connexion VPN pour accepter torrent que j'ai mis sur 1250
iptables -A INPUT -p TCP --dport 1250 -m state --state NEW -i $interfaceVPN -j ACCEPT


#on autorise les connexions sortantes vers le 25 sur interfaceWWW
iptables -A OUTPUT -p TCP --dport 25 -m state --state NEW -o $interfaceWWW -j ACCEPT



echo 0 > /proc/sys/net/ipv4/conf/all/rp_filter
echo 0 > /proc/sys/net/ipv4/conf/$interfaceWWW/rp_filter
ip rule add fwmark 0x1 table connection

#on fait passer les connections SMTP sur la connection internet standard
iptables -t mangle -A OUTPUT -p tcp -m multiport --dports 25 -j MARK --set-mark 0x1
iptables -t nat -A POSTROUTING -o $interfaceWWW -p tcp -m multiport --dports 25 -j SNAT --to $localIP




}
  
 stop() {

     iptables -P INPUT ACCEPT
     iptables -P FORWARD ACCEPT
     iptables -P OUTPUT ACCEPT
     iptables -F
 }
  
 case "$1" in
  start)
         start
         ;;
  
 stop)
         stop
         ;;
 restart)
         stop && start
         ;;
 *)
         echo "Usage $0 {start|stop|restart}"
         exit 1
 esac
  
 exit 0

mon problème c'est que l'authentification du vpn chez riseup.net ne se fait pas au démarrage et la connection vpn échoue.
je suis d'abord obligé de faire un stop parefeu via

gksu /etc/init.d/parefeu stop

pour réussir l'authentification.
si je relance le parefeu par restart via

gksu /etc/init.d/parefeu restart

  l'authentification reste bien en place et tout fonctionne correctement.


@+ et merci :-)
PC 4x Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz Nvidia GeForce GTX560 --> uname -r -m = 4.4.0-116-generic x86_64 /// lsb_release -a =Ubuntu Xenial 16.04.4 LTS
Toshiba C70-B-33G   -->4.4.0-116-generic x86_64// Ubuntu Xenial Ubuntu 16.04.4 LTS

Hors ligne

#666 Le 10/06/2012, à 17:28

bhubuntu

Re : Connexion VPN automatique (NetworkManager)

J'avais l'habitude à plus de réactivité sur ce forum big_smile

J'ai actualisé autoconnectvpn à la version 2.1 cela ne change rien au problème évidemment sad

En fait il semble bien que ce soit effectivement le parefeu qui bloque l'authentification avec mon serveur de vpn riseup.net et ce malgré les lignes:

#version VPN on autorise les connecions sortantes vers le 1194 sur interfaceWWW pour initialiser les connexion VPN
iptables -A OUTPUT -p TCP --dport 1194 -m state --state NEW -o $interfaceWWW -j ACCEPT
iptables -A OUTPUT -p UDP --dport 1194 -m state --state NEW -o $interfaceWWW -j ACCEPT

J'ai vérifié dans la configuration avancée de paramètres réseaux le port utilisé est bien le 1194 pour Open-vpn
Par ailleurs ce même parefeu fonctionnait avec Mint12 Lisa

Quelqu'un a une idée ?

Ma solution actuelle --> stop parefeu attendre quelques secondes que la connexion vpn se fasse et restart parefeu roll
Un peu laborieux mais efficace, pourtant est-ce que je cours un risque de suivi par mon FAI


@+ et merci :-)
PC 4x Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz Nvidia GeForce GTX560 --> uname -r -m = 4.4.0-116-generic x86_64 /// lsb_release -a =Ubuntu Xenial 16.04.4 LTS
Toshiba C70-B-33G   -->4.4.0-116-generic x86_64// Ubuntu Xenial Ubuntu 16.04.4 LTS

Hors ligne

#667 Le 12/06/2012, à 10:04

mastergb

Re : Connexion VPN automatique (NetworkManager)

Oui moi j'ai une idée smile
Quel DNS utilise tu ? ceux FAI? ceux fournisseur de VPN ou ton propre bind9

Dans le cas ou tu utilise bind9 as tu rentré le point d'entrée VPN et son ip directement dans ton fichier host?

Hors ligne

#668 Le 12/06/2012, à 12:00

bhubuntu

Re : Connexion VPN automatique (NetworkManager)

OK et encore comme toujours merci au Master de ce thread...
naturellement comme tu me l'as conseillé j'utilise bind9
Je "comprends à peu près" effectivement la logique: j'utilise bind9 qui en l'absence d'indication par le fichier /etc/hosts ne peut donc contacter le serveur de vpn   " nyc.vpn.riseup.net  " qui est censé m'authentifier.

Mais pour la pratique... j'ai tenté naïvement dans  le fichier /etc/hosts d'ajouter la ligne:

72.15.150.103   riseup.net 

mais cela ne résout rien roll

erreur d'adresse ou probablement erreur grossière de manœuvre de ma part?


@+ et merci :-)
PC 4x Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz Nvidia GeForce GTX560 --> uname -r -m = 4.4.0-116-generic x86_64 /// lsb_release -a =Ubuntu Xenial 16.04.4 LTS
Toshiba C70-B-33G   -->4.4.0-116-generic x86_64// Ubuntu Xenial Ubuntu 16.04.4 LTS

Hors ligne

#669 Le 12/06/2012, à 17:05

bhubuntu

Re : Connexion VPN automatique (NetworkManager)

HIP HIP HIP
Quand mon parefeu est coupé et que j'ai la connexion vpn j'ai lancé

dig nyc.vpn.riseup.net

qui m'a envoyé la réponse

; <<>> DiG 9.8.1-P1 <<>> nyc.vpn.riseup.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6512
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;nyc.vpn.riseup.net.        IN    A

;; ANSWER SECTION:
nyc.vpn.riseup.net.    600    IN    CNAME    kite.riseup.net.
kite.riseup.net.    600    IN    A    198.252.153.26

;; AUTHORITY SECTION:
riseup.net.        172798    IN    NS    primary.riseup.net.
riseup.net.        172798    IN    NS    secondary.riseup.net.

;; Query time: 2001 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Jun 12 16:54:24 2012
;; MSG SIZE  rcvd: 117

j'en déduis donc que mon serveur nyc.vpn.riseup.net se trouve à l'adresse

nyc.vpn.riseup.net.    600    IN    CNAME    kite.riseup.net.
kite.riseup.net.    600    IN    A    198.252.153.26

où en clair je retiens que mon fichier /etc/hosts devra contenir la ligne:

198.252.153.26       nyc.vpn.riseup.net 

je l'ajoute donc via

gksu gedit /etc/hosts

Et cette fois ça roule parfaitement !
merci pour la piste à mastergb big_smile

Dernière modification par bhubuntu (Le 12/06/2012, à 17:07)


@+ et merci :-)
PC 4x Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz Nvidia GeForce GTX560 --> uname -r -m = 4.4.0-116-generic x86_64 /// lsb_release -a =Ubuntu Xenial 16.04.4 LTS
Toshiba C70-B-33G   -->4.4.0-116-generic x86_64// Ubuntu Xenial Ubuntu 16.04.4 LTS

Hors ligne

#670 Le 15/06/2012, à 10:25

bhubuntu

Re : Connexion VPN automatique (NetworkManager)

Une idée folle?
Maintenant que le vpn fonctionne et qu'on est enfin content d'être chez soi, il faut bien constater que le débit a diminué... (mastergb m'a d'ailleurs glissé dans le tuyau de l'oreille qu'il existerait des façons de l'améliorer... on verra plus tard)
Dans l'immédiat,  je n'utiliserai pas ce type de connexion vpn par exemple pour charger la dernière version d'ubuntu ou de Mint.
Donc il va me (nous) falloir écrire un script permettant d'arrêter simplement la connexion VPN et le parefeu associé dans la mesure où le parefeu de la box redeviendra efficace.
Arrêter le parefeu je sais

#!/bin/sh
#
# script pour stopper le parefeu
gksu /etc/init.d/parefeu stop

Ce qui manque ce sont les lignes pour arrêter la connexion vpn en imaginant que vpnautoconnect toujours en fonction sera assez gentil pour ne pas relancer la connection

Il y a encore du monde?


@+ et merci :-)
PC 4x Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz Nvidia GeForce GTX560 --> uname -r -m = 4.4.0-116-generic x86_64 /// lsb_release -a =Ubuntu Xenial 16.04.4 LTS
Toshiba C70-B-33G   -->4.4.0-116-generic x86_64// Ubuntu Xenial Ubuntu 16.04.4 LTS

Hors ligne

#671 Le 20/06/2012, à 16:04

mastergb

Re : Connexion VPN automatique (NetworkManager)

Il y a deux choix:
Tu peut arreter le pare feu, mettre en pause vpnautoconnect avec le cli (lvpnctl -x) et arreter le vpn (avec dbus par exemple mais c deja plus chiant...)

Ou ... ne jamais rien arreter et dire que pour tel IP précise tu passe par la connexion clair constamment smile
Ce sont juste de simple règle iptables.

En dehors de ça je recherche des testeurs pour mon nouveau soft qui gère la neufbox sous ubuntu.
Des personnes interessées????

Dernière modification par mastergb (Le 20/06/2012, à 16:04)

Hors ligne

#672 Le 21/06/2012, à 08:34

bhubuntu

Re : Connexion VPN automatique (NetworkManager)

Si Mint Maya fonctionne aussi je peux tenter de t'apporter un retour à partir de ma 9box (non évolution)... Adresse de ton soft? Tu crées un nouveau thread?

Dernière modification par bhubuntu (Le 21/06/2012, à 08:36)


@+ et merci :-)
PC 4x Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz Nvidia GeForce GTX560 --> uname -r -m = 4.4.0-116-generic x86_64 /// lsb_release -a =Ubuntu Xenial 16.04.4 LTS
Toshiba C70-B-33G   -->4.4.0-116-generic x86_64// Ubuntu Xenial Ubuntu 16.04.4 LTS

Hors ligne

#673 Le 18/07/2012, à 22:24

Pifou34

Re : Connexion VPN automatique (NetworkManager)

Salut mastergb et tout le monde

je me suis permis de mettre à jour cette page en ajoutant la possibilité d'ajouter le ppa au source.list d'ubuntu, j'espère que je n'ai pas fait de boulette, si vous pouvez jeter un œil ?

Hors ligne

#674 Le 06/08/2012, à 12:04

himago

Re : Connexion VPN automatique (NetworkManager)

ringostare a écrit :
n1k1t4 a écrit :
ringostare a écrit :

question intéressante.

sinon moi, j'ai un problème, je reçois ce message à chaque fois que je veux lancer vpnautoconnect :

Le daemon ne répond pas le programme va se fermer automatiquement

et je ne sais pas quoi faire.

salut,
il faut que tu recharge lvpnc. la commande est simple :

sudo service lvpnc reload

vpnautoconnect va se fermer, il te suffira de le relancer pour ne plus avoir a faire a ce type de message.

un grand merci pour ça, ça fonctionne.
excusez moi de ne pas avoir donné suite plut tôt, j'ai été complètement débordé par le boulot.

un truc étrange, je n'arrive plus du tout à rajouter nicotine dans les programmes à déconnecter/reconnecter ? quand je le sélectionne, il ne s'affiche pas. Est ce qu'il y a un fichier ou je pourrai l'ajouter à la main ?
deuxième question : comment avoir le service "lvpnc" au démarrage ?

j'ai le même souci avec nicotine, impossible de l'ajouter. j'ai essayé de le mettre en editant le fichier ~/.vpnautoconnect/config mais ça ne fonctionne pas

Hors ligne

#675 Le 06/08/2012, à 22:01

himago

Re : Connexion VPN automatique (NetworkManager)

une question me taraude... quel est l’intérêt de blind9 quand on peut utiliser le serveur DNS de son VPN ? (à part faire le geek lol)

Hors ligne