Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#51 Le 27/10/2009, à 03:06

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

merci smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#52 Le 27/10/2009, à 21:52

cenwen

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Il s'agit de la version 1.5-3ubuntu1

Je confirme ce que gras_du_bide a dit.

@yann_ubuntu Pourquio tu ne te sers pas du svn ? Modifie le script de Angelo pour ekd. Checkinstall n'est fait que pour "essayer" un logiciel car un binaire est plus facile à desinstaller.:D
Je ne connaissais pas le clone d'imagination : http://sourceforge.net/projects/imagemovie/

Dernière modification par cenwen (Le 27/10/2009, à 21:54)


Le jour où j'ai découvert le libre, j'ai su que je ne reviendrais jamais en arrière.
The OpenShot Team : http://www.openshotvideo.com/
Mon blog perso sur le multimédia et OpenShot : http://linuxevolution.wordpress.com/
Google+ : https://plus.google.com/u/0/111472725110173916234/posts

Hors ligne

#53 Le 28/10/2009, à 04:49

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

cenwen a écrit :

Pourquio tu ne te sers pas du svn ? Modifie le script de Angelo pour ekd. Checkinstall n'est fait que pour "essayer" un logiciel car un binaire est plus facile à desinstaller.:D

Merci pour le conseil mais:
- je débute concernant la compilation, donc si tu pouvais détailler comment on fait..
- je n'arrive plus a faire fonctionner ni Imagination ni Imagemovie, meme en reinstallant ffmpeg &co, j'en conclue que c'est trop le bazard dans les codecs de ma Jaunty donc je vais attendre quelques jours pour me refaire une install fraiche 9.10 .


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#54 Le 28/10/2009, à 18:52

cenwen

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Tiens toi aussi tu attends karmic comme le messie. Ffmpeg est un vrai probleme, le depot de Buntuking est interressant.
Pour le svn la procédure est la meme que celle d'EKD. Meme si je ne l'ai pas essayé, cela fonctionne comme launchpad, les outils et les commmandes sont justes differrentes.
Pour avoir le svn d'imagination il faut (si j'ai bien lu les posts précedants) :
Pour récupérer la dernière version:

svn co http://imagination.svn.sourceforge.net/svnroot/imagination/trunk imagination

Pour le compiler comme il est en C (ekd est en PyQt):

./autogen.sh
make
sudo make install

Pour le script d'Angelo, il faut ouvrir un éditeur de texte et modifier quelques variables (je pense).
Je verrai sur moi si je peux y faire et si ça marche je te tiendrai au courant, pour l'instant la seule chose que j'attends c'est .....karmic. J'ai 3 configs qui attentent mon koala à la maison.:lol:

PS: les captures d'écran de Buntuking sont vraiment superbes !!!! lol lol

Dernière modification par cenwen (Le 28/10/2009, à 18:52)


Le jour où j'ai découvert le libre, j'ai su que je ne reviendrais jamais en arrière.
The OpenShot Team : http://www.openshotvideo.com/
Mon blog perso sur le multimédia et OpenShot : http://linuxevolution.wordpress.com/
Google+ : https://plus.google.com/u/0/111472725110173916234/posts

Hors ligne

#55 Le 28/10/2009, à 23:33

cenwen

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Bon avec le svn imagination se lance sans aucun probleme. Je n'ai rien fait d'autres sur ma jaunty 64bits. Je pense que ça doit venir du deb de Buntuking il doit etre créer sur une 32 bits. Je suis en train de regarder pour modifier un script afin de récupérer la dernière version du svn puis de lancer imagination mais le programme est totalement different puisqu'il s'agit d'une compilation proprement dit et non d'un programme en python. Mais bon je vais essayer quand meme, je te tiens au courant. Il me semblait que j'avais tout mais bon comme c'est un peu le bazard avec toutes mes versions d'Openshot.:P

Je m'attendais à la version 2.1 c'est la version 3.0r533  lol Whaoou Ils sont réactifs et l'aide est en ....français  Du bon boulot de papyjo97223 .

Dernière modification par cenwen (Le 28/10/2009, à 23:37)


Le jour où j'ai découvert le libre, j'ai su que je ne reviendrais jamais en arrière.
The OpenShot Team : http://www.openshotvideo.com/
Mon blog perso sur le multimédia et OpenShot : http://linuxevolution.wordpress.com/
Google+ : https://plus.google.com/u/0/111472725110173916234/posts

Hors ligne

#56 Le 01/11/2009, à 19:37

renaud.guilhou

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

YannUbuntu a écrit :

bonne nouvelle! (et etonnante, car le dev d'Imagination ne propose pas de paquet DEB... )

pour voir le depot: ouvre Synaptic, recherche le paquet Imagination, clic droit dessus -> Proprietes. Dans l'onglet General, ca devrait etre indiqué en face de "Categorie".

Je crois que l'on peut mettre la doc et le haut du sujet à jour, c'est bien plus simple par la smile

Il est top ce logiciel!!!

Hors ligne

#57 Le 03/11/2009, à 14:36

Supo

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Salut l'install de la deb ne marche pas chez moi il me dit qu'une dépendandce n'est pas satisfaite, il veut

Erreur : Dépendance non satisfaite : libsox1 (>= 14.2.0)

et moi j'ai la ...14.3.0 !

Du coup j'ai soit la version présente dans les dépots sans le zoom, soit rien sad

Un coup de pouce?
Merci
Supo

Hors ligne

#58 Le 03/11/2009, à 14:42

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

salut,
tu es sur Jaunty ou Karmic?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#59 Le 03/11/2009, à 14:51

Supo

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Pardon oui, je suis sous karmic

Hors ligne

#60 Le 03/11/2009, à 14:59

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

la version du depot officiel ne te suffit pas ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#61 Le 03/11/2009, à 15:05

Supo

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

bah y a pas le zoom  ("slide motion") hmm qui a l'air présent si on regarde le message #6 de ce forum

Dernière modification par Supo (Le 03/11/2009, à 15:05)

Hors ligne

#62 Le 03/11/2009, à 15:18

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Si la version officielle ne te suffit pas, et que le DEB ne fonctionne pas, il ne te reste plus qu'à essayer l'installation manuelle. http://doc.ubuntu-fr.org/imagination Tiens-nous au courant !

Dernière modification par YannUbuntu (Le 03/11/2009, à 15:19)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#63 Le 04/11/2009, à 13:44

Supo

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

fanfan@fanfan-laptop:~/Bureau/imagination-2.1$ ./configure; make; make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether NLS is requested... yes
checking for intltool-update... no
checking for intltool-merge... no
checking for intltool-extract... no
configure: error: The intltool scripts were not found. Please install intltool.
make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.
make: *** Pas de règle pour fabriquer la cible « install ». Arrêt.
fanfan@fanfan-laptop:~/Bureau/imagination-2.1$ ./configure; make; make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether NLS is requested... yes
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.0
checking for XML::Parser... ok
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for PACKAGE... configure: error: Package requirements (gtk+-2.0 >= 2.14.0 gthread-2.0) were not met:

No package 'gtk+-2.0' found
No package 'gthread-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.
make: *** Pas de règle pour fabriquer la cible « install ». Arrêt.

J'ai pas trouvé de paquet s'appelant 'gtk+-2.0' ni 'gthread-2.0'.

Je me demande si faut pas que j'attende un peu pour que ça soit compatible avec karmic.

Hors ligne

#64 Le 05/11/2009, à 03:54

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Le dev d'Imagination qui utilise Xubuntu m'avait conseillé d'installer les paquets docbook-xsl, libsox-dev or libgtk2.0-dev. L'autre dev (qui utilise une autre distribution) m'a parlé des paquets automake, auoconf, libtool, libgtk2.0-dev,
libsox, xsltproc et ffmpeg. Je ne sais pas si ils existent toujours sous karmic ?

Dernière modification par YannUbuntu (Le 05/11/2009, à 03:56)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#65 Le 05/11/2009, à 22:57

Supo

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Salut,
j'ai pas regardé pour tous les paquets mais la plupart existent.
Mais bon, je suis remonté bosser dans la capitale, ma madre attendra les vacances de noel!
Puis d'ici là y aura p'tet un nouveau .deb de sorti.
Merci en tout cas pour le coup de main.

Hors ligne

#66 Le 06/11/2009, à 08:26

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

ok. dis à ta madré de s'entrainer avec la version stable des depots en attendant wink


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#67 Le 10/11/2009, à 15:57

sigo

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

super comme logiciel.

je l'ai compilé à partir du depot svn.
je n'arrive pas à avoir des transitions en lancant le programme "normalment" (ALT + F2). par contre en le lancant dans un terminal depuis l'endroit ou je l'ai compilé, pas de soucis. il doit donc y avoir des fichiers qui n'ont pas bougé mais lesquels?

c'est pas grave comme problème mais c'est quand meme un peut dérangeant donc si quelqu'un comprend mon soucis, je suis preneur.

ps: j'ai compilé car j'avais le meme problème avec le paquet sur getdeb.

Dernière modification par sigo (Le 10/11/2009, à 17:32)


Pour réussir, il ne suffit pas de prévoir. Il faut aussi savoir improviser. Extrait de « Fondation » de Isaac Asimov

Dell XPS1530

Hors ligne

#68 Le 10/11/2009, à 16:19

titi89

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

sur getdeb il y a un .deb pour karmic 2.1

http://www.getdeb.net/updates/
@+

Dernière modification par titi89 (Le 10/11/2009, à 16:20)

Hors ligne

#69 Le 10/11/2009, à 16:35

sigo

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

barthp a écrit :

*** Building HTML ***
rm -rf ./html
mkdir ./html/
/usr/bin/xsltproc --nonet -o ./html/ ./../imagination.xsl \
        ./imagination.xml
I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/html/onechunk.xsl
warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/html/onechunk.xsl"
compilation error: file ./../imagination.xsl line 7 element import
xsl:import : unable to load http://docbook.sourceforge.net/release/xsl/current/html/onechunk.xsl
make[3]: *** [html-build.stamp] Erreur 5
make[3]: quittant le répertoire « /home/philippe/Desktop/imagination21/doc/en »
make[2]: *** [install-recursive] Erreur 1
make[2]: quittant le répertoire « /home/philippe/Desktop/imagination21/doc/en »
make[1]: *** [install-recursive] Erreur 1
make[1]: quittant le répertoire « /home/philippe/Desktop/imagination21/doc »
make: *** [install-recursive] Erreur 1

****  Installation failed. Aborting package creation.

je ne vois pas comment résoudre

il suffit d'installer docbook-xsl, enfin je pense parce que j'en ai installer pas mal avant de le faire fonctionné


Pour réussir, il ne suffit pas de prévoir. Il faut aussi savoir improviser. Extrait de « Fondation » de Isaac Asimov

Dell XPS1530

Hors ligne

#70 Le 11/11/2009, à 17:36

barthp

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

titi89 a écrit :

sur getdeb il y a un .deb pour karmic 2.1

http://www.getdeb.net/updates/
@+

Je ne comprends pas : je viens de passer sous Karmic et plus d'Imagination ...

Je suis ce lien et c'est la version 1.5 qui est installée ...

Une idée?

Merci d'avance

barthp

Dernière modification par barthp (Le 11/11/2009, à 17:37)

Hors ligne

#71 Le 11/11/2009, à 18:15

titi89

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

oui faut que tu installes le paquet getdeb
dans le lien tu click sur
Click here to learn how to install applications from GetDeb
en haut de page
attention cela va te mettre getdeb dans tes depots donc surveille tes mises à jour si tu ne veux pas mettre à jour d'autres applicactions
sinon dans synaptic tu installes imagination puis tu decoches le depot de getdeb

Hors ligne

#72 Le 11/11/2009, à 19:20

barthp

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

titi89 a écrit :

oui faut que tu installes le paquet getdeb
dans le lien tu click sur
Click here to learn how to install applications from GetDeb
en haut de page
attention cela va te mettre getdeb dans tes depots donc surveille tes mises à jour si tu ne veux pas mettre à jour d'autres applicactions
sinon dans synaptic tu installes imagination puis tu decoches le depot de getdeb

Super, ça a fonctionné.

Merci

barthp

Hors ligne

#73 Le 11/11/2009, à 20:09

titi89

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

de rien smile
@+

Hors ligne

#74 Le 12/11/2009, à 08:15

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

pense à désactiver le PPA de Getdeb après l'installation de Imagination pour ne pas prendre trop de risques smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#75 Le 12/11/2009, à 09:18

titi89

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

oui et à surveiller getdeb il y a déjà une maj wink

Hors ligne