Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#26 Le 15/07/2009, à 17:51

kao_chen

Re : 0 A.D. : Une super bonne nouvelle!

Désolé de te casser le truc mais bon en ce moment je tourne sous Nvidia
et le jeu plante quand même, dés que je veux poser un bâtiment ça plante.
Pour moi ça reste de l'alpha et c'est pas jouable.

Hors ligne

#27 Le 15/07/2009, à 19:45

lululaglue

Re : 0 A.D. : Une super bonne nouvelle!

Salut les gars,

pour ceux qui veulent tester sans ce prendre la tête avec la compilation, nous avons fait une archive à télécharger ici : http://djl.jeuxlinux.fr/fichiers/0ad-0.1-r6953.tar.gz
(y a juste à décompresser l'archive et exécuter le fichier .sh).

Ca devrait marchait chez la plupart d'entre vous, sinon il reste la compilation ^^

@kao_chen: moi aussi j'ai une nvidia, et je n'ai pas de plantage, j'ai pu faire une partie (enfin tout seul :-/).

Dernière modification par lululaglue (Le 15/07/2009, à 19:45)


http://www.jeuxlinux.fr/ - l'actualité du jeu sous linux.
http://www.gimp-session.net/ - tuto & aide pour the gimp.

Hors ligne

#28 Le 15/07/2009, à 20:23

hgo

Re : 0 A.D. : Une super bonne nouvelle!

lululaglue a écrit :

Salut les gars,

pour ceux qui veulent tester sans ce prendre la tête avec la compilation, nous avons fait une archive à télécharger ici : http://djl.jeuxlinux.fr/fichiers/0ad-0.1-r6953.tar.gz
(y a juste à décompresser l'archive et exécuter le fichier .sh).

Ca devrait marchait chez la plupart d'entre vous, sinon il reste la compilation ^^

@kao_chen: moi aussi j'ai une nvidia, et je n'ai pas de plantage, j'ai pu faire une partie (enfin tout seul :-/).

Merci, vous êtes des chefs! J'espère juste que ça marche sur 64bit.

#29 Le 15/07/2009, à 20:52

Malizor

Re : 0 A.D. : Une super bonne nouvelle!

@lululaglue: Quand je le lance je dois avoir cette ligne un bon millier de fois

debug.cpp(220): Function call failed: return value was -1 (Function failed (no details available))

et ça se termine en apothéose par un

Segmentation fault

C'est étrange, car lorsque je compile ça se termine par

b757f000-b7580000 rwxp 0000b000 08:03 294960     /usr/lib/libboost_filesystem-gccAbandon

(ATI radeon mobility X700)


« Vous prouver que j'ai raison serait admettre que je puisse avoir tort. »  -  Beaumarchais  ← Le premier troll ?

Hors ligne

#30 Le 15/07/2009, à 20:53

lululaglue

Re : 0 A.D. : Une super bonne nouvelle!

Moi je suis en 64bits et ça marche, par contre je suis sous archlinux, et un utilisateur d'ubuntu a eu un problème avec les libs fournis dnas le paquet.

Pour régler le problème il a fallu supprimer les libs :
libs/libpulse-simple.so.0 et libs/libpulse.so.0 du repertoire 0ad.


http://www.jeuxlinux.fr/ - l'actualité du jeu sous linux.
http://www.gimp-session.net/ - tuto & aide pour the gimp.

Hors ligne

#31 Le 15/07/2009, à 21:09

Malizor

Re : 0 A.D. : Une super bonne nouvelle!

J'ai testé, ça marche pas mieux sad
De même, aucun résultat en rajoutant renderpath=fixed.

J'essaierai sous Karmic, les pilotes y sont plus à jour.


« Vous prouver que j'ai raison serait admettre que je puisse avoir tort. »  -  Beaumarchais  ← Le premier troll ?

Hors ligne

#32 Le 15/07/2009, à 21:24

lululaglue

Re : 0 A.D. : Une super bonne nouvelle!

Petite précision quand même pour ceux qui veulent tenter, il ni a pas d'ia dans le jeu, et le jeu en réseau plante au bout de quelques minutes sad
Donc cette version c'est uniquement pour du test et voir ce que ça donne, mais pas pour faire de vrai partie.
Il va falloir attendre encore quelques mois pour ça...

Dernière modification par lululaglue (Le 15/07/2009, à 21:24)


http://www.jeuxlinux.fr/ - l'actualité du jeu sous linux.
http://www.gimp-session.net/ - tuto & aide pour the gimp.

Hors ligne

#33 Le 15/07/2009, à 21:29

hgo

Re : 0 A.D. : Une super bonne nouvelle!

Salut!
Bon j'arrive pas à le lancer.
Quand je lance 0ad.sh j'ai ça:

./pyrogenesis: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory

Et quand je lance pyrogenesis j'ai droit à ça:

./pyrogenesis: error while loading shared libraries: libenet.so.2: cannot open shared object file: No such file or directory

Hmmm kamoulox!

#34 Le 15/07/2009, à 21:30

hgo

Re : 0 A.D. : Une super bonne nouvelle!

hgo a écrit :

Salut!
Bon j'arrive pas à le lancer.
Quand je lance 0ad.sh j'ai ça:

./pyrogenesis: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory

Et quand je lance pyrogenesis j'ai droit à ça:

./pyrogenesis: error while loading shared libraries: libenet.so.2: cannot open shared object file: No such file or directory

Hmmm kamoulox!

Je précise que les paquets relatifs à ces libs sont bien installés sur ma distro.

#35 Le 15/07/2009, à 21:30

Zakhar

Re : 0 A.D. : Une super bonne nouvelle!

En tout cas bravo à eux pour l'initiative du passage à l'Open Source.

On lit dans leurs explications :

Up until now, access to the project has been limited to 'official' members of our group, though the intent has always been to produce a non-commercial game and membership has always been quite open. The concept of open source simply wasn't considered interesting a couple of years ago, but times have changed and it now seems the natural way to develop our project.

Comme quoi l'Open Source progresse... même dans le jeu, tout ça me réjouit ! big_smile


"A computer is like air conditioning: it becomes useless when you open windows." (Linus Torvald)

Hors ligne

#36 Le 15/07/2009, à 21:36

lululaglue

Re : 0 A.D. : Une super bonne nouvelle!

hgo a écrit :
./pyrogenesis: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory

Je précise que les paquets relatifs à ces libs sont bien installés sur ma distro.

Peut être que le paquet est installé mais que la lib n'a pas ce nom ?
tu peux vérifier en faisant : ls -la /usr/lib/libncurses*
et voir ce qu'il te trouve, ensuite tu vas dans le repertoire 0ad/libs et tu fais un lien symbolique du nom de libncursesw.so.5 qui pointe vers la lib de ton système.


http://www.jeuxlinux.fr/ - l'actualité du jeu sous linux.
http://www.gimp-session.net/ - tuto & aide pour the gimp.

Hors ligne

#37 Le 15/07/2009, à 21:37

love2hate

Re : 0 A.D. : Une super bonne nouvelle!

Merci pour le tar , c'est plutot prometeur , par contre quelqun a trouvé comment faire une rotation de camera autre que le combo souri+touche ctrl ?


1984 was not supposed to be an instruction manual
Some "poor" wine screencast http://www.youtube.com/user/2m42hy/videos?view=0

Hors ligne

#38 Le 15/07/2009, à 21:45

hgo

Re : 0 A.D. : Une super bonne nouvelle!

lululaglue a écrit :
hgo a écrit :
./pyrogenesis: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory

Je précise que les paquets relatifs à ces libs sont bien installés sur ma distro.

Peut être que le paquet est installé mais que la lib n'a pas ce nom ?
tu peux vérifier en faisant : ls -la /usr/lib/libncurses*
et voir ce qu'il te trouve, ensuite tu vas dans le repertoire 0ad/libs et tu fais un lien symbolique du nom de libncursesw.so.5 qui pointe vers la lib de ton système.

Quand je fais un lien j'ai droit à ça:

./pyrogenesis: error while loading shared libraries: libncursesw.so.5: wrong ELF class: ELFCLASS64

Et j'ai pas de libncurse dans /usr/lib32 . Je suis maudit.

#39 Le 15/07/2009, à 22:05

hgo

Re : 0 A.D. : Une super bonne nouvelle!

Ah voila, j'y suis arrivé! Par contre j'ai du faire un truc pas propre: forcer l'installation du package 32bit, puis faire un lien symbolique.
Alors ce que j'en pense:
- Le fond sonore est excellent (musique, bruitages), ça me rapelle vraiment age of empires
- C'est beau, mais il faudrait que je trouve ou sont les réglages
- Le menu est bien fait
- Ça m'a crashé à la gueule.

Bref c'est du bon, qui nécéssite beaucoup de boulot encore pour virer les bugs, compléter. Mais si les contributeurs affluent et que le projet vient à terme, j'imagine même pas tout les mods/jeux possibles à partir du moteur. J'imagine déja: croisade a.d ou encore pleins de trucs de guerre moderne et futuriste.

#40 Le 15/07/2009, à 22:18

lululaglue

Re : 0 A.D. : Une super bonne nouvelle!

Tu pourras modifier quelques réglages dans les fichiers : 0ad/data/config/default.cfg ou 0ad/data/config/local.cfg


http://www.jeuxlinux.fr/ - l'actualité du jeu sous linux.
http://www.gimp-session.net/ - tuto & aide pour the gimp.

Hors ligne

#41 Le 15/07/2009, à 22:27

hgo

Re : 0 A.D. : Une super bonne nouvelle!

lululaglue a écrit :

Tu pourras modifier quelques réglages dans les fichiers : 0ad/data/config/default.cfg ou 0ad/data/config/local.cfg

Merci!

#42 Le 15/07/2009, à 23:26

hgo

Re : 0 A.D. : Une super bonne nouvelle!

hgo a écrit :
lululaglue a écrit :

Tu pourras modifier quelques réglages dans les fichiers : 0ad/data/config/default.cfg ou 0ad/data/config/local.cfg

Merci!

Du coup j'ai tout niqué avec la libncurse 32bit. Aïe.

#43 Le 16/07/2009, à 00:46

hgo

Re : 0 A.D. : Une super bonne nouvelle!

hgo a écrit :
hgo a écrit :
lululaglue a écrit :

Tu pourras modifier quelques réglages dans les fichiers : 0ad/data/config/default.cfg ou 0ad/data/config/local.cfg

Merci!

Du coup j'ai tout niqué avec la libncurse 32bit. Aïe.

Problème résolu, en tout cas ce serait bien de rajouter dans le dossier libs libncursemachin pour les utilisateurs de 64bit. Je l'ai up ici:
http://rapidshare.com/files/256278732/libncursesw.so.5.html

#44 Le 16/07/2009, à 10:21

elensar-geek

Re : 0 A.D. : Une super bonne nouvelle!

Bonjour tous le monde.
Ce jeu a l'air magnifique *bave* mais j'ai essayer de l'installer avec le fchier .tar.gz donné plus haut dans le poste, et il me renvoie une erreur :

elensar-geek@elensar-geek-desktop:~/Bureau/Trucs/0ad$ sudo ./0ad.sh
[sudo] password for elensar-geek: 
TIMER| InitVfs: 918.44 us
TIMER| InitScripting: 3.85248 ms
TIMER| CONFIG_Init: 6.09568 ms
TIMER| write_sys_info: 47.08 us
TIMER| ps_console: 4.77048 ms
TIMER| ps_lang_hotkeys: 5.45528 ms
TIMER| ps_gui_init: 34.44 us
TIMER| ps_gui_setup_xml: 3.05824 ms
TIMER| ps_gui_styles_xml: 1.9852 ms
TIMER| ps_gui_sprite1_xml: 88.2882 ms
TIMER| ps_gui_1: 52.0002 ms
TIMER| ps_gui_2: 73.8218 ms
TIMER| ps_gui_3: 2.55912 ms
TIMER| ps_gui_4: 42.3955 ms
TIMER| ps_gui_6: 405.36 us
TIMER| ps_gui_6_1: 3.57204 ms
TIMER| ps_gui_6_2: 1.3198 ms
TIMER| ps_gui_7: 311.48 us
TIMER| ps_gui_9: 4.29304 ms
TIMER| InitRenderer: 47.7541 ms
TIMER| SimulationInit: 2.33044 ms
TIMER| Init_miscgamesection: 25.6603 ms
TIMER| Init_guiload: 193.634 ms
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
ALSA lib pcm_pulse.c:616:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

pyrogenesis: pcm_pulse.c:361: pulse_write: Assertion `pcm->stream' failed.
Aborted

Je suis trééés débutant au niveau de la console, donc avec le peu de connaissance que j'ai c'est assez difficile de se débrouiller tous seul.

Merci d'avance pour votre aide et espéront que ce jeu ne tombe pas dans les oubliette smile


Il y'a des jours avec et des jours sans ... Des jours sans ou il faut faire avec !!!
" Avec Windows, on fait ce qu'on peut... Avec Linux, on fait ce qu'on veut !! :p "

Hors ligne

#45 Le 16/07/2009, à 11:04

hgo

Re : 0 A.D. : Une super bonne nouvelle!

elensar-geek a écrit :

Bonjour tous le monde.
Ce jeu a l'air magnifique *bave* mais j'ai essayer de l'installer avec le fchier .tar.gz donné plus haut dans le poste, et il me renvoie une erreur :

elensar-geek@elensar-geek-desktop:~/Bureau/Trucs/0ad$ sudo ./0ad.sh
[sudo] password for elensar-geek: 
TIMER| InitVfs: 918.44 us
TIMER| InitScripting: 3.85248 ms
TIMER| CONFIG_Init: 6.09568 ms
TIMER| write_sys_info: 47.08 us
TIMER| ps_console: 4.77048 ms
TIMER| ps_lang_hotkeys: 5.45528 ms
TIMER| ps_gui_init: 34.44 us
TIMER| ps_gui_setup_xml: 3.05824 ms
TIMER| ps_gui_styles_xml: 1.9852 ms
TIMER| ps_gui_sprite1_xml: 88.2882 ms
TIMER| ps_gui_1: 52.0002 ms
TIMER| ps_gui_2: 73.8218 ms
TIMER| ps_gui_3: 2.55912 ms
TIMER| ps_gui_4: 42.3955 ms
TIMER| ps_gui_6: 405.36 us
TIMER| ps_gui_6_1: 3.57204 ms
TIMER| ps_gui_6_2: 1.3198 ms
TIMER| ps_gui_7: 311.48 us
TIMER| ps_gui_9: 4.29304 ms
TIMER| InitRenderer: 47.7541 ms
TIMER| SimulationInit: 2.33044 ms
TIMER| Init_miscgamesection: 25.6603 ms
TIMER| Init_guiload: 193.634 ms
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
ALSA lib pcm_pulse.c:616:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

pyrogenesis: pcm_pulse.c:361: pulse_write: Assertion `pcm->stream' failed.
Aborted

Je suis trééés débutant au niveau de la console, donc avec le peu de connaissance que j'ai c'est assez difficile de se débrouiller tous seul.

Merci d'avance pour votre aide et espéront que ce jeu ne tombe pas dans les oubliette smile

Il faut supprimer du dossier libs les fichiers libpulse-simple.so.0 et libpulse.so.0

Mais attention: c'est de la pré-pré-pré-pré-pré-pré alpha, donc ultra incomplet, peu stable, et pour modifier les graphismes/résolution tu dois éditer des fichiers cfg.

#46 Le 16/07/2009, à 15:28

elensar-geek

Re : 0 A.D. : Une super bonne nouvelle!

Je viens de les suprimer, et en relancant la commande, j'ai eu les méme message d'éreur :s


Il y'a des jours avec et des jours sans ... Des jours sans ou il faut faire avec !!!
" Avec Windows, on fait ce qu'on peut... Avec Linux, on fait ce qu'on veut !! :p "

Hors ligne

#47 Le 16/07/2009, à 16:22

uz

Re : 0 A.D. : Une super bonne nouvelle!

Hola!

(Avec le paquet), Moi j'ai ça comme erreur:

:~/0ad$ sh 0ad.sh 
./pyrogenesis: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by ./pyrogenesis)

Une idée?

Hors ligne

#48 Le 16/07/2009, à 16:46

hgo

Re : 0 A.D. : Une super bonne nouvelle!

uz a écrit :

Hola!

(Avec le paquet), Moi j'ai ça comme erreur:

:~/0ad$ sh 0ad.sh 
./pyrogenesis: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by ./pyrogenesis)

Une idée?

Installe libstdc++

#49 Le 16/07/2009, à 16:47

hgo

Re : 0 A.D. : Une super bonne nouvelle!

elensar-geek a écrit :

Je viens de les suprimer, et en relancant la commande, j'ai eu les méme message d'éreur :s

Il reste pas une libpulse? Si oui supprimer les. Et utilise alsa dans préférences:::: >son

#50 Le 16/07/2009, à 16:53

uz

Re : 0 A.D. : Une super bonne nouvelle!

Ce paquet est déjà installé:

 sudo apt-get install libstdc++6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libstdc++6 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Hors ligne

Haut de page ↑