Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 16/04/2005, à 17:58

XaMaX

[wifi] Problème avec adaptateur usb belkin

Salut,

Je me présente un petit peu (pour mon premier post)
J'utilisé Suse 9.1 jusqu'à présent et mon adaptateur wifi usb belkin était corectement pris en compte . Hier suse a planté (je pensais que cela n'était pas possible sous Linux tongue ) impossible de redemarrer la distrib . J'en es donc profité pour installer une nouvelle distrib .

Donc j'aimerai savoir si des (utilisateur d'ubuntu ?) membres du forum pouvez m'expliquer comment regler ce problème big_smile

J'oublié mon adaptateur usb (pour utiliser le reseau wifi) de la marque Belkin reference : F5D6050F .

Je precise que j'ai fait une recherche sur le forum et sur mon ami http://gogole.fr smile
Aussi j'ai axé a internet par reseau lan .


Bin merci .  hmm

Hors ligne

#2 Le 16/04/2005, à 19:05

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

Visiblement cette carte fonctionne bien avec ndiswrapper... (je ne l'ai pas mais j'ai trouvé des utilisateurs plus ou moins satisfaits là : http://linuxfr.org/~ploum/16283.html )

Pour ndiswrapper : http://forum.ubuntu-fr.org/viewtopic.php?pid=20728#p20728 ca devrait t'aider.


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#3 Le 16/04/2005, à 20:51

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Merci,

Mais Ubuntu ne le reconai toujours pas .

Si j'ai tout compris ndiswrapper simule les drivers windows .

J'ai le meme problème que tagatao ! le joli message : wlan0     Interface doesn't support scanning.

Voici un lien vers la page du constructeur ( apparament faut donner le lien, je savais pas ) :
http://catalog.belkin.com/IWCatProductPage.process?Merchant_Id=&Product_Id=125463

Je continu à cherché . Gooogle !


Comment on appelle les utilisateur de Ubuntu ?

Hors ligne

#4 Le 16/04/2005, à 21:09

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

Si tu connais le nom de ton reseau wifi tu peux le gerer dans Gnome.

Lance synaptic (pour peu que ton adaptateur soit installé) modprobe synaptic

Là avec la commande ifconfig tu verras tes interfaces actives, à priori wlan0 devrait apparaitre, tu n'as plus qu'à aller dans Systeme / Administration / Réseau


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#5 Le 17/04/2005, à 09:55

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Salut,

La je pige plus rien, ndiswrapper -l ne m'affiche plus rien, on dirai qu'il cherche (je ne sait pas jusqu'a quand), et de même pour sudo iwlist wlan0 scan .

Je ne sait plus quoi faire .

Pour modprobe synaptic cela m'affiche :
FATAL: Module synaptic not found.



J'ai retenté du debut j'ai donc supprimer les driver,
Je les est reinstallé et à sudo modprobe ndiswrapper ça bloque .

Je ne sait pas si il a besoin des driver sur le disk (je pence pas) je les est copier sur le disk .

sad


Voila ce que donne ifconfig

eth0      Lien encap:Ethernet  HWaddr 00:0D:9D:8A:03:17
          inet adr:192.168.0.3  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::20d:9dff:fe8a:317/64 Scope:Lien
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1772 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1646 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1372282 (1.3 MiB)  TX bytes:257807 (251.7 KiB)
          Interruption:10 Adresse de base:0x8000

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8685 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:787308 (768.8 KiB)  TX bytes:787308 (768.8 KiB)

Hors ligne

#6 Le 17/04/2005, à 10:07

lamiricore

Re : [wifi] Problème avec adaptateur usb belkin

modprobe est une fonction pour charger les modules ;or synaptic est un programme ...
Je ne comprends ce que voulais exprimer Ju
Mais bon démarres synaptic recherches ndiswrapper clic droit fais sélectionner pour supression complète
Réinstalle le
Refais la manip comme indiqué dans les liens précédents

#7 Le 17/04/2005, à 10:10

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

Tu as bien fait ndiswrapper -i ton_fichier_de_driver.inf ? Si oui il a fait une copie des fichiers dans /etc/ndiswrapper.

Teste ton installation avec ndiswrapper -l , ca devrait te montrer les drivers installés.
Si tu as une errreur lors de 'modprobe ndiswrapper' copie/colle ici le message (il apparait aussi dans les dernieres lignes renvoyées par la commande 'dmesg')

http://ndiswrapper.sourceforge.net/phpwiki/index.php/Installation

Dernière modification par Ju (Le 17/04/2005, à 10:10)


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#8 Le 17/04/2005, à 10:40

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Salut,

Je n'ai trouvé que ndiswrapper-utils  .

J'ai fait une suppression complète ( et pas suppression tout court )
Puis je l'ai réinstallé . Je ne c'est pas si c'est normal mais je doit toujours supprimer les driver :
netvusba is already installed. Use -e to remove it

Je les ai reinstallé :
Installing netvusba

ndiswrapper -l bloque toujours . La j'y comprend rien cela fonctionnait hier .

Ju >

Oui j'ai bien fait ndiswrapper -i ton_fichier_de_driver.inf
( ici /home/xamax/driver/Netvusba.inf )

Non il n'y à pas d'erreur pour modprobe ndiswrapper, il y'a un curseur qui clignote, c'est tout .


Pour dmesg je copie la dernière ligne ?

UDF-fs: No VRS found
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A

Dernière modification par XaMaX (Le 17/04/2005, à 10:44)

Hors ligne

#9 Le 17/04/2005, à 10:41

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

Si

Non il n'y à pas d'erreur pour modprobe ndiswrapper, il y'a un curseur qui clignote, c'est tout .

C'est bon signe, tente ifconfig pour voir si la carte est listée.

apres tu peux passer à la configuration.


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#10 Le 17/04/2005, à 10:47

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Pour ifconfig, je n'ai que eth0 et lo (lo comme local ?)

eth0      Lien encap:Ethernet  HWaddr 00:0D:9D:8A:03:17
          inet adr:192.168.0.3  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::20d:9dff:fe8a:317/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3072 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2867 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:2070793 (1.9 MiB)  TX bytes:467678 (456.7 KiB)
          Interruption:10 Adresse de base:0x8000

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:23656 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23656 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:2146621 (2.0 MiB)  TX bytes:2146621 (2.0 MiB)

Donc je pence qu'elle n'est pas détecté .

Dernière modification par XaMaX (Le 17/04/2005, à 10:48)

Hors ligne

#11 Le 17/04/2005, à 10:57

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

En effet...


Bon reprenons.

ndiswrapper -l pour voir si ton driver est activé dans ndiswrapper

modprobe|grep ndiswrapper pour voir si ndiswrapper est activé

ifconfig pour voir si ta carte est reconnue.

A quel moment ca plante ?


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#12 Le 17/04/2005, à 11:43

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Heu je vien de redemarrer et
ndiswrapper -l me repond driver present, hardware present

modprobe|grep ndiswrapper ? C'est cette ligne qu'il faut metre ?


ifconfig me donne la meme chose qu'avant.

Pour modprobe ndiswrapper, je pence que c'est de la que vien le problème .
Car il me laisse un curseur qui clignote . Je vias attendre voir si ça chance

Hors ligne

#13 Le 17/04/2005, à 11:47

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

XaMaX a écrit :

ndiswrapper -l me repond driver present, hardware present

Bien.


Pour le modprobe | grep ndiswrapper, j'ai fumé... c'est lsmod |grep ndiswrapper, si la ligne te renvoit quelque chose c'est que ndiswrapper est chargé sinon il faut le charger :

modprobe ndiswrapper

Dernière modification par Ju (Le 17/04/2005, à 11:47)


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#14 Le 17/04/2005, à 11:53

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

J'ai fait modprobe ndiswrapper (ca fonctionne enfin)


lsmod |grep ndiswrapper me renvoi (après modprobe ndiswrapper) :
ndiswrapper           109044  0
usbcore               107384  5 ndiswrapper,usbhid,ehci_hcd,uhci_hcd

ndiswrapper -l me mes un curseur qui clignote .

Dernière modification par XaMaX (Le 17/04/2005, à 12:06)

Hors ligne

#15 Le 17/04/2005, à 13:53

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Salut, j'ai recommencé du debut :

$ sudo ndiswrapper -i /home/xamax/driver/XP/NETVUSBR.INF
Installing netvusbr

$ sudo ndiswrapper -l
Installed ndis drivers:
netvusbr        driver present, hardware present

$ sudo modprobe ndiswrapper

$ ndiswrapper -m
modprobe config already contains alias directive

$ sudo iwlist wlan0 scan
wlan0     Interface doesn't support scanning.

Bin ca marche pas quoi sad .

Hors ligne

#16 Le 17/04/2005, à 18:58

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

Voila il ne veut pas scanner, bon ce n'est pas grave : tu connais ton nom de réseu wifi tu vas dans

Systeme / Administration / Réseau et tu parametres ta carte, comme sous windows.


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#17 Le 17/04/2005, à 20:34

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Salut,
Le problème c'est que la carte n'aparait pas !

Je fait comment ?
Le seul truc que je peut faire c'est "créer un emplacement"

C'est quoi le nom du réseau wifi ?
J'ai un routeur il me met : Station Name:      SCFD4152  Je pence que ça doit être ça .

Ubuntu est pas simpa avec moi sad

Hors ligne

#18 Le 17/04/2005, à 23:06

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

Quand tu dis que ta carte n'apparait pas, tu parles du gestionnaire de réseau ?
Mais que donne ifconfig ? apparait elle là ?

Si tu as configuré ta carte wifi sous windows à un moment le gestionnaire wifi te donne la liste des réseaux accessibles, quel est celui que tu choisis ?

(ote moi d'un doute, tu as bien un point d'accès wifi accessible ?)

Dernière modification par Ju (Le 17/04/2005, à 23:07)


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#19 Le 18/04/2005, à 09:39

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Mon routeur est à 2 metre donc c'est bon tongue !


Voila ce que donne ifconfig

eth0      Lien encap:Ethernet  HWaddr 00:0D:9D:8A:03:17
          inet adr:192.168.0.2  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::20d:9dff:fe8a:317/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:219 errors:0 dropped:0 overruns:0 frame:0
          TX packets:127 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:84130 (82.1 KiB)  TX bytes:14244 (13.9 KiB)
          Interruption:10 Adresse de base:0x8000

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1579 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1579 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:142026 (138.6 KiB)  TX bytes:142026 (138.6 KiB)

La carte n'aparait ni dans ifconfig ni dans le gestionnaire de réseau .


Pour le nom du reseau c'est soit SCFD4152 (Station Name) soit default (SSID) .

Hors ligne

#20 Le 18/04/2005, à 09:45

Ju.

Re : [wifi] Problème avec adaptateur usb belkin

Aie ! Le modprobe ndiswrapper s'execute sans erreur ? parce que là j'ai l'impression que ta carte n'est pas reconnue...

Est ce que tu peux executer la commande suivante *:

sudo modprobe ndiswrapper && sudo tail /var/log/syslog

Qui aura pour effet de charger ndiswrapper et de copier à l'ecran les derniers messages du systeme


* si ndiswrapper est deja charge, enleve le : sudo rmmod ndiswrapper


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#21 Le 18/04/2005, à 09:51

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

sudo modprobe ndiswrapper && sudo tail /var/log/syslog :

Apr 18 10:24:26 localhost kernel:  [pg0+209260010/1070015488] hub_thread+0x1d/0xe4 [usbcore]
Apr 18 10:24:26 localhost kernel:  [autoremove_wake_function+0/58] autoremove_wake_function+0x0/0x3a
Apr 18 10:24:26 localhost kernel:  [ret_from_fork+6/20] ret_from_fork+0x6/0x14
Apr 18 10:24:26 localhost kernel:  [pg0+209259981/1070015488] hub_thread+0x0/0xe4 [usbcore]
Apr 18 10:24:26 localhost kernel:  [autoremove_wake_function+0/58] autoremove_wake_function+0x0/0x3a
Apr 18 10:24:26 localhost kernel:  [kernel_thread_helper+5/11] kernel_thread_helper+0x5/0xb
Apr 18 10:24:26 localhost kernel: Code: 00 00 00 a0 00 2a c4 02 00 00 00 02 00 00 00 01 00 02 00 ff ff 00 00 00 00 00 00 00 60 56 c1 02 00 00 00 40 80 00 00 00 00 00 00 <ff> ff ff ff 64 00 00 00 64 00 00 00 c0 f0 bc c9 c0 20 cf c2 88
Apr 18 10:24:26 localhost kernel:  <6>note: khubd[4780] exited with preempt_count 2
Apr 18 10:24:41 localhost hal.hotplug[8083]: timout(10000 ms) waiting for /devices/pci0000:00/0000:00:0b.0/usb1/1-2/1-2:1.0
Apr 18 10:41:09 localhost -- MARK --

modprobe ndiswrapper s'execute comme plus haut, en laissant aucun message  .

Hors ligne

#22 Le 19/04/2005, à 14:35

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Si j'

Edit oui je sait .

Dernière modification par XaMaX (Le 19/04/2005, à 15:01)

Hors ligne

#23 Le 19/04/2005, à 14:56

coffee

Re : [wifi] Problème avec adaptateur usb belkin

Manque quelque chose là je crois ...


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#24 Le 19/04/2005, à 15:25

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Bon voila ce que me donne sudo tail /var/log/syslog aujourd'hui :

Apr 19 16:23:28 localhost kernel: usb 1-2: device firmware changed
Apr 19 16:23:28 localhost kernel: ndiswrapper (usb_reset_port:663): usb_reset_device() = -19
Apr 19 16:23:28 localhost kernel: ndiswrapper (ndis_init_one_usb:191): Windows driver couldn't initialize the device (C0000001)
Apr 19 16:23:28 localhost kernel: netvusba: probe of 1-2:1.0 failed with error -22
Apr 19 16:23:28 localhost kernel: usbcore: registered new driver netvusba
Apr 19 16:23:28 localhost kernel: ndiswrapper: driver netvusba (Belkin,09/25/2001,1.1.2.22) added
Apr 19 16:23:28 localhost kernel: usb 1-2: USB disconnect, address 4
Apr 19 16:23:28 localhost kernel: usb 1-2: new full speed USB device using uhci_hcd and address 5
Apr 19 16:23:33 localhost kernel: usb 1-2: khubd timed out on ep0out
Apr 19 16:23:43 localhost hal.hotplug[8091]: timout(10000 ms) waiting for /devices/pci0000:00/0000:00:0b.0/usb1/1-2/1-2:1.0

Hors ligne

#25 Le 19/04/2005, à 18:25

XaMaX

Re : [wifi] Problème avec adaptateur usb belkin

Salut,

Je vien d'achter un carte pcmcia parce que la belkin elle me fait ***** !
Elle est marqué compatible Linux, alors la je me suis dit cool je vais pouvoir l'installer facillement .
Bin non, premièrement aucun driver sur le cd, il faut aller les telecharger sur internet sad . Et une fois téléchargé je me rend compte que il n'y a que 2 drivers un pour mandrake est l'autre pour red hat (ce sont pas des rpm) .
J'execute donc les setup.sh :

Kernel Version Running 2.6.10-5-386
Kernel Source Directory Not Found. Please give path :

Si je comprend bien il ne trouve pas Kernel source, il faut donc l'intaller .
Ma question est quel est le nom du packet pour intaller Kernel source ?
Sinon ma carte c'est une peabird : PEAB-WL-PCMCIA
Le mirior pour les driver : http://ftppeabird.peabird.com/
Quelqu'un à une idée ?

Hors ligne

Haut de page ↑