Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 30/08/2009, à 17:26

Jeannot Alpin

[Résolu] Lecteur CD non reconnu

Bonjour à tout le monde !
J'ai installé ubuntu sur mon acer timeline 5810TG qui marche pas trop mal (j'ai deja fait un post ici qui est résolu).
Mais je viens de remarquer que mon lecteur cd ne marche pas :
En fait lorsqu'un cd est inséré dans le lecteur, celui ci tourne mais n'est pas monté sur ubuntu.
Par contre, lorsque le CD est inséré avant le démarrage, il est monté au demarrage mais ensuite, pas moyen de monter un CD différent.

Ensuite ce qui me fait un peu peur c'est qu'il ne marche pas non plus sur XP (ordinateur livré avec VISTA bien sur) car sur vista le lecteur s'éteignait tout seul pour économiser de la batterie (sur XP le logiciel de gestion de l'économie d'énergie d'ACER n'est pas disponible).

Donc le problème viens surement de là (bien que le lecteur tourne lorsqu'un cd est entré) et j'ai peur qu'il n'y est pas de solution mais je tente quand même.

Pour info :
- Pas de trace du lecteur dans fstab
- Le log "message" quand un CD est inséré :

Aug 30 17:09:41 jean-laptop kernel: [  657.208496] VFS: busy inodes on changed media or resized disk sr0
Aug 30 17:09:41 jean-laptop kernel: [  657.214978] VFS: busy inodes on changed media or resized disk sr0
Aug 30 17:09:41 jean-laptop kernel: [  657.225500] VFS: busy inodes on changed media or resized disk sr0
Aug 30 17:09:41 jean-laptop kernel: [  657.281575] VFS: busy inodes on changed media or resized disk sr0
Aug 30 17:10:12 jean-laptop kernel: [  688.000248] ata5: hard resetting link
Aug 30 17:10:18 jean-laptop kernel: [  693.880104] ata5: failed to reset engine (errno=-5)
Aug 30 17:10:22 jean-laptop kernel: [  698.036131] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Aug 30 17:10:22 jean-laptop kernel: [  698.036142] ata5.00: failed to IDENTIFY (I/O error, err_mask=0x40)
Aug 30 17:10:27 jean-laptop kernel: [  703.036024] ata5: hard resetting link
Aug 30 17:10:33 jean-laptop kernel: [  708.924109] ata5: failed to reset engine (errno=-5)
Aug 30 17:10:37 jean-laptop kernel: [  713.064131] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Aug 30 17:10:37 jean-laptop kernel: [  713.064141] ata5.00: failed to IDENTIFY (I/O error, err_mask=0x40)
Aug 30 17:10:37 jean-laptop kernel: [  713.064148] ata5: limiting SATA link speed to 1.5 Gbps
Aug 30 17:10:42 jean-laptop kernel: [  718.064111] ata5: hard resetting link
Aug 30 17:10:48 jean-laptop kernel: [  723.928036] ata5: failed to reset engine (errno=-5)
Aug 30 17:10:52 jean-laptop kernel: [  728.072065] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Aug 30 17:10:52 jean-laptop kernel: [  728.072075] ata5.00: failed to IDENTIFY (I/O error, err_mask=0x40)
Aug 30 17:10:52 jean-laptop kernel: [  728.072081] ata5.00: disabled
Aug 30 17:10:52 jean-laptop kernel: [  728.072103] ata5: hard resetting link
Aug 30 17:10:58 jean-laptop kernel: [  734.344110] ata5: failed to reset engine (errno=-5)
Aug 30 17:11:02 jean-laptop kernel: [  738.092133] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Aug 30 17:11:02 jean-laptop kernel: [  738.092139] ata5: link online but device misclassified, retrying
Aug 30 17:11:02 jean-laptop kernel: [  738.092142] ata5: hard resetting link
Aug 30 17:11:08 jean-laptop kernel: [  744.360112] ata5: failed to reset engine (errno=-5)
Aug 30 17:11:12 jean-laptop kernel: [  748.108130] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Aug 30 17:11:12 jean-laptop kernel: [  748.108136] ata5: link online but device misclassified, retrying
Aug 30 17:11:12 jean-laptop kernel: [  748.108139] ata5: hard resetting link
Aug 30 17:11:18 jean-laptop kernel: [  754.376165] ata5: failed to reset engine (errno=-5)
Aug 30 17:11:23 jean-laptop kernel: [  759.592106] ata5: link is slow to respond, please be patient (ready=0)
Aug 30 17:11:47 jean-laptop kernel: [  783.140127] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Aug 30 17:11:47 jean-laptop kernel: [  783.140133] ata5: link online but device misclassified, retrying
Aug 30 17:11:47 jean-laptop kernel: [  783.140137] ata5: limiting SATA link speed to 1.5 Gbps
Aug 30 17:11:47 jean-laptop kernel: [  783.140140] ata5: hard resetting link
Aug 30 17:11:53 jean-laptop kernel: [  788.680032] ata5: failed to reset engine (errno=-5)

Voila en espérant ne pas avoir été trop confus, je vous remerci d'avance.

Dernière modification par Jeannot Alpin (Le 31/08/2009, à 12:50)

Hors ligne

#2 Le 30/08/2009, à 17:51

wido

Re : [Résolu] Lecteur CD non reconnu

Bonjour, lance cette commande:

pour ouvrir le lecteur CD:

eject cdrom

et vois si tu n'as pas de message d'erreur.

aussi
la doc: http://doc.ubuntu-fr.org/cdrom

Hors ligne

#3 Le 30/08/2009, à 18:13

Jeannot Alpin

Re : [Résolu] Lecteur CD non reconnu

Salut, merci de répondre si vite.

La commande eject ne donne rien (ca reste bloqué le curseur du terminal clignotant sans le nom du PC), et lorsque j'appuie sur eject ca donne :

jeannotalpin@jean-laptop:~$ eject cdrom
eject: impossible d'ouvrir le fichier `/dev/sr0'

.
Après dans la doc, il est necessaire d'avoir le CD-ROM qui apparait dans fstab, hors moi il n'apparait pas donc je connait pas son emplacement.

De plus :

eannotalpin@jean-laptop:~$ dmesg | grep CD-ROM
[   20.077947] scsi 4:0:0:0: CD-ROM            MATSHITA DVD-RAM UJ862AS  1.10 PQ: 0 ANSI: 5
[   20.092859] Uniform CD-ROM driver Revision: 3.20
[   20.092946] sr 4:0:0:0: Attached scsi CD-ROM sr0

Donc le lecteur est bien reconnu au démarrage quand même...

jeannotalpin@jean-laptop:~$ sudo mount /dev/sd0 /media/cdrom
mount: périphérique spécial /dev/sd0 n'existe pas

Et quelques messages des logs :

Aug 30 18:06:00 jean-laptop kernel: [ 4036.612072] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Aug 30 18:06:03 jean-laptop kernel: [ 4039.226599] ata5.00: ACPI cmd 00/00:00:00:00:00:a0 rejected by device (Stat=0x51 Err=0x04)
Aug 30 18:06:03 jean-laptop kernel: [ 4039.226612] ata5.00: ATAPI: MATSHITADVD-RAM UJ862AS, 1.10, max UDMA/33
Aug 30 18:06:03 jean-laptop kernel: [ 4039.230941] ata5.00: ACPI cmd 00/00:00:00:00:00:a0 rejected by device (Stat=0x51 Err=0x04)
Aug 30 18:06:03 jean-laptop kernel: [ 4039.231008] ata5.00: configured for UDMA/33
Aug 30 18:06:03 jean-laptop kernel: [ 4039.236938] ata5.00: configured for UDMA/33
Aug 30 18:06:03 jean-laptop kernel: [ 4039.236973] ata5: EH complete
Aug 30 18:06:03 jean-laptop kernel: [ 4039.237847] ata5.00: detaching (SCSI 4:0:0:0)
Aug 30 18:06:03 jean-laptop kernel: [ 4039.259170] scsi 4:0:0:0: CD-ROM            MATSHITA DVD-RAM UJ862AS  1.10 PQ: 0 ANSI: 5
Aug 30 18:06:03 jean-laptop kernel: [ 4039.278830] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
Aug 30 18:06:03 jean-laptop kernel: [ 4039.279109] sr 4:0:0:0: Attached scsi generic sg1 type 5
Aug 30 18:06:36 jean-laptop kernel: [ 4072.000290] ata5: hard resetting link
Aug 30 18:06:42 jean-laptop kernel: [ 4077.872070] ata5: failed to reset engine (errno=-5)
Aug 30 18:06:46 jean-laptop kernel: [ 4082.020302] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Aug 30 18:06:46 jean-laptop kernel: [ 4082.020319] ata5.00: failed to IDENTIFY (I/O error, err_mask=0x40)
Aug 30 18:06:51 jean-laptop kernel: [ 4087.020267] ata5: hard resetting link

Hors ligne

#4 Le 30/08/2009, à 22:05

wido

Re : [Résolu] Lecteur CD non reconnu

édite le fichier:

sudo gedit /etc/fstab

essaye d'ajouter dans le fstab:

dans la doc ubuntu:

  /dev/hdc      /media/cdrom0   udf,iso9660 ro,user,noauto              0    0

redémarre et analyse le dmesg pour voir si le /dev/hdc est correct
ou
sur ma distribution (archlinux):

/dev/cdrom             /media/cd     iso9660   ro,user,noauto,unhide   0      0

les dossiers /media/cdrom0 ou /media/cd sont à créer:

sudo mkdir /media/cdrom0
sudo mkdir /media/cd

EDIT: tu dois avoir des contrôleurs SATA ( ata5: SATA link up 1.5 Gbps)

  /dev/sdc      /media/cdrom0   udf,iso9660 ro,user,noauto              0    0

vérifie que le fichier existe

Dernière modification par wido (Le 30/08/2009, à 22:09)

Hors ligne

#5 Le 30/08/2009, à 23:18

Jeannot Alpin

Re : [Résolu] Lecteur CD non reconnu

Nan désolé rien de tout ça ne marche. (Pas un seul mot dans dmesg)
Mais pour cette ligne :

[  303.952074] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)

ici http://forum.ubuntu-fr.org/viewtopic.php?id=289885 ils disent que ca vient du rebranchement du cable sata... Pourtant le PC est neuf.

Dernière modification par Jeannot Alpin (Le 30/08/2009, à 23:19)

Hors ligne

#6 Le 30/08/2009, à 23:43

wido

Re : [Résolu] Lecteur CD non reconnu

je me rappelle qu'il y a longtemps (31-10-2008) j'avais eu un problème avec mon graveur:

http://forums.archlinux.fr/topic2651.html
https://bugs.launchpad.net/ubuntu/+sour … bug/291791


essaye une autre version de kernel (liveCD de hardy par exemple)

Hors ligne

#7 Le 31/08/2009, à 12:35

Jeannot Alpin

Re : [Résolu] Lecteur CD non reconnu

Le live démarre (puisque le cd est entré avant de booter sur linux) mais après je peux pas mettre un autre cd a la place du live pour voir si ca marche.

Par contre lorsque le CD est entré avant le démarrage de Linux, c'est /dev/sr0 qui permet de monter le CD.

Hors ligne

#8 Le 31/08/2009, à 12:50

Jeannot Alpin

Re : [Résolu] Lecteur CD non reconnu

Bon apparement ca marche tout le temps à condition que pour ouvrir le lecteur j'utilise le terminal avec

eject cdrom

. Il ne faut donc pas que j'utilise le bouton du pc pour ouvrir le lecteur sinon le lecteur plante.
Je ne sais pas vraiment pourquoi mais bon.

Merci beaucoup de ton aide.

Hors ligne

#9 Le 31/08/2009, à 16:18

wido

Re : [Résolu] Lecteur CD non reconnu

pour refermer le boitier:

eject -t cdrom

voir dans

man eject

Hors ligne

#10 Le 31/08/2009, à 17:30

Jeannot Alpin

Re : [Résolu] Lecteur CD non reconnu

Merci beaucoup.

Hors ligne

#11 Le 19/03/2010, à 22:04

strdoom

Re : [Résolu] Lecteur CD non reconnu

Bonsoir,

Je vous remercie pour ce topic. J'ai installé un adaptateur "SATA -> IDE" pour utiliser mon graveur car j'utilise les 3 ports sata de ma carte mère pour le disque dur et un bracket 2xesata. Confronté au même problème les commandes "eject sr0" et "eject -t sr0" me permette à nouveau d'avoir accès à mon graveur.

Encore merci à vous smile

Hors ligne

Haut de page ↑