Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/09/2009, à 14:59

ymichalak

[RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Salut la communauté :Dbiggrin

Petite présentation pour mon premier post sur le forum :

Je m'appelle Yann, je suis Tice dans l'éducation plus exactement au collège joseph-anglade à Lézignan-Corbières.

Je me tourne vers vous car mes chers professeurs de musique ont fait l'acquisition de MACBOOK (version 5.2) il y a une semaine. (caractéristiques ici voir modèle mid 2009dans le tableau en bas de page)

Malgré mon insistance pour acquérir des PC 100% compatible avec le but final -> faire de la MAO avec PLANET CCRMA sous Fedora, ou avec Ubuntu Studio ils se sont bornés à vouloir du MAC.
Bilan maintenant c'est moi qui suis dans la M _ _ _ _ mad

J'ai terminé l'install des 3 OS (MAc OS X, XP, Ubuntu Studio 8.04.1 recommandé par Linux Mao)

Maintenant je me casse la tête sur la config d'Ubuntu Studio.

__En effet je n'ai pas de SON__

Avouer que c'est embêtant pour une machine dédiée à la MAO tongue

Caractéritiques :

Vendeur : Nvidia
Modèle : Corporation MCP79-1 High Definition Audio
Module : snd-hda-intel
Chip : Realtek ACL 885

Système sonore alsa :

Paquet alsa lib : alsa-lib-1.0.15
Paquet alsa utils : alsa-lib-1.0.15


Quelqu'un sait si ce matériel Nvidia MCP79-1 est compatible avec Ubuntu 8.04.1 ?

Que dois-je faire pour avoir du SON SVP sad
J'ai biensûr vérifier que le son n'était pas sur "muet", j'ai essayer d'installer le driver alsa 1.0.21.......Bilan plus de réaction du clavier et de la souris.

J'ai tenté de faire ces manip :

- Audio HDA Intel

- MacBook5-1

Avec ces manips j'ai bien un peu de son, mais surtout beaucoup de grésillement.

J'attends vos conseils merci par avance smile

Dernière modification par ymichalak (Le 23/09/2009, à 14:55)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#2 Le 21/09/2009, à 15:55

albh

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Personnellement j'en suis au mieux à:
- pas de son dans les écouteurs s'ils sont branchés
- du son mais vraiment cra cra qui sort des hauts parleurs, même écouteurs branchés

Je me rajoute à ce post:D

Hors ligne

#3 Le 21/09/2009, à 16:12

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Merci albh je me sens moins seul cool

Aidez nous SVP lol

Tu peux me dire ce que tu as testé comme manip ?

Quel driver ALSA, etc......

Dernière modification par ymichalak (Le 21/09/2009, à 16:13)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#4 Le 21/09/2009, à 16:33

albh

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Oulala... Tout ce qui est possible sur le net, vraiment tout de tout, à noter que moi le driver c'est l'ACL889 vu que je suis sur Imac, mais le problème est le même.

Dernière modification par albh (Le 21/09/2009, à 17:11)

Hors ligne

#5 Le 21/09/2009, à 16:55

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Exact car je configure des Macbook 5.2 et aussi des imacs 20"

Macbook Mid 2009 : ACL 885

Imac Mid 2009 : ACL 889A


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#6 Le 22/09/2009, à 16:46

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Bon c'est ok pour les macbook 5.2 (Mid 2009) avec Ubuntu Studio 9.04 :


sudo nano /etc/modprobe.d/alsa-base.conf

On ajoute cette ligne à  la fin du fichier :

options snd-hda-intel model=imac24

Oui oui il faut bien mettre imac24 pour les macbook 5.2 . Le chip audio est ACL889A comme les Imac

On reboot, le son est là ....quel bonheur big_smile

alsamixer : on vérifie le master .

Préférences audio :

Périphérique : HDA NVidia (alsa mixer)

Dernier détail pour l'install de Ubuntu Studio 9.04 sur ces MacBook 5.2 :

pingubuntu a écrit :

1. acpi=on mais un seul core (nosmp)
2. acpi=off et le core 2 duo fonctionnel (et qui tourne à coin) et tout les déboires que peut amener l'absence de l'acpi

Personnellement j'ai choisi nosmp

Bon courage à tous !

Dernière modification par ymichalak (Le 22/09/2009, à 17:21)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#7 Le 22/09/2009, à 16:49

dynamos

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Un petit résolu dans le titre alors ?


Ne vous demandez pas seulement ce que Gnu/linux peut faire pour vous, demandez-vous ce que vous pouvez faire pour lui.

Hors ligne

#8 Le 22/09/2009, à 16:52

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Avec plaisir c'est fait big_smile


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#9 Le 22/09/2009, à 18:01

albh

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Tu as bien de la chance, moi j'ai mis ça sur mon imac, et un son tout pourri comme décrit au dessus...

Hors ligne

#10 Le 22/09/2009, à 19:46

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Salut,

as-tu essayé de recharger le module au démarrage ?

Tu peux essayer de rajouter ces deux lignes

/etc/rc.d

rmmod snd-hda-intel
modprobe snd-hda-intel

Je te cherche le site où il traite de ce problème sur les Imac...N'étant plus au Taff (donc pas mes favoris internet) je n'arrive pas à y mettre la main dessus.

Si je ne te le trouve pas ce soir je te poste le lien demain en début de matinée......


Ce n'est pas le bon site maisici ils en parlent

Dernière modification par ymichalak (Le 22/09/2009, à 19:50)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#11 Le 22/09/2009, à 19:47

dynamos

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

@albh : As tu tenté de configurer alsamixer ?
Dans un terminal

alsamixer

notamment le master


Ne vous demandez pas seulement ce que Gnu/linux peut faire pour vous, demandez-vous ce que vous pouvez faire pour lui.

Hors ligne

#12 Le 22/09/2009, à 19:55

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

dynamos a raison sur beaucoup de forum ils conseillent de ne pas mettre le son "A FOND" dans ALSAMIXER pour éviter le grésillement...Mais je suppose que tu as déjà testé lol


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#13 Le 23/09/2009, à 14:59

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Pour les Imac 20" version 9.1

En mettant ceci :

1°)

options snd-hda-intel model=mbp3 position_fix=0

à la fin du fichier

/etc/modprobe.d/alsa-base.conf

puis on reboot l'imac

2°)Dans un terminal saisir :

alsamixer

Tu changes le channel par défaut il est à deux, tu le mets sur 6
Pour te déplacer dans alsamixer utilise la touche tabulation.
Tu mets le line-out à 100% et le son est NICKEL


Tu me tiens au courant pour moi c'est résolu pour les MACBOOK 5.2 et les IMAC 9.1

Dernière modification par ymichalak (Le 23/09/2009, à 15:11)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#14 Le 23/09/2009, à 15:03

albh

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Oui moi c'est exactement ce que j'ai, un grésillement constant. J'avais déjà tout mis de ce que tu m'a donné;)

Hors ligne

#15 Le 23/09/2009, à 15:15

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Tu peux essayer de faire un reset d'alsa pour retrouver les paramétres de départ et faire ma manip.....Il faut que ça marche....Si on a la même machine, le même OS y a pas de raison.

Tu as ta distri à jour ?


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#16 Le 23/09/2009, à 15:35

albh

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Ah bah j'ai fait ce que tu m'a dis, et... J'ai plus de son!

Ah bah j'ai supprimé tous les paquets alsa puis réinstallés, toujours pas de son malgré tout ce que tu m'a dit...

Dernière modification par albh (Le 23/09/2009, à 16:15)

Hors ligne

#17 Le 23/09/2009, à 17:57

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

T'as version d'Alsa stp ? Logiquement la 18 non ?

NoNNNNNNNN...Je ne voulais pas que tu désintalles tous les paquets ALSA...juste que tu réinitialises les réglages d'Alsa par :

sudo /etc/init.d/alsa-utils reset
sudo /etc/init.d/alsa-utils restart

Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#18 Le 25/09/2009, à 14:55

albh

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Bon j'ai fait ça et j'ai toujours le son pourri qui sort des hauts parleurs, rien dans la prise casque qui n'active même pas la coupure des hauts parleurs.

Hors ligne

#19 Le 30/09/2009, à 10:18

LizardKing1980

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

ymichalak a écrit :

Salut la communauté :Dbiggrin

Petite présentation pour mon premier post sur le forum :

Je m'appelle Yann, je suis Tice dans l'éducation plus exactement au collège joseph-anglade à Lézignan-Corbières.

Je me tourne vers vous car mes chers professeurs de musique ont fait l'acquisition de MACBOOK (version 5.2) il y a une semaine. (caractéristiques ici voir modèle mid 2009dans le tableau en bas de page)

Malgré mon insistance pour acquérir des PC 100% compatible avec le but final -> faire de la MAO avec PLANET CCRMA sous Fedora, ou avec Ubuntu Studio ils se sont bornés à vouloir du MAC.
Bilan maintenant c'est moi qui suis dans la M _ _ _ _ mad

J'ai terminé l'install des 3 OS (MAc OS X, XP, Ubuntu Studio 8.04.1 recommandé par Linux Mao)

Maintenant je me casse la tête sur la config d'Ubuntu Studio.

__En effet je n'ai pas de SON__

Avouer que c'est embêtant pour une machine dédiée à la MAO tongue

Caractéritiques :

Vendeur : Nvidia
Modèle : Corporation MCP79-1 High Definition Audio
Module : snd-hda-intel
Chip : Realtek ACL 885

Système sonore alsa :

Paquet alsa lib : alsa-lib-1.0.15
Paquet alsa utils : alsa-lib-1.0.15


Quelqu'un sait si ce matériel Nvidia MCP79-1 est compatible avec Ubuntu 8.04.1 ?

Que dois-je faire pour avoir du SON SVP sad
J'ai biensûr vérifier que le son n'était pas sur "muet", j'ai essayer d'installer le driver alsa 1.0.21.......Bilan plus de réaction du clavier et de la souris.

J'ai tenté de faire ces manip :

- Audio HDA Intel

- MacBook5-1

Avec ces manips j'ai bien un peu de son, mais surtout beaucoup de grésillement.

J'attends vos conseils merci par avance smile

Bonjour ymichalak,

je viens de lire avec attention ton post et je pense que tu peux m'aider.
Je viens d'acquerir un MacBook 5.2 et j'ai de grosses difficultés pour installer un Triple Boot.
Peux tu, si tu as du temps, me décrire les étapes que tu as suivi pour installer ton triple boot.
J'utilise Refit pour le menu de selection de l'OS bien entendu.

Lorsque j'installe ubuntu, Windows ne boot plus et surtout, Linux "Freeze" sous Grub.
J'ai beau utiliser l'utilitaire de Refit, rien n'y fait. Concernant Windows je pense qu'il faut éditer le boot.ini et vérifier que la partition est la bonne.

Comment as-tu fait pour installer ton triple-boot, concernant la partition Windows je l'ai réalisé à laide de bootcamp.
As-tu utilisé un tuto en particulier ? Je sais que pour le moment il n'y pas de doc pour installer Ubuntu 9.04 (Jaunty Jackalope) sur un macbook 5.2
https://help.ubuntu.com/community/MacBook, mais je pense que la version que tu as installé doit juste être une version custom de la version Ubuntu de la même série.
Tu as installé Ubuntu Studio 8.04.1, qui doit je pense être basée sur la version 8.04 (Hardy Heron).

Pour ma part, j'ai installé les OS dans cet ordre ci:
1° Mac OS X
2° BootCamp => création de la partition pour Windows
3° Installation de Windows XP Pro
4° Installation de refit
5° Ajout d'une partition supplémentaire à l'aide l'utilitaire de disque sous Mac OS

Actuellement mon disque dur est composé de ces partitions et permet de booter sur Mac OS ou sur Windows via le menu de Refit.

[=== efi ===][=== Mac OS X ===][=== Fat 32 ===][=== WinXP ===]
/dev/sda1  EFI     200M
/dev/sda2  OSX     110G
/dev/sda3  Fat 32  130G
/dev/sda4  WinXP   60G


Merci

Hors ligne

#20 Le 30/09/2009, à 11:56

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Salut,

Alors tout d'abord tu installes un OSx tout neuf sur tout ton disque.

Après l'install dans le terminal tu tapes :

diskutil list

logiquement tu vois que l'OS x est installé en "disk0s2"

Maintenant tu redimensionnes cette partition et tu crés les nouvelles pour Windows et Linux avec cette commande :

sudo diskutil resizeVolume /dev/disk0s2 61G "MS-DOS FAT32" Linux 20G "MS-DOS FAT32" Windows 30G

Tu adaptes les dimensions de tes partitions selon ton disque.

Tu télécharges REFIT ici http://refit.sourceforge.net/

tu ne l'installes pas. Pas besoin.
Tu copies juste le dossier "EFI" à la racine de ta partition OSx puis dans un terminal tu rends l'utilisation de REFIT effective en tapant ceci :

cd /efi/refit; sudo ./enable-always.sh

Voila ton disque est prêt à accueillir les autres OS.

Tu installes maintenant Ubuntu 9.04 (personnellement, j'ai installé la version UbuntuStudio car ces machines sont dédiées MAO, mais le principe est le même avec la version classique de Ubuntu 9.04)

avant de lancer l'install tu édites la commande en faisant F6 et tu rajoutes à la fin de la ligne nosmp. Si tu ne rajoutes pas cette option tu auras droit à un bel écran tout noir.
Explication du pourquoi du comment :

Alors pour mon macbook blanc 5.2, la seule solution (actuelle) pour faire fonctionner l'acpi est de lancer au démarrage (de l'installation) "nosmp". Faire tourner Ubuntu sur ce macbook demande de faire un choix:
1. acpi=on mais un seul core (nosmp)
2. acpi=off et le core 2 duo fonctionnel (et qui tourne à coin) et tout les déboires que peut amener l'absence de l'acpi

je te passe l'install de Ubuntu, juste pour le partitionnement :
Une fois arrivé à la phase de partitionnement, ne créez qu’un point de montage « / » en « ext3″ sur la partition qui fait 20Go (normalement sda3), et pour grub tu mets "/dev/sda3", tu ignore le fait que des messages d'erreur s'affiche car il n'y a pas de partition de SWAP.

Après la fin de l'install on reboot et tu vois la pomme et le pingouin.
Avant de lancer un des deux os tu lances l'outil "start partionning tools" juste en dessous de la pomme et du pingouin, Si il te demande de remettre en place la synchronisation des tables tu tapes "Y" puis entrer,  puis tu reboot la machine.
Tu testes logiquement tes deux OS se lancent.

Maintenant tu installes Windows dans la dernière partition libre, puis à la fin de l'install tu lances à nouveau l'outil "start partionning tools" juste en dessous de la pomme et du pingouin, Si il te demande de remettre en place la synchronisation des tables tu tapes "Y" puis entrer,  puis tu reboot la machine.

Maintenant tu testes le démarrage de tes 3 OS et tout doit être OK.

En conclusion, je suis arrivé à partitionner mon disque en 6 "EFI, OsX, Xp, DONNEES, Ubuntu, Swap" avec la partition de données accessible depuis les trois OS mais alors bonjour le Taff.
Néanmoins si tu suis ce que je viens de te dire tu auras toi aussi tes trois OS fonctionnels.

Bon courage ;-))

Dernière modification par ymichalak (Le 30/09/2009, à 12:02)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#21 Le 01/10/2009, à 09:30

LizardKing1980

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Merci pour ta réponse ymichalak,

je vais tester tout ça ce week-end, je ferai un retour d'expérience ensuite.

Hors ligne

#22 Le 02/10/2009, à 13:25

LizardKing1980

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Hello,

En réalité, j'aimerai beaucoup arriver à la même configuration que toi, 3 OS et une partition d'échange avec un SWAP.
Sur ce point, il y a une chose que je ne comprends pas dans le détail de l'installation.
Pourquoi as-tu créé un SWAP pour tes 6 partitions, alors que dans le détail que tu me donnes il n'y en a pas.

Comment as tu fait exactement pour avoir un triple boot avec refit en incluant une partition d'échange et un SWAP ?
Il me semblait que rEfit ne supportait pas plus de 4 partitions, hors dans ton cas tu en as 6 ?

Si tu peux me détailler comment tu as fait exactement ce serait formidable !!
Sans vouloir abuser de ton temps, si tu peux me donner le détail assez précis des étapes, création des partitions, divers commandes et options utilisées sur les OS . . .

Encore merci à la communauté Ubuntu !!

Hors ligne

#23 Le 02/10/2009, à 14:10

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Pour arriver a 6 partitions il faut un GPARTED.

Redimensionner les partoches en lignes de commande pour que gparted synchronise le GPT.

C'est surtout Windows qui ne peux fonctionner que sur 4 partitions principales.


La manip que je t'ai décrite est la première que j'ai réalisé. C'est celle que tout le monde utilise. Elle fonctionne c'est certain.

pour créer un swap tu peux suivre ce tuto :

Une fois arrivé à la phase de partitionnement, ne créez qu’un point de montage « / » en « ext3″ sur la partition qui fait 20Go (normalement sda3). Ne créez pas de swap, continuez l’installation malgré les avertissements. Une fois celle-ci terminée, NE REDEMARREZ PAS.

Nous allons créer un fichier de SWAP de 1Go. Pour celà, cliquez à la fin de l’installation sur « continuer à utiliser le live cd » puis lancez un terminal (applications/accessoires) et entrez-y une par une les commandes suivantes :

sudo su -
mkdir /mnt/ubuntu
mount /dev/sda3 /mnt/ubuntu
mount -t proc none /mnt/ubuntu/proc
mount -o bind /dev /mnt/ubuntu/dev
chroot /mnt/ubuntu /bin/bash
dd if=/dev/zero of=/swapfile bs=1024 count=1024000
mkswap /swapfile
swapon /swapfile
echo "/swapfile swap swap defaults 0 0" >> /etc/fstab
exit
cd
sudo umount /mnt/ubuntu/proc
sudo umount /mnt/ubuntu/dev
sudo umount /mnt/ubuntu
sudo reboot now

Source ici

Dernière modification par ymichalak (Le 02/10/2009, à 14:12)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

#24 Le 03/10/2009, à 16:54

LizardKing1980

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Bonjour,

comme prévu je vous retourne mon expérience. Pour ma part, ce fut un échec cuisant. Je n'ai jamais réussi à installer de triple boot. Dans tous les cas le lancement de Ubuntu Freeze sous grub. Je souhaiterai bien comprendre comme fonctionne les systèmes de partitions. Selon ce que j'ai pu lire Mac OS X utilise une table de partition GPT alors que Linux et Windows le MBR, ce dernier ne gérant que 4 partitions primaires au maximum. Mac OS incorpore EFI qui permet de simuler le tout mais semble tout de même poser un problème pour ma part. Quelqu'un peut m'expliquer exactement comment faire ? A savoir que le but ultime serait d'arriver à avoir un triple boot avec une partition d'échange.

Voila pour ma petite histoire sur le triple boot sous MacBokk 5.2 avec un ubutun 9.04

Hors ligne

#25 Le 03/10/2009, à 17:04

ymichalak

Re : [RESOLU] Macbook 5.2, Imac 9.1 : Pas de son :-(

Quel est le résultat ? Au boot du Mac Refit te propose quel choix ?

Quel Os tu arrives à démarrer ? Quels sont ceux qui plantent ?

Dernière modification par ymichalak (Le 03/10/2009, à 17:04)


Yann Michalak
Collège Joseph-Anglade-Lézignan-Corbières http://www.joseph-anglade.fr
Cherche poste admin ou tech systèmes
C.V : http://ymichalak.free.fr

Hors ligne

Haut de page ↑