Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 01/10/2009, à 07:58

SkeRoy

[RESOLU] Partition corrompue. Plus d'espoir ?

Bonjour,

Hier soir j'ai eu un problème bizzare, comme si les ports usb de mon ordi avaient un faux contact ou je ne sais quoi.
Du coup mon disque dur externe a été déconnecté sans que je le veuille.

Ce matin j'ai réussi à monter le DDE, mais plein de dossiers apparaissaient vides/corrompus.
En démontant la partition et en voulant la remonter, j'obtiens une erreur.

Du coup je me dis que je dois réparer la partition. Mais ça ne passe pas. Voici les erreurs :

# jfs_fsck /dev/sda1

jfs_fsck version 1.1.12, 24-Aug-2007
processing started: 10/1/2009 7.52.33
Using default parameter: -p
The current device is:  /dev/sda1
ujfs_rw_diskblocks: read 0 of 4096 bytes at offset 32768
ujfs_rw_diskblocks: read 0 of 4096 bytes at offset 61440
Superblock is corrupt and cannot be repaired 
since both primary and secondary copies are corrupt.  

 CANNOT CONTINUE.

N'y a t'il plus d'espoir pour récupérer mes données ?

Dernière modification par SkeRoy (Le 01/10/2009, à 16:13)


== Debian Lenny == {Linux User #422949}

Hors ligne

#2 Le 01/10/2009, à 08:09

helly

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Visiblement ... ca sent pas bon :s
mais c'est pas très grave vu que tu as une sauvegarde récente ... pas vrai? smile


Archlinux-wmii-dwb.
Un problème résolu ? Faites le savoir en mettant [résolu] à côté du titre de votre topic.
Un problème non résolu ? Faites le savoir en insultant ceux qui cherchent à vous aider.
Un site bleu super remasterised©, un wiki cherchant des volontaires pour traduire un site.

Hors ligne

#3 Le 01/10/2009, à 08:27

SkeRoy

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

en fait c'est un disque dur externe (1 To) qui servait de stock pour les fichiers d'importance mineure / fichiers de grosse taille (des vidéos sans autre sauvegarde, des photos importantes qui sont aussi ailleurs, les archives de mes anciens sites internet sans autre sauvegarde, les setups d'install de quelques programmes compilés ou windowsiens...), surtout que mon disque dur interne (80 Go) ne pouvait plus tout stocker.

Donc non, pour la majorité je n'ai pas de sauvegarde...

En tout cas ce n'est pas fondamentalement un drame, parce que les photos importantes sont aussi ailleurs, mais c'est toujours chiant...

Dernière modification par SkeRoy (Le 01/10/2009, à 08:29)


== Debian Lenny == {Linux User #422949}

Hors ligne

#4 Le 01/10/2009, à 08:31

helly

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Je m'en doutais bien que tu avais pas fait de sauvegarde va , mais c'est sur que si on devait faire des sauvegardes de nos disques de vidéos , les DD 10T seraient déja commercialisés !!

Bon bhéé je crains que tu puisses faire une croix dessus ...


Archlinux-wmii-dwb.
Un problème résolu ? Faites le savoir en mettant [résolu] à côté du titre de votre topic.
Un problème non résolu ? Faites le savoir en insultant ceux qui cherchent à vous aider.
Un site bleu super remasterised©, un wiki cherchant des volontaires pour traduire un site.

Hors ligne

#5 Le 01/10/2009, à 09:03

Autiwa

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Peut-être que je vais pouvoir t'être utile, peut-être pas. Je m'explique. J'ai eu exactement le même soucis. Port USB qui aléatoirement deviennent inactif, mon ordi se fige et je me suis retrouvé avec des erreurs dans mes partitions. J'ai pas du tout fait le lien entre les soucis et je croyais que pour les ports USB c'était un problème de mon ordi. En fait, il s'avère que ma RAM, pourtant neuve, était bourrée d'erreurs.

Je te conseillerais donc de faire un test de la ram via grub qui a une option pour ça (apparemment, le test ne se finit jamais, je l'ai laissé tourner deux heures je crois alors qu'à l'apparition des premières erreurs, j'aurais pu interrompre le test)

Ensuite pour ta partition, il doit être possible de récupérer, je l'ai fait pour mes partitions (j'y ai passé un temps fou d'ailleurs)

Alors déjà, faut tester la ram, parce que si ya des soucis de RAM, ça sert à rien d'essayer de réparer les partitions avec une ram défectueuse.

Ensuite, en lançant un live CD, tu pourras tester tes partitions via fsck. J'avais la ligne de commande avec les bonnes options qui vont bien, mais je l'ai pas sous les yeux. Je devrais l'avoir sous les yeux d'ici quelques heures, si je pense à revenir ici smile .


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#6 Le 01/10/2009, à 09:36

SkeRoy

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Alors en fait c'est vraiment bizarre.

Depuis un second ordi c'est comparable. Donc ça ne doit pas être les ports usb.

J'ai pu réparer le système de fichier, même depuis mon ordi :

# jfs_fsck /dev/sda1

jfs_fsck version 1.1.12, 24-Aug-2007
processing started: 10/1/2009 9.30.42
Using default parameter: -p
The current device is:  /dev/sda1
Block size in bytes:  4096
Filesystem size in blocks:  244190000
**Phase 0 - Replay Journal Log
Filesystem is clean.

Le contenu m'a eu l'air d'être ok. En revanche rebelotte, même depuis cet autre pc, le DDE s'est mis en veille et s'est déconnecté brusquement. Donc RE-fsck. Maintenant le fs est clean, mais je n'ose pas monter le disque dur.

Ce ne serait pas les ports mais plutôt le boitier du DDE...

Je vais quand même tester ma RAM. Merci Autiwa pour le tuyau.
(Ma RAM est cependant censée être neuve. Il y a moins d'un an que la précédente est morte et que j'ai racheté celle-ci).


== Debian Lenny == {Linux User #422949}

Hors ligne

#7 Le 01/10/2009, à 11:45

SkeRoy

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

En fait je ne sais pas.

J'ai pensé un moment au hub, mais c'est pareil en branchant directement.

Maintenant en revanche je remarque que c'est systématiquement en branchant un DDE 2,5" que les DDE 3,5" qui était déjà branchés sont déconnectés. C'est vraiment bizarre...

Ce qui est con c'est que mon but c'est justement de faire une sauvegarde du contenu du 2,5" avant de partir en vacances... Donc il me faut mon 2,5" et un 3,5"...


== Debian Lenny == {Linux User #422949}

Hors ligne

#8 Le 01/10/2009, à 11:54

SkeRoy

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Du coup j'ai lancé un fsck sur le DDE 2,5".

Voici le message d'erreur :

# fsck.vfat -r /dev/sda1 

dosfsck 3.0.1, 23 Nov 2008, FAT32, LFN
There are differences between boot sector and its backup.
Differences: (offset:original/backup)
  76:43/20, 77:55/43, 78:42/55, 79:45/42, 80:32/45, 81:20/32
1) Copy original to backup
2) Copy backup to original
3) No action
? 2
Perform changes ? (y/n) y
/dev/sda1: 11228 files, 1575888/2441533 clusters

Il y avait donc une erreur de boot secteur. J'ai choisi de restaurer la sauvegarde.

La sauvegarde entre les 2 DDE 3,5" vient de finir. Je vais voir si ça change quelque chose...

EDIT : la réparation du boot sector ne change rien. Mais je commence à être sûr que c'est le branchement de ce DDE 2,5" qui déconnecte les autres...

Dernière modification par SkeRoy (Le 01/10/2009, à 11:58)


== Debian Lenny == {Linux User #422949}

Hors ligne

#9 Le 01/10/2009, à 12:24

helly

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

la je suis bien désolée mais je peux pas t'aider plus que ca sad


Archlinux-wmii-dwb.
Un problème résolu ? Faites le savoir en mettant [résolu] à côté du titre de votre topic.
Un problème non résolu ? Faites le savoir en insultant ceux qui cherchent à vous aider.
Un site bleu super remasterised©, un wiki cherchant des volontaires pour traduire un site.

Hors ligne

#10 Le 01/10/2009, à 12:49

Autiwa

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Un DDE 2"5 est alimenté via le port USB, peut-être que t'on ordi a pas suffisamment de jus pour alimenter un DDE 2"5 en plus des autres. Essaye de voir si tu peux pas alimenter de manière extérieure ton 2"5? voire copier du 2"5 vers ton ordi, puis de ton ordi vers les 3"5.

PS : si je t'ai dit ça pour la ram, c'est que mon ordi était neuf. j'ai acheté de la RAM corsair qui avait même pas 3 mois, et pourtant, j'ai galéré pendant 3 mois parce que la ram était pourrie à la base (d'ailleurs je n'achèterais plus jamais corsair. Ils ont fait une erreur en me vendant de la ram défectueuse et n'ont pas voulu me rembourser les frais d'envois (jusqu'en hollande, 16,90€ quand même !))


Pensez à éditer le titre du sujet (en éditant le premier message) pour rajouter un "[Résolu]" ça évite à ceux qui veulent donner un coup de main, d'ouvrir un sujet où il n'y a plus d'aide à donner.

Hors ligne

#11 Le 01/10/2009, à 12:52

sheep

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

EDIT : la réparation du boot sector ne change rien. Mais je commence à être sûr que c'est le branchement de ce DDE 2,5" qui déconnecte les autres...

bonjour,
une question bête: tes disques durs, ils sont auto-alimentés?
Sinon cela pourrait simplement être du à une alim pas assez puissante.

edit: grillé smile

Dernière modification par sheep (Le 01/10/2009, à 12:53)


Save water, Drink beer

Hors ligne

#12 Le 01/10/2009, à 13:36

SkeRoy

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Les disques dur 3,5" non, ils ont une alimentation individuelle.
Le disque dur 2,5" est autoalimenté, mais il possède sa propre batterie aussi (c'est un lecteur de cartes qui copie sur le disque)

Je viens de faire un scandisk depuis windows. Mais ça ne change rien. Le branchement du disque 2,5" entraine le débranchement des 3,5".

Mais en effet, à première vue, si je remplace les DD 3,5" par une clé USB, il n'y a pas de problème. Ca pourrait être une histoire de puissance... mais bon, je n'ai jamais eu de problème auparavent pour sauvegarder d'un DD à l'autre...


== Debian Lenny == {Linux User #422949}

Hors ligne

#13 Le 01/10/2009, à 13:51

SkeRoy

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

En fait dans l'immédiat ce qui m'importe c'est justement ça : est-ce que je peux faire confiance au disque dur 2,5" / lecteur de carte pour partir en vacances, ou bien il vaudrait mieux que je reformate le disque si mon problème est un problème de système de fichier ?


== Debian Lenny == {Linux User #422949}

Hors ligne

#14 Le 01/10/2009, à 16:09

SkeRoy

Re : [RESOLU] Partition corrompue. Plus d'espoir ?

Truc de fou. Je suis en train de faire ma copie entre le 2,5" autonome et le 3,5" d'1 To...

Comment j'ai fait ? Je me suis dit que ça pouvait venir du câble reliant le 2,5" au pc.
J'ai pris le câble que j'utilisais dans le passé. Ca a l'air de marcher.

Une fois la copie finie, je formaterai quand même le disque dur, pour avoir à nouveau quelque chose de propre. On ne sait jamais.

Merci à tout le monde pour vos idées.
@Autiwa : je n'ai pas de memtest dans le grub de ma debian, mais je vais quand même en faire un depuis un live cd prochainement.


== Debian Lenny == {Linux User #422949}

Hors ligne

Haut de page ↑