Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 01/11/2009, à 19:34

astreides

Solution pour internet lent sous karmic[livebox]

Pour ceux qui ont des problèmes avec un internet lent et pour ceux qui ont une livebox, voici un lien pour les résoudre sous karmic : http://www.webdevonlinux.fr/2009/10/07/mon-upgrade-ubuntu-karmic-koala-9-10/
sudo gedit /etc/default/grub
modifier la ligne GRUB_CMDLINE_LINUX="ipv6.disable=1"
puis sudo update-grub
rebooter puis prise en compte

plus pour ceux qui ont une livebox
sudo gedit /etc/dhcp3/dhclient.conf
rajouter cette ligne supersede domain-name-servers 80.10.246.2, 80.10.246.129;
après la ligne send host-name "<hostname>";

PS:
Les pbs dns livebox ne sont pas récents et posent pb quelque soit la distribution linux.
Pour le changement de grub ne pas oublier sudo update-grub et de rebooter ubuntu ensuite

En espérant que cela puisse aider

Dernière modification par ljere (Le 31/12/2009, à 16:21)

Hors ligne

#2 Le 05/11/2009, à 19:47

RK11

Re : Solution pour internet lent sous karmic[livebox]

Merci, pour moi ca a marcher smile

Hors ligne

#3 Le 09/11/2009, à 16:13

antoinedechartreuse

Re : Solution pour internet lent sous karmic[livebox]

Oui, pour moi aussi la connexion est redevenue normale, merci !

Antoine

--
eeepc 1101ha et karmic koala

Hors ligne

#4 Le 09/11/2009, à 23:21

yannoslemanos

Re : Solution pour internet lent sous karmic[livebox]

pour moi ca ne fonctionne pas j'ai un tres gros ping sur google et les pages sont longues a charger
eeepc701 ubuntu minimale.
La 9.04 et la 8.10 fonctionnai parfaitement

Dernière modification par yannoslemanos (Le 09/11/2009, à 23:25)

Hors ligne

#5 Le 10/11/2009, à 00:34

rigoma

Re : Solution pour internet lent sous karmic[livebox]

Trés efficace.Merci

Hors ligne

#6 Le 10/11/2009, à 11:18

xamaco

Re : Solution pour internet lent sous karmic[livebox]

Merci, problème résolu avec la Livebox et Karmic 64 bits.

Je veux ajouter que j'avais déjà fait la manip. pour le démarrage du noyau (ipv6.disable=1). A la suite de ça, l'appel 'ip -a' ne retournait rien sur ipv6. Malgré cela le problème persistait (temps fou perdu avec le DNS).

L'ajout de

supersede domain-name-servers 80.10.246.2, 80.10.246.129;

dans /etc/default/grub est donc ce qui a finalement résolu mon problème.

Dernière modification par xamaco (Le 10/11/2009, à 11:26)

Hors ligne

#7 Le 15/11/2009, à 12:34

zobi8225

Re : Solution pour internet lent sous karmic[livebox]

Ca marche aussi pour moi, il est vraiment incroyable ce problème...... Il faut mettre ça sur le WIKI...

Hors ligne

#8 Le 16/11/2009, à 02:33

fraks

Re : Solution pour internet lent sous karmic[livebox]

Bonjour,

J'ai juste fait la modification dans dhclient.conf et ça fonctionne.
Ca commençait à devenir bien lourd internet en haut débit d'un escargot.
Merci beaucoup.


Il y avait à l'origine 8 merveilles du monde... mais Tux a déclaré qu'il préférait rester modeste.
(Trouvé sur : http://www.php-astux.info/tux-facts.php)

Hors ligne

#9 Le 18/11/2009, à 12:25

decinois

Re : Solution pour internet lent sous karmic[livebox]

Bonjour,
Y aurait il une soluce plus simple pour les nouveaux utilisateurs Ubuntu ?
sad

Hors ligne

#10 Le 18/11/2009, à 19:28

xb28

Re : Solution pour internet lent sous karmic[livebox]

j'aimerai avoir plus d'explication sur la manip car je debut sur ubuntu et je ne vois pas ou il faut taper le texte, et est ce que sa fonctionne avec une freebox car c'est mon cas

Hors ligne

#11 Le 18/11/2009, à 21:24

dudur

Re : Solution pour internet lent sous karmic[livebox]

Bonsoir,

c'est dans le terminal :  accessoires / terminal  tu as un magnifique petit ecran noir qui permet de ( presque) tout faire

pour revenir à la manip du 1er post :

dans le terminal taper (ou copier coller ):  sudo gedit /etc/default/grub faire entree

comme il est dit : modifier la ligne GRUB_CMDLINE_LINUX="ipv6.disable=1" enregistrer

dans la console taper : sudo update-grub
(eventuellement fermer ce terminal puis en rouvrir un)
rebooter pour prise en compte

pour la freebox je ne sais comment cela fonctionne puis que les DNS doivent etre differents

bon courage

Dernière modification par dudur (Le 18/11/2009, à 21:26)

Hors ligne

#12 Le 19/11/2009, à 08:24

decinois

Re : Solution pour internet lent sous karmic[livebox]

Bon ben c'est ok.
C'est meme le TGV !!!
En plus c'est pas sorcier.
Bien suivre le lien d'Astreide ci-dessus. smile
En fait il faut "incerer" (ou C/C) le fameux "ipv6.disable=1" dans la ligne : GRUB_CMDLINE_LINUX="" (entre les deux "")
Ce qui donne : GRUB_CMDLINE_LINUX="ipv6.disable=1"
Ne pas oublier de faire la commande : sudo update-grub dans la fenetre du terminal initial et redemarrer.

Ensuite
(Si vous avez une Livebox)
réouvrir le terminal et taper ou C/C la commande : sudo gedit /etc/dhcp3/dhclient.conf
Puis:
Sous la ligne: send host-name "<hostname>";
Rajouter une nouvelle ligne: supersede domain-name-servers 80.10.246.2, 80.10.246.129;
Fermer en enregistrant.
Ne pas oublier de faire la commande : sudo update-grub dans la fenetre du terminal initial et redemarrer.

Et voila.
Firefox retrouve toute sa rapidité. Et c'est peu dire.
J'espere que ca aidera. Et pas de panique. Pour moi c'etait la premiere fois que j'ouvrais ce fameux Terminal.:)

A +

Hors ligne

#13 Le 19/11/2009, à 21:42

Little Ghost

Re : Solution pour internet lent sous karmic[livebox]

J'ai essayé la première manip mais rien de mieux. En ce qui concerne la seconde, je fonctionne avec SFR et une ancienne Tele2Box (je sais, pourquoi faire simple...). Quelqu'un sait-il où trouver ce que l'on doit entrer dans le deuxième commande, à propos des DNS ?

Merci. (ça rame c'est terrible...)

Hors ligne

#14 Le 19/11/2009, à 21:54

Little Ghost

Re : Solution pour internet lent sous karmic[livebox]

OK, j'ai trouvé une liste de DNS et j'ai ajouté a ligne avec ceux de Tele2 (qui sont les mêmes que les anciens de SFR, apparemment toujours actifs). Pour ceux qui en ont besoin, les voici :

DNS Primaire : 212.30.96.108
DNS Secondaire : 213.203.124.146

Seulement voilà : après avoir tapé la commande d'update du grub, le terminal me répond :

                             /etc/default/grub: 11: supersede: not found

Que pasa ?

Hors ligne

#15 Le 20/11/2009, à 18:43

Henrira

Re : Solution pour internet lent sous karmic[livebox]

Merci pour ces infos.
La modification du grub a résolu les lenteurs de connexion d'une façon spectaculaire.
J'utilise une livebox de première génération, la modification du fichier dhclient.conf n'apporte aucun plus je l'ai donc abandonné.

Hors ligne

#16 Le 20/11/2009, à 22:47

eranthys02

Re : Solution pour internet lent sous karmic[livebox]

Bonsoir,
Je débute avec linux et galère avec la livebox depuis Karmic. Lorsque je copie   sudo gedit /etc/default/grub
dans le terminal, rien ne s'affiche ! Es possible ? ou dois-je encore progresser ?
Merci.

Hors ligne

#17 Le 20/11/2009, à 23:26

ami_bagueri

Re : Solution pour internet lent sous karmic[livebox]

BOnjour tout le monde.
c'est vraiment interessant comme sujet. Moi cela fait une semaine que je cherche à regler le problème de ma connexion car elle faible.
j'ai une freebox, et une livebox et sur les deux c'est vraiment lent.
quelqu'un sait si la manipe pourrai m'aider?
Merci.
voilà ce que donne ces commandes :

laptop:~$ sudo lshw -C network
*-network               
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wmaster0
       version: 01
       serial: 0c:60:76:40:f4:4f
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath9k ip=192.168.0.10 latency=0 multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f1200000-f120ffff
  *-network UNCLAIMED
       description: Ethernet controller
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list
       configuration: latency=0
       resources: ioport:2000(size=256) memory:f1004000-f1004fff(prefetchable) memory:f1000000-f1003fff(prefetchable) memory:f1010000-f101ffff(prefetchable)

ET:

   -laptop:~$ iwconfig
lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"freebox_kolb"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 92:84:62:B4:1C:54   
          Bit Rate=0 kb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=30/70  Signal level=-80 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Encore merci d'avance

Hors ligne

#18 Le 21/11/2009, à 01:15

dudur

Re : Solution pour internet lent sous karmic[livebox]

à eranthys02

bizarre cette affaire, c'est la bonne commande.

tu peux verifier l'existence de ce fichier avec :

poste de travail -  Systeme de fichiers  puis /etc puis /default  le fichier grub doit apparaitre au milieu des autres

un clic dessus, il est lisible avec gedit

il y a de fortes chances qu'il soit verrouille il faut donc donner permission pour écriture

taper dans le terminal : sudo chmod 777 /etc/default/grub

faire sauvegarde au cas ou : sudo cp /etc/default/grub  /etc/default/grub.bak

faire la modification sur le fichier comme recommandé précédemment

enregistrer

remettre les permissions d'origine sudo chmod 644 /etc/default/grub

Hors ligne

#19 Le 21/11/2009, à 11:36

mloupiot

Re : Solution pour internet lent sous karmic[livebox]

@ eranthys02
Que veux-tu dire ? rien ne s'affiche dans le terminal ? Si c'est ça : pour coller dans un terminal : CTRL+MAJ+V (CTRL+MAJ+C pour copier)

Hors ligne

#20 Le 21/11/2009, à 19:44

eranthys02

Re : Solution pour internet lent sous karmic[livebox]

a dudur,
merci pour ta réponse
Suite à tes explications je suis passé par poste de travail -  Systeme de fichiers  puis /etc puis /default mais là aussi pas de fichier grub    ??? mais dans /etc il y a fichier grub.d ?

j'ai désactivé Ivp6 dans firefox et là effectivement je gagne énormément en rapidité, mais j'aimerai bien comprendre le "mystère" grub.

Hors ligne

#21 Le 21/11/2009, à 22:44

dudur

Re : Solution pour internet lent sous karmic[livebox]

On parle bien de Karmic Koala ?

regardes cette doc sur grub :  http://doc.ubuntu-fr.org/grub-pc

cordialement

Hors ligne

#22 Le 22/11/2009, à 12:00

eranthys02

Re : Solution pour internet lent sous karmic[livebox]

a dudur
merci por la doc. Problème résolu.
effectivement lorsque migration de jaunty 9.04 vers karmic la commande est
sudo gedit /boot/grub/menu.lst
puis
placer ipv6.disable=1 sur les lignes contenant kernel exemple:
kernel        /boot/vmlinuz-2.6.31-14-generic root=UUID=ae02ece1-192f4996-8067-144aaa760f93 ro ipv6.disable=1 quiet splash

cordialement

Hors ligne

#23 Le 24/11/2009, à 21:19

Little Ghost

Re : Solution pour internet lent sous karmic[livebox]

Je n'avais pas copié la seconde partie au bon endroit. Maintenant tout est fait comme indiqué, mais... Ça rame toujours !!!

Hors ligne

#24 Le 24/11/2009, à 21:48

lalounator

Re : Solution pour internet lent sous karmic[livebox]

Bonsoir à tous,

sauriez-vous me dire si le problème survient uniquement avec les utilisateurs qui ont une Livebox ou alors est-ce possible que cela survienne chez d'autres fournisseurs (j'habite en Allemagne et j'ai donc un fournisseur d'accès allemand qui s'appelle Arcor)

Merci d'avance !


lalounator

Hors ligne

#25 Le 24/11/2009, à 21:53

Little Ghost

Re : Solution pour internet lent sous karmic[livebox]

Personnellement je n'ai pas de Livebox et j'ai eu ce problème... J'ai trouvé apparemment la solution (enfin celle qui me convient en tout cas) sur ce site même, voici l'adresse (je n'ai pas lu comment on fait pour insérer un lien...)

http://doc.ubuntu-fr.org/karmic_internet_problemes

En espérant que ça te réussisse aussi bien qu'à moi !

Bonne chance !

Hors ligne

Haut de page ↑