Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 10/11/2009, à 15:19

patoncito1

ventilo du processeur non détecté sous karmic 64

Bonjour à tous,

Je ne sais pas si mon problème est réellement en relation avec l'architecte 64 bits de mon système mais je poste tout de même dans cette rubrique.

Voilà j'ai récemment acheté une belle bête de marque taïwanaise, c'est le BenQ Joybook S57B, smile et après avoir installé la version 64 de karmic, je me suis vite aperçu que le ventilo du proc n'était pas détecté sad alors que sous windows le pb n'existe pas.
Csc : la machine chauffe et coupe violemment au bout de 10/20 minutes d'utilisation.
J'ai bien essayé d'installer et de configurer lm-sensor, mais aucun ventilo n'est reconnu. Je me demande si ce ne serait pas le noyau utilisé dans cette version qui serait en cause car avant d'installer ubuntu j'avais loadé une debian testing... avec le même résultat.
Bref je suis un peu perdu et me demande bien sur quelle piste avancer pour résoudre ce problème de surchauffe. Actuellement je suis en train de me demander si une solution provisoire ne serait pas d'installer un os virtuel avec un win guest juste pour faire fonctionner le ventilateur ??
Avez-vous connu pareil problème sur d'autres modèles de portable, comment en êtes-vous venu à bout ?

Hors ligne

#2 Le 10/11/2009, à 16:27

ppmt

Re : ventilo du processeur non détecté sous karmic 64

Je vais sans doute dire une betise mais c'est pas le BIOS qui s'occupe de faire tourner le ventilo normalement?

Sous mon systeme je n'utilise pas lm-sensors et mon ventilo tourne quand il faut

sur certain PC le ventilo du CPU ne tourne que si il y en a besoin...pour etre plus silencieux...


le dock dont vous avez toujours rêvé  Cairo-Dock
irc://irc.freenode.net/#Cairo-Dock-fr

Hors ligne

#3 Le 10/11/2009, à 18:08

patoncito1

Re : ventilo du processeur non détecté sous karmic 64

Oui effectivement il semble que ce soit souvent le bios qui gère le ventilateur du processeur, mais dans mon cas aucun menu n'y fait référence.
De toute façon, la logique voudrait qu'il soit reconnu dans le matériel.
Et comme il ne démarre jamais sous linux à froid comme à chaud le problème persiste.
J'ai même peur de cramer le proc ou la carte mère tellement le dessous de la machine est chaud...
Vraiment je commence à désespérer de pouvoir utiliser karmic normalement sur mon ordi hmm
Il y aurait il une solution logicielle ou matérielle pour refroidir ce portable ??

Hors ligne

#4 Le 10/11/2009, à 18:21

brakbabord

Re : ventilo du processeur non détecté sous karmic 64

Il y a eu un sujet similaire il y a quelques mois, mais j'arrive pas à le retrouver.
Si c'est le ventilo CPU, alors oui normalement c'est le bios qui gère.

Mais pour celui de la carte graphique, pas forcément.

Hors ligne

#5 Le 11/11/2009, à 11:19

patoncito1

Re : ventilo du processeur non détecté sous karmic 64

sad L'installation de 2K en virtualbox ne résoud pas mon problème : le ventilo reste muet. Mon processeur monte rapidement à 60° et coupe aux alentour de 75.
A l'aide............................. sad sad sad ubunteros en detresssssssssssssssseeeeeeeeeeeeeeee !!!!!!!

Hors ligne

#6 Le 11/11/2009, à 15:18

brakbabord

Re : ventilo du processeur non détecté sous karmic 64

http://forum.ubuntu-fr.org/viewtopic.php?id=356101

Essaie une mise à jour du bios aussi, on ne sait jamais

Dernière modification par brakbabord (Le 11/11/2009, à 15:19)

Hors ligne

#7 Le 11/11/2009, à 20:09

ppmt

Re : ventilo du processeur non détecté sous karmic 64

brakbabord va pas etre content...mais as tu essaye d'installer une version 32 bit de linux des fois que c'est pas le BIOS qui controle ca pour toi?

mais perso j'ai jamais vu de cas ou linux controle d'office le fan du cpu....
on peut l'influencer comme le montre le lien de brakbabord mais de la a le faire d'office

Meme windows ne doit pas faire ca


le dock dont vous avez toujours rêvé  Cairo-Dock
irc://irc.freenode.net/#Cairo-Dock-fr

Hors ligne

#8 Le 12/11/2009, à 11:02

patoncito1

Re : ventilo du processeur non détecté sous karmic 64

D'après vos message, je comprends que mon OS interprète mal les infos du bios...

ppmt, je viens d'essayer une version 32 bits, le problème est strictement identique, l'arch 64 n'est donc pas à remettre en cause.
brakbabord, merci pour le script, je vais tenter de suite après mise à jour du bios.
Si ça fonctionne tjs pas, je pense me diriger au moins provisoirement vers une autre distribution non debian-like.

Hors ligne

#9 Le 20/11/2009, à 04:08

patoncito1

Re : ventilo du processeur non détecté sous karmic 64

Salut les gars,
j'ai tenté le script proposé par ppmt,
mis à jour le bios et même réinstallé une version 32. RIen n'y a fait.
Je suis donc passé sur Mandriva 2010. J'en suis vraiment déçu car je suis vraiment partisan d'Ubuntu mais là j'avais vraiment trop peur de griller mon matos.
Merci à tous pour votre aide !

Hors ligne

#10 Le 20/11/2009, à 15:54

ppmt

Re : ventilo du processeur non détecté sous karmic 64

j'ai rien propose du tout moi wink

Sous Mandriva ton ventilo marche? c'est bizarre ca alors

je dois avouer que jene sais pas quoi recommande.

Essayer avec une version anterieur de Ubuntu pour voir?


le dock dont vous avez toujours rêvé  Cairo-Dock
irc://irc.freenode.net/#Cairo-Dock-fr

Hors ligne

#11 Le 21/11/2009, à 19:02

micro-ice

Re : ventilo du processeur non détecté sous karmic 64

Bonsoir.

Ce sujet m'intéresse, ce script, il fonctionne comment ?

#!/bin/bash

# Automatic fan controller
# Tested on a eee 1005ha running Ubuntu 9.10 Karmic Koala

# Test with 'sudo eeefan background'.
# If works, 'sudo cp eeefan /etc/rc2.d/S99eeefan'
# and reboot.

temperature_reading=/sys/devices/virtual/thermal/thermal_zone0/temp
fan_control=/sys/devices/platform/eeepc/hwmon/hwmon1/pwm1
fan_manual_switch=/sys/devices/platform/eeepc/hwmon/hwmon1/pwm1_enable

# Set critical temperature
TEMP_CRITICAL=57

# Set critical temperature interval size. See figure for details
TEMP_INTERVAL_SIZE=5

# Maximum fan speed
FAN_SPEED_MAX=55

eeefanupdate() {

    # Get temperature reading
    TEMP=$(cat $temperature_reading)
    TEMP=$(($TEMP / 1000)) 

    # Calculate optimum fan speed
    X=$(echo "$FAN_SPEED_MAX*1/(1+e(-($TEMP-$TEMP_CRITICAL)/$TEMP_INTERVAL_SIZE))" | bc -q -l)
    # Workaround to convert it to nearest integer
    FAN_SPEED=$(echo "scale=0; $X/1.0" | bc -q -l)
    # Set fan speed
    FAN_SPEED=$(($FAN_SPEED * 250 / 100)) 
    echo $FAN_SPEED > $fan_control
}

        # Turn on manual fan control
        echo 1 > $fan_manual_switch

        # Run eeefanu, then wait 10 seconds.

        while [ 1 ]
        do
            eeefanupdate
                sleep 10
        done

Si j'ai bien compris il permait de modifié la vitesse du ventillo ?

Hors ligne

#12 Le 11/12/2009, à 15:09

Le Pyrénéiste...

Re : ventilo du processeur non détecté sous karmic 64

Je confirme même pb sur HP 6830s processeur T5870, je suis obligé de surveiller la température du processeur lors de l'exécution de processus lourd (dans mon cas photo HDR). Je suis sous Karmic 64 bits, le bios est bien configuré la ventilation est active.


Fou d'3000...
http://fou3000.over-blog.com/

Hors ligne

#13 Le 14/01/2010, à 12:12

patoncito1

Re : ventilo du processeur non détecté sous karmic 64

Quelques semaines plus tard...
sad:(:(
je reviens sur ce problème de ventilateur. Peut-être d'autres personnes auront connu pareille déconvenue.
Suite à la surchauffe provoquant l'arrêt du processeur sous karmic 64, je me suis tourné vers Mandriva 2010. La prise en charge semblait bien meilleure mais il s'est avéré que le même problème revenait au bout de plusieurs heures d'utilisation.
A noter que OpenSuse 11.2 fait tourner la machine correctement mais je ne souhaite pas utiliser cette distribution. J'ai donc tenté de me retourner vers Slackware 13 et dérivée (zenwalk 6.2). Ces distributions 32 ou 64 bits prennent très bien en compte mon ventilo mais le serveur X ne fonctionne pas sans doute dû au caractéristiques graphiques peu communes de la machine.
ATI Mobility Radeon™ HD 4650
15.6" WXGA (1366x768) 16:9 LED backlight

J'ai donc tenté un retour sur ubuntu en testant la version alpha de Lucid...
toujours le même problème de surchauffe
Je ne sais plus trop sur quel pied danser, je suis actuellement sous 7 home premium livrée avec la machine... le ventilo est reconnu, la carte graphique aussi mais bon...
Merci aux bonnes âmes qui ont eu des problème à installer linux sur des machines neuves de me donner quelques pistes.

Hors ligne

#14 Le 14/01/2010, à 15:40

Le Galéanthrope

Re : ventilo du processeur non détecté sous karmic 64

Pas sur que ce soit le même problème mais j'ai déjà eu un ubuntero avec un problème similaire, tu devrais jeter un coup d'oeil au sujet :
http://forum.ubuntu-fr.org/viewtopic.php?id=339878


Miaou ! ー Nyamiou Le Galéanthrope

Hors ligne

Haut de page ↑