Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 16/04/2006, à 19:12

meska83

Compilation g++ impossible

Slt ! Eh bien voilà, jsuis nouveau sur Ubuntu, jdebarque de windows avec Devc++ pour programmer...
Quand j'essaie de créer l'executble, j'ai ces messages d'erreurs :

root@meska83-scrup-2006:~/code/buffer_overflow# g++-4.0 overflow.o -o overflow

overflow.o:(.rodata+0x0): définitions multiples de « _fp_hw »
/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crt1.o:../sysdeps/i386/elf/sta rt.S:65: défini pour la première fois ici
overflow.o: dans la fonction « __data_start »:
: définitions multiples de « __dso_handle »
/usr/lib/gcc/i486-linux-gnu/4.0.2/crtbegin.o:(.data+0x0): défini pour la premièr e fois ici
overflow.o: dans la fonction « _init »:
/build/buildd/glibc-2.3.5/build-tree/i386-libc/csu/crti.S:36: définitions multip les de « _init »
/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crti.o:/build/buildd/glibc-2.3 .5/build-tree/i386-libc/csu/crti.S:12: défini pour la première fois ici
overflow.o: dans la fonction « _start »:
../sysdeps/i386/elf/start.S:65: définitions multiples de « _start »
/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crt1.o:../sysdeps/i386/elf/sta rt.S:65: défini pour la première fois ici
overflow.o: dans la fonction « _fini »:
/build/buildd/glibc-2.3.5/build-tree/i386-libc/csu/crti.S:52: définitions multip les de « _fini »
/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crti.o:/build/buildd/glibc-2.3 .5/build-tree/i386-libc/csu/crti.S:(.fini+0x0): défini pour la première fois ici
overflow.o:(.got.plt+0x0): définitions multiples de « _GLOBAL_OFFSET_TABLE_ »
/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crt1.o:../sysdeps/i386/elf/sta rt.S:65: défini pour la première fois ici
overflow.o:(.rodata+0x4): définitions multiples de « _IO_stdin_used »
/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crt1.o:../sysdeps/i386/elf/sta rt.S:71: défini pour la première fois ici
overflow.o: dans la fonction « __data_start »:
: définitions multiples de « __data_start »
/usr/lib/gcc/i486-linux-gnu/4.0.2/../../../../lib/crt1.o:../sysdeps/i386/elf/sta rt.S:65: défini pour la première fois ici
collect2: ld a retourné 1 code d'état d'exécution

Je cherche depuis hier soir pour trouver une solution, mais rien n'y fait. G bien trouvé quelques pistes, comme le probleme des dependances... Mais j'ai aussi du mal à trouver des infos la dessus (peut etre que je cherche mal...), puis le message d'erreur ne me parle pas de dependances donc...

Le fichier objet est bien créé et les paquets suivants sont installés :
libc6-dev = 2.3.5
g++ = 4:4.0.1-3
g++40 = 4.0.1
entre autres, mais je telecharge lextension pour faire du c sous eclipse et jpeu pas accéder aux paquets pour l'instant.

Merci d'avance pour l'aide que vous pourriez m'apporter, jnai pas l'habitude de poster avant d'avoir mal au crane...

#2 Le 18/04/2006, à 11:14

meska83

Re : Compilation g++ impossible

Bon bah voilà, ca marche ! Merci pour votre aide lol !
Ca marche, mais je n'ai toujours pas trouvé la cause du probleme. Ce n'était pas un probleme de dependances, nin, a priori, une erreur de commande. Peut-être des interactions entre bibliothèques...

En tout cas, j'ai formaté, ca ne marchait toujours pas (autres erreurs), j'ai installé l'edi code::blocks, un clone de Dev-c++ qui fonctionne sous linux. Et là ca marche, toujours en utilisant le compilateur g++.
En gros, pour finir, l'ereur venait de moi (pour les probs après formatage en tout k), j'aurais aimé savoir ce que j'avais fait de mal, mais bon... ca marche.

Ps : Je recommande amplemant l'editeur Code::Blocks, pour ceux qui viennent de Windows/Dev-C++ et qui sont un peu perdu. Si vous avez besoin de programmer dans l'ugence, que vous n'avez pas forcément le temps d'étudier les subtilité de linux, prenez cet éditeur. Perso, je le trouve largement meilleur que Dev-C++. Allez voir google !

edit : J'ai créé le sujet en tant qu'invité donc je ne peut pas le marquer résolu, dsl.

Dernière modification par meska83 (Le 18/04/2006, à 11:15)

Hors ligne

Haut de page ↑