Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#76 Le 18/01/2010, à 19:33

vs20-100

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

j'ai 2 hdd
l'un avec les données (le F)
le 2° est partitionné :C avec xp et E avec ubuntu(30 Go)

donc pour moi c'est hd0,2

Dernière modification par vs20-100 (Le 18/01/2010, à 19:50)

Hors ligne

#77 Le 18/01/2010, à 21:39

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

malbo a écrit :

Ensuite, il est demandé de faire ça :
http://forum.ubuntu-fr.org/viewtopic.php?pid=2811956#p2811956
Peux-tu poster le résultat obtenu ? Et préciser (si tu peux) d'après ce résultat, sur quelle partition se trouve Ubuntu?

vs20-100, peux-tu répondre à cette partie ?

D'autre part, tu écris "E avec ubuntu(30 Go)". Peux-tu détailler un peu plus s'il te plait ?
1) Quelle est la taille du disque E vu par Windows (combien de Go)?
2) Est-ce qu'il existe bien un dossier ubuntu dans le disque E:
3) quelle est la taille du dossier ubuntu (combien de Go) vu par Windows ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#78 Le 19/01/2010, à 10:06

vs20-100

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

malheureusement je n'arrive pas a booter sur le cd(j'ai verifier ds le bios et je demarre bien le boot sur cd(le cd xp marche!) et ma cle usb n'est pas reconnu au boot(2° choix).

ds xp la taille de E est 40 go et ubuntu fait 30 go

j'espere qu'avec le peu de renseignement que je vous donne , vous pourrez m'aider.


carte msi pcu amd3800+
ram 1go /xp et ubuntu 9.10 installé avec wubi

Hors ligne

#79 Le 19/01/2010, à 13:53

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Quand tu choisiras de démarrer sur ubuntu et que tu arrives à l'invite de commande Grub, il faut taper la commande ls /boot (c'est un L minuscule) comme ceci :
sh:grub>ls /boot
ça doit te donner la liste de tous les fichiers contenus dans le dossier /boot de ton Ubuntu. S'il n' y a rien, c'est inquiétant.
Tu peux aussi taper cette commande et dire ce que tu vois à l'écran (tu recopies sur un papier et tu postes) :
sh:grub>set

Nota : les commandes que je viens de te donner sont issues de cette doc :
https://help.ubuntu.com/community/Grub2#Rescue%20Mode

Dernière modification par malbo (Le 19/01/2010, à 14:07)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#80 Le 20/01/2010, à 15:54

vs20-100

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

merci malbo

quand je fait ls /boot j'obtiens error:file not found

quand je fait set j'obtient :

color_highlight=
color_normal=
pager=
prefix=(hd0,1)/boot/grub
root=hd0,1
show_panic_message=true

à priori le boot se fait sur hd0,1 malgrès que le fichier ubuntu soit sur la 2° partition(une concéquence de wubi?)

bizarrement je n'arrive pas à rentrer ds le fichier "disk" ds ubuntu ==>le message de windows me dit qu'il est ds l'incapacité de l'ouvrir!?!

maintenant j'essaye les lignes de commande étape 1 et 2
set root=(hd0,1)
loopback loop0 ubuntu/disks/root.disk

et on me répond :error invalid file name 'ubuntu/disks/root.disk

je pense qu'il y a plus de dégats que prévu!!!

je ne voulais pas réinstallé ubuntu mais j'ai peur que se soit la derniere solution; à moins que tu es une meilleur idée.

depuis karmic koala cela fait 2 fois que je le réinstalle ,j'aurai bien voulu trouver une solution moins radical...

Dernière modification par vs20-100 (Le 20/01/2010, à 16:10)

Hors ligne

#81 Le 20/01/2010, à 16:28

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Moi, si je commute vers l'invite de commande Grub (en appuyant sur la touche C quand le menu GRub apparait), j'ai à peu près la même chose sauf vers la fin où je n'ai que ces deux lignes et je crois que c'est significatif :

prefix=(hd0,1)/boot/grub
root=loop0

Moi je passe bien l'étape root=loop0, c'est à dire que Grub arrive bien à fouiller dans ubuntu/disks/root.disk pour créer loop0 et ça se termine par root=loop0
Alors que toi, tu as les deux lignes qui ne sentent pas bon :

root=hd0,1
show_panic_message=true

Oui, je constate comme toi qu'il y a une ligne bizarre prefix=(hd0,1)/boot/grub parce que moi non plus je n'ai pas ubuntu dans (hd0,1). Je suis loin de tout comprendre moi-même...

D'autre part tu écris :"bizarrement je n'arrive pas à rentrer ds le fichier "disk" ds ubuntu ==>le message de windows me dit qu'il est ds l'incapacité de l'ouvrir!?!"
Là, ça sent bien le brun. En effet, c'est complètement anormal que tu ne puisses pas rentrer dans le dossier disks (tu as écris "disk" mais je pense que tu voulais écrire "disks") de ubuntu. Moi, si je vais dans le chemin (oui, j'ai ubuntu sur mon disque L) :
L:\ubuntu\disks
j'y trouve un fichier nommé root.disk de 10 Go environ, un fichier nommé swap.disk de 260 Mo environ et un dossier boot qui contient lui-même un dossier grub qui est vide.
Je pense que tu es quitte pour une réinstallation complète.
Après que tu auras réinstallé, que tu auras fait tes mises à jour et remis tous tes logiciels préférés, pense à faire une sauvegarde régulière de ton ubuntu pour éviter de réinstaller :
http://forum.ubuntu-fr.org/viewtopic.php?pid=2276187#p2276187
Le plus fiable étant de passer à une installation classique de Ubuntu sur partitions Linux pour ne pas rester trop longtemps avec Wubi qui semble assez instable depuis Ubuntu 910

Dernière modification par malbo (Le 20/01/2010, à 16:55)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#82 Le 20/01/2010, à 16:47

vs20-100

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

merci malbo

donc a priori pas d'autre solution que de réinstallé

Dernière modification par vs20-100 (Le 20/01/2010, à 19:16)

Hors ligne

#83 Le 21/01/2010, à 09:08

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

malbo a écrit :

Oui, je constate comme toi qu'il y a une ligne bizarre prefix=(hd0,1)/boot/grub parce que moi non plus je n'ai pas ubuntu dans (hd0,1). Je suis loin de tout comprendre moi-même...

Ce point de détail, je viens de l'éclaircir : la partition (hd0,1) est celle sur laquelle il y a les dossiers visibles depuis Windows XP : wubildr et wubildr.mbr. J'ai réussi à le savoir parce que sur un de mes PC, j'avais installé Ubuntu par Wubi depuis une partition XP qui n'était pas la partition habituelle (hd0,1) mais une partition sur un autre disque dur. Pour résumer, pour la plupart des gens qui installent Ubuntu par Wubi, je pense qu'il est normal de trouver cette ligne :
prefix=(hd0,1)/boot/grub
Mais que cette ligne ne dit pas du tout sur quelle partition se trouve le dossier ubuntu.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#84 Le 22/01/2010, à 11:20

vs20-100

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

je me doutais que s'était ça!

bon j'ai tout réinstallé

et comme la 1° fois quand je vais ds l'utilitaire de disque il m'affiche que ma partition est bien
sda2 soit hd0,2 et windows en sda1

se qui est bête ,c'est que la nouvelle install a tjs grub 1.97 beta au démarrage ,donc ds peu de temps, je risque de me retrouver avec le même problème,mais cette fois j'ai fais une sauvegarde du fichier "ubuntu" et j'espère que la mise à jour de grub a été amélioré .

Hors ligne

#85 Le 22/01/2010, à 14:25

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

vs20-100 a écrit :

mais cette fois j'ai fais une sauvegarde du fichier "ubuntu"

Avec cette précaution, j'espère que tu pourras "passer la barre" de la prochaine mise à jour du noyau. C'est vrai que c'est chiant...
Je ne sais pas si tu as pu installer le dossier ubuntu sur une autre partition que le disque C: de Windows. Si c'est le cas (si ton dossier ubuntu est sur le disque D: ou autre), je t'engage vivement à ne pas stocker de documents dans le /home de ubuntu mais dans un dossier spécial. Je développe le concept là :
http://forum.ubuntu-fr.org/viewtopic.php?pid=3100472#p3100472
Le but étant que le dossier ubuntu ne contienne que les fichiers système de ubuntu et aucun document (ou le minimum mais rien de précieux). Comme ça, si tu es emmerdé avec ubuntu, tu restaures ta sauvegarde et hop, c'est reparti sans avoir besoin se s'attendrir sur les moignons de ton ubuntu malade.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#86 Le 26/01/2010, à 13:45

nadiarezgui

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Bonjour Malbo!

Sais tu exactement quel mise à jour cause ce probleme? parce que là mon kubuntu me propose d'autres mise à jours et si je les fais pas j'aurai pas de son en streaming.
il me prpose presque 150 mise à jour et j'ai peur que ça me cause le meme prblm!

Hors ligne

#87 Le 26/01/2010, à 14:05

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

nadiarezgui,
A mon avis, si tu vois dans tes mises à jour ce genre de paquet :
linux-image-X.X.XX-XX-generic
qui commence donc par "linux-image..", je pense que c'est une mise à jour du noyau donc une mise à jour à risque pour ceux qui ont installé Ubuntu par Wubi. Attention : je ne te dis pas de ne pas faire cette mise à jour, je te dis seulement qu'avant de faire la mise à jour (ou les mises à jour parce que souvent elles sont plusieurs à graviter autour), tu redémarres le PC sous Windows et tu fais une sauvegarde :
http://forum.ubuntu-fr.org/viewtopic.php?pid=2276187#p2276187


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#88 Le 27/01/2010, à 13:42

nadiarezgui

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Merci infiniment Malbo!
j'ai installé toutes les mise àjour sauf 5, et ça a demarré correctement ^_^!
je vais jouer à pile ou face avec les 5 autres mises àjours et on verra c'est laquel qui pause probleme smile
merci encore

Hors ligne

#89 Le 27/01/2010, à 19:01

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Pour info nadiarezgui, il existe un historique des mises à jour qui est consultable assez facilement (sauf quand tu es dans la panade avec "Minimal BASH-like"). Pour consulter l'historique, c'est Système > Administration > Gestionnaire de paquets Synaptic puis dans la fenêtre de Synaptic qui va s'ouvrir après que tu as donné ton mot de passe, c'est Fichier > historique.

Dernière modification par malbo (Le 27/01/2010, à 19:01)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#90 Le 31/01/2010, à 12:29

Mangatd

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Bonjour,

Hier, quand j'ai démarré Ubuntu, le chargement de l'écran orange qui est juste avant celui de l'ouverture de session était plus lent que d'habitude. Après peut-être 2 minutes, il était enfin apparut. Mais, après m'être connecté, nouvelle attente plus longue que la normale. La, je n'ai pas eu la patience d'attendre, j'ai redémarré le PC comme un bourrin à coup de bouton reset. J'ai redémarré sous Windows XP, fait un "chkdsk /r" (c'est une commande qui peut nous sauver d'un "bug BusyBox", qui peut arriver soit quand Windows plante et qu'on le redémarre, soit dans des circonstances mystérieuses). Sait-on jamais, je me suis pas mal servi de Windows XP ces derniers jours, alors, peut-être qu'il a fait quelque chose...

J'ai donc perdu une bonne partie de mon après-midi, et, quand enfin la vérification de disque était terminée, j'ai redémarré sous Ubuntu, et là, horreur :

Minimal BASH-like line editing is supported. For
the first word, TAB lists possible command
completions. Anywhere else TAB lists the possible
completions of a device/filename. ESC at any time exits.

Bon, vraisemblablement, le "chkdsk /r", au lieu de résoudre mon problème, a fait exactement l'inverse ! yikes

J'ai donc essayé de suivre les conseils du 1er post. Mon disque dur selon Ubuntu (lancé en live CD) est hd0,1
Ensuite, j'ai copié/collé la commande du 1er post en changeant le numéro du disque, donc :

sh:grub>set root=(hd0,1)

Sauf que le terminal me dit que je l'ai mal tapée ! (j'arrive plus à retrouver le message exact)
Même chose si je met hd0,0

Mais bon... je me suis rendu compte que de toute façon je perdais mon temps quand j'ai vu que le dossier ubuntu qui se trouve dans C:\ (Sous Windows, bien sur !) ne pesait plus que... 695 Mo ! ! mad

Bon, de toute évidence, il faut que je réinstalle Ubuntu, ceci dit je serais curieux de savoir ce qui s'est passé...:/

De toute façon, j'ai un avis de plus en plus mitigé sur Wubi :
- J'ai Ubuntu Hardy Heron depuis maintenant 1 an (à peu près) et j'ai du réinstaller l'OS environ 6 fois (je vous promet que c'est pas une blague ! ! sad ), la plupart du temps à cause de BusyBox (pas toujours possible de résoudre à coup de "chkdsk /r"). Dans ces cas là aussi d'ailleurs, j'ai remarqué que des fichiers disparaissaient du dossier ubuntu ;

- Ubuntu vas plus vite en Live CD que quand il est lançé façon Wubi (bon, après c'est peut-être par ce que j'avais installé des programmes, aussi, m'enfin... roll

- Ces derniers temps, mon Ubuntu freezait autant qu'un Windows 9x (punaise mais vous allez jamais me croire, je vais attirer les foudres de tout le forum...)

Alors peut-être que si j'investissais dans un disque dur je m'installerais Ubuntu avec la méthode "classique". Je vais peut-être enfin comprendre pourquoi les gens disent que Linux est rapide et qu'il plante jamais (en plus une vidéo en plein écran sur un site comme Youtube ou Dailymotion me croque le processeur de 2.01 GHz à 100 %, ce qui n'arrive pas sous Windows, alors...)

Bon, en tout cas ça prouve bien que pour Wubi il faut suivre le conseil de malbo et faire une sauvegarde de son dossier ubuntu...

Dernière modification par Mangatd (Le 12/02/2012, à 13:16)


Si tu aimes jardiner, achète Windows, il t'aidera à mieux planter XD
Source : http://www.siteduzero.com/tuto-50-14941.html (page morte, je ne sais plus ce que c'était à l'origine)

Hors ligne

#91 Le 01/02/2010, à 14:17

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Mangatd,
Ce matin, je viens de me payer aussi une petite séance de "sh:grub>" et moi aussi j'ai bien la moutarde qui monte au nez avec cette vacherie de Wubi. Moi, ce matin, il n'y avait rien à faire : j'arrivais à démarrer sur tous les noyaux avec la procédure du post #1 mais impossible de rétablir un démarrage normal (avec le menu pour choisir entre les différents noyaux). Quelque soit le noyau sur lequel je démarrais, arrivé sur le bureau, j'ai tenté de passer cette commande dans un terminal :
sudo update-grub
Mais ça n'a jamais pu réparer Grub. Il a fallu que je désinstalle tout ce qui s'appelle 2.6.31-17 (le noyau le plus récent) pour finir par retrouver le démarrage "normal". Si vous voulez tenter la chose pour voir si ça résout pour vous :
Système > Administration > Gestionnaire de paquets Synaptic
Dans le champ de recherche de la fenêtre Synaptic, vous tapez 2.6.31-17 et vous supprimez tous les paquets qui "viennent avec" (qui sont proposés pour désinstallation parce qu'ils sont liés).
Au redémarrage du PC, ça ne marchera encore pas, si vous êtes comme moi, il faudra encore y aller avec la procédure du post #1 puis un :
sudo update-grub
Et enfin au redémarrage du PC, ça veut bien démarrer avec le menu Grub et tout et tout.
J'ai envie de piler le PC (en pensée) parce que du coup, je ne sais pas comment je vais réinstaller ce putain de noyau 17.

Edit : Finalement un peu calmé, j'arrive à réinstaller les morceaux du noyau 17 en réinstallant dans cet ordre (pas tout en même temps : d'abord l'étape #1 seulement, puis le #2 seulement, puis le #3) et depuis le PC démarré sur le noyau 16 :
1) linux-image-2.6.31-17-generic (2.6.31-17.54)
2) linux-generic (2.6.31.17.30) qui m'impose d'installer en même temps linux-image-generic (2.6.31.17.30)
3) linux-headers-generic (2.6.31.17.30) qui m'impose linux-headers-2.6.31-17 (2.6.31-17.54) et linux-headers-2.6.31-17-generic (2.6.31-17.54)
ça tient avec des bouts d'allumettes et il ne faut pas souffler dessus. Cependant, j'arrive bien à mettre à jour Grub par la commande sudo update-grub depuis le PC démarré sur le noyau 16 ou bien sur le noyau 17 sans aboutir au "sh:grub>"
J'ai l'impression que c'est très important que cette installation des morceaux du noyau 17 soit toujours faite quand le PC est démarré sur un noyau précédent ( moi, c'est sur le noyau 16). Je ne dis pas forcément qu'il faut choisir le noyau immédiatement précédent mais en tout cas, il ne faut pas démarrer sur le noyau en cours (le noyau 17)

Dernière modification par malbo (Le 01/02/2010, à 18:25)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#92 Le 01/02/2010, à 17:09

mamagubida10

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Hello,

moi les commandes passent mais après je tombe sur la busybox v1.13.3

arffff Ubuntu commence à copier sur Windows avec ses mises à jour foireuses ?:P

Je suis dégouté. Ca fait 2 fois que j'installe ubuntu avec Wubi, 2 fois que j'ai les problèmes. J'ai pas de disque dur externe pour sauvegarder mes données, sniff sinon j'aurai installé ubuntu en dur


Dual boot Ubuntu 12.04LTS / Windows8 sur Toshiba Satellite A200-258
Processeur Intel® Core™2 Duo  T5450 1.66 GHz
ATI Mobility™ Radeon® HD2400 128Mo dédiés

Hors ligne

#93 Le 01/02/2010, à 18:23

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

mamagubida10 a écrit :

arffff Ubuntu commence à copier sur Windows avec ses mises à jour foireuses ?

En fait, les mises à jour foireuses sont en ce moment une exclusivité des installations par Wubi. Moi, dans mes PC, j' ai à la fois une installation classique de Ubuntu sur partition Linux et une installation par Wubi alors je peux dire que l'installation par Wubi me fait des emmerdes dans mon PC Acer (dans ma signature) pour Ubuntu 64 bits alors qu'elle ne me pose pas de problème dans mon PC Medion pour Ubuntu 32 bits. Cependant que Ubuntu installé classiquement sur partition Linux dans ces mêmes deux PC ne me pose aucun problème. Donc, c'est plutôt le couple maudit Ubuntu 9.10 et Wubi qui nous fait braire. Alors que je n'ai jamais en d'ennuis comme ça avec le couple Ubuntu 9.04+Wubi et ceux d'avant. Peut-être Grub2 qui ne s'entend pas bien avec Wubi ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#94 Le 08/02/2010, à 15:48

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

J'AI LA SOLUTION A MON PROBLEME :
Dire que ça fait deux mois que je me fais chier avec ça (c'est moi qui ai créé le post #1 de cette discussion fleuve).
A noter que j'ai installé Ubuntu 9.10 avec Wubi sous Windows XP.
La cause de mes ennuis avec Wubi est due à un bogue du fichier C: \wubildr
qui est décrit là :
https://bugs.launchpad.net/ubuntu/+sour … mments/210
Ajouté le 9 mars 2010 : la réparation décrite dans les lignes suivantes (remplacement du fichier wubildr par un autre téléchargé spécialement) s'effectue entièrement depuis Windows.
Vous le croyez ça ? Il suffit tout simplement de renommer son fichier C: \wubildr en C: \wubildr_pourri et de coller à la place le fichier wubildr proposé dans le lien pour résoudre complètement le problème.
Ce fichier wubildr peut être téléchargé directement là (c'est très léger : 78,6 Ko) :
http://launchpadlibrarian.net/36920146/wubildr

Ajouté le 10 février 2010 : il est possible que ce soit superflu mais je n'en suis pas sûr parce que ça dépend de l'installation de chacun : je vous recommande, lecteurs concernés par le Pb qui ont installé par Wubi dans Vista ou dans Windows 7 de renommer aussi en "wubildr_pourri" le fichier wubildr qui se trouve dans le dossier ubuntu dans le chemin suivant ubuntu\winboot\wubildr afin que seul le fichier téléchargé wubildr que vous aurez placé sous C: soit utilisé au démarrage. Attention ne touchez pas (et ne déplacez pas) au fichier qui a l'extension .mbr et dont le chemin est ubuntu\winboot\wubildr.mbr parce que là, ça ne démarre plus du tout si vous faites ça. En effet, j'ai constaté qu'au démarrage, Wubi parcourt les partitions du disque (en commençant par la première) à la recherche d'un fichier wubildr qui se trouverait à la racine de la partition. Donc, il vaut mieux qu'il ne le trouve qu'à un seul endroit (sous C: )

Pour que vous puissiez vérifier la chose chez vous, j'ai fait le md5sum du bon fichier et du mauvais fichier (celui que vous avez probablement puisque vous avez le problème) :
http://doc.ubuntu-fr.org/md5sum

1) Voici le md5sum du bon fichier wubildr (celui du lien) : c37450b88f986d557c1a4feca6548c89

2) Voici le md5sum du fichier pourri : 92760c3e836a0affe8ebd64fc2f195d6

à noter qu'à la date d'aujourd'hui, 8 février 2010, et c'est toujours vrai le 3 mars 2010 (voir post #98), je viens de le vérifier par curiosité : si on installe Ubuntu 9.10 avec Wubi, on est gratifié de ce fichier pourri...pas glop.

Pour ceux que ça intéresse, des explications en anglais sur la cause (moi, je ne comprends pas tout) :
http://sourceforge.net/apps/mediawiki/b … :Wubi_9.10
Edit : et un lien trouvé par nargel qui présente le Pb, la cause et donne la même solution :
http://sourceforge.net/apps/mediawiki/b … :Wubi_9.10

Dernière modification par malbo (Le 19/10/2010, à 07:35)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#95 Le 11/02/2010, à 02:07

TSIPC

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Tes pas sérieux lol:lol::lol::lol::lol:

Ben bravo pour ta trouvaille.


Portable HP G60 414-CA, 4 gigs de mémoire.
Ubuntu 9.10 depuis le 12 décembre 2009. Mise à jour à 10.04 ensuite à 10.10. Seul et unique OS sur le portable. Aucun problème non résolu à ce jour (30 novembre 2010) très stable et rapide.

Hors ligne

#96 Le 11/02/2010, à 17:57

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Hé les amis, je m'aperçois que je suis trop léger sur ce coup là. Après le post de zoreil97434 de ce matin :
http://forum.ubuntu-fr.org/viewtopic.php?pid=3272411#p3272411
Je me rends compte que la majorité d'entre vous risque d'attendre de voir si la prochaine mise à jour va merder pour faire la réparation que je décris dans le post #94.
Grosse erreur : si vous avez été confrontés à ce problème lors de mises à jour précédentes, n'attendez plus, il faut faire immédiatement la modif du post #94. Je ne dis pas que tout le monde doit faire cette correction parce que je vérifie moi-même que le problème dépend des PC et des configurations (je n'ai jamais d'emmerdes avec Wubi installé dans mon PC Medion alors qu'elles sont quasi-systématiques avec Wubi installé dans mon PC ACER), mais ceux qui ont déjà taté des ennuis suite à certaines mises à jour, n'attendez pas.

Dernière modification par malbo (Le 11/02/2010, à 17:58)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#97 Le 13/02/2010, à 10:48

Bankette

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Yes super, ça fonctionne pour moi !!! Je peux enfin démarrer sur les kernel plus recent que le 15 !!!! big_smile

Merci Malbo !

J'ai un Sony VGN-FW510F avec ubuntu 9.10 installé en décembre depuis windows 7 avec wubi.

Dernière modification par Bankette (Le 13/02/2010, à 11:05)


-- Bankette --
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème....

Hors ligne

#98 Le 16/02/2010, à 15:48

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Si on installe Ubuntu avec Wubi aujourd'hui (16 fevrier 2010) on a toujours le problème dont j'ai donné la solution au post #94 ci-dessus.
Afin de surveiller une possible mise à jour de Wubi, je fais un md5sum du fichier wubi.exe que je viens de télécharger là (c'est le lien qu'on trouve dans la doc Wubi de notre site) :
http://wubi-installer.org/latest.php
résultat :

malbo@ubuntu:~/Téléchargements$ md5sum wubi.exe
37a04db193b1a342f961f59aea2fada8  wubi.exe

Donc, si vous faites une installation avec un fichier wubi.exe dont le md5sum est 37a04db193b1a342f961f59aea2fada8, c'est que la version que vous avez téléchargée n'a pas évolué et je vous recommande d'appliquer la soluce du post #94 parce que Wubi est vérolé.

Edit : le 3 mars 2010, je revérifie que le md5sum du fichier wubi.exe est 37a04db193b1a342f961f59aea2fada8.
Dans un mois, ubuntu 10.04 va sortir, dans ce contexte et vu l'empressement des concepteurs de Wubi à se bouger, ça m'étonnerait que ça change.

Edit le 18 mars 2010 : attention, c'est juste pour info (n'allez pas prendre ce wubi.exe que j'indique ci-après pour installer Ubuntu 9.10). Je viens de contrôler que le live CD de Lucid (futur ubuntu 10.04 mais toujours sévèrement bogué à l'heure qu'il est) contient un fichier wubi.exe dont je viens de faire le md5sum :
b0aa28bf7e5b1a6fd965077e65ec621d  wubi.exe
C'est normal qu'il ait un md5sum différent puisqu'il s'agit de l'installateur de la future version 10.04 (il ne peut pas être identique au Wubi.exe qui installe Ubuntu 9.10)

Dernière modification par malbo (Le 18/03/2010, à 10:02)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#99 Le 18/02/2010, à 01:58

Mangatd

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Re-bonjour,

Merci à toi Malbo pour tout cet acharnement.

J'avais complètement oublié de dire que j'avais pu résoudre mon problème d'une manière aussi stupide que inattendue : dans un dossier de sauvegarde dont le nom est found (si ma mémoire est bonne), j'y est trouvé 3 sous dossier qui s'appelaient je crois found001, found002 et found003. 2 d'entre eux contenaient chacun un album de musique (? !) et le dernier... des fichiers d'Ubuntu ! Parmis eux, il y avait surement root.disk qui pèse actuellement 8,38 Go, ce qui explique pourquoi mon dossier ubuntu était si léger ! En replaçant ces fichiers au bon endroit, j'ai pu redémarrer Ubuntu comme c'était avant la panne.

Maintenant, je me demande ce qui explique pourquoi l'outil de vérification des disques de Windows XP s'amuse à me déplacer des fichiers (en + pour les musiques, il m'a l'air d'avoir fait des copies de sauvegardes et non un déplacement de fichiers car je n'ai pas remarqué une disparition de ce côté là...) neutral

Bon maintenant j'ai un autre problème suite à une mise à jour (un "gdm ne peut écrire dans votre fichier d'autorisation..." bla bla bla, problème qui pourrait arriver quand le disque est plein, et c'est vrai que ma partition virtuelle Linux était déjà pleine (je me suis toujours demandé de quoi, faut surement accumuler beaucoup de petits fichiers pour le savoir). en tout cas, comme c'était une grosse MAJ, je me demande si je n'ai fini ma partition avec ! big_smile C'est ballot, hein ?
La je suis en train de chercher sur le forum diverses solutions au cas ou le problème vient d'ailleurs... bref, la routine, quoi ! roll

Dernière modification par Mangatd (Le 12/02/2012, à 13:23)


Si tu aimes jardiner, achète Windows, il t'aidera à mieux planter XD
Source : http://www.siteduzero.com/tuto-50-14941.html (page morte, je ne sais plus ce que c'était à l'origine)

Hors ligne

#100 Le 19/02/2010, à 09:14

malbo

Re : [Résolu]"Minimal BASH-like" au boot de Karmic installé avec Wubi

Mangatd a écrit :

Maintenant, je me demande ce qui explique pourquoi l'outil de vérification des disques de Windows XP s'amuse à me déplacer des fichiers (en + pour les musiques, il m'a l'air d'avoir fait des copies de sauvegardes et non un déplacement de fichiers car je n'ai pas remarqué une disparition de ce côté là...)

Moi, il ne m'est pas arrivé de mésaventure comme ça mais il faut bien reconnaitre que dans une installation avec Wubi, ubuntu vient squatter sur une partition NTFS (ou FAT32 chez certains) donc une partition visible depuis Windows et "sous contrôle" de Windows. Du coup, il me parait possible (mais pas du tout souhaitable) que des erreurs soient commises par Windows. Pourtant, ça ne m'est jamais arrivé comme je l'ai dit et je fais assez souvent des vérifications des partitions NTFS sur lesquelles j'ai installé ubuntu avec Wubi, je fais des défragmentations et je n'ai pas d'ennuis. A noter toutefois que je n'installe jamais ubuntu dans le disque C: de Windows mais toujours dans un disque de stockage (souvent sur le disque D: qui est ma partition DATA). Peut-être que c'est moins sujet à problèmes ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

Haut de page ↑