Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 19/12/2009, à 03:52

-Mätic-

[RESOLU] Problème à la compilation de Blender

Bonsoir,
J'essaie de compiler Blender ( 2.49b) car j'ai un bug d'affichage en l'installant avec Synaptic.

Voici le message d'erreur :

nasm -Iextern/xvidcore/src/image/x86_asm/ -I../../src/ -f elf -DMARK_FUNCS -o /home/matic/bureau/build/linux2/extern/xvidcore/src/image/x86_asm/colorspace_yuyv_mmx.o extern/xvidcore/src/image/x86_asm/colorspace_yuyv_mmx.asm
extern/xvidcore/src/image/x86_asm/colorspace_yuyv_mmx.asm:26: fatal: unable to open include file `nasm.inc'

Merci d'avance à ceux qui sauront m'aider !

Dernière modification par -Mätic- (Le 20/12/2009, à 20:03)

Hors ligne

#2 Le 19/12/2009, à 10:35

nisnis

Re : [RESOLU] Problème à la compilation de Blender

Je ne pourrai pas t'aider pour la compilation de blender, mais si j'étais toi j'essaierai plutôt de regarder du côté des pilotes de la carte graphique ou de télécharger blender directement sur le site: http://www.blender.org/download/get-blender/


"Un Windows meurt...Des Linux apparaissent !.."

Hors ligne

#3 Le 19/12/2009, à 23:10

-Mätic-

Re : [RESOLU] Problème à la compilation de Blender

Merci pour cette réponse, mais j'ai toujours le meme bug d'affichage en utilisant Blender téléchargé depuis le site officiel.

Pour les pilotes de la carte graphique, je suppose que c'est bon, puisque Compiz fonctionne parfaitement ( si ça peut etre un indicateur.. )

Je continue à suivre la piste de la compilation..

Hors ligne

#4 Le 20/12/2009, à 12:54

nisnis

Re : [RESOLU] Problème à la compilation de Blender

Et si tu désactives compiz pendant l'utilisation de blender ?

Sinon il y a peu être une option à cocher ou décocher dans compiz (comme la synchronisation verticale par ex)

à mon avis la compilation de blender, ne résoudra pas ton problème.

Dernière modification par nisnis (Le 20/12/2009, à 13:02)


"Un Windows meurt...Des Linux apparaissent !.."

Hors ligne

#5 Le 20/12/2009, à 13:44

-Mätic-

Re : [RESOLU] Problème à la compilation de Blender

Oui, je l'ai désactivé, le probleme est toujours là.. sad

Hors ligne

#6 Le 20/12/2009, à 14:02

pomalin

Re : [RESOLU] Problème à la compilation de Blender

question bête tu as installé yasm avant de lancer la compilation ?

Hors ligne

#7 Le 20/12/2009, à 14:28

-Mätic-

Re : [RESOLU] Problème à la compilation de Blender

Oui, yasm est installé, c'est la version disponible la plus récente.

Hors ligne

#8 Le 20/12/2009, à 20:03

-Mätic-

Re : [RESOLU] Problème à la compilation de Blender

Je viens de passer à la 9.10, le problème est en partie résolu ( seul quelques boutons s'affichent mal ) mais ça me suffit roll.
Je met donc ce sujet en résolu.
Merci à ceux qui se sont penché sur mon problème smile.

Hors ligne

#9 Le 27/12/2009, à 14:40

lebigouden

Re : [RESOLU] Problème à la compilation de Blender

Pour ceux qui auront ce problème

Ce rendre dans le dossier des sources:

blender/extern/xvidcore/src/ (par défaut)

Taper dans un terminal
find . -type d -exec cp -v nasm.inc '{}' \;

(testé avec kubuntu 64 9.10)
Vous n'aurez plus cette erreur de compil
smile

Hors ligne