Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 07/02/2010, à 11:13

Le Barde

Problème de buffer en mode console

Salut à tous,

* Je viens de faire une install fraîche et minimaliste du dernier Alternate CD (donc je suis sur les tty, petit retour aux sources). Lorsque j'utilise emacs -nw, pas moyen d'exécuter quelque raccourci que ce soit ! Je suis obligé de killer emacs depuis un autre shell.

* Ensuite de cela, il y a quelques problèmes lorsque je kille Emacs ou que je sors de Nano : le retour chariot fait afficher la ligne de shell suivante sur la même ligne en continu, du genre :

jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/ jacques@permafrost:~/

Des idées pour ces deux problèmes ?

Hors ligne

#2 Le 07/02/2010, à 11:20

snapshot

Re : Problème de buffer en mode console

Salut

pour restaurer le terminal, utilise l'une et/ou l'autre de ces commandes :

stty -sane
reset

Quand tu tapes des raccourcis dans emacs, est-ce qu'ils s'affichent dans la ligne de status du bas ?


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#3 Le 07/02/2010, à 11:43

Le Barde

Re : Problème de buffer en mode console

Merci pour la commande, je vais tester !
Sinon, non : c'est comme si Ctrl-TOUCHE n'était pas capturé !

EDIT : Après avoir fait plein de tests, c'est TTY1 qui a un souci.
Les autres TTY se comportent normalement. Seul TTY1 a un souci de buffer.

Dernière modification par Le Barde (Le 07/02/2010, à 12:19)

Hors ligne

#4 Le 07/02/2010, à 12:20

Le Barde

Re : Problème de buffer en mode console

Post précédent mis à jour.

Hors ligne

Haut de page ↑