Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#151 Le 05/06/2006, à 18:05

emil_p8

Re : [Info] Installation du driver Libre ATI Radeon

@john5168
Pourtant j'avais l'impression que j'ai la 3D!!!
Si des jeux 3D comme Penguin Racer marchent avec 15 fps et que j'ai "direct rendering: Yes" je pensais bien que l'acceleration marche, même si ce n'est pas du tonnerre vu ma config, et même si glxgears n'indique que 390 fps. Sur mon 2ème ordi, plus récent (amd64 3200+, 1giga, Ati X700) sur lequel j'ai pas encore configuré la 3d, j'ai 700 fps et "direct rendering=no", mais si j'essaie Penguin Racer, ça bouge peut-être à 5-6 fps!!!
Si je me trompe, j'aimerais bien savoir quels sont les symptomes de possesion d'accélération 3D :-)


creaphot@creaphot:/mnt$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:

#152 Le 06/06/2006, à 12:44

Gillaume

Re : [Info] Installation du driver Libre ATI Radeon

Bonjour à tous

j'ai tenté une install serveur + fluxbox + xserver-xorg. Je n'ai pas réussi à avoir X, apres moult dpkg--reconfigure xserver ...
et hier, j'ai installé proprement xubuntu-desktop.
J'ai X, mais dans une résolution... aïe aïe aïe aïe ..
je n'ai jamais eu une aussi mauvaise résolution sous nux !

j'ai une ati 7200. dans Xorg, j'ai mis le driver "radeon".

ma question est simple. Comme il y  a des post absolument partout sur le forum, je ne sais plus où j'en suis...
ya t il le wiki qui traite simplement le sujet :  une adresse ?

Merci
Guillaume smile


Guili Guili

Hors ligne

#153 Le 06/06/2006, à 14:16

Gillaume

Re : [Info] Installation du driver Libre ATI Radeon

j'ai trouvé : a tester ce soir !
Gui smile


Guili Guili

Hors ligne

#154 Le 07/06/2006, à 12:42

bobousse

Re : [Info] Installation du driver Libre ATI Radeon

bon moi ma migration vers dapper n'a rien fait avancer au niveau de l'accélération graphique mais je vois que des gens se bougent et ont de nouvelles méthodes alors voila j'ai une ati radéon 9200
voici le résultat d'un glxgears -printfps

963 frames in 5.2 seconds = 183.461 FPS
928 frames in 5.2 seconds = 177.668 FPS
1060 frames in 5.4 seconds = 195.555 FPS
1060 frames in 5.4 seconds = 194.878 FPS
1060 frames in 5.6 seconds = 190.594 FPS
927 frames in 5.0 seconds = 184.608 FPS

voila c'est pas fameux mai bon remarquez la pointe à 195 fps remarquable non big_smile

et voila une copie de mon xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"latin9"
	Option		"XkbOptions"	"azerty"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ExplorerPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. M9+ 5C61 [Radeon Mobility 9000 (AGP)]"
	Driver		"ati"
	BusID		"PCI:1:5:0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. M9+ 5C61 [Radeon Mobility 9000 (AGP)]"
	Monitor		"Generic Monitor"
	DefaultDepth	16
	SubSection "Display"
		Depth		1
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice     "stylus" "SendCoreEvents"
	InputDevice     "cursor" "SendCoreEvents"
	InputDevice     "eraser" "SendCoreEvents"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

bon donc si un esprut éclairé peu m'aider.... (please please please ca va faire six mois que je galère avec ca)
merci d'avance de vos réponses

Hors ligne

#155 Le 07/06/2006, à 20:22

forficule

Re : [Info] Installation du driver Libre ATI Radeon

normalement si tu remplaces dirver "ati" par "radeon" ça devrait marcher encore mieux, tu fais ça avec gedit :

sudo gedit /etc/X11/xorg.conf

.
attention a enregistrer ton xorg.conf qui marche en rajoutant .bak (par exemple) à la fin... comme ça si les bidouilles se passent mal et que tu te retrouves en ligne de commande, un petit

sudo  cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

et tu te retrouves au moment où tout marchait pour le mieux wink

Hors ligne

#156 Le 07/06/2006, à 21:06

bobousse

Re : [Info] Installation du driver Libre ATI Radeon

bon j'arrive a 200 fps
mais c'est pas ce que j'appelle de l'accélération graphique fait ch***

Hors ligne

#157 Le 08/06/2006, à 20:20

bobousse

Re : [Info] Installation du driver Libre ATI Radeon

up up

Hors ligne

#158 Le 10/06/2006, à 13:38

forficule

Re : [Info] Installation du driver Libre ATI Radeon

et qu'est que donne glxinfo ? as-tu la ligne direct rendering=yes ?
voici ce que ça donne chez moi :

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

Parce que 200 fps avec une radeon 9200 c'est pas beaucoup... sinon tu peux tenter un default depth à 24 dans ton xorg.conf, chez moi ça passe mieux comme ça... (attention chez beaucoup ça crashe à 24 d'après ce que j'ai vu sur le forum...) sinon au tout début de ce fil tu trouveras des options d'optimisation qui sont sans doute indiquées pour toi...

Hors ligne

#159 Le 10/06/2006, à 17:47

haerdaelis

Re : [Info] Installation du driver Libre ATI Radeon

Hum bonjour tout le monde ça doit faire 3 jours que j'essaie d'installer sur mon portable ASUS avec une carte ATI Mobility Radeon 9600 M10, l'acceleration 3D j'ai suivi pas mal de methodes sans aucun resultat , la meilleur chose que j'ai eu est la configuration issue de l'installation de base de Dapper , alors que sous Brezzy y avait aucun probleme , alors pourquoi en passant a Dapper je n'arrive pas a avoir de la BONNE 3D comme sous Brezzy .

Voila les differentes choses que j'ai fait :

Installation du driver "Radeon"
Installation du driver "Fglrx"
dans les deux cas je me retrouvais avec un vieux FPS

Merci d'avance


Le plus dur c'est de voir que c'est simple.

Hors ligne

#160 Le 10/06/2006, à 22:20

c-cube

Re : [Info] Installation du driver Libre ATI Radeon

Bien. Tout d'abord, un grand merci à stemp pour avoir posté la méthode d'installation du driver libre Radeon.

J'ai une ATI Radeon 9200 RV280SE.

Chez moi je n'atteins pas les scores que certains ont réussi à obtenir avec le driver proprio mais la commande "glxgears -printfps" m'affiche un honorable 1091 FPS et "glxinfo" m'indique que le direct rendering est activé. J'ai testé quelques jeux qui tournent très bien (entre 30 et un peu plus de 50 FPS à Planet Penguin Racer par exemple).

Avant d'installer les drivers ATI libres ou propriétaires, surtout, pensez à sauvegarder votre fichier xorg.conf comme indiqué par stemp dans son tuto :

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.bak

Vous pourrez ensuite le restaurer à tout moment avec la commande suivante (la même à l'envers en fait) :

sudo cp /etc/X11/xorg.bak /etc/X11/xorg.conf

Croyez-moi, ça vous évitera pas mal d'embrouilles et de tripatouillages superflus en cas d'échec d'une méthode d'installation.

Si ça peut aussi servir à quelqu'un, ma config matérielle exacte et complète est la suivante :

Ordinateur "IXTREME4021PHOTO DREAM MACHINE" de marque Packard Bell acheté en juin 2004 (modèle sorti le 24/09/2003) :
- Châssis UC1 µATX
- Carte-mère µATX Quasar (MS6786) V1.0 (fabriquant MSI)
- Processeur AMD Athlon XP 3000+
- 512 Mo de SDRAM récemment étendue à 1 Go avant passage à Dapper (en prévision de l'install de XGL/Compiz que je croyais stable mais qui ne l'est visiblement pas encore, donc j'attends...)
- Sur port AGP : Carte vidéo ATI RADEON 9200 (RV280SE) 128 Mo DDR +2 Sorties TV
- Graveur DVD±RW NEC ND-2 500A/GEN
- Lecteur de DVD HLDS GDR-8 162B
- Disque dur Seagate Alpine 160 Go
- Modem interne    Aztech CNR2900-W (C1) SEC modem (on ne rit pas, c'est un winmodem...)
- Syntoniseur FM de télévision TV-7134
- Hauts-parleurs Multimédia Volume
- Carte PCI IEEE 1394 Gigabyte
- Carte son SoundBlaster Audigy 2 ZS installée par mes soins sur emplacement PCI libre.

S'agissant du driver proprio, j'ai galéré hier soir et toute la nuit jusqu'à 3h du mat' en tentant de l'installer. Puis encore aujourd'hui pendant près de cinq heures... cinq heures de de prises de tête, tentatives désespérées par 3 ou 4 méthodes différentes (dont celle du wiki), recherches dans tous les sens sur google et dans je ne sais plus combien de forums... Tout ça pour un résultat nul... enfin pas tout à fait, j'ai quand même appris des trucs.

En fait, avec le driver proprio j'obtenais systématiquement une floppée de messages API ERROR en lançant glxgears et l'accélération 3D était inexistante.

J'ai finalement découvert dans ce post quelle était la méthode pour réussir à installer ce driver pour ma carte :

http://forum.ubuntu-fr.org/viewtopic.ph … 60#p329460

Seulement je me refuse à recourir à une bidouille pareille pour obtenir l'accélération 3D par le driver proprio. D'abord parce que si dans quelques mois il sort une nouvelle version du driver en question et comme j'aurai eu le temps d'oublier les subtilités de la manip susmentionnée, qui me dit que je ne vais pas me retrouver dans un caca tout noir ? J'ai déjà dû réinstaller une Breezy à cause d'une bidouille du même genre, je ne compte pas recommencer sous Dapper... Y a pas écrit "Windows" là quand même ! hmm

D'autre part en fouillant un peu plus, j'ai découvert ceci :

https://launchpad.net/distros/ubuntu/+s … +bug/47371

Il s'agit d'un rapport de bug concernant précisément le problème des drivers proprios ATI sur cartes Radeon 9200 (et autres) avant la sortie de Dapper.

On peut y lire qu'en fait ATI a parfaitement connaissance de ce problème et semble faire la sourde oreille.

Du coup, je ne sais pas s'il faut s'attendre à ce qu'ils se montrent très conciliants pour que les choses évoluent lors de la sortie d'un éventuel nouveau driver...

En tout, cas, je viens de découvrir aussi qu'aujourd'hui quelqu'un (un certain damko) a posté, dans le fil de discussion en question, une nouvelle méthode qui semble bien fonctionner pour l'install des drivers proprios ATI.

La voici traduite et complétée par moi :

1. Pour ceux qui avaient déjà tenté d'installer les drivers proprio par d'autres méthodes, ouvrir un terminal et taper :

apt-get remove --purge fglrx-kernel-source xorg-driver-fglrx-dev xorg-driver-fglrx

2. Changer le driver en "vesa" dans xorg.conf (section "Device"), avec la commande suivante :

sudo gedit /etc/X11/xorg.conf

Dans la section Device, vous recherchez la ligne qui commence par Driver et vous tapez "vesa" à la place de ce que vous aviez (chez moi, au tout début avant de changer quoi que ce soit, j'avais "ati" par défaut mais, suite aux diverses manips d'installation, je suis passé par "fglrx" et finalement "radeon" pour l'utilisation du driver libre).

3. Télécharger le driver ATI propriétaire.

Là j'avoue que je ne sais pas trop ce qu'il veut dire puisqu'il ne donne pas de lien. Je suppose qu'il ne s'agit pas d'un paquet mais qu'il faut aller à la pêche directement chez ATI.

Il semble qu'on puisse trouver ce qu'il faut sur le site d'ATI (http://www.ati.com). Dans la section "Drivers and Software", cliquer sur le lien "Linux Display Drivers and Software" puis choisir "RADEON 8500 Series and higher". Cliquer alors sur le lien proposé. Je crois que le fichier à télécharger est celui qui correspond au "ATI Driver Installer" mais c'est sans garantie aucune...

4. Taper :

/etc/init.d/gdm restart

5. Taper :

./ati-driver-installer-8.25.18-x86.run

6. Changer le driver en "fglrx" dans xorg.conf (section "Device"), avec la commande suivante :

sudo gedit /etc/X11/xorg.conf

7. Taper :

/etc/init.d/gdm restart

C'est sensé marcher... roll

Je ne sais pas si je vais essayer ça tout de suite. J'en ai ma claque pour aujourd'hui de la bidouille.

Bon courage à ceux qui tentent le coup et tenez-nous au courant.

Dernière modification par c-cube (Le 10/06/2006, à 22:55)


Il y a quelque chose d'ubuntu dans Trisquel.
Bons vendeurs d'ordinateurs
La musique libre ? J'aime !

Hors ligne

#161 Le 14/06/2006, à 10:32

oswald-p

Re : [Info] Installation du driver Libre ATI Radeon

J'ai un protable Acer TM 800 avec une carte video ATI radeon 9000 mobility.
J'ai essayé les trois drivers possibles (ati, radeon, fglrx). Pour fglrx il a fallut que j'installe à la main le driver 8.24.x mais ça fonctionne. Voici le résultat de la commande "fglrx -printfps":
driver ati: environ 1500 fps
driver radeon: environ 2200 fps (optimisé grace à ce post)
driver fglrx: environ 2000 fps

Voilà mon problème... j'ai installé (pour l'instant) le driver fglrx d'ATI pour pouvoir bénéficier du double écran (sur un portable c'est très pratique pour faire les présentations avec impress). Sauf que du coup j'ai une accélération 3D qui pose des problèmes (gnome-screensaver non accéléré, apparence bizard de certaines appli 3D dont FGL_GLXGears....)

Ma question (après tous ces préliminaires wink): Je préférerais utiliser le driver radeon qui donne de meilleurs performances 3D et qui ne pose pas de problème d'affichage sauf que j'ai absolument besoin du double écran. Est-ce possible?
Quelqu'un aurrait-il un exemple de configuration qui marche?

merci

O-p


Chuck Norris a terrassé Prince de Lu avec un cookie

Hors ligne

#162 Le 14/06/2006, à 11:30

FiFouille

Re : [Info] Installation du driver Libre ATI Radeon

tu peux t'inspirer de mon fichier de config
http://www.fifi.be/vrac/xorg_Acer_TM292.conf

sinon man radeon et regarder à l'option MergedFB (dans mon fichier de config, si tu décommentes cette ligne tu auras un bureau étendu par défaut, avec les autres server layout, juste la sortie externes, ou juste le LCD du portable)

Hors ligne

#163 Le 14/06/2006, à 13:29

Aquel

Re : [Info] Installation du driver Libre ATI Radeon

Salut a tous,

j'ai également un problème (jusque là, rien d'etonnant wink): J'utilise une Radeon X800GT. Tout allait bien jusqu'à hier mais aujourd'hui j'ai voulu installer un nouvel écran Philips 200W6 (1680x1050).
Et là problème, cette résolution ne semble pas supportée par xorg. J'ai donc modifié xorg.conf pour l'ajouter, mais rien n'y fait. Je ne peux pas passer sous cette résolution: elle n'est pas listée dans les Préférences de la resolution de l'écran.
J'ai donc un écran de 20' avec une résolution de 1280x768 et c'est vraiment moche smile

Si quelqu'un pouvait essayer de m'aiguiller sur le chemin de la vérité, je lui en serais reconnaissant.
A bientot

Axel

#164 Le 14/06/2006, à 14:07

oswald-p

Re : [Info] Installation du driver Libre ATI Radeon

merci Fifouill! c'est génial!
je test ça de suite...

O-p


Chuck Norris a terrassé Prince de Lu avec un cookie

Hors ligne

#165 Le 14/06/2006, à 15:02

Aquel

Re : [Info] Installation du driver Libre ATI Radeon

Problème Résolu
dans xconf: "DCCMode" "true"

Aquel a écrit :

Salut a tous,

j'ai également un problème (jusque là, rien d'etonnant wink): J'utilise une Radeon X800GT. Tout allait bien jusqu'à hier mais aujourd'hui j'ai voulu installer un nouvel écran Philips 200W6 (1680x1050).
Et là problème, cette résolution ne semble pas supportée par xorg. J'ai donc modifié xorg.conf pour l'ajouter, mais rien n'y fait. Je ne peux pas passer sous cette résolution: elle n'est pas listée dans les Préférences de la resolution de l'écran.
J'ai donc un écran de 20' avec une résolution de 1280x768 et c'est vraiment moche smile

#166 Le 14/06/2006, à 15:22

oswald-p

Re : [Info] Installation du driver Libre ATI Radeon

Ok, avec le xorg.conf de Fifouille ça marche (il faut encore je j'affine les réglages mais dans l'ensemble c'est bon smile)
Plus besoin du driver proprio big_smile
je suis content lol

MERCI!

O-p


Chuck Norris a terrassé Prince de Lu avec un cookie

Hors ligne

#167 Le 14/06/2006, à 15:57

FiFouille

Re : [Info] Installation du driver Libre ATI Radeon

pour ceux qui ont des écrans bizarres avec lesquels l'option DCCMode ne donne rien de bon, y'a aussi moyen de calculer le modeline soi même à partir des données constructeur (mais évitez de déconner, ya des risques de griller la bête si on tape trop à pouf)

man gtf
gtf faisant partie de xserver-xorg-core

Hors ligne

#168 Le 14/06/2006, à 19:38

raphoun

Re : [Info] Installation du driver Libre ATI Radeon

Bonjour,

J'ai fait plusieurs install de kubuntu et j'installais à chaque fois l'accélération à partir de ce topic avec le driver radeon.

Or j'ai essayé d'installer fglrx et j'ai réussi après lutte intense mais j'ai décidé de revenir au driver libre radeon mais plus moyen de l'installer. yikes
J'ai bien entendu supprimé tous les paquets portant le nom fglrx et j'ai supprimé les fichiers se nommant *fglrx*
Je pense que mon xorg est bon.
Voyez vous d'où ça pourrait venir?

J'ai une ati mobility 9000

Raphaël

Hors ligne

#169 Le 15/06/2006, à 01:20

Eric P.

Re : [Info] Installation du driver Libre ATI Radeon

raphoun a écrit :

Or j'ai essayé d'installer fglrx et j'ai réussi après lutte intense mais j'ai décidé de revenir au driver libre radeon mais plus moyen de l'installer. yikes
J'ai bien entendu supprimé tous les paquets portant le nom fglrx et j'ai supprimé les fichiers se nommant *fglrx*
Je pense que mon xorg est bon.
Voyez vous d'où ça pourrait venir?

La cause habituelle du non fonctionnement du driver radeon après test du fglrx est que les paquets nécessaires à fglrx n'ont pas été désinstallés. Ca a priori tu l'as fait donc... il faut investiguer smile

Pourrais-tu poster ton xorg.conf et surtout ton /var/log/Xorg.0.log après un démarrage en driver radeon ?
Il faudra résoudre les éventuelles erreurs présentes dans le log, et s'il n'y en a pas c'est que le problème ne se situe pas au démarrage d'X mais au lancement des applis openGL (au chargement de la libGL). Dans ce cas on pourra facilement investiguer grace a glxinfo regle a VERBOSE.

Dernière modification par Eric P. (Le 15/06/2006, à 11:28)

Hors ligne

#170 Le 18/06/2006, à 11:40

raphoun

Re : [Info] Installation du driver Libre ATI Radeon

Ha me revoila big_smile

J'ai une nouveau problème roll

L'accélération 3D fonctionne très bien et j'ai voulu installé xgl.... qui par ma grande stupeur fonctionne sous kde mais l'accélération 3D est désactivé donc c'est assez lent.

Savez vous pourquoi l'accélération 3D fonctionne avec le driver libre sous xorg mais pas sous xgl?

Raphaël

Hors ligne

#171 Le 18/06/2006, à 11:46

Gillaume

Re : [Info] Installation du driver Libre ATI Radeon

Salut,
j ai une ati 7200, etje n'ai pas installé *fglrx*.
dans xorg, j'ai mis le driver "radeon".... mais tj pas de 3D

qd je tape :

wech@pik-txu:~$ glxgears -printfps
496 frames in 5.3 seconds = 94.313 FPS
456 frames in 5.7 seconds = 79.307 FPS
456 frames in 5.8 seconds = 79.222 FPS
456 frames in 5.7 seconds = 79.379 FPS
456 frames in 5.5 seconds = 82.620 FPS
456 frames in 5.7 seconds = 79.470 FPS
456 frames in 5.6 seconds = 81.948 FPS
456 frames in 5.7 seconds = 79.403 FPS
456 frames in 5.8 seconds = 79.274 FPS
456 frames in 5.5 seconds = 82.493 FPS
456 frames in 5.7 seconds = 79.401 FPS
456 frames in 5.8 seconds = 79.025 FPS
456 frames in 5.5 seconds = 82.186 FPS
456 frames in 5.8 seconds = 79.260 FPS
456 frames in 5.5 seconds = 82.343 FPS
456 frames in 5.7 seconds = 79.389 FPS

ce qui est moche
je ne sais pas quoi faire !
ma souris se bloque ....
ya plein de méthodes pour les ati récentes ou un peu moins, mais pour une ati radeon 7200, je trouve rien....
please, aidez moi hmm
chui un bon gars .
gui

Dernière modification par Gillaume (Le 18/06/2006, à 11:47)


Guili Guili

Hors ligne

#172 Le 19/06/2006, à 10:14

Gillaume

Re : [Info] Installation du driver Libre ATI Radeon

up up  ?? neutral

Dernière modification par Gillaume (Le 19/06/2006, à 10:14)


Guili Guili

Hors ligne

#173 Le 19/06/2006, à 12:12

Eric P.

Re : [Info] Installation du driver Libre ATI Radeon

Reponse classique: il peut y avoir plein de raisons pour que l'acceleration graphique ne s'active pas hmm
Pour qu'on puisse t'aider, il faudrait que tu postes le contenu des fichiers /etc/X11/xorg.conf et de /var/log/Xorg.0.log
Et puis la sortie de la commande

LIBGL_DEBUG=verbose glxinfo

Hors ligne

#174 Le 19/06/2006, à 12:15

Gillaume

Re : [Info] Installation du driver Libre ATI Radeon

OK Eric P.
bien sur, réponse classique ... roll
je poste ça des que je peux !
merci
gui

ya tellement de post sur les pb avec des ati.... hmm


Guili Guili

Hors ligne

#175 Le 19/06/2006, à 17:16

Gillaume

Re : [Info] Installation du driver Libre ATI Radeon

xorg.conf

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
 Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                    # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "ATI Technologies, Inc. Radeon R100 QD [Radeon 7200]"
        Driver          "vesa"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "àcran générique"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon R100 QD [Radeon 7200]"
        Monitor         "àcran générique"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1024x768" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1024x768" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1024x768" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1024x768" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1024x768" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
        SubSection "Display"
   Depth           24
                Modes           "1024x768" "800x600" "720x400" "640x480" "640x350"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "stylus" "SendCoreEvents"
        InputDevice     "cursor" "SendCoreEvents"
        InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
        Mode    0666
EndSection

merci pour vos conseils. wink
Guillaume


Guili Guili

Hors ligne

Haut de page ↑