Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 09/05/2010, à 19:39

Bastien95

[résolu] Petit probléme avec visudo

Bonjour,
j'ai un ordinateur avec Ubuntu server 9.10 qui nous permet de scanner des documents avec un vieux scanner SCSI via l'interface Linux Scanner Server. Une fois les documents scannés, j'aimerais bien pouvoir éteindre cet ordinateur avec cette interface. Je pense avoir trouvé mais j'aurais besoin que www-data ai le droit d'exécuter la commande halt sans taper de mot de passe.

J'ai modifié sudoers avec visudo dont voici le contenu :

# /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the man page for details on how to write a sudoers file.
#

Defaults        env_reset

# Host alias specification

# User alias specification

# Cmnd alias specification

#User privilege specification
root    ALL=(ALL) ALL
www-data   ALL=NOPASSWD:/sbin/halt

# Uncomment to allow members of group sudo to not need a password
# (Note that later entries override this, so you might need to move
# it further down)
#%sudo ALL=NOPASSWD: ALL

# Members of the admin group may gain root privileges
%admin  ALL=(ALL) ALL

Après ces modifications en me connectant sous www-data, je tape sudo -l et voici ce qui s'affiche :

Matching Defaults entries for www-data on this host:
    env_reset

User www-data may run the following commands on this host:
    (root) NOPASSWD: /sbin/halt
    (ALL) ALL

Normalement www-data devrais pouvoir exécuter halt sans taper de mot de passe mais voila, il demande quand même le mot de passe ... hmm

Je sais qu'il y a d'autres sujets qui traitent mon problème mais aucun ne m'a permis de résoudre le problème neutral en espérant que celui ci puisse résoudre mon problème, merci d'avance pour vos réponses big_smile

Dernière modification par Bastien95 (Le 09/05/2010, à 20:53)


J'ai eu du mal à y croire mais bootchart indique que Ubuntu (10.04) démarre en 14 sec :D
(GRUB en prends 14 :( et le bios 10...)

Hors ligne

#2 Le 09/05/2010, à 19:52

skingrapher

Re : [résolu] Petit probléme avec visudo

Les droits de www-data ont été revus et corrigés par la ligne qui suit peu après

%admin ALL=(ALL) ALL

ce qui signifie que tous les utilisateurs appartenant au groupe admin doivent soumettre leur mot de passe.

Change de place la ligne «www-data ALL=NOPASSWD:/sbin/halt» en la mettant en fin de fichier, et je pense que ton problème sera réglé.


Je suis un obsédé textuel. J'aime trop le LaTeX.

Hors ligne

#3 Le 09/05/2010, à 20:01

Bastien95

Re : [résolu] Petit probléme avec visudo

Merci beaucoup skingrapher, problème résolut, c'était tout bête lol .


J'ai eu du mal à y croire mais bootchart indique que Ubuntu (10.04) démarre en 14 sec :D
(GRUB en prends 14 :( et le bios 10...)

Hors ligne

Haut de page ↑