Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#551 Le 04/05/2011, à 15:52

b_b

Re : Arte +7 recorder version 5

Salut et merci une fois de plus aux devs d'arte7 recorder (c'est de la boulette ce truc).

Je me pose une petite question. Maintenant que les vidéos d'arte7 sont disponibles sur dailymotion et que ce site propose une version HTML5, on pourrait peut être récupérer les vidéos en mp4 ? À votre avis, es-ce que les vidéos seraient de meilleure qualité ? Est-ce que c'est possible techniquement ?

++

Hors ligne

#552 Le 04/05/2011, à 17:37

bowmore

Re : Arte +7 recorder version 5

Petite question technique.
J'ai installé Arte +7 recorder qt sous un Ubuntu 10.10.
Dès que je le lance, j'obtiens ceci:

... Connexion à http://arte7.arte.tv ...
Error : malformed start tag, at line 74, column 17 
Essayez plus tard.

Bon, j'essaye plus tard, puis encore plus tard, puis toujours plus tard... sans autre résultat.
Sur un autre PC, sous Natty 11.04, tout fonctionne normalement avec la même version qt...
Moi pas comprendre... neutral


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#553 Le 05/05/2011, à 11:33

yamo

Re : Arte +7 recorder version 5

Salut,

bowmore a écrit :

Petite question technique.
J'ai installé Arte +7 recorder qt sous un Ubuntu 10.10.
Dès que je le lance, j'obtiens ceci:

... Connexion à http://arte7.arte.tv ...
Error : malformed start tag, at line 74, column 17 
Essayez plus tard.

Pas mieux sad

bowmore a écrit :

Bon, j'essaye plus tard, puis encore plus tard, puis toujours plus tard... sans autre résultat.
Sur un autre PC, sous Natty 11.04, tout fonctionne normalement avec la même version qt...
Moi pas comprendre... neutral

Ah?
Je n'arrive pas à installer arte+7 sur Xubuntu natty sad

W: Impossible de récupérer http://ppa.launchpad.net/arte+7recorder/ppa/ubuntu/dists/natty/main/source/Sources  404  Not Found

W: Impossible de récupérer http://ppa.launchpad.net/arte+7recorder/ppa/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found

En remplaçant natty par lucid apt-get update focntionne mais arte+7-qt ne fonctionne pas mieux sad le site d'arte+7 doit avoir encore changé!]

Dernière modification par yamo (Le 05/05/2011, à 11:43)


Stéphane
--
Debian 9 XFCE  Xubuntu 16.04.2  - #ubuntu sur freenode

sudo / matrix

Hors ligne

#554 Le 05/05/2011, à 11:47

yamo

Re : Arte +7 recorder version 5

Bon j'essaierai un autre jour, les dépôts sont en vrac

Err http://ppa.launchpad.net/arte+7recorder/ppa/ubuntu/ lucid/main arte+7recorder-5 all 5.0.beta3~ppa4~lucid
  Quelque chose d'imprévisible est survenu lors de la détermination de « ppa.launchpad.net:http » (-5 - Aucune adresse associée avec le nom de l'hôte)
Impossible de récupérer http://ppa.launchpad.net/arte+7recorder/ppa/ubuntu/pool/main/a/arte+7recorder-5/arte+7recorder-5_5.0.beta3~ppa4~lucid_all.deb  Quelque chose d'imprévisible est survenu lors de la détermination de « ppa.launchpad.net:http » (-5 - Aucune adresse associée avec le nom de l'hôte)

En insistant l'installation a fonctionné :

Paramétrage de arte+7recorder-5 (5.0.beta3~ppa4~lucid) 

Dernière modification par yamo (Le 05/05/2011, à 11:51)


Stéphane
--
Debian 9 XFCE  Xubuntu 16.04.2  - #ubuntu sur freenode

sudo / matrix

Hors ligne

#555 Le 05/05/2011, à 12:03

VinsS

Re : Arte +7 recorder version 5

Non, il ne faut pas mettre natty dans le nom du ppa

Pour le site, je regarde.

Edit : Je ne vois rien d'anormal, la page se charge correctement.

J'attend confirmation de Launchpad pour le ppa natty.

Dernière modification par VinsS (Le 05/05/2011, à 12:15)


Vincent
Oqapy      Qarte      PaQager

Hors ligne

#556 Le 05/05/2011, à 12:07

yamo

Re : Arte +7 recorder version 5

C'est tombé en marche pour la version QT!


Stéphane
--
Debian 9 XFCE  Xubuntu 16.04.2  - #ubuntu sur freenode

sudo / matrix

Hors ligne

#557 Le 05/05/2011, à 17:37

bowmore

Re : Arte +7 recorder version 5

Pareil chez moi sur mon PC sous 10.10. Ça marche depuis que je n'ai rien fait... big_smile
Mais ce que je n'explique pas c'est pourquoi sur mon autre PC sous 11.04 ça a toujours fonctionné très bien... neutral

Ah et oui!!! J'ai relevé une faute de frappe lors de l'ouverture d'Arte +7 qt, il est inscrit:

... lectire du contenu

Dernière modification par bowmore (Le 05/05/2011, à 17:37)


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#558 Le 06/05/2011, à 08:08

VinsS

Re : Arte +7 recorder version 5

Bonjour,


    NOUVELLE VERSION  Qt


Beaucoup de changements.

Par soucis de simplicité et pour résoudre un problème de nommage de fichier le programme s'appelle désormais : Qarte+7

Le code a été réécrit à 80 % c'est une nouvelle série de développement que j'ai ouverte. Le premier numéro de version est donc : 0.3

J'ai déposé trois distributions sur mon ppa, ajoutez à votre sources.list celui qui correspond à votre version Ubuntu

   

   

   

Avec Synaptic, il faut ouvrir le menu Configuration >> Dépôts >>  onglet Autres logiciels >> cliquer Ajouter  et remplir les champs de la boite de dialogue.

En ligne de commande :

sudo add-apt-repository ppa:vincent-vandevyvre/vvv

et rechargez :

sudo apt-get update

Si toutefois une clé de chiffrement devait être demandée, entrez ceci dans une console :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 89F92A1A

Pour installer:

sudo apt-get install qarte+7

Un .deb est aussi directement téléchargeable sur le site Oqapy page Téléchargements
Ou, plus simplement en ligne de commande :

$ cd Bureau
$ wget http://oqapy.eu/releases/qarte+7_0.5_all.deb

(Mis à jour: 22 oct 2011)


Ce qui a changé :

  • Le téléchargement est lancé individuellement pour chaque fichier, ce qui signifie que vous pouvez modifier la liste pendant que le téléchargement du premier fichier est en cours. ce qui n'était pas possible auparavant ;

  • Les options permettent de forcer le chargement de la page allemande si votre pc est en français et inversement.
    Il est nécessaire de relancer le programme pour cela ;

  • La vitesse de téléchargement est maintenant affichée ;

  • Si les notifications vous agacent, vous pouvez les désactiver dans les options ;

  • La partie de code de téléchargement à été divisée en section afin de pouvoir intercepter d'éventuels message d'erreurs plus explicite qu'avant ;

  • Et bien sur le graphisme, plus dans le courant actuel.

    Un aperçu :

    Qarte+7


J'ai testé avec Lucid et Maverick, pour Natty je dois encore me battre avec Unity, mais je pense qu'il ne devrait pas y avoir de soucis.


Après installation, Qarte+7 est dans le menu Applications >> Sons et vidéos.

Il peut aussi être lancé en console en entrant simplement

qarte+7
qarte+7 -v 

Affiche la version et

 qarte+7 -h

affiche l'aide. (vous allez dire que je ne me pas suis fatigué)


Il ne faut toujours pas désinstallé la version GTK, les deux peuvent cohabiter.


Une demande à été faite pour que le streamer utilise le port 80, nécessaire à ceux qui sont situés derrière un proxy.
Je ne suis pas parvenu à le faire fonctionner de cette manière, l'appli se fige et rien ne se télécharge.
Un complément d'infos de la part de ceux qui utilisent un proxy sera nécessaire avant d' implémenter cette option.

Bons films

Edit 15 oct 2011  15:57 J'ai updaté le ppa avec la version 0.5, voir ici:
                                           http://forum.ubuntu-fr.org/viewtopic.ph … 1#p6567081
Edit 06 mai 2011  21:20 J'ai posté la version 0.4 qui corrige un problème de conflit avec l'ancienne version Qt et le fichier de
                                            configuration.  Ce sera tout pour aujourd'hui.
Edit 06 mai 2011 : Les sources sont à jour : https://code.launchpad.net/~vincent-van … nk/Qarte+7
Edit 06 mai 2011 : Ajout du lien Oqapy 
Edit 06 mai 2011 : modification des ppa et clé de chiffrement.

Dernière modification par VinsS (Le 22/10/2011, à 08:44)


Vincent
Oqapy      Qarte      PaQager

Hors ligne

#559 Le 06/05/2011, à 10:03

yamo

Re : Arte +7 recorder version 5

Salut,

VinsS a écrit :

   

Avec Synaptic, il faut ouvrir le menu Configuration >> Dépôts >>  onglet Autres logiciels >> cliquer Ajouter  et remplir les champs de la boite de dialogue.

En ligne de commande :

sudo add-apt-repository ppa:<nom_du_dépôt>

J'ai essayé j'ai eu cette erreur :

sudo add-apt-repository ppa:vincent-vandevyvre

Error reading https://launchpad.net/api/1.0/~vincent-vandevyvre/+archive/ppa: HTTP Error 404: Not Found

Puis, j'ai essayé en ajoutant la bonne ligne (deb http://ppa.launchpad.net/vincent-vandevyvre/vvv/ubuntu natty main) dans source.list.d et j'ai eu ces erreurs après l'update :

W: Erreur de GPG : http://ppa.launchpad.net natty Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A5ADEEFF89F92A1A
W: Impossible de récupérer http://ppa.launchpad.net/vincent-vandevyvre/ppa/ubuntu/dists/natty/main/source/Sources  404  Not Found

W: Impossible de récupérer http://ppa.launchpad.net/vincent-vandevyvre/ppa/ubuntu/dists/natty/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Pour Unity, je suis passé à XFCE après avoir testé unity sur Ubuntu 10.10 UNE (des tonnes de bogues) donc là sur Natty pas d'unity smile

XFCE 4.8.1 est vraiment pas mal.

Merci pour les développements, tu as peut-être posté l'annonce trop tôt, je réessaierai dans la journée.

Dernière modification par yamo (Le 06/05/2011, à 10:04)


Stéphane
--
Debian 9 XFCE  Xubuntu 16.04.2  - #ubuntu sur freenode

sudo / matrix

Hors ligne

#560 Le 06/05/2011, à 11:08

VinsS

Re : Arte +7 recorder version 5

Salut yamo,

Bien vu, d'abord il y a une première erreur : c'est un double-point après ppa et pas un point et ensuite il ne faut pas ajouter ubuntu.

Ca donne ceci :

vincent@tiemoko:~$ sudo add-apt-repository ppa:vincent-vandevyvre/vvv
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 7CAA00CD3DCA73E24462D646A5ADEEFF89F92A1A
gpg: requête de la clé 89F92A1A du serveur hkp keyserver.ubuntu.com
gpg: clé 89F92A1A: « Launchpad PPA for VinsS » n'a pas changé
gpg: Quantité totale traitée: 1
gpg:              inchangée: 1

Pour la clé, Launchpad n'indique cette procédure comme utile qu' uniquement pour les versions 09.04 jaunty et précédentes

J'ai fait les modifications dans le post d'annonce

Merci


Vincent
Oqapy      Qarte      PaQager

Hors ligne

#561 Le 06/05/2011, à 12:07

yamo

Re : Arte +7 recorder version 5

VinsS a écrit :

Salut yamo,

Bien vu, d'abord il y a une première erreur : c'est un double-point après ppa et pas un point et ensuite il ne faut pas ajouter ubuntu.


J'ai fait les modifications dans le post d'annonce

Merci

Je confirme :

sudo add-apt-repository ppa:vincent-vandevyvre/vvv


sudo apt-get install qarte+7 


Réception de : 1 http://ppa.launchpad.net/vincent-vandevyvre/vvv/ubuntu/ natty/main qarte+7 i386 0.3-0ubuntu1 [47,9 kB]
Paramétrage de qarte+7 (0.3-0ubuntu1) ...

Bon maintenant j'ai trois applications arte+7 tongue

On pourrais pas lancer de télécharger par double clic?
À mon avis il manque les flèches vers le haut et le bas dans l'ascenseur.
look sur Xubuntu 11.04


Stéphane
--
Debian 9 XFCE  Xubuntu 16.04.2  - #ubuntu sur freenode

sudo / matrix

Hors ligne

#562 Le 06/05/2011, à 12:10

yamo

Re : Arte +7 recorder version 5

Et, je viens de voir pourquoi le téléchargement ne fonctionnait pas :

qarte a écrit :

Pas de dossier de destination !

Il vaudrais mieux mettre ce message sous forme de popup modale et/ou de proposer la configuration au premier lancement.

Dernière modification par yamo (Le 06/05/2011, à 12:12)


Stéphane
--
Debian 9 XFCE  Xubuntu 16.04.2  - #ubuntu sur freenode

sudo / matrix

Hors ligne

#563 Le 06/05/2011, à 12:15

VinsS

Re : Arte +7 recorder version 5

Content que ça marche.

yamo :

On pourrais pas lancer de télécharger par double clic?
À mon avis il manque les flèches vers le haut et le bas dans l'ascenseur.

On pourrait effectivement lancer le téléchargement en double-cliquant sur le premier item de la liste, donc celui du haut.
De toutes façon je dois remettre en place les raccourcis clavier qui se sont perdus en route.

Les flèches de la scroll bar n'apparaissent pas avec ce style.


Vincent
Oqapy      Qarte      PaQager

Hors ligne

#564 Le 06/05/2011, à 12:19

yamo

Re : Arte +7 recorder version 5

VinsS a écrit :

Content que ça marche.

yamo :

On pourrais pas lancer de télécharger par double clic?
À mon avis il manque les flèches vers le haut et le bas dans l'ascenseur.

On pourrait effectivement lancer le téléchargement en double-cliquant sur le premier item de la liste, donc celui du haut.
De toutes façon je dois remettre en place les raccourcis clavier qui se sont perdus en route.

Les flèches de la scroll bar n'apparaissent pas avec ce style.

Pour le double clic, c'était par ce que je n'avait pas de répertoire de téléchargement défini et que je ne voyait pas le message d'erreur  en dessous de la description de la vidéo.

Pour les flèches, j'en ai pourtant ; enfin, je viens de mettre ce style donc je n'en mettrai pas ma main à couper!

Pour l'instant, le téléchargement a l'air de fonctionner merci smile

Dernière modification par yamo (Le 06/05/2011, à 12:21)


Stéphane
--
Debian 9 XFCE  Xubuntu 16.04.2  - #ubuntu sur freenode

sudo / matrix

Hors ligne

#565 Le 06/05/2011, à 12:37

bowmore

Re : Arte +7 recorder version 5

Salut les gens.

Installation de Qarte+7 ce matin, difficulté avec le PPA, et puis en suivant les infos de yamo et VinsS, c'est bon, ça tourne sur mon PC sous Natty.
Belle interface, ma foi!!!
Là, je télécharge les épisodes 5 et 6 de toute la vérité sur les Monty Python, obligégatoire!!! wink
Merci encore pour ce nouvel opus Arte+7 recorder.

Dernière modification par bowmore (Le 06/05/2011, à 12:40)


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#566 Le 06/05/2011, à 16:32

bowmore

Re : Arte +7 recorder version 5

Installation sur mon autre PC sous Maverick... Pas au top...

49811c167bd749d5caeb1d5f7a8131f2_Capture.png

On voit que le rendu est "curieux", les titres n'apparaissent que si je passe la souris dessus.
Et si je place deux émissions dans la file de téléchargement, seul la première est téléchargée. La seconde ne se lance pas. Il faut l'effacer de la file, et la reprendre pour pouvoir la charger. Dans mon exemple, j'ai fini de charger X:enius et Arte Journal reste en plan dans la file..
Normal ou pas???

Dernière modification par bowmore (Le 06/05/2011, à 16:35)


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#567 Le 06/05/2011, à 17:05

VinsS

Re : Arte +7 recorder version 5

@ bowmore : Ce problème d'affichage est un bug Qt confirmé :
     
       http://bugreports.qt.nokia.com/browse/QTBUG-14498

Il faut que je fouille dans mes  archives pour retrouver comment j'avais fait pour upgrader la version de Qt.

Pour la deuxième émission qui ne se charge pas à la suite de la première la prochaine fois que tu l'utilise lances le en console au cas où un message apparait.


Vincent
Oqapy      Qarte      PaQager

Hors ligne

#568 Le 06/05/2011, à 17:35

bowmore

Re : Arte +7 recorder version 5

Aucun message en console... Désolé, ça n'aide pas trop... sad


"Bon bah, je vais essayer de ne pas claquer la porte en sortant"
Buzz Aldrin, le 21 juillet 1969 sur la Mer de la Tranquillité

Hors ligne

#569 Le 06/05/2011, à 21:32

VinsS

Re : Arte +7 recorder version 5

J'ai effectués quelques correctif dont un conflit avec le fichier de configuration et son ancienne version.

Les paquets sont à jour.


Vincent
Oqapy      Qarte      PaQager

Hors ligne

#570 Le 07/05/2011, à 02:19

ricothebrol

Re : Arte +7 recorder version 5

Bonjour,

J'ai installé le paquet suivant :
http://www.oqapy.eu/releases/qarte+7_0.4_i386.deb (conseillé plus haut par VinsS)
Au lancement du logiciel Qarte+7 le message suivant apparaît :

Error in stage 1 : BeautifulSoup can't read the page
malformed start tag, at line 1162, column 12

J'ai récemment eu le problème de la "mauvaise page d'accueil" décrit ici :
http://forum.ubuntu-fr.org/viewtopic.php?id=464781&p=2
réglé grâce aux commandes données par Deevad (post #40). Je ne sais pas si cela a un rapport mais depuis que j'ai expérimenté ce problème il m'était impossible de me connecter avec l'ancienne version d'arte recorder.

Merci d'avance.

Eric

Hors ligne

#571 Le 07/05/2011, à 09:24

Alfraid

Re : Arte +7 recorder version 5

meme constatation que ricothebrol :
 

Error in stage 1 : BeautifulSoup can't read the page
malformed start tag, at line 1165, column 12

par curiosité un essai sur la 10.10 donne le meme résultat qu'avec la 11.04
    si çà peut etre utile, arte7recorder renvoie:
          Traceback (most recent call last) :
           File "arte7recorder.py" , line 495, in <module>
            app = GUI ()
           File "arte7recorder.py" , line 146, in_init_
             self.emi dispo ()
           File "arte7recorder.py" , line 394, in emi_dispo
              self.liststore.append([t[0], t[1], t[2], t[3] ])
           IndexError: list index out of range

autre chose (mais je ne comprends pas tout du premier coup):
  sur la 11.04 et seulement avec Unity (et pas Ubuntu classique),avec Qarte les "Options" n'apparaissent pas apres un clic; donc on ne peut pas indiquer de fichier de destination .

Sinon, c'est vraiment très beau (çà a fonctionné 1 fois avec 11.04) .
  y a t-il incompatibilité entre arte7 et Qarte?
Merci

Dernière modification par Alfraid (Le 07/05/2011, à 10:53)

Hors ligne

#572 Le 07/05/2011, à 09:45

David

Re : Arte +7 recorder version 5

Pour info :
1/ Je viens d'installer qarte+7 sous Natty (Unity) : 0 souci, et là il tourne comme un charme. C'est cool.
2/ La seule chose qui m'a fait hésiter ce sont les boutons en bas de la colonne de téléchargement, je n'étais pas sur de savoir si je devais appuyer ou pas, et sur lequel/dans quel ordre.

J'en profite au passage pour te remercier : pour un gars comme moi, qui n'a pas la TV, pouvoir récupérer les rares morceaux qui m'intéressent, c'est le pied smile

Hors ligne

#573 Le 07/05/2011, à 10:18

Ghislain_B

Re : Arte +7 recorder version 5

Bonjour,
Je viens de découvrir ce super outil ! Merci !
J'ai suivi le post #558 pour installer sous Lucid, impeccable.
Mais quand je lance, seule l'option allemande fonctionne, pas la française !
Message d'erreur, comme Ricothebrol :

Error in stage 1 : BeautifulSoup can't read the page
malformed start tag, at line 1162, column 12

Edit : Par "option allemande", j'entends : "Die deutsche Seite beladen". En faisant "connexion", tout plein de miniatures s'affichent et je peux télécharger. La même chose avec "Charger la page française" donne le message d'erreur ci-dessus

Dernière modification par Ghislain_B (Le 07/05/2011, à 12:00)

Hors ligne

#574 Le 07/05/2011, à 11:41

VinsS

Re : Arte +7 recorder version 5

Salut,

@ David en bas de l'interface, dans la barre d' état, tu as une ligne de texte qui indique l'usage des boutons quand tu passes la souris dessus.

@ Ghislain_B comment peux-tu voir que tu charges la page allemande, aucune page ne se charge.

Bon, c'est de nouveau le boxon dans leur page html,  l'émission "7 days in La Habana' est mal formatée.

Je viens de faire un bricolage dans le code qui à l'air de passer.
Je prépare un deb et je dis quoi.


Vincent
Oqapy      Qarte      PaQager

Hors ligne

#575 Le 07/05/2011, à 12:05

VinsS

Re : Arte +7 recorder version 5

OK, j'ai compris, si tu charges la page allemande alors il n'y a pas d'erreur.

Ben oui, sont sérieux les allemands, hein.

Alors j'ai fait un deb qui fonctionne mais comme c'est du code pas propre (du code du samedi) je ne le change pas dans le dépôt, je dois d'abord valider ce patch et le réécrire convenablement.

Vous pouvez télécharger ce deb sur mon site :

            http://www.oqapy.eu     >> page téléchargements

ou en console :

cd Bureau
wget http://oqapy.eu/releases/qarte+7_0.4.1_i386.deb

Une dernière solution consiste à apprendre l'allemand.


Vincent
Oqapy      Qarte      PaQager

Hors ligne