Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 22/05/2010, à 17:25

dorsai

[résolue] Wine en "vrai" plein écran ?

Bonjour,

j'ai installé WINE et je m'en sers pour FarCry, Eve etc, tout marche impec.

Par contre, j'aimerais le mettre en "vrai" plein écran (sans le menu Ubuntu en haut ni le cadre fenetre de Wine

Est-ce que c'est possible ?

merci de votre aide...

Dernière modification par dorsai (Le 23/05/2010, à 17:58)


Je comprends vite, il faut juste m'expliquer longtemps ;)

Hors ligne

#2 Le 22/05/2010, à 18:31

abelthorne

Re : [résolue] Wine en "vrai" plein écran ?

Oui.
Par défaut, Wine se lance en plein écran. Si tu vois les menus Ubuntu, ça vient probablement du fait que tu as Compiz (les effets visuels du bureau) activé et il n'est pas très copain avec Wine.

Tu peux désactiver les effets dans les préférences d'Apparence, ça devrait résoudre ton problème. Tu peux aussi essayer les correctifs divers qu'il y a dans le configurateur de Compiz (CCSM − paquet compizconfig-settings-manager à installer). Ça peut résoudre le problème sans pour autant désactiver Compiz (mais c'est conseillé de le faire de toute façon, ne serait-ce que pour les performances).

Et si tu dois désactiver les effets mais que ça t'emmerde de passer par les préférences d'Apparence à chaque fois, tu peux installer des petits logiciels qui simplifient tout ça, comme fusion-icon.

Dernière modification par abelthorne (Le 22/05/2010, à 18:32)

En ligne

#3 Le 22/05/2010, à 19:27

dorsai

Re : [résolue] Wine en "vrai" plein écran ?

hmmm. activé ou désactivé, Wine ne se lance pas en plein écran. J'ai la bare de la fenetre Wine et la bare de menu Ubuntu... c'est tristoune... :s


Je comprends vite, il faut juste m'expliquer longtemps ;)

Hors ligne

#4 Le 22/05/2010, à 19:32

abelthorne

Re : [résolue] Wine en "vrai" plein écran ?

Dans la config de Wine (winecfg), vérifie que tu n'as pas un bureau virtuel activé.

En ligne

#5 Le 23/05/2010, à 17:58

dorsai

Re : [résolue] Wine en "vrai" plein écran ?

YESSSS smile merci à toi !

question pour ma culture générale : certains jeux tournent mieux (si, si) sous wine que sous Windows Vista (en terme de vitesse) ce qui me surprend quand même puisque WINE est une interface "supplémentaire"...

qqn peut il essayer de me donner une piste du pourqui ? juste vraiment pour ma culture générale wink

merci de la solution ci dessus !


Je comprends vite, il faut juste m'expliquer longtemps ;)

Hors ligne

#6 Le 23/05/2010, à 18:03

abelthorne

Re : [résolue] Wine en "vrai" plein écran ?

Difficile à dire : Vista charge énormément de conneries en mémoire qui tournent en tâche de fond et qui peuvent bouffer une partie des ressources du système. D'un autre côté, l'affichage en DirectX doit être traduit par Wine à la volée en OpenGL, ce qui bouffe aussi des ressources (au désavantage de celui-ci).

C'est du cas par cas en fonction des jeux, y a pas vraiment de règles, à part qu'un jeu qui utilise nativement OpenGL tournera généralement mieux avec Wine qu'avec Windows (du moment que toutes les fonctionnalités qu'il utilise sont gérées par Wine).
Disons que généralement, un jeu lancé via Wine est dans un environnement plus léger que sous Windows.

Dernière modification par abelthorne (Le 23/05/2010, à 18:04)

En ligne

#7 Le 23/05/2010, à 18:20

dorsai

Re : [résolue] Wine en "vrai" plein écran ?

bon, ça me donne qq arguments quand je défendrais le gentil Ubuntu wink merci en tout cas abelthorne pour ton aide ! (edit : solutionné dans le titre fait)


Je comprends vite, il faut juste m'expliquer longtemps ;)

Hors ligne

#8 Le 08/10/2011, à 22:35

Illitch

Re : [résolue] Wine en "vrai" plein écran ?

Bonjour à tous,

Mon problème sans être semblable est similaire :

Sous wine avec émulation en bureau virtuel Rome Total War se lance mais dans une fenêtre trop petite à mon goût (quelle que soit la résolution) et le "resize" du bureau ne fonctionne pas (bug graphique si je maximise le bureau en1024x800) et avec burau virtuel en 1920x1200 et option graph du jeu en 1920x1200 j'ai alors un plein écran mais le curseur ne descend pas plus bas que le cinquième de l'écran dans le jeu.
En mode plein écran (sans émulation du bureau) Rome Total War se lance également mais là c'est Gnome qui m'enquiquine : les tableaux de bord restent affichés (le masquage automatique fonctionne mais bon...) et les fonctions de défilement automatique à la souris ne fonctionnent que sur deux bords (malgré un réglage de l'écran et évidemment le masquage automatique des tableaux de bord -en bas- fait des siennes).
Wine et mes pilotes (GForce GTX8800) sont à jour. Wine v1.2.3 (dépôts Canonical & wine)

Merci de vos lumières.

/EDIT : j'ai posté ici pensant que ma question y serait à sa place (Hit Google en 1ère page avec q=Ubuntu.fr+wine+"plein écran") mais si vous pensez que je me trompe (surtout les modérateurs wink ) n'hésitez pas à le dire : j'éditerai et posterai un nouveau sujet duquel je mettrai le lien ici.

//EDIT

configuration graphique (avec bureau)
http://i44.servimg.com/u/f44/15/04/67/93/captur30.png
(modifier le paramètre de contrôle de la souris par directX ne change rien au comportement du curseur dans le jeu).
configuration du jeu :
http://i44.servimg.com/u/f44/15/04/67/93/captur32.png

Dernière modification par Illitch (Le 09/10/2011, à 00:07)

Hors ligne

#9 Le 12/10/2011, à 09:06

abelthorne

Re : [résolue] Wine en "vrai" plein écran ?

Si tu as les barres de menu qui restent affichées, le problème vient de Compiz (qui n'est pas très copain avec Wine). Seules solutions dans ce cas-là :
- désactiver Compiz (si tu utilises Unity, il faut passer sur une session sans effets)
- tester le plugin des correctifs de Compiz, il y en a qui concernent Wine. Ça ne résoudra pas forcément le problème, faut faire des essais

Pour le coup de la souris qui ne couvre pas toute la surface de l'écran, ça peut éventuellement venir de Compiz mais c'est plus certainement lié à un bug de Wine qui touche pas mal de jeu et qui a trait à un changement dans la façon dont celui-ci gère la souris, pour être compatible avec une nouvelle façon de faire de Microsoft. Pour l'instant, il y a pas mal de jeux qui sont cassés à ce niveau-là (ça peut aller du curseur qui ne bouge pas à une amplitude moindre, en passant par la situation où il marche dans le menu mais pas en jeu...). Il y a un patch pour corriger ça, qui nécessite de compiler Wine à partir des sources. Pour le moment, les développeurs attendent d'avoir plus de retours dessus pour l'implémenter, histoire d'être sûr qu'il ne casse pas des tas de trucs à côté.
Dans certains cas, utiliser un bureau virtuel (en virant Compiz et les décorations de la fenêtre) peut être une solution. Ça dépend des jeux.

En ligne

#10 Le 15/10/2011, à 21:13

Illitch

Re : [résolue] Wine en "vrai" plein écran ?

Merci d'être passé abelhorne

Je réussi en bureau virtuel à faire tourner le jeu en résolution moindre (1400x1050 max) mais comme dit plus haut tintin pour un resize plein écran

"- tester le plugin des correctifs de Compiz, il y en a qui concernent Wine. Ça ne résoudra pas forcément le problème, faut faire des essais"

Peux tu être plus explicite ? (my name is Kevin) -> articles, liens divers...
Merci encore

Dernière modification par Illitch (Le 15/10/2011, à 21:14)

Hors ligne

#11 Le 15/10/2011, à 21:49

abelthorne

Re : [résolue] Wine en "vrai" plein écran ?

Si tu utilises Compiz, tu peux installer CCSM (compizconfig-settings-manager), qui permet de faire plein de réglages. Dedans, il y a un plugin dont j'ai oublié le nom et qui propose divers correctifs, notamment pour Wine.

En ligne

#12 Le 16/10/2011, à 09:30

Illitch

Re : [résolue] Wine en "vrai" plein écran ?

Merci d'être repassé abelhorne smile
Je vois ça...

Hors ligne

#13 Le 12/07/2012, à 10:03

guylapi

Re : [résolue] Wine en "vrai" plein écran ?

disait  de regarder si on n'avait pas un bureau virtuel activé. c'es super, ça marche plein écran maintenant (evidemment !)
merci

Hors ligne

#14 Le 03/02/2017, à 10:33

CharlieF

Re : [résolue] Wine en "vrai" plein écran ?

Salut tout le monde,
J'ai un probleme similaire mois aussi, Je joue a Warcraft 2, la fenetre de wine est petite 15cm/ 10cm et j'aimerais l'agrandir.

Voila se que j'ai fait, j'ai essayer de regler la taille de la fentre du "bureau" Wine avec, Configuration Wine. Se qui se passe est que la fenetre de wine se presente comme un mini bureaux a l'interrieur duquel d'autre fenetre plus petite s'ouvre ... et la en cherchent a modifier la taille de la fenetre, c'est la fenetre de configuration interrieur a la fenetre wine qui s'est agrandi de tel sorte que je n'est plus acces au 3/4 de la fenetre et sa a l'interrieur d'une fenetre qui fait deja le quart de mon ecran reel.

Et se qui est genant c'est que cette fenetre de configuarion est devenus inutilisable, je n'est plus acces dans son cadre au changement de dimension. et en essayant de bouger la fenetre manuellement, a la souris... sa ne marche pas non plus. Peut etre desinstaller et reinstaller ...

En tout cas le jeux n'a pas bronché il se lance toujours de la meme facon, alors comme ne suis plus sur de la maniere dont j'avais reussi a installer tout ca, j'ai pas envie de me retrouver sans rien en esseyant de faire mieu ...

J'ai essayer aussi, le "CCSM (compizconfig-settings-manager)" que j'ai trouve inefficace dans mon cas et inquietant .

Bon bref comme tout le monde j'aimerais avoir un bureau wine en plein ecran , non j'ai pas d'ecran virtuel, ni compiz, pas a ma connaissance en tout cas . C'est aussi un probleme depuis l'instalation, je n'est jamais vu Wine en pleine page - - - Donc pas une erreur ou un beug de passage
Auriez vous des pistes a me donner merci .

Dernière modification par CharlieF (Le 03/02/2017, à 10:39)

Hors ligne

#15 Le 03/02/2017, à 11:36

abelthorne

Re : [résolue] Wine en "vrai" plein écran ?

Le bureau virtuel, c'est ce que tu as réglé dans winecfg et qui te donne un "mini bureau Wine". Ça permet surtout de faire l'inverse de ce que tu voudrais, c'est à dire définir une zone à une résolution définie dans laquelle s'afficheront les logiciels Windows sans toucher au bureau Linux. Le seul intérêt (outre que certains jeux ne fonctionnent qu'en bureau virtuel, d'autres spécifiquement sans) est d'éviter qu'un jeu en basse résolution (disons 320 × 240 ou 640 × 480) redimensionnent le bureau Linux et ne le remettent pas en état après avoir quitté : tu te retrouves alors avec un bureau Linux en très basse réso et c'est le bordel pour le remettre à la bonne.

Dans ton cas, pour avoir Warcraft 2 en plein écran, il faut donc paramétrer Wine pour ne pas utiliser de bureau virtuel. Sachant, donc, que tu te retrouveras probablement avec un bureau Linux en basse réso ensuite. Il y a aussi la possibilité que ton écran ou le pilote graphique ne gèrent pas la basse réso nécessaire et que tu te retrouves sans affichage (message "hors plage"), même si c'est assez rare.

Cela dit, il me semble que Warcraft 2 était un jeu DOS, non ? À moins que tu aies une version pour Windows 95 (il y avait peut-être les deux à cette époque de transition), il pourrait alors tourner avec DOSBox, qui a des options plus évoluées pour l'affichage en plein écran.

Note : si tu veux réinitialiser les paramètres de Wine (ce qui supprimera les jeuxi nstallés au passage), ne va pas supprimer et réinstaller le paquet wine, ça ne changera rien. Il faut supprimer le dossier .wine (caché) qui est dans ton dossier perso, ou le dossier concerné si tu as paramétré un préfixe spécifique.

En ligne

#16 Le 02/09/2017, à 15:06

#++

Re : [résolue] Wine en "vrai" plein écran ?

Bonjour à tous.
Personnellement, j'ai essayé plusieurs jeux sous playonlinux et crossover, le plein écran marche pour certains mais d'autres pas :-(
Ma solution a été d'utiliser un environnement de bureau comme xfce qui gère les fenetres plein écran et lancer mes jeux en mode fenetré :-)
On peut également créer un petit script qui redimmensionne la résolution juste avant de lancer le jeux (xrandr -s 1024x768 par exemple). Dans xfce, quand une appli en fenetré fait la même résolution que le bureau, elle se met direct en pleine écran, pratique ^^
En espérant vous avoir apporté de l'aide :-)


Tout mes jeux amateurs à télécharger sur :

https://dieseplusplusblog.wordpress.com/

Hors ligne